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Welcome to WaspTime  

 
WaspTime tracks employees' time and provides a daily reconciliation of time records. This data can later 
be exported into your payroll software system and can also be used to generate various management 
reports. 
Key Features: 

1. Compatible with external payroll providers 
2. PCPunch allows users to punch in at a PC 
3. Generate powerful management reports 
4. Monitors employee attendance 
5. Track vacation, sick and personal leave 
6. Provide flexible shifts 
7. Automate time rounding policies 
8. Quickly retrieve historical data 
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        Getting Started Using WaspTime  

  
Step 1: Register 
and Activate 
WaspTime  

The first time you access WaspTime after installation, a screen 
will appear prompting you to register the product serial number 
and enter an Activation Key.  You can use the system for 30 days 
without entering an activation key by clicking the Activate Later 
button.  After 30 days, however, you MUST activate the product 
to continue using it. 
 

1. Click the link on the Activation screen.  You will be 
directed to the Registration Website.   
 
You can use the product without Activation for a period of 
30 days, by clicking the Activate Later button, however it 
is recommended that you activate immediately to ensure 
continued access to the system. 
 

2. Enter your address information in the fields provided on 
the Registration Website.  You should copy and paste 
your serial number into the Serial Number field to make 
sure you enter the correct number. 
 
An email containing your Activation Key will be sent to 
the email address you entered on the Registration 
Website.   
 

3. When you receive the Activation Key, enter it into the 
Activation Key field, then click the Activate Now button.  
 

 
 
A message will appear stating you have successfully 
activated the software. 
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Step 2: Enter a 
Time Zone 

The software has the ability to capture and calculate times from 
clocks across multiple time zones.  The first time you open the 
software, you will be prompted to enter your local time zone. This 
should be the time zone where your server is located. 
 
For detailed information on entering this information, please refer 
to the Time Zone Screen topic. 
 

Step 3: Enter Your 
Company and 
System 
Information 

From the Main Window, select Settings to open the System 
Setup screen.  Here you can enter your Company information, 
Payroll Settings, Payroll Codes, Departments, Absences and 
Holidays as well as your email options if you want to receive 
system updates and selected reports via email (Professional and 
Enterprise versions only). 
 
For detailed information on entering this information, please refer 
to the System Setup topic. 
 
You can continue without completing all of the tasks on the 
System Setup screen but not all of the software functionality will 
be available until all items have the information they need. 
 

Step 4: Create 
Groups 

From the Main Window, select Groups.  The Groups List will 
appear.  Click New on the Groups List toolbar to begin adding 
your groups.  For an overviewof the List screens' functionality, 
please refer to the topic Working with Lists. 
 
For detailed information on entering groups, please refer to the 
Adding/Editing Groups topic. 
 

Step 5: Create 
Employees 

From the Main Window, select Employees.  The Employee List 
will appear.  Click New on the Employee List toolbar to begin 
adding your employees.   
 
For detailed information on entering employees, please refer to 
the Adding/Editing Employees topic. 
 

Step 6: Setup your 
Clocks 

Now you can add your time clocks.  To do this, from the Main 
Window, select Clocks.  The Clock Setup screen will appear. 
For detailed information on setting up clocks, please refer to the 
Clock Setup topic. 
 
Keep in mind that a typical small business using WaspTime 
should download punches at least once a day. Then once every 
pay period the payroll administrator should review each 
employee's time cards for that period and make corrections for 
missing punches, apply absences for holidays and vacations, 
export the payroll data, and print reports. 

  
 

Software activation system licensed under Patent No. 5,490,216 
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Logging On 

This section discusses the following topics: 
Logging onto the System 
Changing Your Password 
Accessing Forgotten Passwords 
Troubleshooting Logging On 

 

Logging onto the System 

1. If you have selected to require a user name and password, each time you access the software 
after Activation (see the Getting Started section for information on Activating the software), the 
following screen will appear prompting for a user name and password.  
 

 
 
 
 
Note:  The option to require a User Name and Password is found on the System Setup screen 
> Options tab.  For more information on this option, please refer to the System Setup topic. 
 

2. Enter your User Name and Password, then click Login. 
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Changing Your Password 

Passwords can be changed on the Employee screen.  For information on this screen, please refer to the 
Adding/Editing Employees topic. 

 

Accessing Forgotten Passwords 

If you become locked out of the program because you do not remember your password, call Wasp 
Support for a temporary password.  This password will only work for that day. 

 

Troubleshooting Logging On 

If you have more than one instance of the Time Service running, the software will present you with a list 
of services from which to select.  Finding more than one service is usually caused by having a WaspTime 
demo installed on one machine and the actual software installed on another.  If more than one service is 
detected, while the software is searching, the following screen will display: 
 

 
 
If more than one service is found, you will be shown a list of available services to select from as shown 
below: 
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Select a time server by highlighting a listing, then click OK. 
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Time Zone Screen 

The software has the ability to capture and calculate times from clocks across multiple time zones.  The 
first time you open the software, you will be prompted to enter your local time zone.   
  
The time zone you enter here should be the time zone where your server is located.  Only a user with 
Admin privileges can set or change the time zone.   
  
There are a couple of points to keep in mind regarding how the software uses time zones: 
  

1. The time zone entered on the Time Zone screen should be the zone where the server is located. 
 

2. Only a user with Admin privileges can set or change the time zone. 
 

3. A time zone is entered for each employee (on the Employee Screen).  This should be the local 
time zone for the employee's physical location. All times shown on an employee's Timecard 
screen are the employee's local time zone. 
 

4. A time zone is entered for each clock (on the Clock interface).  This should be the local time zone 
for the clock's physical location. When you sync the time on the clocks with the server time, the 
system will perform any conversions for you (converting the times from the clock's time zone to 
the server's local time zone). 

  
To Set Your Time Zone: 
 

1. The first time you enter the software after installing, you will be prompted to set the time zone. 
 
OR 
 
You can manually change the time zone (if you are setup as an Administrator in Security) by 
selecting File > Set Server Time Zone. 
 
The Set Server Time Zone screen appears: 
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2. Select the correct time zone from the Server Time Zone drop down.   
 
Note:  The Offset field displays the number of hours from difference (if any) between the client 
and the server.  This field is calculated by the system and cannot be modified. 
 

3. Click the Set Time Zone button. 
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Main Window Overview 

The Main Window is the first screen you will see when you open WaspTime .  This screen allows access 
to all other functions in the software via the Main Menu (section A in the graphic below) and Toolbar 
(section B in the graphic below).   
  

 

Section A: Main Menu 

The Main Menu contains the following drop down menus: 
  

1. File - This menu provides access to the following functions: 

1. Print Setup - Accesses the Print Setup screen which allows you to select and configure 
a local or network printer and specify page setup options such as paper size, orientation, 
and margins. 
 

2. Launch Setup Assistant - Accesses the Setup Assistant which guides you through 
definition of Company Information, Payroll Settings, Departments, Holidays, 
Paycodes and other options. 
 

3. Check for Updates - Allows the system to search for updates to the software. 
 

4. Log off - Logs off the current user. 
 

5. Exit - Closes the software. 
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2. Tools - This menu provides access to the following functions: 

1. Payroll Export - Calculates and writes your employees' pay period hours worked and 
absence time to a file in the selected format. The employees can be filtered by 
department and group and the date range can be specified. If you are using QuickBooks, 
use this screen to specify which employee's time to send directly to QuickBooks. 
 

2. Process Holidays - Allows you to apply Holiday hours to the timecard data of 
Employees in All or Selected Departments or Groups. 
 

3. Request Approval - Available in the Professional and Enterprise versions only. 
 Accesses the Request Approvals screen allowing you to request approvals for selected 
employees. 
 

4. Setup Email Alerts - Available in the Professional and Enterprise versions only. 
 Accesses the Email Alerts Setup screen where you can configure the software to send 
you a notification email when certain situations occur or to receive specific information on 
an automated basis.    
 

5. Process Daylight Savings Time - Accesses the Daylight Savings Time screen where 
you can apply Daylight Savings Time to all timecards in your system. 
 

6. Archive Timecards - Allows you to archive all timecards that fall within a specified date 
range. 
 

7. Restore Archive - Allows you to restore the archived timecard that fall within a specified 
range of dates. 
 

8. Unprocessed Punches - Allows you to see punch data that was not processed by the 
software because of Unknown Badges. 
 

9. Database Backup - Allows you to back up your data and set up Auto Back Up. 
 

10. Database Recovery - Allows you to replace all information as long as you have been 
backing up your database. 
 

11. Import - allows you to import external data from a File or from QuickBooks. 
 

12. System Setup - Allows you to enter information regarding your Company and to 
establish Payroll Settings, Options, Departments, Payroll Codes, Absences, and 
Statutory Holidays. 

3. Help - This menu provides access to the following functions: 

1. Online Help - Accesses this help file. 
 

2. About - Allows you to view and manage your licenses and provides program version 
details. 
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Section B: Toolbar  

The Toolbar icons access the following areas: 

1. Employees - Opens the Employee List. 
 

2. Groups - Opens the Groups List. 
 

3. Timecards - Opens the Employee List allowing access to an employee's Timecard screen. 
 

4. Reports - Opens the Reports feature. 
 

5. Payroll - Allows you to write Department, Group or Employee data from the database to an 
external file. 
 

6. Settings - Opens the System Setup screen. 
 

7. Lists - Accesses the generic List screen where you can select data to view and create 
filters/group settings.  The List screens allow you to view: 
 
Anniversaries 
Departments 
Employees 
Groups 
Phone Extensions 
Organization 
Reviews 
 
You can use the filter and group settings to arrange the data as needed, then print or export it. 
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Email Alerts 

This feature is available in the Professional and Enterprise versions only. 
  
You can configure the software to send you a notification email when certain situations occur or to receive 
specific information on an automated basis.    
  
IMPORTANT: Before you can use this feature, you must setup your email in the software.  For 
information on the initial setup process, please refer to the System Setup - Options topic. 
  
Below is a list of occurrences for which you can receive an email notification: 
 

1. When a backup fails 
2. When a clock download fails 
3. When a clock time sync fails 

 
Below is a list of reports you can set to automatically run and be emailed to you: 
 

1. Report of all employees with incomplete timecards 
2. Report containing all employees tardy yesterday 
3. Report of Employee Daily Anniversaries 
4. Report of Employee Daily Birthdays 
5. Report of Employee Daily Reviews 

 
Below are instructions for setting up email alerts: 
  

1. From the Main screen, select Tools > Setup Email Alerts. 
 
The Email Alert Setup screen appears: 
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2. Select the checkbox in front of the option you wish to enable.  The available settings for your 
selection will be enabled. 
 

 
 

3. For sending emails regarding backups, downloads and time syncs, you have the following setup 
options: 
 

Return E-mail address - Enter a return email address or click the "..." icon to choose 
from recently entered email addresses.  This will be the "From" address.  Below is an 
example of the Select screen. 
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Send E-mail To - You can choose to send the notification email to selected 
Managers, Admins or a Custom List.  Click the "..." icon next to your selection to 
view a list of all Managers, Admins, or all Employees (for a Custom List), then 
chose the address to which the email will be sent.   
 
  

For sending emails with scheduled reports, you can choose: 
 

a. Recurrence - Choose to create and send this report Once or Daily.  Click the Now 
button to generate the report and sent it now. 
 

b. Schedule - Select the Date and Time you want the report to be generated and sent. 
 

• Return E-mail address - Enter a return email address or click the "..." icon to 
choose from all employee email addresses.  This will be the "From" address. 
 

• Send E-mail To - You can choose to send the notification email to selected 
Managers, Admins or a Custom List.  Click the "..." icon next to your selection 
to view a list of all Managers, Admins, or all Employees (for a Custom List), 
then chose the address to which the email will be sent. 
 
You can also choose to send the email to the affected employee and the 
employee's manager.  For example, if an employee's name appears on the Tardy 
report and you have selected these two options, an email will be sent to that 
employee and his/her manager. 
 

4. Click Test Email to create and send a test email address entered in the Send E-mail To field 
(optional). 
 

5. Click Save when you are done setting options for this email alert.  You can continue selecting 
email alerts and setting options as needed. 
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System Setup 

The System Setup window is where you will begin.  This window allows you to enter information 
regarding your Company and to establish Payroll Settings, Options, Departments, Payroll Codes, 
Absences, and Statutory Holidays. 
Note: The System Setup screen will appear each time you open the software until you turn this feature 
off.  Please see the Entering Options section below for information on turning this feature off. 
  
This topic is divided into the following sections: 
  
Entering Company Information 
Entering Payroll Settings 
Entering Options 
Creating Departments 
Creating Payroll Codes 
Creating Absence Types 
Creating Statutory Holidays 

 

Entering Company Information 

This is the first tab on the System Setup window.  To access this tab: 
  

1. From the Main screen, click Settings on the toolbar, or click Tools>System Setup.  The System 
Setup window appears with the Company information tab displayed. 
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2. Enter your company information as you want it to appear on reports, then click the Save button to 
save your information. 
 

3. Click the Next button to enter your Payroll Settings or Exit to close the System Setup window. 
 

Entering Payroll Settings 

Payroll Settings affect how your overtime and pay periods are calculated.  To access this screen: 
  

1. If you are going through the steps, click Next after you have saved your Company Information 
or, click the Payroll Settings icon on the left of the System Settings screen. 
 

 
 

2. Enter information on this screen following the steps provided on the screen as a guide, then click 
Save to save your information. 
 
Below are some helpful definitions.  These can also be found on the Glossary tab: 
 
 

a. Pay Period - The actual calendar days included in one paycheck. Any time worked or 
vacation spent on the first day of the pay period through the last day of the pay period is 
added together to determine total hours worked. 
 

b. Pay Day - The day the paychecks are distributed. A pay day may be different from the 
last day of the pay period because it takes some time to calculate and create the pay 
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checks. Some companies pay in arrears by some number of days, weeks or even a 
month. 
 

c. First day of the pay period - The first day that time starts to accumulate in a given pay 
period. Depending on the type of pay period, the first day of the pay period and the first 
day of the week may not be the same. 
 

d. Weekly Pay Period – This pay period is always 7 days long. It can start any day of the 
week, but it starts on the same day every week. There are always 52 pay periods in a 
year. 
 
In the software, when you select the first day of the week, the pay period will include that 
first day plus 6 more days. 
 
For example, if you select Sunday as the first day of the week, all time on Sunday 
through the following Saturday is included on the timecard. If you select Tuesday as the 
first day of the week, the timecard will run from Tuesday through the following Monday. 
 

e. Bi-Weekly Pay Period – This pay period is always 14 days long. It can start any day of 
the week, but it starts on the same day every week. There are always two complete 
weeks, which means two complete sets of overtime, in each bi-weekly pay period. There 
are 26 to 28 pay periods in a year depending on the year and when the pay periods start. 
 
In the software when you specify the date of the first day in any pay period, the software 
calculates the first day of the week and all the other pay periods. The pay period will 
include the date specified plus the next 13 days. Note that you are not specifying the pay 
day but the day pay starts to accumulate. 
 
For example you might select July 23rd.  That means that your pay week always runs 
from Sunday through Saturday because the 23rd is a Sunday. The pay period would be 
the two weeks starting on Sunday July 23rd through Saturday August 5th. 
 

f. Monthly Pay Period – This pay period means one pay period per month. It can be 28 to 
31 days long. You specify the first day of the week because it does not change even if 
the pay period does not fall evenly on the selected day.  There will always be 12 pay 
periods in a year. To define when the monthly pay period starts and ends, you will select 
the day of the month that is the first day of the pay period. 
 
In the software when you specify the date of the first date in any pay period, the software 
will calculate the length of the pay periods. You can also specify the first day of the week 
because the pay period will rarely start on the same day from month to month. This also 
means that some pay periods will include partial weeks. For more detail, please see 
Partial Weeks in a Pay Period defined below. 
 
For example, you might select July 2nd 2006 as the first day of your monthly pay period. 
That means that your pay period for July will run from July 2nd to August 1st— 31 days. 
August will include August 2nd to September 1st –32 days. Most monthly pay periods 
start on the 1st of the month and are as long as the month. 
 

g. Semi-Monthly Pay Period – This pay period means two pay periods per month. It is 
different from bi-monthly because semi-monthly pay periods are not always the same 
number of days. There are always 24 pay periods a year. To define when the pay period 
starts and ends, you will select the day of the month that starts the first and second pay 
period. 
 
In the software you specify the day of the month where pay starts to accumulate for the 
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first and second pay periods. You must also specify the first day of the week because the 
pay period will rarely start on the same day month to month. This means that some pay 
periods will include partial weeks.  For more detail, please see Partial Weeks in a Pay 
Period defined below. 
 
For example, if you select the 1st and 15th as the start of the first and second pay 
periods. Then for July 2006, the first pay period will be from July 1st through July 14th  —
14 days. The second pay period would be July 15th to July 31st—16 days. 
 

h. Partial Weeks in a Pay Period  – Some Monthly and Semi-Monthly pay periods will be 
longer than 7 or 14 days and therefore will include partial weeks. These weeks can be 
the end of one week or the beginning of another or both. 
 
Assume the pay period type is Monthly and the pay period starts on the 1st of the month 
and the week runs from Sunday through Saturday. In 2006, August 1st was on a 
Tuesday. The last week of July has Sunday July 30th and Monday July 31st as part of 
the week but the rest of the week is in August. The end of the pay period is July 31st. The 
30th and 31st is a partial week. 
 
Regular time for each day that is part of a pay period will be included in that pay period. 
 
Using the above July example, if the employee worked 8 hours on Monday July 31st, that 
8 hours would be included in the total hours for the month of July. 
 
Overtime is always calculated weekly. If the overtime calculation is daily any overtime 
earned on the days included in the pay period will be paid in that pay period. 
 
Using the July 2006 example above, if the employee worked 10 hours on the 30th and 10 
on the 31st and the daily threshold was overtime after 8 hours, that employee would get 8 
hours of regular time and 2 hours of overtime for each of the last 2 days on his July 
timecard totals. 
 
If the overtime calculation method is weekly, once the weekly threshold is reached 
overtime on each day included in a pay period will be included in that period. 
 
If the employee worked 10 hours on the 30th and 31st but his weekly threshold of 40 
hours was not reached until Thursday, he would see 10 hours of regular time on his 
timecard for the 30th and 31st for July. If on the other hand he worked 24 hours a day on 
the 30th and 31st his 40 hours would be reached on the 31st and he would see 4 hours 
of overtime for that week in July. 
 
If the software is set up to calculate both weekly and daily and choose the best method, 
when a pay period includes partial weeks, the method of calculating overtime for the 
partial week will default to daily. If the calculation switches from daily to weekly after the 
pay period is closed, any overtime due the employee will be paid in the second pay 
period. If overtime was paid in the first pay period that was not earned then, it will be 
subtracted from the next pay period. The net effect will always be correct and since the 
only legal limitation is that overtime be paid as part of the week it was earned. 
 
For example an employee works 9 hours on the 30th and 31st and is given 2 hours of 
overtime for that partial week in July. He continues to work 8 hours a day for the next 4 
days for a total of 50 hours. Calculated daily he would get 2 hours of overtime but weekly 
he is due 10 hours. He has already been paid 2 hours in the July pay period for that 
partial week so in the August pay period he will get 8 hours of overtime for the rest of the 
week. 
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Export Type options are: 
  

a. None 
b. ADP Export 
c. ADP EZPay Export 
d. CSV Export 
e. PayChex/Time in a Box 
f. MAS50 
g. PayChoice 

 
If you are using PayChoice, your payroll codes must match those used by PayChoice. 
 Acceptable codes as of this writing are: 
 
01 – Regular 
02 – Overtime 
03 – Vacation 
04 – PTO 
05 – Holiday 
08 – Other 
13 – Bonus 
14 – Commission 
 
These codes are subject to change by PayChoice at any time.  We recommend that you 
confirm the current paycodes with PayChoice before inputting them into your software. 
 

i. QuickBooks Export 
 
For information on connecting the software to QuickBooks, please refer to the topic 
Connecting to QuickBooks. 
 

3. Click the Next button to enter Options or Exit to close the System Setup window. 
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Entering Options 

The Options tab allows you to setup a punch interval, select to use military time within the application, 
view or modify your server location, check for updates at startup, clear any grid (list) settings, setup your 
email for notifications and automatic reports, etc.  To access this screen: 
  

1. If you are going through the steps, click Next after you have saved your Payroll Settings or, click 
the Options icon on the left of the System Settings screen. 
 

 
 

2. Enter information in the fields using the help text incorporated on the screen as a guide, then click 
Save to save your information. 
 
Note:  Deselect the Run Setup Assistant at Logon checkbox to stop the System Setup window 
from appearing each time you open the software. 
 
Clear Grid Settings: The Clear Grid Settings button resets all lists screens, such as the 
Employee list, back to the default settings.  For information on how to customize your list 
screens, please refer to the topic Working with Lists. 
 
Setup Email - Click this button to setup your internal email options.  This feature can be used to 
email reports.  When you click the Setup Email button, the following screen will appear: 
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Enter the Server and Port information.  If your SMTP server requires a user name and password, 
you will need to enter information in the Use Credentials section. 
 
Totals as Decimals - Select this checkbox to display the times on the Timecard screen as 
fractions of hours rather than hours:minutes. 
 
Allow Managers Access to Employee Info - Select this checkbox to allow users setup as 
Managers to view and change employee data such as social security numbers. 
 
Show Demographics Data - Select this checkbox to display an employee's demographic data in 
the New and Edit Employee screens. 
 
Set Password Policy - Select this button to setup guidelines for passwords.  Below is an 
example of the Password Policy screen: 
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Select the desired parameter, then enter the limit.  For example, you can select Minimum 
Password Length, then enter 6 in the number field next to it.  This means passwords must be at 
least 6 characters long.  You can choose any combination of requirements.   
 
For instance, if you make the following selections: 
 
Minimum Password Length = 6 
Minimum Number of Numbers = 1 
Minimum Number of Upper Case Letters = 2 
 
Then passwords must be at least 6 characters, contain at least 1 number and contain at least 2 
upper case letters. 
 

3. Click the Next button to enter Departments or Exit to close the System Setup window. 
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Creating Departments 

You can setup departments into which you can organize your employees.  Lists and reports can be 
filtered by department for easier viewing.  To access this screen: 
 

1. If you are going through the steps, click Next after you have saved your Options or, click the 
Departments icon on the left of the System Settings screen.  Note that the department 
Administration appears by default. 
 

 
 

2. Create New: To create a new code, click the New button, then enter an alphanumeric code up to 
4 letters and/or numbers in the Department code field, then enter a name in the Department 
Name field.  For example, the Department Code may be HR, and the Department Name may 
be Human Resources.  Click the Save button to add the new department to your database.  The 
new department will appear in the list at the top of the screen. 
 
Modify Existing: To modify an existing department, highlight the department in the list at the top 
of the screen.  The Department Code and Department Name fields will display the information 
for the selected department.  Change the information in these fields as needed, then click the 
Save button. 
 
Delete: To delete a department, highlight the department in the list, then click the Delete button. 
 A confirmation message will appear.  Click Yes on the message to delete the department.  Keep 
in mind that you cannot delete groups that have employees assigned to them.  If you do need to 
delete a department that has employees assigned to it, you first need to assign those employees 
to a different department on the Employee screen. 
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Print: Click this button to print a list of all departments in your database. 
 
Export: Click this button to export the list of departments to a comma separated file. 
 
 

3. After you have completed this screen, click Next to proceed to the Payroll Codes screen or Exit 
to close the System Settings screen. 

 

Creating Payroll Codes 

This screen allows you to create/modify codes for your different payroll types (overtime, regular time, paid 
vacation, etc.).  If you are using accounting or payroll software, you should enter the codes as they 
appear in those applications.  To access this screen: 
 

1. If you are going through the steps, click Next after you have saved your Departments or click the 
Payroll Codes icon on the left of the System Settings screen. 
 

 
 

2. Create New: To create a new code, click the New button, then enter an alphanumeric code up to 
4 letters and/or numbers in the Payroll Code field, then enter a name in the Payroll Code 
Description field.  For example, the Payroll Code may be OT, and the Payroll Code 
Description may be Overtime.  Click the Save button to add the new payroll code to your 
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database.  The new payroll code will appear in the list at the top of the screen. 
 
Modify Existing: To modify an existing payroll code, highlight the code in the list at the top of the 
screen.  The Payroll Code and Payroll Code Description fields will display the information for 
the selected code.  Change the information in these fields as needed, then click the Save button. 
 
Delete: To delete a code, highlight the code in the list, then click the Delete button.  A 
confirmation message will appear.  Click Yes on the message to delete the code.  Keep in mind 
that you cannot delete payroll codes that are in use.   
 
Print: Click this button to print a list of all payroll codes in your database. 
 
Export: Click this button to export the list of payroll codes to a comma separated file. 
 

3. If you want this payroll code to be used for vacation accrual tracking, select the Include in 
vacation accrual checkbox.  If your third party payroll system tracks vacation accrual, make sure 
you select this checkbox for any vacation payroll codes to ensure they are accounted for correctly 
in the export. 
 

4. After you have completed this screen, click Next to proceed to the Absences screen or Exit to 
close the System Settings screen. 
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Creating Absences 

Enter codes here that you can later assign to employee absences on the Timecard screen to tell the 
system how to calculate pay for those absences.  For instance, you can set up some absences to be 
included in overtime calculations and others not to be included in these calculations.   
 

1. If you are going through the steps, click Next after you have saved your Payroll Codes or click 
the Absences icon on the left of the System Settings screen. 
 

 
 

2. Create New: To create a new code, click the New button, then enter a description in the 
Absence Description field.  Select a Payroll Code from the drop down list (the Payroll codes 
you previously entered will appear in this list), then enter the default number of hours to use for 
this absence.  The number of hours entered here will automatically appear when this absence is 
entered for an employee, but can be changed if needed. 
 
WaspTime Web Only: Select the Set as Default checkbox if you are using WaspTime Web and 
want this absence to be the default for new absences added to an employee's timecard.  This 
means that when you are adding an absences for an employee via WaspTime Web, this 
absences code will appear first.  You can change it if needed. 
 
Select the Paid checkbox if this absence should be paid and/or select the Included in Overtime 
Calculation if this absence should count toward the overtime threshold or be included in overtime 



 

27 

  
WaspTime User Manual 

pay.  Click Save when you have entered all information.  The new code will appear in the list at 
the top of the screen. 
 
Modify Existing: To modify an existing code, highlight the code in the list at the top of the 
screen.  The fields at the bottom of the screen will display the information for the selected code. 
 Change the information in these fields as needed, then click the Save button. 
 
Delete: To delete a code, highlight the code in the list, then click the Delete button.  A 
confirmation message will appear.  Click Yes on the message to delete the code.  Keep in mind 
that you cannot delete absence codes that are in use.   
 
Print: Click this button to print a list of all absence codes in your database. 
 
Export: Click this button to export the list of absence codes to a comma separated file. 
 

3. After you have completed this screen, click Next to proceed to the Statutory Holidays screen or 
Exit to close the System Settings screen. 

 

Creating Statutory Holidays 

This screen allows you to enter paid holidays that you can be applied to employees timecards via 
Utilities>Process Holidays. 
 

1. If you are going through the steps, click Next after you have saved your Absence Codes or, click 
the Statutory Holidays icon on the left of the System Settings screen. 
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2. Create New: To create a new holiday, click the New button, then enter a Name for the holiday 
and select the Date.  Click Save when you have entered all information.  The new holiday will 
appear in the list at the top of the screen.  Keep in mind that holidays spanning more than one 
day will need a holiday created for each day. 
 
Modify Existing: To modify an existing holiday, highlight the holiday in the list at the top of the 
screen.  The fields at the bottom of the screen will display the information for the selected holiday. 
 Change the information in these fields as needed, then click the Save button. 
 
Delete: To delete a holiday, highlight the holiday in the list, then click the Delete button.  A 
confirmation message will appear.  Click Yes on the message to delete the holiday.  Keep in mind 
that you cannot delete holidays that are in use.   
 
Print: Click this button to print a list of all holidays in your database. 
 
Export: Click this button to export the list of holidays to a comma separated file. 
 

3. After you have completed this screen, click Exit to close the System Setup screen. 
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Applying Daylight Savings Time 

The software allows you to apply Daylight Savings Time to all timecards in your system. 
  
Applying Daylight Savings Time: 
  

1. From the Main screen, select Tools > Process Daylight Savings Time.  This Daylight Savings 
Time screen will appear: 
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2. Select the Time Zone to which you want to apply Daylight Savings Time.   

3. Select whether you want to process Daylight Savings Time Start or End.  By default, the usual 
date for DST beginning and end will be displayed here.  You can change the date or time, if 
needed. 

4. A list of employees will appear at the bottom of the screen. This list displays all employees in the 
selected time zone who show an IN punch on their timecard when the adjustment occurred will be 
shown.  If you have created groups (ex. Salary, Hourly, Temp, etc.), you can filter this list by 
groups.  When you click Filter Groups, the following screen appears listing all groups in your 
system: 
 
 

 
 
 
Select individual employees to apply the DST changes to by clicking on the checkbox in front of 
his/her name, or, apply DST to all listed employees by selecting the checkbox at the top of the 
grid, as shown below: 
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5. Click Apply Changes when you have made your selections. 
  

  
  



 

32 

  
WaspTime User Manual 

Clock Setup 

WaspTime allows you to maintain all of your attendance clocks directly from the WaspTime application. 
 Whether you have one clock or 10, or even clocks of different types, this software allows you to setup 
and edit your clock settings from one convenient location.  Remember, your clocks must be connected to 
the network prior to adding them to WaspTime .  Please refer to the Quick Start Guide for instructions on 
connecting your clocks.   
  
Topics in this section: 
  
Clock Setup Screen Overview 
Add Clocks 
Edit Clocks 
Delete Clocks 
Manually Download Punches from Clocks 
Setup Automatic Punch Download Times 
Setup Clock Synchronization 
Verify Clock Connectivity 
  
  
Important! PCPunch is not treated like a clock. Punches from PCPunch are handled as soon as they are 
made by the user; you will not have to download these punches.  You will not see each installed 
PCPunch in your clock list. 
 
Managing Biometric Clocks: From the Clock Setup screen (Clock Setup > Tools > Clock Utility) you 
can add users and fingerprints to your bioclocks and import punches from one clock to another.  A user of 
a clock is considered to be someone who has an employee badge and fingerprints entered on the clock. 
  
  

If you are using biometric clocks, there are a few points to keep in mind. 
  

 
1. Each bioclock holds its own internal database that contains the fingerprint data used to recognize 

employees.    
 

2. You can have other bioclocks setup if, for example, you want to have multiple clocks for 
employees to use or want to have clocks for a subset of employees to use (for example, 
warehouse workers may have their own clock so they do not have to spend time going to a main 
clock to punch in and out).  In this case, you can upload the fingerprint information to that specific 
clock.  The point to remember is, if you are using more than one clock, the clock on which an 
individual employee will be punching in and out must contain that employee's fingerprint 
information, otherwise the clock will not recognize that employee. 
 

3. The fingerprint information is part of your database and is, therefore, automatically backed up 
when you backup your database.  Note: If you have installed the Enterprise version, the Backup 
and Restore options are not available.  You will need to manually backup the database. 

  
All of the functions listed below are accessed from the Clock Setup screen (Main Window > Clocks). 
 The columns in the Clock Setup screen behave as other List screens found in WaspTime (such as 
sorting and moving columns).  For instructions on how to sort or move columns, and for an overview of 
the List screen functionality, please refer to the Working with Lists topic.   
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Below is an example of the Clock Setup screen: 
 
 

 

 

Clock Setup Screen Overview 

The Clock Setup screen is divided into three sections: 
  
  
Main Menu - The Main Menu contains the following options: 
 

1. File - Click File > Exit to close the Clock Setup screen. 
2. Options - 

• Server Settings - Click Server Settings to open the Service Settings screen.  The 
Server Settings option allows you to setup automatic polling options for all of your 
clocks that are set to automatically download. 

• Refresh - Click Refresh to update the clock list shown on the Clock Setup screen. 
3. Tools -  

1. Clock Utility - Downloads the latest information from the clocks and allows you to 
assign users to clocks. 

  
Toolbar  - The toolbar contains the following options: 

• Verify 
• New 
• Edit 
• Delete 
• Download Now 
• Download Setup 
• Time Sync Setup 

  
  
Clock List  - This list displays all clocks you have connected to WaspTime 
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Adding Clocks 

Remember, your clocks must be connected to the network prior to adding them to WaspTime .  Please 
refer to the Quick Start Guide for instructions on connecting your clocks.   
 

1. From the Main Window, click Clocks on the toolbar.  The Clock Setup screen appears (shown 
above). 

2. Click the New button from the toolbar at the top of the Clock Setup screen.  A screen similar to 
the following appears: 
 
 

 
 
 
You have two options on this screen: 
 
 
Option 1 - Search for new clock: The Clock Setup window searches the network to find clocks 
used by WaspTime . This is done by sending out a UDP broadcast to query the network. UDP 
broadcasts will generally not travel across network routers, therefore you must initially setup all 
clocks that will be used by the software on the network local to the PC on which the software is 
installed.  
 
 
Note: From this point forward, all communication with the clocks is done by TCP, which does 
travel across routers.  Once clocks have been ‘discovered’ by the Clock Setup window, they can 
be moved anywhere on your domain for normal day-to-day use. 
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If Clock Setup cannot detect the clock, you will be given the option to add it manually.   

Option 2: Add new clock manually: If your clock cannot respond to the broadcast message, 
select this option to add it manually.  

Select an option, then click the Next button.   

3. If you are auto-searching for a clock, a list of found clocks will appear. 
 
 

 
 
 
Select a clock, then click Next to continue. 

4. The Clock Settings screen appears allowing you to enter setup information. 
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If ClockSetup automatically detected the clock for you, most of the fields on this screen will be 
populated with information.  If you are manually adding this clock , complete the fields as 
described below, then click the Finish button.   
 
 
Note:  Help for each field will appear at the bottom of the screen as you click on each field. 
 
  

• Auto Download - Select True from the drop down menu if punches from this 
clock will be automatically downloaded.  You will set the interval for automatic 
downloads on the Server Settings screen.  You can manually download 
punches at anytime even if you have this field set to True. 
 
 
Select False if you will be importing the punches manually. 
 
  

• Clock Time - Enter the current time to set the clock. 
 
 
Daylight Savings Time Note:  Be aware that your time clocks will NOT 
automatically update with the correct time for Daylight Savings Time, even if 
the PC where the service is installed does automatically update. Usually the 
time change occurs at 2:00 am.  If you have employees who will be working an 
overnight shift that spans 2:00am when the time changes, you will need to 
arrange to have someone change the time on the clocks by entering in the 
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correct time in this field in ClockSetup.  This means you will need to change 
the time back or forward one hour at 2:00am on the day the time change 
occurs. 
 

• Clock Type - Select the clock type from the drop down menu. 
 
 
If you select a bioclock from the drop down list, a new field -  Clock 
Fingerprint Algorithm - will appear on the screen. 
 
 

 
 
 
Your clock will either be running Algorithm version 9.0 or 10.0.  If you are 
using a B2000, you will usually be using 10.0, but can change the field to 9.0 if 
needed.   
 
 
If you have a B1100/B1000, you will be running 9.0. The Clock Fingerprint 
Algorithm field will display 9.0 and the field will be disabled if you select 
B1100/B1000. 
 
 
If you change the value in the Clock Fingerprint Algorithm to 9.0 , and you 
have already added a clock using 10.0, the following warning message will 
appear: 
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• Description - Enter a description of this clock.  You may want to enter a 
physical location to help you identify the clock.  Example: Clock near the front 
door. 

• IP Address - Network clocks arrive with the IP Address set to 127.0.0.1. In 
this case we show 0.0.0.0 in the IP address window. This is a ‘loopback’ 
address that cannot be used to communicate across the network. In order for 
the software to communicate with the clocks, the IP Addresses must be set to 
a valid IP Address. 
 
 
Enter the IP address in this field.  Notice that the area where you enter this 
information is formatted.  Each section can hold three characters, therefore, if 
a section has two numbers and a period (.), you must enter the period. 
 
 
Example: If the IP Address is 555.55.55.55, you would enter 555 55. 55. 55 
 
 
Note on Editing the IP Address:  
 
 
Wx100 - If you edit the IP address on this clock, the clock CANNOT be 
connected over a router.  ClockSetup sends a UDP broadcast message to the 
clock when you change the IP address. This message cannot cross a router 
(this is the same situation as adding a new clock).  You must move the clock 
to the local network where the PC on which you installed ClockSetup is 
located, then change the IP address. Once the change is made, ClockSetup 
communicates with the clock via TCP IP, which can cross a router so you can 
move the clock as needed.  Changing the IP address in ClockSetup changes 
the address in the database and on the clock. 
 
 
All Other Clock Types - Changing the IP address in Clock Setup changes the 
IP address in the database only; the IP address actually set on the clock is not 
changed.  You will need to change the IP address on the clock as well so 
Clock Setup can continue to communicate with that clock.  Instructions for 
changing the IP address is included in the user manuals that came with your 
clocks.  

• MAC Address - This read-only field will display the MAC address of the clock 
when this information is available to the system. 

• Status - Select Active or Inactive from the drop down menu. 

• Time Format - Select 12 Hour Format or 24 Hour Format.   

• Time Zone - Select the time zone where the clock is located. 
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5. After you have entered all information, click the Finish button.  The clock will be added to 
the Clock Setup screen as shown below: 
 
 

 
 

Editing Clock Settings 

You can edit a clock’s settings by following the instructions below: 

1. From the Main Window click Clocks.  The Clock Setup screen (shown above) appears. 

2. On the Clock Setup screen, highlight the clock you want to edit in the list, then click the Edit 
button.  The Clock Settings screen appears populated with the selected clock's information. 
 
 

 

3. Make changes as needed, then click the Save button. 
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Deleting a Clock 

1. To delete a clock from your system, from the Main Window toolbar, click Clocks.  The Clock 
Setup screen appears (shown above). 

2. On the Clock Setup screen, highlight the clock you want to delete and click the Delete button. 
 The following confirmation screen appears: 
 
 
 

 

3. Click Yes on this screen to delete the clock. 
 

Verifying Clock Connectivity 

After you have entered your clocks, you can make sure the application is communicating with them by 
"verifying" their connectivity. 

1. To verify a clock, from the Main Window, click Clocks.  The Clock Setup screen appears 
(shown above). 

2. On the Clock Setup screen, highlight the clock you want to verify, then click the Verify button, or 
click the Verify button without selecting a clock to verify all clocks in your list.  The system will be 
unavailable while it tries to communicate with the clocks.  A symbol appears in front of each clock 
with which the system is able to successfully communicate. 
 
 

 
 
 
If the system is not able to communicate with the clocks, a symbol appears in front of the clock 
and a message appears as shown in the graphic below: 
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3. If the Verify process is successful, you are finished!  When you close and re-open the 
application, you will need to click the Verify button again if you want to make sure all clocks still 
have connectivity. 

  
  
  
  

  



 

42 

  
WaspTime User Manual 

 

Clock Utility 

The Clock Utility screen allows you to download fingerprint and employee information from your 
clocks.  You can then assign employees in WaspTime to certain clocks.  The Clock Utility is useful 
when you are transition from an old clock to a new one.  You download all employee, badge and 
fingerprint information from the old clock and use the Update Clocks feature to assign those users to a 
new clock and push the data to the new clock. 
  

1. From the Clock Setup screen, select Tools > Clock Utility. 
 
 

 
 
 
The Download Clock Data screen appears: 
 
 

 
 
 
The Download Clock Data displays all clocks you have connected to WaspTime. 
 
 
Note:  If you try to close the screen by clicking the red x in the top, right corner at this point, the 
following warning message appears: 
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Click Yes to close, No to continue the download process.  You will not lose any data if you 
close at this point. 

2. To being downloading employee data, select the clocks from which you want to download data, 
then click the Start button. 
 
 

 
 
 
A progress bar will appear on the screen and the status will display at the bottom. 
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When the download is complete, a confirmation message will appear at the bottom of the 
screen. 
 
 

 
 
 
 
Note:  If you attempt to close the Download Clock Data screen during the download process, 
the following warning message appears: 
 
 

 
 
 
Click Yes to cancel the download and close the screen.  Click No to continue the download.   If 
you cancel the download, no new data will be saved to your database. 

3. Click the Next button to begin processing the downloaded data.   
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4. If badges are found on the clock that do not exist in WaspTime, the following message will 
appear: 
 
 

 
 
 
Click Yes to delete the badges from the clock.  Click No to leave them on the clock.  Since 
these badges do not match those in WaspTime, they will not appear in your downloaded data. 
 
 
 
A progress screen will appear if you are downloading fingerprints: 
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5. The Update Clocks screen appears. 
 
 

 
 
 
This clock lists all employees found on the clocks that match those in WaspTime, along with the 
clock(s) they are assigned to.   
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There are two ways to assign employees to clocks. 
 

1. On the Basic Assignment tab, you can change clock assignments or assign them to a 
new clock by selecting the checkboxes.  By default, all employees are selected.
 
Important!  Do not deselect any clock or employee on a clock, 
unless you want to delete that employee or all employees from the 
clock.  
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2. The Employee Clock Assignment tab lists the same information as the Basic 

Assignment tab, but organizes it in a different way. 
 
 

 
 
 
The top of the screen lists all clocks connected to WaspTime. Click on a clock  to view employees 
assigned to it. All employees assigned to the selected clock appear  in the Selected Employees on 
clock section. By default, all employees will be assigned  to a clock.  You can manually remove an 
employee from a clock (meaning that employee  will not be sent to the selected clock) by following the 
instructions below.  
 
Employees  you have removed from the selected clock appear in the Available Employees section.  
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To add an employee to the clock, highlight the employee(s) in the Available Employees section and click 
the right arrow button: 
 
 

 
 
 
The employee(s) will now appear in the Selected Employees on clock section: 
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To remove an employee from a clock, highlight the employee in the Selected Employees on Clock 
section and click the left arrow: 
 
 

 
 
 
The employee(s) will now appear in the Available Employees section. 
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6. When you are done adding and/or removing employees from your clocks, click the Update 

Clocks button at the bottom of the screen. 
 
 

 
 
 
The Push Data to Clocks screen appears.  A progress bar will appear on the screen and the 
status will display at the bottom. 
 
 

 
 
 
When the upload is complete, a confirmation message will appear at the bottom of the screen. 
 
 

 
 
 

7. Click Close to complete the process and return to the Clock Setup screen. 
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Creating/Editing Automatic Downloads from Clocks 

The Download Setup screen allows you to set up a clock for punch downloads into WaspTime and on a 
specific date, time and frequency (once, daily or monthly) or edit, export, delete or print an existing 
download setup for one or more clocks. 
  
This topic covers: 
  
Creating/Editing Automatic Download Times 
Deleting an Automatic Download 
Exporting the List of Automatic Downloads 
Printing the List of Automatic Downloads 
Understanding Download Statuses 
Troubleshooting Downloads 

 

Creating/Editing Automatic Download Times 

You can setup one or more of your clocks to automatically download punches at a specified time by 
following the instructions below. 
  

1. From the Main Window, click Clocks.  The Clock Setup screen appears. 
 

2. Click the Download Setup button.  A screen similar to the following appears: 
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3. Note:  This list screen behaves as other list screens in the software.  For information on the List 
screens, please refer to Working with Lists. 
 
Select the New button to add a new automatic download or highlight a listing on the screen and 
click Edit to make changes to an existing download.  The Automatic Download Settings screen 
appears: 
 

 
 
Note:  This screen will be populated with the selected download's information if you are editing a 
download. 
 

4. Enter a Description, select a Clock and enter the Time and Frequency for the download. 
 
Available Frequencies are: 
 

• Once - The download will run once at the specified time. 
• Daily - The download will run daily at a specified time. 
• Monthly - The download will run monthly at a specified time.  If you select Monthly, you 

can choose the day on which to run the download.  You can choose from the dates 1 
through 28 or End of Month, since all months have dates 1 through 28, while only 
some have the dates 29, 30 or 31.   (For example, June has 30 days while July has 31 
so selecting Last Day of Month will set the download to occur on June 30 and again on 
July 31.) 
  

5. Click OK when you have completed the screen.  A confirmation message will appear and your 
new auto download will appear on the Automatic Download List. 
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Deleting an Automatic Download 

1. From the Main Window, click Clocks.  The Clock Setup screen appears. 
2. Click the Download Setup button.  The Automatic Download List appears (shown above). 
3. Highlight the download you want to delete, then click the Delete button. 

 

Exporting the List of Automatic Downloads 

Export allows you to export the entire list to a comma-delimited text file.   
 

1. When the Export button is selected, a screen appears allowing you to specify where the exported 
data will be saved on your computer.  An example of the Export screen is shown below: 
 

 
  

2. Make sure you save this to a location you can remember.  You must also choose a name for your 
file on this screen.  After you have made your selections, click Save to export your data. 
 
A confirmation message will appear when your data has been successfully exported by the 
system.   
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Printing the List of Automatic Downloads: 

1. Print allows you to print the list.  Select the Print button on the toolbar of the Automatic 
Downloads List.  A standard Page Setup screen appears allowing you to enter margins.  An 
example of this screen is shown below: 
 

 
 

2. Click the OK button on the Page Setup screen to print the list.  The list will print to your default 
printer.  To change which printer the list is sent to, click the Printer button on the Page Setup 
screen.  A Printer selection screen similar to the one shown below appears: 
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Understanding Download Statuses (Pass/Fail) 

When running normally, your automatic downloads will occur at the specified times with no errors.  When 
this occurs, the Download Setup screen will list Pass in the Result column.  If there is a problem, Fail will 
appear in the Results column.  When you see Fail, one of two problems have occurred: 
  
The Download Ran with Errors: This means your download did run, but contains errors.  The system 
will handle this differently depending on the Frequency you have selected. 
  

1. Once - A 'Once' schedule will NOT attempt to run again, so you must edit the schedule (by 
highlighting the listing on the Download Setup screen and clicking Edit) to attempt another 
download in the future. 

2. Daily - If a 'Daily' download has failed today, the system will NOT try to download again 
until tomorrow, unless the schedule is edited (by highlighting the listing on the Download 
Setup screen and clicking Edit). 

3. Monthly - If a 'Monthly' download has failed today, the system will NOT try to download 
again until next month on the date and time specified, unless the schedule is edited (by 
highlighting the listing on the Download Setup screen and clicking Edit). 
 

The Download was Missed:  This may occur if the service was down at the time the download was set 
to run.  As with errors, the system will handle missed downloads differently depending on the Frequency 
you have selected. 
  

1. Once - A 'Once' schedule will run again as soon as the service is back up. 
2. Daily - A 'Daily' download will run the next day at the time specified. 
3. Monthly - A 'Monthly' schedule will attempt to download again as soon as the service is back up. 

 

Troubleshooting Downloads 

Auto-Polling - Keep in mind that if Auto-Polling on the Service Settings screen is set to FALSE, all 
automatic downloads, syncs and backups will be turned off.  If Auto-Polling is set to TRUE, all automatic 
downloads, syncs and backups will run on schedule.  Refer to the Service Settings topic for more 
information. 
  
Clock Connectivity and Server Log - If you receive a Fail message, make sure your clock is connected. 
 On the Clock Setup screen, you can Verify the clock to make sure it is communicating with the 
software.  Refer to the Clock Setup topic for information on Verifying the clocks.  If the clock is not 
connected, refer to the Clock Troubleshooting section.  If the clock is connected, the log will contain 
further information on what went wrong.  The log can be accessed from Program Files > Wasp 
Technologies > WaspTime > WaspTimeServer.log. 
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Manually Downloading Punches from a Clock 

You can manually download punches from your clocks at anytime, even if you have them set to auto 
download. 
 
  

1. To manually download punches, from the Main Window toolbar, click Clocks.  The Clock Setup 
screen appears. 
 

 
 

2. You have two choices for downloading: 
 

1. Highlight the clock from which you want to download punches and select Download Now 
> Download.  This will download punches from the selected clock only. 
 

 
 
The system will retrieve the punches for you and populate the Timecard Screen in 
WaspTime. 

3. Select Download > Download All.  This will download punches from all clocks. 
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When Download All is selected, the following status screen appears listing all clocks. 
 

 
 
A progress bar will appear at the top of the screen while punches are being downloaded.   
 

 
 
When all punches are downloaded, the bottom of the screen will state "Finished getting punches 
from all clocks" as shown in the screen shot above. 
 
Click Exit at the bottom of the Download All Punches screen to return to the Clock Setup 
screen. 
 
While the system is downloading punches, all other functions in Clock Setup are unavailable. 
 You can minimize the application and work on other tasks while the punches are downloading. 
 
 
Important!  If the system is unable to download the punches, an error message will appear and 
the icon next to the clock will change.  This indicates that the clock is offline.  Make sure the clock 
is on and that you have the correct IP address entered for this clock.  For more information on 
possible causes of not being able to download information, see the Troubleshooting section. 
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Creating/Editing Clock Synchronize Times 

The Time Sync Setup tool allows you to setup a time for your clocks to sync to the server time. 
  
The topics discussed in this section are listed below: 
  
Creating/Editing Automatic Synchronization Times 
Deleting an Automatic Synchronization 
Exporting the List of Automatic Synchronizations 
Printing the List of Automatic Synchronizations 
Understanding Sync Statuses (Pass/Fail) 
Troubleshooting Syncs 
Daylight Savings Time Note 

 

To Setup a Synchronization Time 

1. From the Main Window, click Clocks.  The Clock Setup screen appears. 
 

2. On the Clock Setup screen, click Time Sync Setup.  The Automatic Clock Time Syncs screen 
appears. 
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3. Click New on the Automatic Sync List.   The following screen appears: 
 

 
  

4. Enter a Description for this sync in the Description field, then select which clock you want to 
sync from the list. 
 

5. Select the Frequency, then enter a date and/or time for the sync. 
 
Available Frequencies are: 
 

• Once - The sync will run once at the specified time. 
• Daily - The sync will run daily at a specified time. 
• Weekly - The sync will run weekly at a specified day/time. 
• Monthly - The sync will run monthly at a specified time.  If you select Monthly, you can 

choose the day on which to run the download.  You can choose from the dates 1 
through 28 or End of Month, since all months have dates 1 through 28, while only 
some have the dates 29, 30 or 31.   (For example, June has 30 days while July has 31 
so selecting Last Day of Month will set the download to occur on June 30 and again on 
July 31.) 
 

6. Click OK to save your auto sync.  It will now appear in the List of Automatic Clock Time Syncs. 
 

To Delete an Automatic Synchronization 

1. From the Main Window, click Clocks.  The Clock Setup screen appears. 
2. Click the Time Sync Setup button.  The Automatic Clock Time Syncs screen appears (shown 

above). 
3. Highlight the sync you want to delete, then click the Delete button. 
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To Export the List of Automatic Synchronizations 

Export allows you to export the entire list to a comma-delimited text file.   
  
  

1. When the Export button is selected, a screen appears allowing you to specify where the exported 
data will be saved on your computer.  An example of the Export screen is shown below: 
 

 
  

2. Make sure you save this to a location you can remember.  You must also choose a name for your 
file on this screen.  After you have made your selections, click Save to export your data. 
 
A confirmation message will appear when your data has been successfully exported by the 
system.   
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To Print the List of Automatic Synchronizations 

1. Print allows you to print the list.  Select the Print button on the toolbar of the Automatic Clock 
Time Syncs screen.  A standard Page Setup screen appears allowing you to enter margins.  An 
example of this screen is shown below: 
 

 
 

2. Click the OK button on the Page Setup screen to print the list.  The list will print to your default 
printer.  To change which printer the list is sent to, click the Printer button on the Page Setup 
screen.  A Printer selection screen similar to the one shown below appears: 
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Understanding Sync Status (Pass/Fail) 

When running normally, your automatic syncs will occur at the specified times with no errors.  When this 
occurs, the Automatic Clock Time Syncs screen will list Pass in the Result column.  If there is a problem, 
Fail will appear in the Results column.  When you see Fail, one of two problems have occurred: 
  
The Sync Ran with Errors: This means your sync did run, but contains errors.  The system will handle 
this differently depending on the Frequency you have selected. 
  

• Once - A 'Once' schedule will NOT attempt to run again, so you must edit the schedule (by 
highlighting the listing on the Automatic Backup screen and clicking Edit) to attempt another 
backup in the future. 

• Daily - If a 'Daily' sync has failed today, the system will NOT try to sync again until tomorrow, 
unless the schedule is edited (by highlighting the listing on the Automatic Backup screen and 
clicking Edit). 

• Weekly - If a weekly sync has failed, the system will NOT try to sync again until the next 
week, unless the schedule is edited (by highlighting the listing on the Automatic Backup 
screen and clicking Edit). 

• Monthly - If a 'Monthly' sync has failed today, the system will NOT try to sync again until next 
month on the date and time specified, unless the schedule is edited (by highlighting the listing 
on the Automatic Backup screen and clicking Edit). 
 

The Sync was Missed:  This may occur if the service was down at the time the sync was set to run.  As 
with errors, the system will handle missed syncs differently depending on the Frequency you have 
selected. 
  

• Once - A 'Once' schedule will run again as soon as the service is back up. 
• Daily - A 'Daily' sync will run the next day at the time specified. 
• Weekly - The 'Weekly' sync will run the next week at the specified day/time. 
• Monthly - A 'Monthly' schedule will attempt to sync again as soon as the service is back up. 

 

Troubleshooting Syncs 

Auto-Polling - Keep in mind that if Auto-Polling on the Service Settings screen is set to FALSE, all 
automatic downloads, syncs and backups will be turned off.  If Auto-Polling is set to TRUE, all automatic 
downloads, syncs and backups will run on schedule.  Refer to the Service Settings topic for more 
information. 
  
Clock Connectivity and Server Log - If you receive a Fail message, make sure your clock is connected. 
 On the Clock Setup screen, you can Verify the clock to make sure it is communicating with the 
software.  Refer to the Clock Setup topic for information on Verifying the clocks.  If the clock is not 
connected, refer to the Clock Troubleshooting section.  If the clock is connected, the log will contain 
further information on what went wrong.  The log can be accessed from Program Files > Wasp 
Technologies > WaspTime  > WaspTimeServer.log . 
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Daylight Savings Time Note 

Be aware that your time clocks will NOT automatically update with the correct time for Daylight Savings 
Time, even if the PC where the service is installed does automatically update.  You must set up an 
alternate sync at the time of the change.  Usually the time change occurs at 2:00am.  If you have 
employees who will be working an overnight shift that spans 2:00am when the time changes, you will 
need to arrange to have someone change the time on the clocks by entering the correct time through 
Clock Setup.   
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Service Settings 

The Server Settings option allows you to setup automatic polling options for all of your clocks that are 
set to automatically download. 
  
To View/Edit Server Settings: 
  

1. From the Main Window, select Clocks.  The Clock Setup screen appears. 
 

2. On the Clock Setup screen, select Options > Server Settings.  The Service Settings screen 
appears: 
 

 
 

3. Enter or change information on this screen as needed.  Help text for each field appears at the 
bottom of the screen as you click in the fields.  Each field is described below: 
 

• Auto Polling - Select True from the drop down list if you want to automatically poll clocks 
at a certain time.  If this is set to true, all clocks set to download punches automatically 
 (this option is set on the Clock Settings screen when you add or change a clock ) will 
download at a certain interval. 
 
Select False from the drop down list if you do not want to poll clocks automatically at a 
certain time.  If this option is set to False, clocks will not be automatically downloaded, 
even if you have selected True in the Auto Download field for individual clocks. 
 

• Server Name - Enter the name of the computer where you have the Service installed. 
 
Be very careful when editing this field.  If you enter incorrect information here, the 
software will not be able to communicate with the Service. 
 

• Server Port -  This field displays the port number for the server where you have the 
Service installed.  Usually this number is 10002.   
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On the machine where the service is installed, the software will use the port number 
you entered plus one port up as well.   For instance, if you enter port 10002, the 
software will also tie up port 10003, making both unavailable for other uses.  If you 
enter 1010 here then port 1010 and port 1011 will be used. 
 
Changing the port number on this screen does NOT affect the port being used on the 
machine where the service is actually installed.  This field tells the software how to 
communicate with the service.  If you enter the wrong port number here, the software 
will not be able to communicate with the Service. 
 

4.  After you have entered the information, click the OK button to save your changes. 
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Troubleshooting Clocks 

The System is Unable to Verify a Clock(s) or Fails to Connect to the Service 
I Stopped the Service and Cannot Restart It 
Using the Software if There are Multiple Network Cards on the Service Machine 
Selecting a Valid IP Address 
  
  
The System is Unable to Verify a Clock(s) or Fails to Connect to the Service:  

This error occurs when you are trying to add new clocks or otherwise communicate with the service, but 
your Service Settings are incorrect.  This could mean that your service is not running, or that the wrong 
port number or server name is entered in the Service Settings screen.  You may receive an error 
message similar to the following when trying to search for new clocks: To resolve this issue, follow the 
steps below. 
 
First Verify that the Service is Running:  
 
Note: These steps should be performed on the machine where the Service is installed. 

 
1. Click Start > Control Panel > Administrative Tools > Services.  A list of all 

installed services appears.  Notice the Status column displays Started if the service 
is running.  Look for WaspTimeServer in the list. 
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1. Highlight the WaspTimeServer listing, then click Start. 
 

 

2. When the service is started, the listing will display Started in the Status column. 
 

 

Make sure the clock is connected to the network:  Make sure the Ethernet cable is securely 
connected to the PC and to the clock. 

Make sure the correct Server Port and Server Name are entered on the Service Settings 
screens: 

If starting the service did not resolve this issue the Server Port or Server Name may be wrong on the 
Service Settings screen in ClockSetup.  To change the port number: 

1. Open the Clock Setup screen 

2. Click Options > Server Settings.   
 

 
  

3. It may take a few seconds for the screen to open and you may receive the following 
message if the screen contains incorrect information: 
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Click OK on this screen to access the Service Settings screen. 

4. Verify that the Server Name and Server Port fields contain the correct information. 
 
 
Server Name - Enter the name of the computer where you have the Service 
installed. 
 
 
Server Port - This field displays the port number for the server where you have the 
Service installed.  Usually this number is 10002.  This field should always be set to 
10002 unless you have something else installed on this port. 
 
 
Both of these settings initially populate from information you entered on the 
Installation Wizard -  Remote Database/Service Server Name screen when you 
were installing this product.  This tells ClockSetup how to communicate with the 
Database and Service.  
  
 
If you do not know the computer name of the machine where you installed the 
service, follow the steps below: 
 
 
For Windows XP and Windows 2003 Server:  
  
 
Note:  The screen shot shown below is from Windows XP. The appearance of the 
Windows 2003 Server screen may vary slightly. 

1. On the computer where you installed the Database and Service, click Start > 
Control Panel > System.  The System Properties screen appears. 
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b. Click the Computer Name tab.   

c. Enter the computer name listed here in the field on the Service 
Setting screen. 
  

For Windows 2000: 

a. Click Start > Settings > Control Panel > System.  The System 
Properties screen appears. 

b. Click on the Network ID tab. 

c. Enter the computer name listed on this screen in the field on the 
Service Settings screen. 

Make sure you have the clock's correct IP address entered in ClockSetup:  
 
 
The steps for verifying the clock's IP address vary depending on the type of clock you have.  Refer to the 
clock manual for more detailed instructions. 
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B2000 Clock: 

1. From the Main screen, use the arrow keys to highlight the Comm icon.  Press the M 
key. 

2. On the Comm menu, highlight the Network icon and press the M key. 

3. The IP address appears at the top of the screen. 

4. Make sure this address matches the address entered in ClockSetup.  For instructions 
on changing the IP address listed in ClockSetup for the clock, see the Editing Clock 
Settings section. 

BC100, RF200, HD300 Clock 

You will not need to manually check the IP on a Wasp Clock.  WaspTime can communicate with this 
clock to determine the IP address so the address displayed in ClockSetup is the correct IP address. 

 

I Stopped the Service and Cannot Restart It: 

If you need to stop your Service, you might get an error message when trying to restart it.  This happens 
if you try to restart it too soon after stopping it.  The port the service is running on is freed after a short 
wait (usually 1-2 minutes) after which you can restart the service on that port.  If you try to start the 
service before this time, the process will fail.  The actual wait time depends on your operating system 
and the number of processes (applications, etc.) you have running.  If you find you are unable to restart 
 the service after stopping it, wait a few minutes, then try again. 

 

 Using ClockSetup if There are Multiple Network Cards on the Service Machine: 

1. Create a registry entry on the machine where the Service is installed under 
"HKEY_LOCAL_MACHINE\SOFTWARE\Wasp Technologies\WaspTime\Options. 
 
 
name: ListenOnIPAddress 
type: string value 
value: the actual ip address in the format of: dotted-quad notation (such as: 555.55.55.55) 
 
 
To do this: 

1. Click Start > Run. 
2. Type regedit in the Open field, then click OK. 
3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wasp 

Technologies\WaspTime\Options. 
4. Right-click in the right-hand window and select New > String Value as shown below: 
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The new registry entry appears labeled New Value #1. 
 
 

 

5. Rename the entry ListenOnIPAddress, then press [ENTER]. 
 
 

 

6. Double-click on your new entry.  The Edit String screen appears. 

7. Type the actual IP address of the machine where you installed the service, then click 
OK. 
 
 
 
The address should be in the format of dotted-quad notation (ex. 555.55.55.55). 
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2. On the machine where you installed the WaspTime application(s), edit the registry entry labeled 
"TimeServer" under HKEY_LOCAL_MACHINE\SOFTWARE\Wasp 
Technologies/WaspTime/Options. 
 
 
To do this: 

1. Click Start > Run. 
2. Type regedit in the Open field, then click OK. 
3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wasp 

Technologies\WaspTime\Options. 
4. Double-click in the TimeServer entry. 

 
 

 
 
 
The Edit String screen appears. 

5. The name of the machine where the service is installed appears in the Value 
Data field.  Change this to be the actual IP address of the machine where the 
service is installed, then click OK. 
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3. On the machine where you installed ClockSetup and PCPunch, edit the registry entry 
labeled "TimeServer" under HKEY_LOCAL_MACHINE\SOFTWARE\Wasp 
Technologies\WaspTime\Options following the steps listed in Step 2, above. 

 
  
Selecting a Valid IP Address: 

The IP address of the clock should match the net mask on the machine where your service is installed. 

To determine the net mask: 

1. On the computer where you installed the service, select Start > Run. 
2. Type cmd in the Open field, then click the OK button.  The Command prompt screen appears. 

On the Command prompt screen, type ipconfig.  Your computer’s settings will appear.  A listing for 
Subnet Mask will appear.  You need to match your IP address to the format of your Subnet Mask.   
Example: If your Subnet Mask is 255.255.0.0 and the IP Address shown on the ipconfig screen is 
192.168.0.1, you should set your clock’s IP Address to 192.168.xxx.xxx where the last two sets of 
numbers are any numbers of your choosing between 1 and 254.   

Also, the IP Address you select should not already be in use.  If you are in doubt, you can Ping the IP 
Address you selected to make sure it is not being used.   
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Import from File into Database 

Import allows you to bring existing Department, Group, or Employee data in from a file external to the 
database. 
  
You must import information in the following order: 
  

1. Department 
2. Group 
3. Employee 

 
When importing your employees, make sure the group_id and dept_id in the employee file match the 
group and department ids you already imported.  If these numbers do not match, the employees will not 
import correctly. 
There are examples of the import format on your installation CD in the Samples folder.  These examples 
are in .csv (comma-delimited) format. 
  
  
To Import Data: 
  

1. From the Main Window, select Tools > Import.  The Import Assistant screen appears. 
 

2. Select Import from File into Database and click the Next button.  The screen shown below 
appears: 
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3. Enter the name of the file to import or click Browse to navigate to it on your computer, then select 
the table to which you want to import.  Click Next to continue.  The Field Delimiter screen 
appears. 
 

 
 

4. Step 2 of the wizard allows you to specify how you want your information broken up in the import 
file.  This is called the Field Delimiter.   Make your selection from the Field Delimiter drop down 
list, then select the checkbox if you want to include field names in the first row of your export file. 
Select the First row contains column headings option only if the first record of the file you are 
importing does not contain actual data.   WaspTime cannot remove subtotals, section headers, 
nor any other records within the file that do not match the format of the actual data records. 
 These must be removed before you attempt the import.   
 
The table displays the information using the selected delimiter, as shown above.  If all the data is 
in one column of the preview pane, you have not selected the right Delimiter. 
 
Click Next to continue.  The Field Mapping screen appears: 
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5. This screen allows you to associate columns in your imported data file with corresponding fields 
in the table into which you are importing the data.  Depending on the contents of your original 
database, not every column in your imported data needs to be mapped to a corresponding field in 
WaspTime. The object is to bring over at least the required fields and any others that may be of 
use. 
 
Note:  Your .csv or .txt file may have column headers with names that do not exactly match the 
software field names the way this example data does. By mapping the imported data's columns to 
the software table's columns, any difference in field names can be accommodated.   
 
If the names of the columns in your import file are the same as those in the WaspTime database 
you can use the Auto Map button to match them quickly.  Click Next to continue.   
 

6. Next a confirmation message will appear stating your import was completed successfully. 
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Import from QuickBooks 

This window allows you to import employees or payroll items from Quick Books into WaspTime . See the 
QuickBooks documentation for instructions on exporting to an .IIF file. 
Notes:   
  

1. If you are running the software on Vista, you must be assigned user rights in order to import to or 
export from QuickBooks.  Logging in to WaspTime as an admin will not enabled you to 
import/export with QuickBooks if you do not have user rights on the Vista machine.   
 

2. At this time, QuickBooks prevents WaspTime from sending in\out times to QuickBooks 2008 and 
later if the QuickBooks Payroll service is turned on.  This is a limitation of QuickBooks and may 
be resolved at a later date. 
 

To import from QuickBooks: 
 

1. From the Main Window, select Tools > Import.  The Import Assistant screen appears. 
 

2. Select Import from Quickbooks and click the Next button.  The screen shown below appears: 
 

 
 

3. Select Employees or Payroll Items from the drop down list, then click Next.   
 

4. The system will establish a connection with QuickBooks.   
 
After the file is created select it and pick a default department and group. You will want to change 
each employee after import to put him or her in the correct group and department. 
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5. Click the Finish button to complete the operation. 
 
A report will display that lists the successfully imported employees and any employees that were 
not. 
 

For information on connecting the software to QuickBooks, please refer to the topic Connecting to 
QuickBooks. 
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Export 

You can export information, including Employees and Groups to a text or .csv file from various list 
screens within the software.  For detailed information on the List screens and on Exporting information, 
please refer to the topic Working with Lists. 
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Group List Example 

The Group List window allows you to view all of your previously created groups.  Groups allow you to 
establish more than one set of rules for paying employees who fall into a variety of payment categories, 
such as Exempt, Nonexempt, Night Shift, Normal Shift, and Contract workers.   
 
Below is an example of the Groups List screen: 
  

 
  
The Group List window allows you to Edit, create New, Copy, Delete, Show, Filter, Export or Print 
Groups.  For detailed information regarding each of these options, refer to the Working with Lists topic. 
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Adding/Editing Groups 

Groups allow you to define sets of schedules and rules for clocking in and out, time rounding, grace 
periods, break and meal periods, overtime and holidays. 
  
The Groups screen allows you to set time processing rules and schedules for employees. 
  
The following items are discussed in this topic: 
  
Accessing the Adding/Editing Groups Screen 
Schedule Tab 
In/Out Rules Tab 
Breaks Tab 
Meals Tab 
Overtime Tab 
  
This screen also gives you the option to Apply Changes to Prior Pay Periods. 
  

 

Accessing the Adding/Editing Groups Screen 

1. From the Main Window, click the Groups button on the toolbar.  The Groups List screen 
appears.  For more information on the List screen, please refer to the Working with Lists topic. 

2. On the Groups List screen, click New to add a new group, or highlight a group in the list and 
click Edit to edit an existing group.   A screen similar to the following will appear (if you are editing 
a group, that group's information will populate the fields on the screen): 
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3. Enter a Name for this group.  The group name stays visible when you change tabs. 
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Schedule Tab 

The Schedule tab (shown on page 89) is where the regularly scheduled work hours are set for the 
Group, as well as the Pay Code that should be applied to those hours. Click the Save button when you 
are done making changes to this tab.   Note that helpful information is built into the screen to assist you 
with completing each field.   
  
Select the Working checkbox next to each day on which this employee is scheduled to work.  If the 
Working checkbox is not selected, then the employee will not be considered scheduled to work on that 
day, even if times are entered in the In and Out field. 
 
Schedules are used to determine if an employee is tardy or leaving early. Schedules are also used to limit 
a user if your company policy does not allow employees to clock in early or clock out late and to calculate 
overnight shift rules. 
  
To enter times on the schedule, click in the desired day field, then enter the shift in and out times.  Notice 
that after you enter the scheduled times, you can select a date in the Weekly Day Bounds section, then 
click the Calculate button to see how the schedule will be applied for a given week.   
  
Select Report Tardies for Employees in this Group if you want late in punches for this group to appear 
on the Tardy report. 
  
Important Note!  Please be aware that if there is a chance an overnight employee will be coming in at 
times other than his/her regular schedule, you MUST enter time in all days on which the employee could 
possibly come to work.  For example, if the employee might come in on a Saturday when his/her regular 
schedule is Monday through Friday, you should enter time in the Saturday fields as well, otherwise the 
software will consider the day for Saturday as 12:00am through 11:59pm rather than the employee's 
actual day, and the times will not total correctly.  When this is the case, make sure you only select the 
Working checkbox for those days the employee is regularly scheduled to work. 
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In/Out Rules Tab 

The In/Out Rules tab allows the user to set rules governing Shift In/Out times.  Below is an example of 
this tab: 
  

 
  
This tab is divided into two sections: In Rounding and Out Rounding. 
  
Rounding To/Round Up After: Set the time interval to round, as well as the cut-off point for rounding up. 
  

Example:  If the Round To field was set to 15 (minutes), and the Round Up After field was set to 7 
the following rules would apply: An employee clocks in at 7:51 - time is rounded to 7:45. An 
employee clocks in at 7:52 - time is rounded up to 8:00 (7:45 + 7 minutes).  This rounding happens 
on final calculation of the time. The actual clock in and out times will be shown on the timecard. 
  
New groups do not round by default. The usual use for rounding is to encourage employees to 
arrive and leave on time. Check with local and national rules about what rounding is allowed. 
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Grace Period: Set the number of minutes that an employee can arrive tardy or leave early without 
penalty. If the user arrives late or leaves early within the grace period his actual time will be shown on the 
timecard but he will be paid for the full time he is scheduled to work. For instance if the employee is 
scheduled to work from 7am to 5pm and clocks in at 7:10, if the grace period is 15 minutes he/she will get 
paid as if the clock in time was 7am. 
To set a Grace Period, select the Grace Period radio button, then enter the number of minutes: 
 
 

 
  
This feature is often used if there are many people using one clock all at the same time and you don't 
want to penalize people for having to wait in line. It can be used with rounding to penalize people who are 
late but the Grace Period will be applied before any rounding. 
  
Penalty Period: Set the number of minutes (up to 60) that an employee will be penalized for arriving late 
or arriving early.  If an employee clocks in late or out early, he/she will be paid for the actual punch times 
on the timecard.  For example, if the employee is scheduled to work from 7 to 5 and clock in at 7:15, if the 
Penalty Period is set to 15 minutes, the employee will be paid starting at the punch time of 7:15. 
 
 
To set a Penalty Period, select the Penalty Period radio button, then enter the number of minutes (up to 
60): 
 
  

 
  
Early In / Late Out: Specifies whether or not employees are credited for time that they work when they 
arrive early or stay late. If these options are not checked and the employee is in a group with a schedule, 
that employee will not get credit for the actual time if he or she arrives early or leaves late. 
  
Unpaid Buffer: After you select the Early In Paid/Late Out Paid options, you can select to add an Unpaid 
Buffer.  This setting allows up to 60 minutes before a schedule starts or after it ends as unpaid buffer. 
 When used, employees who punch in/out within the buffer will be paid as if they punched in/out at the 
scheduled time. 
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To set an Unpaid Buffer, select Early In Paid (or Late Out Paid), then select Unpaid Buffer.  Enter the 
number of minutes, up to 60, of unpaid buffer time in the Preliminary Buffer field. 

 
  
Preliminary and Concluding Period:  The Preliminary and Concluding Periods are events that happen 
before the shift starts or after it ends like waiting in line to clock in or out or to be paid. If you want to allow 
an employee to clock in early or clock out late, assuming you have disallowed early in and late out, you 
can do that by setting the Preliminary and/or Concluding Activity Period. 
  

A Note on Rounding 

  
Rounding in WaspTime is done differently for the in/out times than for the meal or break times. 
  
The software does not round the final calculated time for the day because in work places where 
employees come and go many times, the rounding would not average out over time and may lead to a 
violation of FLSA rules. Even if the In and Out times are rounded to an exact multiple 15 minutes, it is 
possible that the total time for the day will not be a multiple of 15 minutes because breaks, meals, 
rounding or the grace period may add or subtract time that is not an increment of 15 minutes. 
  

1. In/Out Rounding 
 
 
The in and out times are each rounded up or down independently based on program settings.  
 
Round To is the setting that tells the program what increment of an hour you want to see the in 
and out times rounded to. Multiples of this round to number of minutes will be used to determine 
how to round. 
 
The Round Up After number is used to determine how many minutes after the multiple of the 
Round To number to use as the break point between round up and round down. If you set this 
number to 5 anyone who is 6 minutes after the hour or more is rounded up. Five minutes after the 
hour would be rounded down. 
 
For instance if you want anyone who comes in late to be penalized up to 15 minutes you could 
set the In Rounding -> Round To = 15 and Round Up After to 1. Every employee who is 2 
minutes late up to 15 minutes late will be shown as in at 15 minutes past their scheduled clock in 
time. The seconds are not used for calculations. 
 
If you want to give employees a Grace Period which we define as an amount of time after they 
are scheduled to arrive or before they are scheduled to leave that they can come in late or leave 
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early and still get paid you can use the Grace Period setting. It can be set up to 59 minutes. The 
Grace Period overrides the rounding rules and allows an employee who comes in after his 
scheduled in time to be paid as if he had arrived at his scheduled time or leaves before his 
scheduled out time to be paid as if he had left at the scheduled time. 
 
 Rounding can be set to occur after 0 minutes for in/out punches, breaks and meal times. 

2. Break/Meal Rounding 

Breaks and meals are usually dealt with as an amount of time allowed rather than a scheduled 
time.  Because of this, the breaks and meals are rounded according to the time taken, not the time 
the meal or break started and ended. 
Some companies need a break or meal to be scheduled to an exact time and the employee to be 
penalized if he does not stick to those times. The software does not have a way to schedule 
breaks or meals or penalize based on a schedule. 
If you require an employee to take a meal or break of a certain duration, the software does track 
and round based on the meal or break duration. 

 

Breaks Tab 

The Breaks tab allows you to set rules governing employee breaks.  The concept of a break or meal is 
used to help the software know how to treat time the employee is out between the in and out punches. 
Each set of punches that happen between the in and out time for a day is categorized as either a meal or 
a break. Let’s call each set of punches an out time. You can define 2 meals and 2 breaks. Each out time 
is categorized as a break or a meal using the following method. 
  

1. If meal 1 is turned on and only one out time is made it will be Meal 1 type. 
2. If two or more out times are made and if meal 1 is on and break 1 are on, the first will be Break 1 

and the second will be Meal 1. 
3. Any other combination of out times and turned on Meals and Breaks will be categorized in order 

of Break 1, Meal1, Break 2, Meal 2, Break 1 (Repeated). 
4. If any one of the meals or breaks are turned off they will never be assigned as a type. 
5. At least one meal or break time must be turned on so the system knows how to treat out times. If 

you do not allow any out times we suggest you turn off all the meals and Break 2 and make Break 
1 unpaid. 
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Below is an example of this tab: 
  

 
  
Breaks Checkboxes - The checkbox to the left of 1st Break and 2nd Break allows you to specify an 
order for breaks and meals. Un-checking this box will prevent time punches for people in this group from 
being entered in these time slots. You should only un-check this option if you need to reorder the 
expected meal and break times. 
  
If you are expecting the break to always come after the first meal you must un-check the 1st Break box 
because the software always expects the first break to come before lunch and the next to come after 
lunch. 
  
Type - Each Break or Meal can be treated on one of five ways: 
  

1. Paid - Time categorized as paid will be paid and will be included in overtime. The duration of a 
paid break or meal is not considered. The whole break or meal is always paid. 
 
 
If a meal or break is paid there is no reason for it to be automatically deducted because there is 
nothing to deduct.   
 
 
It can be subject to eligibility. If a paid meal or break is not eligible it will not be paid. 

2. Unpaid - Time categorized as unpaid will not be paid or included in overtime. 
 
 
The duration of an unpaid break or meal is considered only if the break or meal is automatically 
deducted. The whole break or meal is unpaid regardless of duration if there are actual punches 
for the break or meal. For example an unpaid meal is set up for 30 minutes. If the employee 
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punches out for 35 minutes the entire 35 minutes will be deducted. If the employee only takes a 
10 minute meal only 10 minutes will be deducted. 
 
 
If however the meal is automatic and the employee takes 35 minutes but does not punch out, 
only 30 minutes will be deducted since there is no way for the program to know the actual meal 
length. 
 
 
Eligibility for a unpaid meal or break is only considered if the meal is automatically deducted. If 
punches for the meal or break are made eligibility is not considered but if there are no punches 
and the employee is not eligible no break will be automatically deducted. 

3. Paid (Limited) - Time categorized as paid limited is paid up to the duration of the break or meal 
and then the rest is unpaid. If an employee is allowed a 30 minute paid break and he takes 35 
minutes, his timecard will show a 5 minute deduction. 
 
 
Paid limited meals or breaks are never automatically deducted. 
 
 
Paid limited meals or breaks can be subject to eligibility. In this case if an employee is not eligible 
for a paid meal or break the entire duration of the break or meal will be deducted. 

4. Unpaid (Minimum) - Time categorized as Unpaid (Minimum) always deducts a minimum number 
of minutes from the employee each day that employee is in. 
 
 
If the meal or break is set up as unpaid minimum for 30 minutes and an employee punches out 
and in for 35 minutes the entire 35 minutes is deducted. If the employee punches out for 10 
minutes 30 minutes is deducted. If an employee does not punch out, 30 minutes is deducted if 
Automatic Deduction is selected. 
 
 
Eligibility is not considered unless automatic is on and no punches are registered for this meal or 
break. In this case the deduction will only be applied if the employee did not punch out for the 
break or meal and is eligible. If the employee punches out and in for this meal or break the unpaid 
minimum rules will always apply even if he is ineligible. 
 
 
This type is automatically deducted by default. Deselecting the Automatic Deduction checkbox 
will cause eligibility to be disregarded and will mean that employees who do not punch out will not 
get any deduction. 

5. Unpaid Minimum Unless Eligible - Time categorized as Unpaid Minimum Unless Eligible 
always deducts a minimum number of minutes from the employee each day that employee works 
unless they are eligible in which case the lunch is paid. 
 
 
If the meal or break is set up as unpaid minimum for 30 minutes and an employee punches out 
and in for 35 minutes the entire 35 minutes is deducted. If the employee punches out for 10 
minutes 30 minutes is deducted. If an employee does not punch out, 30 minutes is deducted if 
the Automatic Deduction checkbox is selected and the employee is ineligible. If the employee is 
eligible up to 30 minutes will be paid. Time over 30 minutes will be deducted. 
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Eligibility is not considered unless automatic is on and no punches are registered for this meal or 
break. In this case the deduction will only be applied if the employee did not punch out for the 
break or meal and is not eligible. If the employee punches out and in for this meal or break the 
unpaid minimum rules will always apply even if he is eligible. 
 
 
This type is automatically deducted by default. Deselecting the Automatic Deduction checkbox 
will cause eligibility to be disregarded and will mean that employees who do not punch out will not 
get any deduction. 

Duration - The scheduled duration of the Paid (Limited) and Unpaid (Minimum) breaks. 
  
Daily Eligibility - The amount of time, in hh:mm format, that the employee needs to work to be eligible to 
take this break. 
  
There are two types of eligibility. 
  

1. Prior Accumulation means that prior to the time that the break or meal is taken (If there are 
punches) the employee must have the Time Required accumulated or he is ineligible for that 
meal or break. 

2. Daily Accumulation means that if the Time Required is not accumulated by the punch out for the 
end of the day the employee is ineligible for that break or meal. All time is considered for eligibility 
from the first punch in to the out for the meal or break or to the punch out for the day. 
 
 
For example if a meal or break is eligible daily after 8 hours and the employee punched in at 
8:00am and out at 5:00pm he has 9 hours of eligibility is eligible. 
 
 
If the employee took an hour and a half meal in the middle of the day that time is not deducted 
from eligibility unless it is not the break or meal being considered and is before the break or meal 
being considered. 
 
 
For example if the employee took a 30 minute break and then an hour long meal that is under 
consideration, he will still have worked 8:30 that day and will be eligible. If he took a 1:30 minute 
break before the meal the daily time would be 7:30 minutes and the employee would be ineligible. 
 
 
If the 1:30 minute break came after the meal under consideration it is not included in the 
calculation because we would get into a looping problem where a break or meal after another 
break or meal cancels the prior break or meal that in tern cancels the later break or meal. 

Automatic Deduction - If this is checked, the software will automatically deduct breaks from an 
employee’s timecard. In effect, employees will only need to punch in and out for the day’s shift, and the 
software will deduct break times according to the specified settings. If an employee does punch in or out 
for breaks, those actual values will override the automatic deductions. 
  
In most cases automatic meals and breaks should be used when an employee is required to take a meal 
or break. This setting means that an employee will be penalized for not taking the meal or break because 
they will not get paid for time they worked. 
  
If you require a paid or unpaid meal or break and use the Unpaid or Paid type, the actual duration of the 
meal or break will be taken into consideration so the employee could cheat the system by only taking a 1 
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minute meal or break. If you require a certain duration make the break or meal an Unpaid Minimum or 
Paid Minimum type. 
  
Rounding - Sets the time interval to round to, as well as the cut-off point for rounding up. For instance, 
you can configure the software so that Break In/Out times are rounded to 15 minute intervals, rounding up 
after 7 minutes.  For additional information on rounding, please see the section of this topic labeled A 
Note on Rounding. 
  

 

Meals Tab 

The Meals tab allows you to set up options for how meal time is handled.  Below is an example of the 
Meals tab: 
  

 
  
Meals Checkboxes - The checkbox to the left of 1st Meal and 2nd Meal allows you to specify an order 
for breaks and meals. Un-checking this box will prevent time punches for people in this group from being 
entered in these time slots. You should only un-check this option if you need to reorder the expected meal 
and break times. 
  
This feature is used to manipulate how WaspTime accounts for the punches that come in. There is no 
way to know from the data that comes in from the time clocks for which time slot each punch is intended. 
You can use these checkboxes to help tell WaspTime what to expect. 
  
In WaspTime we expect that if there are only 4 punches for a day, they are for in out and the lunch meal. 
When you use the checkboxes on the Meals tab you are telling WaspTime that you do not have meals. 
You will be forcing the punches that would normally go into meals to go into breaks. 
  
The other settings for meals work the same way as those for breaks. 
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Overtime Tab 

The Overtime tab sets the rules for calculating overtime.  Note:  This screen defaults to Calculate Best.   
  
By law, overtime is always calculated weekly. A week is defined as 7 days but not necessarily Sunday 
through Saturday. This allows you to pick which day of the week you want to start your overtime week. 
You might change the first day of the week to simplify your reporting or because your industry has weekly 
days off different from Saturday and Sunday. 
  
There are exceptions to the rule that requires overtime to be calculated on a 7 day week, but WaspTime 
does not support those kinds of overtime weeks at this time. 
  
Below is an example of the Overtime tab: 
  

 
  
WaspTime supports California's specific overtime regulations. Please see the California Overtime Rules 
topic for details. 
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Daily Calculation Method - You can choose Daily Only, Weekly Only, Calculate Best Method or 
None.  If you choose Weekly Only, you can specify how many total hours in the week an employee must 
work before qualifying for overtime. If you choose Daily Only, you can specify how many hours each day 
an employee must work before qualifying for overtime. If you select Calculate Best Method,   WaspTime 
will automatically calculate whether daily or weekly overtime is greater and will report the larger of the 
two.  The Timecards will also show how overtime has been calculated. 
  
Note that beside each day of the week, there is a drop down menu. This menu gives you the following 
options: 
 
 
Normal: This is the default setting.  If Normal is selected, all hours recorded for an employee more than 
the hours listed will be counted as overtime.  For example, if you enter overtime after 8 hours in the 
Monday field and select Normal, all hours an employee in this group works over 8 hours will be 
considered overtime. 
  
All:  If All is selected, all hours worked on this day will be considered overtime. 
  
None:  If None is selected, overtime will not be applied to any hours worked on this day. 
  

Overtime Selections: 
  
Weekly Overtime - This time is calculated using a threshold total after which all time is overtime. 
The standard weekly overtime threshold is 40 hours. Once an employee works 40 hours in a pay 
week, all time worked after the 40 hours is overtime. 
 
 
For example, if the first day of the week is Tuesday and you work 8 hours every day of the week, 
then on Saturday you will have accumulated 40 hours. If you work any hours on Sunday or 
Monday, these hours count as overtime. 
  

Total: Specify the number of hours that must be worked before overtime is paid. 
Days Required: Specify number of days required to be eligible for overtime. 
Pay Factor:  The amount by which a member of this group’s pay changes for overtime.  (for 
example, 1.5 for time and a half) 
Payroll Code: The payroll code that will be applied to this group’s overtime. 
  

Daily Overtime  - This time is calculated using a daily total threshold after which all time is 
overtime. The standard daily overtime threshold is 8 hours. Once an employee works 8 hours in a 
day, all time worked after the 8 is overtime. 
 
 
For example if you work 10 hours today, you will get 8 hours of regular pay and 2 hours of 
overtime. 
  

Daily Requirements: For daily overtime, specify the amount of time required per day before 
overtime is paid.  Select the Normal checkbox 
Total: Specify the number of hours that must be worked before overtime is paid.  If you 
want overtime for this group to be calculated on a daily basis only, enter 0 in this field.   
 
If you want the system to calculate both daily and weekly overtime and use the larger of the 
two totals, enter a number in this field. For example if an employee works four - 12 hour 
days in a weekly pay cycle, he has 48 hours total. If the daily overtime is set to start at 8 
hours each day (every hour over 8 hours is considered overtime) and the Total is set to 40, 
he would have 16 hours of daily overtime but only 8 hours of weekly overtime. In this 
situation, WaspTime will report 16 hours of overtime. If the employee is on a 24-hour 3-day 
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work week (24 in Total, 8 hours for each day) but works an extra day, he would have 32 
total hours. If he worked 8 hours each day, however, he would have no overtime on a daily 
calculation. In this case he would show 8 hours of weekly overtime. 
  

Daily vs. Weekly Overtime – By law in some states an employer must use the overtime calculation that 
is most beneficial to the employee on any given week. If daily overtime gives the employee more overtime 
hours than weekly overtime, then it must be calculated that way. 
  
WaspTime handles making this decision for you. If you have thresholds for both daily and weekly 
overtime set up, WaspTime will do both calculations and apply the one that gives the employee the most 
overtime. 
  
For example, assume daily overtime is set to 8 hours a day and weekly overtime is set to 40 hours a 
week. An employee might work 8 hours every day of the week. In this case the employee has worked 56 
hours. The employee would receive no overtime pay if you calculate overtime on a daily basis, but the 
employee would receive 16 hours of overtime if you calculate overtime on a weekly basis.   WaspTime 
will choose to calculate weekly overtime. 
If the next week that employee worked 16 hours a day for 3 days only, he or she would have worked 48 
hours that week. The employee would receive 24 hours of overtime calculated for daily overtime but only 
8 hours of overtime calculated for weekly overtime. WaspTime will choose to calculate daily overtime. 
  
Pay Factor: The amount by which a member of this group’s pay changes for overtime.  (for example, 1.5 
for time and a half). 
  
Payroll Code:  Select the payroll code that will be applied to this group’s overtime hours.  The payroll 
codes you setup on the System Setup > Payroll Codes tab will appear in the drop down list. 
  
Export Scheduled Regular Hours Only -  This feature tells WaspTime to only export scheduled hours to 
the payroll file for employees in this group. Check this box if you want to only have the hours that the 
employees in this group are scheduled to work exported. For instance, if you have a group of salaried 
employees and you want to track their overtime but do not want to report it to ADP and show it on their 
paychecks, you should check this box and make sure this group has a schedule. Then when the export is 
done for these employees they may have worked 90 hours in a two-week period but if their schedule only 
shows 80 for two weeks then they will only get 80 on their paycheck. If they worked fewer than 80 hours 
their actual hours will be reported. 
  
Regular Hours Payroll Code - Select the payroll code you want to apply to regular hours worked (hours 
that are not overtime).  The payroll codes you setup on the System Setup > Payroll Codes tab will appear 
in the drop down list. 
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Apply Changes to Prior Pay Periods 

This feature allows you to make changes to the rules used in prior pay periods. By default, changes made 
to groups affect time cards in the current pay period only. WaspTime does this to maintain the history of 
pay. 
We do not recommend changing the rules in older pay periods. Doing this will change the totals on old 
time cards and they will no longer reflect the actual amounts paid to employees or reported to your 
accounting system. 
Often, users of time and attendance packages are into the next pay period before reviewing and updating 
the one they are about to export. If you find you need to change the last pay period to make it correct, 
select this checkbox and put a 1 in the number spinner. 
  
When you save the changes to this group they will apply to the last pay period and you can then go into 
the timecard and see how the change affected totals. 
  
Not all group changes will force changes on the older time cards because WaspTime may not have 
enough information to make the changes for you. In these cases you will have to manually update each 
old timecard to properly reflect the group rules. 
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California Overtime Rules 

This software supports California's specific overtime rules that were implemented in 2000. These rules 
apply to all non-exempt employees as defined by the California Legislature and the Industrial Welfare 
Commission in its Wage Orders, to all non-exempt employees as defined by the Fair Labor Standards 
Act, and to those required by state provisions. 
  
These policies include: 
  

1. First eight hours worked on the seventh consecutive day of a work week must be paid at 1.5 
times the normal hourly rate. 

2. Over eight hours on the seventh consecutive day of a work week must be paid at 2.0 times the 
normal hourly rate. 

3. One day of rest in seven is required. That can be met if employees receive the equivalent amount 
each calendar month. Weekly reconciliation is not required.  Use the Monthly Required Days 
Off report to help you comply with this rule.  This report is accessed by selecting Reports > 
Monthly Required Days Off. 

4. Employees are allowed to "make-up" short, personal time-off absences without activating a 
requirement for paid overtime. Time must be made-up within the same work week as the 
personal time that was taken. Employees with alternative work weeks are not eligible to use the 
make-up provision.  Use the Makeup Time screen to designate the days and hours the employee 
will be making up.   

5. Overtime must be paid at 1.5 times the normal rate after 8 hours of work in a day.  Overtime must 
be paid at 2.0 times the normal rate after 12 hours of work in a day. 
 
 
Note: To enable support of these special policies, make sure the Apply California Overtime 
Rules checkbox is selected in the Overtime tab of the Groups screen. 

California Overtime Calculation "And" Method 
  
In California, the law reads and is interpreted in a way that is more beneficial to the employee and 
therefore it overrides other laws. The California law states that employees will get overtime after 8 hours a 
day AND after 40 hours a week. In other states the AND is an OR and therefore is interpreted to mean 
that if daily overtime is more beneficial to the employee than weekly you get paid using the daily 
calculation. With the And Method however time over 40 hours that is worked and not part of daily 
overtime is added to the daily overtime. 

Example Best Method Calculation: (Daily Best) 
Day Sun Mon Tues Wed Thurs Fri Sat TOTAL 
Hours 
Worked 

  8 11 8 5 8 2 42 

Regular 
Hours 

  8 8 8 5 8 2 39 

Overtime 
Hours 

  0 3 0 0 0   3 
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The employee would get paid 39 hours of regular time and 3 hours of overtime because the daily 
calculation gives the employee 3 hours of overtime. The weekly calculation would give the employee 40 
hours of regular time and 2 hours of overtime. 
  
Example Best Method Calculation: (Weekly Best) 
Day Sun Mon Tues Wed Thurs Fri Sat TOTAL 
Hours 
Worked 

  9 8 8 8 8 2 43 

Regular 
Hours 

  8 8 8 8 8 2 42 

Overtime 
Hours 

  1 0 0 0 0   1 

 
The employee would get paid 40 hours of regular time and 3 hours of overtime because the weekly 
calculation gives the employee 3 hours of overtime. The daily calculation would give the employee 42 
hours of regular time and 1 hours of overtime. 
  
Example California And Method: 
Day Sun Mon Tues Wed Thurs Fri Sat TOTAL 
Hours 
Worked 

  9 8 8 8 8 2 43 

Regular 
Hours 

  8 8 8 8 8 2 42 

Overtime 
Hours 

  1 0 0 0 0   1 

 
In this example the numbers are exactly the same as in the Weekly Best method above but the employee 
gets paid 40 hours of regular time. The 2 hours of regular time that are over 40 get moved into overtime 
and the employee gets paid 3 hours of overtime. This method is very similar to weekly but there are 
circumstances where they would calculate different numbers. 
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Employees: Adding/Editing 

Employee List 

The Employee List screen allows you to view all of your previously created employees.  From this screen 
you can also add or edit employees, view timecards, export a list of employees or print a list of 
employees.  Please see the Working with Lists topic for detailed information on these functions. 
  
Below is an example of the Employee List screen. 
  

 
   
  
  

  



 

100 

  
WaspTime User Manual 

 

Adding/Editing Employees 

The Employees screen allows you to define those employees whose time you want to track in the 
software. At least one employee must be defined to make use of the Timecards function. On this screen 
you can add and edit information about your employees. 
  
When you are adding employees, keep in mind that the number of employees allowed on your system by 
your license is equal to the number of employees plus admin/managers you add here.   
  
The following items are discussed in this topic: 
  
Accessing the Add/Edit Employee Screen 
Management Tab 
Security Tab 
Clock Tab (appears only if WaspTime is connected to a biometric clock such as the B2000, or to 
the Wasp clocks BC100, RF200, HD300). 
Personal Tab 
Picture Tab 
Pay Tab 
Notes Tab 

 

Accessing the Add/Edit Employee Screen 
 

1. From the Main Window, click the Employees button on the toolbar.  The Employee List 
appears. 

2. On the Employee List, click New if you are adding a new employee or highlight an employee in 
the list and click Edit if you are editing an existing employee.  A screen similar to the following will 
appear (if you are editing an employee, that employee's information will populate the fields on the 
screen): 
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Note:  The Clock tab only appears if WaspTime is connected to the B2000 biometric clock or to 
the Wasp clocks BC100, RF200, HD300. 

3. Enter an Employee ID.  The Employee ID field automatically populates with the next available 
employee number.  For instance, if you just entered Employee 11, this field will say 12.  You can 
type a new number into this field as needed.  This number should be the same as the Badge 
Number, but can be a different number if you need it to be.  This field must be numeric only. 
 
 
The number in the Employee ID field should match the employee's ID number on the clock. 

4. Enter the employee's Last Name, First Name and Middle Initial. 
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Management Tab 

The Management tab (shown above) holds organizational information about an employee including: 
Department, Group, Badge Number and Status.  Enter information in the fields, then click the Save button 
to save your changes.  Each of the fields on this tab are described in the table below: 
  

Field Description 
Badge Number This field is required when entering a new employee. 

Enter the number that is encoded onto the employee's badge.  This 
number is recorded when he/she uses the time clock. 
The card number must match exactly the number entered into the 
Badge Number field for the software to recognize the information 
coming in from the time clocks and to record the time to the correct 
employee. If preprinted WaspTime cards came with your product, the 
number is printed on the outside of the card. If leading zeros are 
included as part of the number on the employee's card you can choose 
to include them in the Badge Number or omit them  (Example: 
00000004184). 
  
This number is not used on reports. 
  
Note:  Wasp Biometric Clock Users - The Wasp biometric clock 
B1000 and B1100 accepts badge numbers from 1 to 65534.  The B2000 
biometric clock accepts badge numbers up to 9 digits.  Alphanumeric 
badge numbers will not work with the Wasp Biometric Clocks.  In 
addition, as with other clocks, the badge number entered in WaspTime 
must match the user id/badge assigned to the employee or the 
employee's punches may be mixed up with other employees. 

Department This field is required when entering a new employee. 
  
Select a department from the drop down menu. The department is used 
to group employees on certain reports. This allows you to print a report 
for a specific department or after printing, distribute the reports by 
department.  Departments must be created prior to creating employees. 
 You can create departments in the System Setup screen (Main 
Window > Settings > Departments).  Please refer to the topic System 
Setup for detailed instructions regarding creating departments. 

Group This field is required when entering a new employee. 
  
Select a group from the drop down menu. Groups define how the time 
for each employee is handled (salaried, hourly, contract, etc.)  Groups 
must be created prior to creating employees.  You can create groups in 
the Add/Edit Groups screen (Main Window > Groups > New).  Please 
refer to the topic Adding/Editing Groups for detailed instructions 
regarding creating departments. 
  
You can change an employees assigned group at any time.  If you 
change the group the following screen will appear asking how many 
prior pay periods (if any) should be applied to this change: 
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Enter the number of pay periods in the Apply to Prior Pay Periods 
field, then click OK. 

Supervisor Select a supervisor from the drop down menu.  Any employee can be 
the supervisor of another employee. This feature is provided to allow 
organizational charts and certain reports to be printed broken down by 
supervisor.  All employees will appear in the Supervise drop down 
menu. 

This field is optional. 
Office Phone Enter the employee's internal contact information.  This field is optional. 
Employment 
Dates 

Enter the employee's Start Date, End Date (if any) and Next Review 
date. 

Employment dates entered into the software are used for reporting 
purposes only; they do not affect how data is used.  The Start Date 
defaults to the date the employee is set up in the software. You should 
change this to the date the employee actually started working.  The End 
Date is intended to help record when an employee left the company. 
The Next Review date is used in the Reviews report to remind the 
employer when an employee's review is due. 

These fields are optional. 
Job Title Select the employee's job title from the drop down list.  You can also 

type in a new job title in the field.  Job titles you enter here will be saved 
and appear in the Job Title drop down list. 

Home Time Zone Enter the time zone where the employee is located.  All punch times will 
be displayed on the time card in the employee's time zone.   

Status (Active, 
Inactive, Leave) 

Select the employee's current employment status.  Active employees 
show up on all reports. Inactive employees are excluded from most 
reports. Employees on leave are excluded from some reports and 
included on others. 
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Security Tab 

Use this tab to enter the employee's login name, password, security level and indicating if timecard 
approvals are needed. 
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Field Description 
Name If you are requiring users to login to the system or if you have set the Password 

Required option on the System Setup>Options screen, a login Name must be 
entered.  In addition, if you will be using WaspTime Web, you will need to create 
a login Name. Enter the user's login Name here.    
 
  
WaspTime Web Note:  If you will be using NT Authentication to automatically 
log employees into Wasptime Web, you must make their Login Name the same 
as their PC login name (the login they use to access your domain).  The 
password does NOT need to be the Network password because the password 
will not be used to authenticate the user on the network. Keep in mind that you 
should not use a generic password since someone else using this login will be 
prompted for a password. When you use NT Authentication with WaspTime 
Web, if a user is logged into your domain with their NT user name and 
password, and if their Login Name in WaspTime is the same as their NT login 
name, when they open WaspTime Web it will authenticate and grant access 
without asking that user for a user name and password. This setup may be 
desirable for certain secure locations, but be aware that if a user leaves his PC 
logged in and walks away from it, anyone can use WaspTime Web to gain 
access from that machine. 
  

Security 
Level 

Select the user's Security Level from the drop down list.  Options are: 
  

1. Employee -  Can access PCPunch and can punch in and out using any 
clock. 

2. Manager - This user has all the privileges of Employees.  Managers can 
also access the software to view and edit their employee’s timecards. 
Managers also have a limited set of reports they can run that only show 
data for the employees that report to them. Managers cannot view 
reports pertaining to payroll. 

3. Admin - Can access all programs and modify all data for all employees. 
This user has all the privileges of Managers and Employees and can 
process and export payroll. 

Password If you have selected the Use PCPunch checkbox, or if you have set the 
Password Required option on the System Setup>Options screen, a password 
must be entered.  In addition, if you will be using WaspTime Web, you will need 
to create a password. Enter the user's password here.  
 
 
WaspTime Web Note:  If you will be using NT Authentication to automatically 
log employees into Wasptime Web, you must make their Login Name the same 
as their PC login name (the login they use to access your domain).  The 
password does NOT need to be the Network password because the password 
will not be used to authenticate the user on the network. Keep in mind that you 
should not use a generic password since someone else using this login will be 
prompted for a password. When you use NT Authentication with WaspTime 
Web, if a user is logged into your domain with their NT user name and 
password, and if their Login Name in WaspTime is the same as their NT login 
name, when they open WaspTime Web it will authenticate and grant access 
without asking that user for a user name and password. This setup may be 
desirable for certain secure locations, but be aware that if a user leaves his PC 
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logged in and walks away from it, anyone can use WaspTime Web to gain 
access from that machine. 

Verify 
Password 

Re-enter the password. 

Employee 
Approval 
(Professional 
Version 
Only) 

Check this box if the employee must approve his/her weekly timecard. 

Manager 
Approval 
(Professional 
Version 
Only) 

Check this box if the manager must approve this employee's weekly timecard. 

Approval 
Required 
Only if there 
is Overtime 
(Professional 
Version 
Only) 

Check this box if timecard approval is only required if there is overtime. 

Allow 
Punches 
from 
PCPunch or 
WaspTime 
Web 

Select this checkbox if you want to enable this employee to use PCPunch or 
WaspTime Web  for clocking in and out.  A User ID and Password are required 
if you select this checkbox. 

Never Export 
Payroll 

Select this checkbox to prevent this employee from being included on the payroll 
export list. 

Clear Prints 
(Edit User 
only) 

This button will only be enabled if the employee is enrolled on a biometric clock 
and fingerprints have been downloaded to WaspTime.  Click the Clear Prints 
button to delete all fingerprints for the employee.  When selected, the following 
confirmation message appears: 
 
 

 

Click Yes to clear the fingerprints from the database.  You can return to the 
Clock tab and download new fingerprints for the employee from the clock. 
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Clock Tab 

The Clock tab only appears if WaspTime is connected to the B2000 biometric clock or to the Wasp clocks 
BC100, RF200, HD300.   
  

 
  

Field Description 
Name Enter the login name (if any) the employee will use on the clock.   
Security Select the security level this employee will have on the clock.  Options 

are: 

1. Punch Only 
2. Enroller 
3. Admin 
4. Supervisor 

Note:  The B2000 clock only has two security levels, User and Admin. 
 Punch Only will be added to the clock as User and Enroller, Admin 
and Supervisor will be added as Admin. 

Password You can optionally enter a password for the employee to use for 
punching in/out of the clock.  This field must be numeric. 

If you are setting this user to Admin, Enroller or Supervisor, you will need 
to create a password. 

Verify Password Re-enter the password. 



 

108 

  
WaspTime User Manual 

Download 
Fingerprints 
from Clock 

Select this checkbox if you want to download fingerprints for this 
employee from the clock.  If you have more than one biometric clock, use 
the drop down list to select the clock from which you want to download 
fingerprints.    Note:  If you only have one biometric clock, the clock 
selection drop down will be disabled.  If you do not have a biometric 
clock, the Download Fingerprints from Clock option will be disabled.  
  
The fingerprints will download when you click the Save button. 
  
If WaspTime does not detect an active biometric clock (such as the 
B2000), the Download Fingerprints from Clocks checkbox is disabled. 

Select Clocks Select the clock(s) to which you want to upload data using the 
checkboxes. 

Upload to 
Clocks 

Select this checkbox to upload the data entered on this tab (Name, 
Password) to the clock when the Save button is selected.  Any existing 
name and/or password data already on the selected clock(s) will be 
overwritten with the new data.   
  
This checkbox is only enabled for new WaspTime employees or if you 
have not already uploaded the employee's data. 

 

Personal Tab 

The Personal tab stores an employee’s Social Security Number (SSN, SIN or NIN), Contact Information 
and Demographic Information.  Enter information in the fields, then click the Save button to save your 
changes.  This data is used for reporting only. 
  
Note:  Demographic data is not available in the Australian version of WaspTime. 
  
Below is an example of the Personal tab: 
  

 
  
You can hide the demographic data by de-selecting the Show Demographic Data option on the System 
Setup > Options tab. 
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Picture Tab 

The Picture tab allows you to attach a picture of the employee to their WaspTime file. 
  

 
  
To add a picture: 
 

1. Select the Add button at the bottom of the Picture tab: 
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OR 
 
 
Click the center of the Picture tab select Add Image from the popup menu: 
 
 

 
2. A standard Windows Explorer screen appears.  Navigate to the picture you would like to attach, 

then click Open.  The selected picture will appear in the Picture tab. 
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3. You can continue to add pictures as needed using the Add button or the popup menu.  Only the 
picture you have selected as the default picture will appear in the Picture tab.   

  
To Change the Default Picture 
  

1. Click on the image in the Picture tab to display the popup menu. 
 
 

 

2. Click on Select Image to view a list of pictures attached to this employee. 
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3. Select a new picture from the menu.  The image you select will appear in the Picture tab. 
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To Delete a Picture: 
  
You have two options for deleting pictures.  You can: 
  

1. Delete the default image by clicking the Delete button on the Picture tab. 
 
 

 
 
 
The default picture (the image showing on the picture tab) will be deleted. 
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2. Delete an image other than the default image by clicking on the picture tab to view the popup 
menu.  On the popup menu, selecting Delete, then clicking on the image you want to delete from 
the resulting picture list. 
 
 

 

  
To View the Picture: 
  
You can view the default picture in the Windows Picture Viewer (or the picture viewer you have set as 
default on your PC) by clicking the View button. 
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Pay Tab 

Use this tab to identify the method for paying an employee and how much that employee is paid. Some 
reports use this data to calculate the base wages that an employee is due according to the timecards and 
group settings. 
  

 
  
Enter information in the fields, then click the Save button to save your changes.  Each of the fields on this 
tab are described in the table below: 
  

Field Description 
Hourly/Salaried Select whether this employee is paid by the hour or receives a salary. 

  
Hourly 
Rate/Salary 

Displays the employee's salary or hourly rate. 

The amount entered here is transferred to the JobTrack application and 
appears in the Hourly Cost History section on the Employee 
Maintenance screen (only Administrators have access to this screen). 
 This information is transferred from WaspTime to JobTrack only once. 
 Subsequent changes made to this information, either in JobTrack or in 
WaspTime are NOT transferred to the other application. 
Example: The first time you open John Doe's Employee Maintenance 
screen in Job Track, his hourly rate entered in WaspTime appears in the 
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Hourly Cost History section.  You can then add to this amount as 
needed (adding in bonuses, per diem or any other cost that affects the 
budget of projects he is assigned to).  The changes you make in the 
Hourly Cost History section are NOT transferred back to WaspTime as 
the information in WaspTime is a base rate and should not include 
bonuses, etc.  Changes made to this information in WaspTime are also 
not transferred back to JobTrack. 

This data alone should not be used for making payroll checks 
because it does not consider account taxes. 

Effective Date Displays the date this pay rate went into effect. 
Rate History 
Table 

This table grid displays all rates setup for this employee along with their 
effective dates. 

Full Time/Part 
Time 

Select whether this employee is full time or part time. 

 
To Create a New Rate: 
  

1. Select whether this is an Hourly or Salaried employee. 

2. Click the New Rate button below the Rate History Table.  A screen similar to the following 
appears: 
 
 

 

3. Enter the Rate and select an Effective Date. 

4. Click the OK button to save your new rate.  You will be returned to the Edit Employee 
Screen/Pay tab. 

To Delete a Rate: 
  

1. Highlight the rate you want to delete in the Rate History table. 

2. Click the Delete Rate button. 
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Notes Tab 

The Notes tab allows you to enter notes (up to 255 characters) about an employee as well as 
Emergency Contact information.  This data is used for reporting only.   
  
Below is an example of the Notes tab: 
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To Add a Note: 

1. Click the Add Note button.  A screen similar to the following will appear: 
 
 

 

2. Enter your note text in the field, then click the OK button. 

3. Your note will appear in the Notes section along with the date and time the note was entered. 
 
 
Note:  You cannot delete notes. 

  
To Add Emergency Contact Information: 
  
Type the information directly into the Emergency Contact field. This information can be changed or 
deleted as needed. 
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Timecards: Viewing/Editing 

Timecard Screen Overview 

The Timecard screen allows you to view and/or edit Timecard entries and calculated totals for each 
employee in a week-at-a-glance grid and provides access to a variety of functions to maintain an 
employees time record. 
  
The Timecard screen is divided into four sections: 
  
Section A: Toolbar 
Section B: Timecard Entries 
Section C: Totals 
Section D: Options 
  
Below is an example of the Timecard screen displaying the sections: 
 

 
 
Note:  The Approve will only appear on the Timecard if you are using the Professional or Enterprise 
version. 
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Section A: Toolbar 

 
  
The functions available on the toolbar are described below: 
  

1. Employee Drop Down - Click the down arrow located beside the Next Employee button to 
display a drop down of employees.  Select an employee from the drop down menu to change to 
display that employee's timecard. 
 

 
2. Absences - Opens the Absences screen which allows you to add an absence to an employee's 

timecard. 
3. Adjustments - Opens the Adjustments screen which allows you to view any adjustments made 

while calculating the totals for this timecard. 
4. History - Opens the History screen which allows you to view changes made to an employee's 

timecard and identify who made those changes. 
5. Overtime - Opens the Overtime Override screen which allows you to give overtime to an 

employee on a daily basis, which overrides the preset group overtime rules for that particular 
employee. 

6. Make-Up Time - Opens the Make-up Time screen which allows you to account for an employee's 
make up time as regular hours instead of overtime as required by California law.   

7. Schedule - Opens the Schedule Override screen which allows you to change an employee's in 
and out schedule for one week.  This affects early in, late out, and overnight rules. 

8. Print - Allows you to print the employee's timecard data.  This button gives you three options for 
printing the timecard: 

• Printed Selected Timecard Week - Print one timecard for the selected week. 
• Print One Timecard for Each Pay Period Week - Print all weeks of an employee's pay 

period on separate sheets. 
• Print Timecard Pay Period Summary - Print a summary of an entire pay period on one 

sheet. 
Below is an example of the Print button options: 
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Section B: Time Entries 

 
This section displays all punch data retrieved from the clocks and PCPunch.  Manual time entries can 
also be entered here. Attendance punches are displayed in chronological order (if you are using 
JobTrack, punches into projects will NOT display here) . The software will attempt to pair the punches into 
the correct slots based on the Group selected for each employee. 
  
Hover over a punch field to view a popup screen detailing the punch type (in, out, etc.) 
  
The Timecards screen opens to the current pay period.  You can move through pay periods using the 
scroll buttons. 
  
To change an entry or make a manual entry, click on the cell and enter a new time.  Click Save to save 
your changes.  A record of any manual changes made can be viewed on the History screen.  For more 
information on the History screen, please refer to the History topic. 

 

Section C: Totals Section 

 
This section provides an overview of how this week will be reported. Keep in mind that by default all times 
are displayed in the hour:minute format.  You can change them to display in fractional hours on the 
System Setup - Options screen. The Totals rows include: 
  

1. Punch: The number of hours recorded. Automatic deductions are taken out of this total. 
 Therefore, if an employee has 9 hours, but a 15 minute break is set to be automatically 
deducted, the total displayed here will be 8.45. 

2. Absences: The total time charged to this employee as an absence. If an absence is charged to 
an employee, the totals will change color to indicate if the absence is paid (Green) or un-paid 
(Red). 

3. Regular: This is the number of non-overtime hours that will be posted for each day. 
4. OT After: The number of Regular hours and minutes that must be worked each day before 

overtime is paid (if daily overtime is picked). The total in the Totals column of this row is the 
weekly Regular hours that must be worked before overtime is paid. This field displays hours and 
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minutes.  For instance, if the employee must work 8 hours before getting paid overtime, the field 
will display 08:00. 

5. Overtime: The number of hours and minutes that will be reported as overtime for that day and 
the sum of those hours in the Totals column. 

6. OT2 After: The number of Regular plus Overtime hours and minutes that must be worked each 
day, if daily overtime is picked, before overtime 2 is paid. The total in the Totals column of this 
row is the weekly Regular plus Overtime hours that must be worked before overtime is paid.  For 
instance, if the employee must work 8 hours before getting paid overtime, the field will display 
08:00. 

7. Overtime 2: The number of hours and minutes that will be reported as overtime 2 for that day 
and the sum of those hours in the Totals column.   

Color Coding: Some cells are color coded to indicate extra information. 
Time Entries Area (Top of Timecard Screen) 

1. Red - Missed Punch 
2. Light Green - Next Day Punch 

Totals Area (Bottom of Timecard Screen) 
1. Purple - Overtime 
2. Dark Green - Paid Absence + Overtime 
3. Cyan - Paid Absence, no Overtime 
4. Red - Unpaid Absence 

 

Section D: Options 

 
  
This section contains several options, Auto Calculate, Next Day and Approve (Professional and 
Enterprise versions only). 
  
Auto Calculate: The Auto Calculate checkbox, which is selected by default, enables the Timecard 
screen to automatically determine whether daily or weekly overtime will be used.  You can deselect this 
checkbox to prevent the auto calculation if, for example, you are inputting many times at once and do not 
want the timecard to recalculate after each time is entered.  When this option is deselected, a button 
appears that allows you to manually calculate as needed.  When you save the screen or recheck the Auto 
Calculate checkbox, the times will be recalculated again. 
  
Next Day: This button applies to overnight shifts only.  If an overnight employee forgets to clock out, you 
can enter the correct clock out time and click this button to move the punch to the correct day.   
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Example: An employee works 8pm to 5am Monday through Friday and forgets to clock out on 
Wednesday.  Wednesday will display only an in punch at 8pm. You can manually enter the out 
punch here.   The punch will initially appear as before 8pm punch on Wednesday.  Click the Next 
Day button to move the 5am out punch to the next day. 
  

 
  
Approve: This button only appears if you are using the Professional or Enterprise version of the 
software.  If you are using the Approve feature, this button will appear highlighted on the employee's 
timecard when a request for approval has been sent.  For detailed information on using the Approve 
feature, please refer to the topic Approvals. 
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Absences Screen 

The Absences screen allow you to add an absence to an employee's timecard.  On this screen you can 
enter the reason for an employee's Absence, the time, and absence code for a designated week. 
  
Note: You must have Absence Codes setup before using this screen.  To set up an absence code, from 
the Main Window, select Settings, then click the Absence icon.  For further information on creating 
Absence Codes, please refer to the System Setup topic. 
  
To Add an Absence to an Employee's Timecard: 
  

1. From the Main Window, select Timecards or Employees.  The Employee List appears. 

2. Highlight the employee whose timecard you wish to edit in the list, then click View Timecard. 
 The Timecard screen for the selected employee appears. 

3. On the Timecard screen, click Absences. 
 
 

 
 
 
An Absences screen similar to the following appears: 
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4. Make sure the correct week is displayed (using the Next Week and Previous Week buttons if 
necessary), then select an Absence Code from the drop down menu and enter the amount of 
time the employee was absent.   You can enter multiple absences for the same day, if needed. 
For example, if can enter that an employee had a 4 hour paid absences for a conference, 
followed by a 4 hour unpaid absence for sick leave on the same day.  You can enter an unlimited 
number of absences for any given day. 

5. After selecting the absence code, click the Add Absence button.  You will need to select this 
button each time you add a new absence to a day. 

6. Select the Save button when you are finished.  You will be returned to the Timecard screen.  The 
absences you just entered will appear on the Timecard screen. 
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Adjustments Screen 

Use the Adjustments screen to view any adjustments made while calculating the totals for this timecard. 
 Adjustments are made according to the employee’s Group settings, and include such things as 
Rounding and Automatic Unpaid Breaks. You cannot enter values into this window; it is for at-a-glance 
review of current adjustments applied.  These adjustments are subtracted from the Regular total 
displayed on the Timecard screen.   
  
To View the Adjustments Screen: 
  

1. From the Main Window, select Employees or Timecards.  The Employee List appears. 

2. On the Employee List, highlight an employee and select View Timecard.  The Timecard screen 
appears. 

3. On the Timecard screen, select Adjustments. 
 
 

 

4. The Adjustments screen appears.  Below is an example of the Adjustments screen: 
 
 

 

5. You can export this information to a .csv or text file by clicking Export.  Click Print to print the list 
of adjustments. 
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History Screen 

The History screen allows you to view changes made to an employee's timecard and identifies who 
made those changes.  All manual changes made to the timecard are recorded on this screen.  Changes 
are listed with the most recent change at the top of the list.  You cannot edit data in this window. It is used 
for review purposes only. 
  
This section covers the following topics: 
  
Viewing the Timecard History 
Printing the History Screen 
Exporting the History Screen 
Grouping the History Screen 
Filtering the History Screen 

 

To View Timecard History 

1. From the Main Window, select Employees or Timecards.  The Employee List appears. 
 

2. On the Employee List, highlight an employee and select View Timecard.  The Timecard screen 
appears. 
 

3. On the Timecard screen, select History. 
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4. The History screen appears. 
 

 
 

To Export the History 

Export allows you to export the entire list to a comma-delimited text file.   
  
 

1. From the Main Window, select Employees or Timecards.  The Employee List appears. 
 

2. On the Employee List, highlight an employee and select View Timecard.  The Timecard screen 
appears. 
 

3. On the Timecard screen, select History.  The History screen appears (shown above). 
4. On the History screen, select Export.  A screen similar to the following appears: 
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5. Enter the file name and type, then click Save. 
 

To Print the History 

1. From the Main Window, select Employees or Timecards.  The Employee List appears. 
2. On the Employee List, highlight an employee and select View Timecard.  The Timecard screen 

appears. 
3. On the Timecard screen, select History.  The History screen appears. 
4. On the History screen, click Print.  The Page Setup screen will appear. 
5. Click the OK button on the Page Setup screen to print the list.  The list will print to your default 

printer. 
 

To Group the List 

The History screen provides you with the capability of "grouping" the displayed information so you can 
view data in a way that is most easy-to-read for you.  You can have one group, two groups, or many 
groups depending on how you want to view your information.  For instance, if you want all changes on the 
History screen to be grouped by Date Changed, you can quickly set this up.   
  

1. From the Main Window, select Employees or Timecards.  The Employee List appears. 
2. On the Employee List, highlight an employee and select View Timecard.  The Timecard screen 

appears. 
3. On the Timecard screen, select History.  The History screen appears. 
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4. To see the grouping options, click the Group button.  The top of the list screen expands to 
display the group selections as shown below: 
 

 
 

5. To create a new group, click on a column header, then drag it to the space indicated on the 
screen.  For example, if you want to group information by Date Changed, click on the Date 
Changed column header and drag it to the indicated space. 
  

6. The screen now lists Date Changed as one of your groups and the information is displayed 
according to when the changes were made. 
  

Deleting Groups 
  

1. If you no longer want to display information in a particular group you can easily ungroup 
the data.  For instance, if you have created a group for Date Changed, but now wish to 
only group by site, you can remove the group by clicking on the group name and 
dragging it down into the column header section.  Let go of your cursor anywhere in the 
column header section and the group disappears. 
  

2. The information contained in that group still appears on the display screen, but it is no 
longer grouped together. 

 
  

Filtering the History Information 

Filter allows you to limit the information that appears in the list by a keyword or phrase you enter. 
  
Creating Filters: 
  

1. Click the Filter button.  A field appears at the top of the list allowing you to enter your keyword. 
 

 
 

2. Click in the space.  A field appears below the first column header (Last Name in this example). 
 Type in the word or phrase by which you want to filter. 
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3. After you have enter your word, hit the Enter key.  A field will appear in the next column over 
(First Name in this example).  You can continue to enter keywords for each column by typing in 
the field, then hitting the Enter key, or you can skip a column by hitting Enter without typing any 
information.  After you have Entered through all the columns, only the items that match your 
entered filter (in this example, Last Name = deBlonk) will appear in the list. 
 

 
 

Deleting Filters: 
1. To remove a filter, click on the filter you want to remove.  Notice an icon appears next to the field. 

 

 
  

2. Click the icon to delete the filter.  The filter field becomes blank and the list displays all 
information again. 
 
You can quickly delete all filters by clicking the Filter button.  The filter fields are hidden and all 
information is listed on the screen again. 
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Overtime Override 

The Overtime Override screen allows you to give overtime to an employee on a daily basis, which 
overrides the preset group overtime rules for that particular employee. 
  
To Give Overtime to an Employee: 
  

1. From the Main Window, select Timecards or Employees.  The Employee List appears.   
 

2. Highlight an employee on the Employee List and click View Timecards.  The Timecard screen 
for the selected employee appears. 
 

3. On the Timecard screen, click Overtime.   
 

 
 
The Overtime Override screen appears: 
 

 
 

4. Select the day you want to override, then enter the number of hours after which overtime should 
be applied.  In the example below, the employee will receive overtime after working 7 hours on 
Monday. 
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5. You can scroll through weeks using the arrow buttons at the top of the screen.  Click Save to 
save your changes.  Click Done to exit the Overtime Override screen. 
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Schedule Override 

The Schedule Override screen allows you to change an employee's in and out schedule for one week, 
which affects early in, late out, and overnight rules. 
  
To Change an Employee's Schedule: 
  

1. From the Main Window, select Timecards or Employees.  The Employee List appears.   
 

2. Highlight an employee on the Employee List and click View Timecards.  The Timecard screen 
for the selected employee appears. 
 

3. On the Timecard screen, click Schedule. 
 

 
 
The Schedule Override screen appears: 
 

 
  

4.   Enter new times, then click Save. 
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Makeup Time 

The Makeup Time screen allows you to account for an employee's make up time as regular hours 
instead of overtime as required by California law.   
  
Please be aware that if the daily overtime for the group to which the employee is assigned is set to zero, 
any make up time entered here will be ignored by the system.  You must enter values in the daily 
overtime fields on the Groups screen (even if you are calculating weekly) to use the Make Up Time 
Missed function. 
  
To Enter Makeup Time: 
  

1. From the Main Window, select Timecards or Employees.  The Employee List appears.   
 

2. Highlight an employee on the Employee List and click View Timecards.  The Timecard screen 
for the selected employee appears. 
 

3. On the Timecard screen, click Makeup Time.   
 

 
 
The Makeup Time screen appears. 
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4. Select the Out checkbox next to the day on which the employee will be absent (you will need to 
enter an absence for the employee on the Absences screen before using the Makeup Time 
screen).  
  

5. Enter the number of hours the employee will be absent that day in the Hours field. 
 

6. Select the Make Up checkbox next to each day the employee will be making up time.   
 

7. Enter the number of hours the employee will be making up in the Hours field for each day that 
has Make Up selected.   
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Example: 
  
John Doe is going to be absent for 8 hours on January 1, 2007.  He wants to make up this time by coming 
in two extra hours each day from January 2 through January 5.  You would fill out the screen as shown 
below: 
 

 
  
The extra hours the employee works on the make up days is not counted as overtime, even if you have 
daily overtime set to 8.  Any time worked beyond the 2 hours of make up time on these days is 
considered overtime.  The totals section on the Timecards screen will list the make up hours as regular 
time.  Therefore, if the employee works 10 hours on 01/02/2007, the Regular field on the Timecards 
screen will display 10 and the Overtime field will display 0.  If the employee works 11 hours on 
01/02/2007, the Regular field on the Timecards screen will display 10 and the Overtime field will display 
1. 
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Timecard Approvals 

Professional and Enterprise Versions Only 
  
The Professional and Enterprise versions of the software give you the ability to require employee or 
manager approval on selected employee timecards. 
  
Setting Up Timecard Approvals: 
  
To use this feature, you will need to indicate that timecard approval is required on the employee's Edit 
Employee screen.  To steps for setting up Approvals are as follows: 
  

1. When you create a new employee (or edit an existing employee), if he/she will need manager 
approval for the timecard, indicate who the manager is in the Supervisor field (Edit Employee 
Screen > Management Tab). 

2. On the Edit Employee Screen > Security Tab, select the checkbox Employee Approvals and/or 
Manager Approvals.  You can also select to require the entire timecard to be approved, or only if 
overtime is indicated. 

3. Make sure a valid email address is entered on the manager's Edit Employee screen and each 
employee's Edit Employee screen. 

Using Timecard Approvals: 
  
Note: Once you create your approval request for a time period by following the steps below, the 
approvals cannot be re-requested.  The software will send out the approval request emails one time only 
for a given pay period. 
 
At payroll time, the payroll clerk needs to send a request to all employees and/or managers who need to 
approve timecards.  To do this: 
  

1. From the Main screen, select Tools > Request Approvals.  The following Approvals screen will 
appear: 
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2. Select the Pay Period for which you want to request approvals.  The screen defaults to the most 
recently completed pay period.  Any employees that require timecard approval will appear in the 
window at the bottom of the screen. 

3. Select the employees for which you want to request approvals or select the checkbox in the 
column header to choose all employees. 
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4. If you are using email alerts, you can select the Send employees and managers emails for 
new requests checkbox to have the software email them your request. 
 
 

 
5. When you have made your selections, click the Request Approval button.  The request will be 

sent to the employee (if Employee Approval is selected on the Edit Employee screen) and/or 
the employee's manager (if Manager Approval is selected on the Edit Employee screen. 

6. Now the employee and/or manager should go to the employees' timecard.  Keep in mind that the 
timecard must be Saved before it can be approved.  The Approve button will be enabled.  After 
review, the employee and/or manager should click Approve to approve the timecard or Request 
Change if the timecard cannot be approved in its current state.   
 
 

 
 
 
When this button is clicked, a screen similar to the following will appear.  If you are a user who 
cannot change your own times or an Admin or a Manager approving someone else's time, the 
screen will appear as follows: 
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If you are a manager approving your own time, your screen will appear as follows: 
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This screen gives you the ability to request a change to your timecard if you see a mistake.  The 
change request will be sent to your Admin. 
 
  

7. Click the Approve radio button to approve the time.  If you are the employee, the current date 
and time will appear in the Approved By Employee.  If you are the manager, the current date 
and time will appear in the Approved by Manager On field and your login will appear in the 
Approved By Manager field. 
 
 
Click the Request Change radio button to request a change to the timecard.   

8. Click Save when you have made your selection.  Any changes made to the timecard will 
invalidate the approval.  If the timecard is changed, the employee and/or manager will need to 
Approve it again. 

9. Click Done to close the screen. 
  

  



 

143 

  
WaspTime User Manual 

Tools 

Payroll Export 

Payroll Export calculates and writes your employees' pay period hours worked and absence time to a file 
in the selected format. The employees can be filtered by department and group and the date range can 
be specified. If you are using QuickBooks, use this screen to specify which employee's time to send 
directly to QuickBooks. 
  
The file name and type for the Payroll Export is entered on the Payroll Settings tab of the System 
Setup screen (accessed from the Main Window by selecting Settings). On the Payroll Export screen 
you can limit the file to a specific date range, department or employee. 
  
For information on connecting the software to QuickBooks, please refer to the topic Connecting to 
QuickBooks. 
  
To Export Your Payroll File: 
  

1. From the Main Window, select Tools > Payroll Export.   
 
OR 
 
From the Main Window, click the Payroll icon. 
 
A Payroll Export screen similar to the one below appears: 
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2. Select the date range for the payroll information you want to send.  Options are: 
• This Period 
• Last Period (default) 
• Next Period 
• Custom 

 
Custom enables the date fields allowing you to enter a range of dates. 
 

3. Next choose which departments or groups (or all) you want to export.  You can filter by 
Department or Group using the drop down menu, or export payroll for all employees by selecting 
the checkbox in the Last Name field. 
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4. (Pro and Enterprise versions only) Select if you want to Export Approved Timecards Only.  If 
timecards exist that have not yet been approved, you will see the following notice on this screen: 
 

 
 

5. Select if you want to "Always export default time (based on group schedule) for salary 
employees".  When this checkbox is selected, if an employee is a salaried employee, WaspTime 
will export the default schedule (set on the Group screen), even if there are no punches entered 
for that employee.  Overtime for salaried employees will also be excluded from the export.  
Absences will be sent for vacation accrual tracking. 
 

6. Click Export when you are ready to create your file. 
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Process Holidays 

The Process Holidays screen allows you to apply Holiday hours to the timecard data of Employees in All 
or Selected Departments or Groups. 
  
This allows you to, for instance, apply holiday pay for Labor Day to all employees at once. 
  
To use the Process Holidays screen, you should have already set up any applicable holidays and 
absence codes in the System Setup > Statutory Holidays and Absence Codes tabs. 
  
To Process Holidays: 
  

1. From the Main Window, select Tools > Process Holidays.  A Process Holidays screen similar 
to the one below appears: 
 

 
 

2. Select a Holiday from the drop down menu. 
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3. Enter the number of hours to be applied to each employee's timecard. 
 

4. Select the employees to which you want to apply the holiday.  You can filter my Department or 
Group or choose all employees by selecting the checkbox in the Last Name field. 
 

5. Click Apply Holiday when you are finished making your selected.  A confirmation message will 
appear stating the holiday was successfully applied. 
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Archive Timecards 

The Archive Timecards screen allows you to archive all timecards that fall within a specified date range. 
  
Archived timecards will no longer appear in the Timecards window or in most Reports. If you want to run 
quarterly or year-end reports, archived data can be viewed using the Archived Timecard report. 
  
To Archive a Timecard(s) from the Main Window 
  

1. From the Main Window, select Tools > Archive Timecards.  A screen similar to the following 
will appear: 
 
 

 

2. Select From and To dates using the drop down arrows.  When you select the drop down arrows, 
a calendar will appear allowing you to quickly select a date. 

3. Select Archive to archive the timecards.  For information on restoring archived timecards, please 
refer to the topic Restore Archive. 
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Applying Daylight Savings Time 

The software allows you to apply Daylight Savings Time to all timecards in your system. 
  
Applying Daylight Savings Time: 
  

1. From the Main screen, select Tools > Process Daylight Savings Time.  This Daylight Savings 
Time screen will appear: 
 
 

 

2. Select the Time Zone to which you want to apply Daylight Savings Time.   
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3. Select whether you want to process Daylight Savings Time Start or End.  By default, the usual 
date for DST beginning and end will be displayed here.  You can change the date or time, if 
needed. 

4. A list of employees will appear at the bottom of the screen. This list displays all employees in the 
selected time zone who show an IN punch on their timecard when the adjustment occurred will be 
shown.  If you have created groups (ex. Salary, Hourly, Temp, etc.), you can filter this list by 
groups.  When you click Filter Groups, the following screen appears listing all groups in your 
system: 
 
 

 
 
 
Select individual employees to apply the DST changes to by clicking on the checkbox in front of 
his/her name, or, apply DST to all listed employees by selecting the checkbox at the top of the 
grid, as shown below: 
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5. Click Apply Changes when you have made your selections. 
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Restore Archive 

The Restore Archive screen allows you to restore all archived timecards that fall within a specified range 
of dates. 
  
To Restore Archived Timecards: 
  

1. From the Main Window, select Tools > Restore Archive.  A screen similar to the following 
appears: 
 

 
 

2. Select an employee from the drop down list or select Timecards and enter a date range to 
restore. 
  

3. Click Restore when you have made your selections. 
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Unprocessed Punches 

The Unprocessed Punches screen displays punch data that has been collected but was not able to be 
processed by WaspTime due to unknown badge numbers.  If a punch data record is collected that 
contains a badge number that is not known to WaspTime , it cannot be processed. Unknown badge 
numbers are commonly the result of data entry errors on the Employee screen.   
  
If an employee’s badge number has been entered incorrectly, his or her punch records will not appear in 
WaspTime . Once you have corrected the badge number in the system (on the Employee screen), all 
corresponding Unknown Badge records should be processed the next time that WaspTime processes 
punch data records, or you can re-process punches from this screen. 
  
On the Unprocessed Punches screen, you can view invalid punches with the option of deleting them 
from the database.  (Deleting invalid punches may improve punch data record processing times.) 
  
The information on the Unprocessed Punches screen can be grouped and filtered the same as other list 
screens in WaspTime.  For detailed information on grouping and filtering, please refer to the topic 
Working with Lists. 
 
The following topics are covered in this section: 
  
Accessing the Unprocessed Punches Screen 
Deleting Unprocessed Punches 
Reprocessing Punches 
Assigning Badges 
Exporting Unprocessed Punches 
Printing Unprocessed Punches 
Importing Punches 
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To Access the Unprocessed Punches Screen 

1. From the Main Window, select Tools > Unprocessed Punches.  A screen similar to the 
following will appear: 
 

 
 
Invalid punches will appear in the list. 
 

2. Click the Refresh button to view an updated list of unprocessed punches. 
 

To Delete Unprocessed Punches 

1. From the Main Window, select Tools > Unprocessed Punches.  The Unprocessed Punches 
screen appears. 
 

2. On the Unprocessed Punches screen, select the checkbox next to the record(s) you want to 
delete and click Delete Selected. 
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To Reprocess Punches 

1. From the Main Window, select Tools > Unprocessed Punches.  The Unprocessed Punches 
screen appears. 
 

2. On the Unprocessed Punches screen, select the Reprocess All Punches button. 
 

 

To Assign Badges 

The Assign Badges icon is enabled if you download a punch or punches from a clock with a badge 
number that does not match an active user in WaspTime.  You can assign the badge number to an 
existing employee in WaspTime using this feature. 
 

1. On the Unprocessed Punches screen highlight the instance you want to assign (you can select 
only one line at a time to assign), then click the Assign Badge icon.  
 
 

 
2. A list of all employees in WaspTime will appear:    
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3. Select the employee to which you want to assign the badge number, then click the OK button.  
Note:  If this employee already has a badge number assign to them, it will be overwritten with the 
new number.       
 

 
 

4. A confirmation screen will appear when the badge is successfully assigned.      Click OK on the 
confirmation screen.   
 

5. On the Unprocessed Punches screen, click the Re-Process All Punches icon to apply the 
punches to the employee. 
 

 

To Export the List of Unprocessed Punches 

Export allows you to export the entire list to a comma-delimited text file.   
  
 

1. From the Main Window, select Tools > Unprocessed Punches.  The Unprocessed Punches 
screen appears. 
 

2. On the Unprocessed Punches screen, select Export.  A screen will appear allowing you to 
select a file name and location for your exported data.   

 

To Print the List of Unprocessed Punches 

1. From the Main Window, select Tools > Unprocessed Punches.  The Unprocessed Punches 
screen appears. 
 

2. On the Unprocessed Punches screen, select Print.  The Page Setup screen will appear. 
 

3. Click the OK button on the Page Setup screen to print the list.  The list will print to your default 
printer.   

 
 
 

Importing Punches 
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If you do not have network connectivity where you want to mount your bioclock, you will need to load the 
punches from the clock to a USB 1.0 memory stick, save the punch file to your computer, then download 
the file to the software via the Unprocessed Punches screen.   
  

B2000 

1. To download punches from the B2000, insert the USB 1.0 memory stick into the USB port on the 
side of the clock.   

2. On the clock main menu, highlight the PenDrive icon and press the M key.  
 
The USBDrive screen appears: 
 
 

3. Use the up and down arrow keys to highlight the desired option.   
 

4. Highlight Download and press the M key.    
 

5. Select Download Attlog and press the M key. 
 
The following files are copied to the USB disk/PenDrive: 
 
o    X_attlog.dat (attendance log) 
 
o    X_oplog.dat (management log) 
 
o    X_user (User information including templates.) 
 
Note: The X represents the machine number from which the data file(s) originated. 
 
 

6. Click Import from the toolbar on the Unprocessed Punches screen.  A screen similar to the 
following appears: 
 

 
 



 

158 

  
WaspTime User Manual 

7. Navigate to the punch file on your computer, then click Open.  The punches will download to the 
software. 
 

8. Click Re-Process All Punches on the toolbar of the Unprocessed Punches screen, or Process 
Punches from the Tools menu of the Clock Setup screen. The punches you just added will be 
processed and inserted into the timecards. 
 

9. Verify that the punches are appearing correctly on the timecards, then delete the punches from 
the clock.  The steps to delete the punches from your clock are: 
 
On the click navigate to Menu - Options - System Options - Advanced Options - Del AttLogs 
- OK, then hit ESC to exit. 

B1000/B1100 

1. To download punches from the B1000 or B1100, insert the USB 1.0 memory stick into the USB 
port on the side of the clock.   
 

2. Log into the clock menu as an Admin or Supervisor and choose PenDriveMng > Download 
AttLog > OK.   
 

3. ESC out of the clock menu and remove the memory stick. 
 

4. From the Main Window click Tools > Unprocessed Punches.  The Unprocessed Punches 
screen appears. 
 

5. Click Import from the toolbar on the Unprocessed Punches screen.  A screen similar to the 
following appears: 
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6. Navigate to the punch file on your computer, then click Open.  The punches will download to the 
software. 
 

7. Click Re-Process All Punches on the toolbar of the Unprocessed Punches screen, or Process 
Punches from the Tools menu of the Clock Setup screen. The punches you just added will be 
processed and inserted into the timecards. 
 

8. Verify that the punches are appearing correctly on the timecards, then delete the punches from 
the clock.  The steps to delete the punches from your clock are: 
 
On the click navigate to Menu - Options - System Options - Advanced Options - Del AttLogs 
- OK, then hit ESC to exit. 
 
If you need additional help deleting punches from the clock, please refer to your clock's user 
manual. 
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Database Backup 

The Database Backup screen allows you to back up your data and set up Auto Back Up.  If for any 
reason your system goes down, backing up your data ensures you do not lose all of the employee 
punches you have collected. The Backup function allows you to backup your entire database. 
  
Note: If you have installed the Enterprise version, the Backup and Restore options are not available.  You 
will need to manually backup the database. 
  
The topics covered in this section are: 
  
To Backup Your Database 
Changing the Default Backup Location 
To Schedule an Automatic Backup 
To Delete a Scheduled Automatic Backup 
Exporting the List of Automatic Backups 
Printing the List of Automatic Backups 
Understanding Backups Statuses (Pass/Fail) 
Troubleshooting Backups 

 

To Backup Your Database 

1. From the Main Window, select Tools > Backup Database.  A screen similar to the following will 
appear: 
 

 

2. Specify a file name, then click the Backup button.   
 
 
The backup always saves to the C:\Program Files\Microsoft SQL 
Server\MSSQL.1\MSSQL\Backup. 
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Changing the Default Backup Location 

You can change the default location of the backup file if you are setup as an Admin.  To do this: 
 

1. From the Database Backup screen, click Set Backup Location.  The following screen appears: 
 
 

 

2. Enter the path to the new backup folder.  If the client is running on the same machine as the 
database server, you can browse to this folder by clicking the "..." icon.  If it is on a different 
machine, you will need to type in the path manually. 

3. Click Save when you are done. 
 

To Schedule or Edit an Automatic Backup: 

1. From the Main Window, select Tools > Database Backup.  The Backup Database screen 
appears. 

2. Select the Schedule Backup button.  The Automatic Backup List screen appears: 
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Note:  The grid on this list screen functions as other list screens in this software.  Please refer to 
the Working with Lists topic for instructions on arranging the columns, etc. 

3. Select the New button if you want to schedule a new backup time, or highlight an item in the list 
and select the Edit button to edit an existing scheduled backup.  A screen similar to the following 
appears: 
 
 

 

4. Enter a Description for this backup and a Frequency and Time. 
 
 
Available Frequencies are: 

• Once - The backup will run once at the specified time. 
• Daily - The backup will run daily at a specified time. 
• Weekly - The backup will run weekly at a specified time. 
• Monthly - The backup will run monthly at a specified time.  If you select Monthly, you 

can choose the day on which to run the backup.  You can choose from the dates 1 
through 28 or End of Month, since all months have dates 1 through 28, while only some 
have the dates 29, 30 or 31.   (For example, June has 30 days while July has 31 so 
selecting Last Day of Month will set the backup to occur on June 30 and again on July 
31.) 

5. Click the OK button.  Your backup will be added to the Automatic Backups List screen. 
 

 

To Delete a Scheduled Backup 
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1. From the Main Window, click Tools > Database Backup.  The Database Backup screen 
appears. 
 

2. Click the Schedule Backup button.  The Automatic Backups List screen (shown above) 
appears. 
 

3. Highlight the listing you want to delete and click the Delete button. 
 

Exporting the List of Automatic Backups 

Export allows you to export the entire list to a comma-delimited text file.   
  
  

1. When the Export button is selected, a screen appears allowing you to specify where the exported 
data will be saved on your computer.  An example of the Export screen is shown below: 
 

 
 
  

2. Make sure you save this to a location you can remember.  You must also choose a name for your 
file on this screen.  After you have made your selections, click Save to export your data. 
 
 
A confirmation message will appear when your data has been successfully exported by the 
system.   
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Printing the List of Automatic Backups 

1. Print allows you to print the list.  Select the Print button on the toolbar of the Automatic 
Downloads List.  A standard Page Setup screen appears allowing you to enter margins.  An 
example of this screen is shown below: 
 
 

 

2. Click the OK button on the Page Setup screen to print the list.  The list will print to your default 
printer.  To change which printer the list is sent to, click the Printer button on the Page Setup 
screen.  A Printer selection screen similar to the one shown below appears: 
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Understanding Backup Status (Pass/Fail) 

When running normally, your automatic backups will occur at the specified times with no errors.  When 
this occurs, the Automatic Backups screen will list Pass in the Result column.  If there is a problem, Fail 
will appear in the Results column.  When you see Fail, one of two problems have occurred: 
  
The Backup Ran with Errors: This means your backup did run, but contains errors.  The system will 
handle this differently depending on the Frequency you have selected. 
  

• Once - A 'Once' schedule will NOT attempt to run again, so you must edit the schedule (by 
highlighting the listing on the Automatic Backup screen and clicking Edit) to attempt another 
backup in the future. 

• Daily - If a 'Daily' backup has failed today, the system will NOT try to backup again until 
tomorrow, unless the schedule is edited (by highlighting the listing on the Automatic Backup 
screen and clicking Edit). 

• Monthly - If a 'Monthly' backup has failed today, the system will NOT try to backup again until 
next month on the date and time specified, unless the schedule is edited (by highlighting the 
listing on the Automatic Backup screen and clicking Edit). 

The Backup was Missed:  This may occur if the service was down at the time the backup was set to run. 
 As with errors, the system will handle missed backups differently depending on the Frequency you have 
selected. 
  

• Once - A 'Once' schedule will run again as soon as the service is back up. 
• Daily - A 'Daily' backup will run the next day at the time specified. 
• Monthly - A 'Monthly' schedule will attempt to backup again as soon as the service is back up. 

 

Troubleshooting Backups 

Auto-Polling - Keep in mind that if Auto-Polling on the Service Settings screen is set to FALSE, all 
automatic downloads, syncs and backups will be turned off.  If Auto-Polling is set to TRUE, all automatic 
downloads, syncs and backups will run on schedule.  Refer to the Service Settings topic for more 
information. 
  
Manual Backups - If you click backup to manually run a database backup the backup will not appear 
immediately. The backup file should be expected to appear after 1 minute or so. Restoring backups is 
instantaneous as these are not scheduled. 
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Database Recovery 

The Database Recovery screen allows you to replace all information as long as you have been backing 
up your database. 
  
To Recover the Database: 
  
In order to restore the database, all connections to the database from machines other than the one you 
are using must be closed.  This means all users who connect to the database on any of the software suite 
applications ( WaspTime , PCPunch or JobTrack ) must close the application.  If an application is still 
connected to the database when you try to restore, you will get an error message stating that users are 
still connected and be unable to proceed.   
 
The steps to take on each machine that runs a component of the software suite are listed below: 
 

1. Make sure all applications from the software suite are closed. 
 

2. Make sure all other applications that connect to the SQL database are closed (Ex: SQL 
Enterprise Manager). 
 

3. From the Main Window, click Tools > Database Recovery.  A screen similar to the following 
appears: 
 

 
 

4. Specify the file name, then click the Restore button. 
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Import Assistant 

The Import assistant allows you to import external data from a File or from QuickBooks.  Below is an 
example of this screen: 
  

 
  
To access this feature: 
  

1. From the Main Window, select Tools > Import.  The screen shown above appears. 
 

2. Select 
 
Import from file into Database, or 
Import from QuickBooks. 
 

3. Click the Next button to continue. 
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Reports 

Viewing/Importing/Editing/Scheduling Reports 

The View Reports screen allows you to Import, Edit, or Delete reports (such as Daily/Weekly Overtime 
or Absence) and specify a Date/Time Range, Timespan, and frequency Criteria (Once, Daily, Monthly) 
for Employees, Departments or Groups. 
  
This section covers the following topics: 
  
View Reports 
Edit Reports 
Import Reports 
Delete Reports 
Scheduled Reports 

 
  

View Reports 

1. From the Main Window, click Reports.  The View Reports screen appears: 
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2. Click on the report you want to view.  The options on the right side of the screen will change 
depending on the report you have selected. 
 

3. Enter your report parameters (Employee, Time Span, Ending Date, etc.), then click View Report. 
 

Viewing Reports if you are a Manager: 
  
By default, all reports (and lists) will display employees that report to you.  For example, if you select the 
Attendance report, all employees that report to you will appear in the Criteria - Employees field.  Select 
All to have the report display all employees that report to you, or select individual employees.   
 
Viewing Reports if you are an Admin: 
  
If you are an Admin, selecting All means all employees will appear on reports, regardless of to whom they 
report.  Admins can run reports for any manager in the list. 

 
  

Edit Reports 

You can rename existing reports and make changes to custom reports by following the instructions 
below. 

1. From the Main Window, click Reports.  The View Reports screen appears.   
 

2. Select the report you want to edit, then click the Edit button. 
 

 
 
A screen similar to the following will appear: 
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3. You can make changes to all enabled fields on this screen.  If you have selected a custom report 
that you imported into the system, you can make changes to the criteria; however, if it is a report 
that came with the software (such as the Absence report), you will not be able to make changes 
to the criteria fields. 
 

4. Click Save when you are done making changes. 
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Import Reports 

1. From the Main Window, click Reports.  The View Reports screen appears. 
 

2. On the View Reports, screen, click Import. 
 

 
 
The New Report screen shown below appears: 
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3. Enter the Report FileName or click browse to navigate to it. 
 

4. Enter name of the report in the Report Name field.  This is the name that will appear in the 
reports list. 
 

5. Enter the criteria for your custom report.   
 

6. Click Save when you are done.  You can now view your report by returning to the View Reports 
screen and selecting your report from the list. 
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Deleting a Report 

1. From the Main Window, click Reports.  The View Reports screen appears. 
 

2. On the View Reports screen, highlight the report you want to delete and click the Delete button. 
 

 
 
A confirmation message will appear. 
 

Click Yes on the confirmation message to delete the selected report.  Keep in mind that reports that came 
with the software are not actually deleted from the system.  They are marked Inactive and no longer 
appear in the Active Only Reports list.   
 
To Reactivate a Report: 
  

1. Deselect the Active Only checkbox on the View Reports screen.  The checkbox will now say 
"Show All" and all reports (active and inactive) appear in the list. 
 

 
 

2. Highlight the report you want to reactivate and click Edit.   
 

3. On the Edit Report screen, select the Active checkbox. 
 

 
 

4. Click Save. 
 

5. The report is now active again and will appear in the Reports List. 
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 Scheduled Reports 

You can create filters for a report, then set it to run at a specific time each day, week, pay period, etc. 
using the Scheduled Reports screen. 
  
The following topics are discussed in this section: 
  
Accessing the Scheduled Reports Screen 
Creating a New Scheduled Report 
Deleting a Scheduled Report 
Editing a Scheduled Report 
Exporting the Scheduled Reports List 
Printing the Scheduled Reports List 
Marking a Scheduled Report Inactive 

 

Accessing the Scheduled Reports Screen 

  
1. From the Main Window, click Reports.  The View Reports screen appears 

 

 

2. On the View Reports screen, click the Scheduled Reports icon. 
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The Scheduled Reports screen appears: 
 
 

 
 
The Scheduled Report screen lists any reports you have scheduled to run and provides access 
to the following functions: 
 
New - Create a new scheduled report. 
Delete - Delete a scheduled report. 
Edit - Edit the filter or scheduled run time of a report. 
Export - Export the list of scheduled reports displayed on the Scheduled Reports screen. 
Print - Print the list of scheduled reports displayed on the Scheduled Reports screen. 
Marking a Scheduled Report as Inactive - Make a scheduled report inactive. 
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Delete a Scheduled Report 

  

1. On the Scheduled Reports screen, highlight the report you want to delete, then click the Delete 
button. 
 

 
 
 
A confirmation screen will appear: 
 

 
 

2. Click Yes on the confirmation screen to delete the report.  The following screen will appear 
confirming the deletion: 
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Edit a Scheduled Report 

You can edit the parameters for how a report is scheduled at anytime using this feature. 
  

1. On the Scheduled Report screen, highlight the report you want to edit and click the Edit icon on 
the toolbar. 
 

 
 
The Schedule Report screen for the selected report appears. 
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2. Make changes as needed and click the Save button when done.  For detailed information on 
each field on the Schedule Report screen, please refer to the Adding a Scheduled Report topic. 
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Export the Scheduled Reports List 

  
Export allows you to export the entire list to a comma-delimited text file.   
  
  

1. Click the Export button on the Scheduled Reports toolbar. 
 

 
 
The following confirmation screen appears: 
 

 
 

2. You have the option of exporting all data, including any columns you have hidden, or exporting 
the grid as is (excluding hidden columns).   
 
If you want to export the data in the grid as it is currently displayed, click Yes.  
 
If you want to export all data including any columns you have hidden, click No.   
 
Click Cancel to cancel the export process. 
 

3. When the Export button is selected, a screen appears allowing you to specify where the exported 
data will be saved on your computer.  An example of the Export screen is shown below: 
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Make sure you save this to a location you can remember.  You must also choose a name for your 
file on this screen.  After you have made your selections, click Save to export your data. 
 
A confirmation message will appear when your data has been successfully exported by the 
system.  
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Printing the Scheduled Reports List 

  
Print allows you to print the list.   
  

1. Click the Print button on the Scheduled Reports toolbar. 
 

 
 
A standard Page Setup screen appears allowing you to enter margins.  An example of this 
screen is shown below: 
 

 
 

2. Click the OK button on the Page Setup screen to print the list.  The list will print to your default 
printer.   
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Marking a Scheduled Report Inactive 

  
Marking a report as inactive allows you to retain the report settings, but stops it from running 
automatically. 
  

1. On the Scheduled Reports screen, highlight the report you want to mark as inactive and click 
the Edit button. 
 

 
 
The Schedule Report screen appears: 
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2. Deselect the Active checkbox at the bottom of the screen. 
 

 
The Schedule Reports list will show the reports status as inactive: 
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Adding a Scheduled Report 

1. From the Scheduled Reports screen, click the New icon on the toolbar. 
 
 

 
 
 
The Scheduled Report screen appears. 
 
 

 
 
 
Note:  The Active checkbox is selected by default and disabled when creating a new report.   
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2. Enter a description for this report in the Description field.  For example, if you are setting the 
Absence report to run weekly, you might enter "Weekly Absence Report" in the Description 
field. 

3. Select a report from the Pick the report this schedule is for drop down list.  All reports 
available in WaspTime, including any reports you have imported, are included in the drop down 
list. 

4. On the When to Run tab, select the Frequency that you want this report to run from the drop 
down menu.  Options are: 

1. Once - This sets the report to run once on the day and time you specify.  Below is an 
example of the When to Run tab with Once selected: 
 
 

 
 
Select the Date and Time on which you want the report to run.  Click the down arrow in 
the Date field to access the calendar: 
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2. Daily - This sets the report to run once daily at a specified time.  Below is an example 
of the When to Run tab with the Daily option selected. 
 
 

 
 
 
Select the Time you want this report to run each day. 
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3. Weekly - This sets the report to run each week on a specified day and time.  Below is 
an example of the When to Run tab with the Weekly option selected. 
 
 

 
 
 
Select the Day and Time on which you want this report to run. 

4. Monthly - This sets the report to run each month on a specified day of the month and 
time.  Below is an example of the When to Run tab with the Weekly option selected. 
 
 

 
 
Select the Day of the month (1 through 28 or End of month) and Time at which you 
want the report to run. 
 
 
Note: End of month means the report will run on the last day of each month. 



 

188 

  
WaspTime User Manual 

5. Pay Period - This sets the report to run each pay period on the specified day and time. 
 
 

 
 
Select the Day (1 through 13 or End of period) and Time at which you want the report 
to run. 

5. The Filter tab allows you to set limits on the data included in the report.  An example of this tab 
is provided below: 
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On the Filter tab, select the following options: 

1. Date/Time Range - Select the Date/Time Range for which you want to limit the data in 
the report. Options are: 
 
 
Today 
Yesterday 
Previous Pay Period 
Current Pay Period 
Last Week 
This Week 
Next Week 
Last Month 
This Month 
Next Month 
Year to Date 

2. Select which Employee(s), Department(s) and/or Group(s) from which you want to 
include data. 

6. On the How to Receive tab, select how you want WaspTime to send you the completed report. 
 An example of the How to Receive tab is provided below: 
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Options are: 

Print - Select a printer from the drop down list and set the number of copies.  The report will be 
sent to the printer on the date/time specified on the When to Run tab.   
 
 
Why don't I see all of my printers? - Reports are sent to the printer using the WaspTime 
Service.  Because of this, only printers local to the network on which your service is installed 
will appear in the drop down. To print to a printer that does not appear in the drop down list, 
there are two solutions: 
 
 
Option 1: Manually type the printer name into the field.  Depending on how your network printer 
was installed, this may solve the issue.   If the report is not sent to the printer you indicated, you 
need to make an alteration to the service setup (Option 2).  
 
 
Option 2: Only use this option if option 1 did not solve the problem.   
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1. On the machine where the service is installed, click Start > Control 
Panel > Administrative Tools > Services.  A list of all installed 
services appears.  Find WaspTimeServer in the list.   

2. Click on WaspTimeServer.  The WaspTimeServer Properties screen 
appears: 
 
 

 

3. Click on the Log On tab.  Select This account and enter a network 
user name and password, then click the OK button. 
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4. Start and restart the service but right-clicking on WaspTimeServer in 
the list and selecting Stop, then right-clicking and selecting Start. 

  
Email - You can set the report to email to multiple people.   
 
 
Note:  In order to use the email option, you must have email setup on the System Setup screen 
> Options tab.  If email is not setup, the Email option will be disabled on the How to Receive 
tab. 
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To use the Email option: 

1. Select the Report Format.  Options are: 
 
 
Portable Doc Format (pdf) 
Microsoft© Word (.doc) 
Microsoft© Excel (.xls) 
Rich Text (.rtf) 

2. Enter the From email address in the Return Email Address field. 

 Click the  button to view a list of employees setup in WaspTime 
with email addresses.  Keep in mind that only employees with email 
address entered on the Employee screen > Personal tab will appear in 
this list. 

3. In the Send Email To section, check which users you want to send the 
report to.  Options are: 
 
 
Selected Managers 
Selected Admins 
Custom List 

4. After you select an option or options, click on the  button next to 
your selection to view a list of employees within that group.  Below is 
an example of the Select screen that appears: 
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Select the employees to which you want to email the report, then click 
the OK button. 

6. Click the OK button to save the scheduled report.  It will appear on the Scheduled Reports list 
screen. 
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Print Setup 

The Print Setup screen allows you to select and configure a local or network printer and specify page 
setup options such as paper size, orientation, and margins.  This is the printer that will be used for 
printing reports from the software. 
  
To Use the Print Setup Screen: 
  

1. Select File > Printer Setup.  The Page Setup screen shown below appears: 
 
 
 

 
 

2. Select Printer at the bottom of the Page Setup screen.  A screen similar to the one shown below 
appears: 
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3. Use the drop down menu in the Name field to select a printer (all printers you have setup on your 
system will appear in the list).   
 

4. Click Properties to make changes to the printer configuration. 
 

5. Click OK when you are done making changes. 
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Working with Lists 

WaspTime contains easy to use List screens that allow you to view and access a variety of information 
quickly.  Screens that use the list view are Employees, Groups, Timecards and Reports.  Each of these 
screens can be accessed by clicking the option on the Main Window.   
  
In addition, you can access a Generic List screen from the Main screen by clicking the Lists icon. 
 Below is an example of the Generic List screen: 
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You can change the data displayed on the screen by making a selection from the drop down list: 
 

 
  
The Generic List screen allows you to group information and create filters so you can arrange the 
information as needed, then print or export the data.  To use the Generic List screen, click on the List 
icon from the Main screen, then pick which group of data (Anniversaries, Departments, etc.) you want to 
view from the drop down menu.  Follow the instructions provided below for Grouping, Filtering and 
Exporting the data.   
  
Note: These screens all function the same; however, individual options may vary for each screen.  This 
topic covers how to use all possible functions available on the list screens.  Keep in mind that not all list 
screens contain all functions mentioned here.  The Clock Setup screen also uses the list functionality. 
 The toolbar options for the Clock Setup screen are discussed individually in the Clock Setup section. 
  
Below is an example of the basic list screen layout.  This is an example of the Employee List. This screen 
can be divided up into three sections (labeled A through C in the example below): 
  
A. Toolbar 
B. Contents List 
C. Buttons    
  
In addition to these menus there are also "Context-Sensitive Menus" that appear when you right-click on 
certain areas of the screen.  These provide another way to access many of the functions available in the 
toolbar.  These types of menus are also discussed later in this section. 
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Quick Links: 
Click a link below to jump to that section of the topic: 
Section A: Toolbar 
Section B: Contents List 
Section C: Buttons 
"Context-Sensitive Menus" 

 

Section A: Toolbar 

 
  
The toolbar at the top of the list screen provides quick access to a variety of functions and also allows you 
to customize how the information on the list is displayed.  Each of these functions is described below: 
  

Button Description 
View 
Timecard 

(Available on the Employee List screen only.) Highlight an employee in the list, then click the View 
Timecard button to view the Timecard screen for that employee.  Please refer to the Timecard Screen 
topic for detailed information. 

Edit Highlight a listing on the screen, then click the Edit button.  The Edit screen appears allowing you to 
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update and change information. 
New Accesses the New screen allowing you to enter a new Employee, Group, etc.   
Copy (Available on the Groups List screen only.)  Highlight a listing, then click the Copy button.  The New 

screen appears with all fields populated with the information from the listing you copied except for the 
Group Name field.  Enter a name for your new group, then click Save. 

Archive (Available on the Employee List screen only.) Highlight a listing on the screen, then click the Archive 
button.   For complete information on Archiving Timecards, please refer to the topic Archive Employees. 

Show 
Group 

The list screens provide you with the capability of "grouping" the displayed information so you can view 
data in a way that is most easy-to-read for you.  You can have one group, two groups, or many groups 
depending on how you want to view your information.  For instance, if you want all employees on the 
Employee List to be displayed grouped by Group, you can quickly set this up.   
  
To see the grouping options, click the Show Group button.  The top of the list screen expands to display 
the group selections as shown below: 
 

 
  
Creating Groups 
  

1. To create a new group, click on a column header, then drag it to the space indicated on the 
screen.  For example, if you want to group information by Group, click on the Group column 
header and drag it to the indicated space. 
 

 
 

2. The screen now lists Group as one of your groups and the employees are displayed according to 
what Group they are assigned. 
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3. You can create additional groups to further organize your information by continuing to drag and 
drop column headers.  For example, you can create a second group for Department dragging the 
Department column header to the top of the screen.   
 
Now the Employee List groups information by Group, and then by Department. 
 

 
 

4. You can switch the order of the groups (Department, then by Group) by dragging and dropping. 
 

5. By default, the groups list information in ascending order (A through Z in this example.).  You can 
change this to descending order (Z through A) by clicking on the group name.  Notice that after 
you click on the group name, the arrow next to the name is now pointing in the opposite direction 
and the information on the screen is reorganized. 
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Deleting Groups 
  

1. If you no longer want to display information in a particular group you can easily ungroup the data. 
 For instance, if you have created a group for Group and another for Department, but now wish 
to only group by site, you can remove the Department group by clicking on the group name and 
dragging it down into the column header section.  Let go of your cursor anywhere in the column 
header section and the group disappears. 
 

 
 

2. The information contained in that group still appears on the display screen, but it is no longer 
grouped together. 
 

 
  

Filter Filter allows you to limit the information that appears in the list by a keyword or phrase you enter. 
  
Creating Filters: 
  

1. Click the Filter button.  A field appears at the top of the list allowing you to enter your keyword. 



 

203 

  
WaspTime User Manual 

 

 
 

2. Click in the space.  A field appears below the first column header (Last Name in this example). 
 Type in the word or phrase by which you want to filter. 
 

 
 

3. After you have enter your word, hit the Enter key.  A field will appear in the next column over 
(First Name in this example).  You can continue to enter keywords for each column by typing in 
the field, then hitting the Enter key, or you can skip a column by hitting Enter without typing any 
information.  After you have Entered through all the columns, only the items that match your 
entered filter (in this example, Last Name = deBlonk) will appear in the list. 
 

 
 

Deleting Filters: 
1. To remove a filter, click on the filter you want to remove.  Notice an icon appears next to the field. 

 

 
  

2. Click the icon to delete the filter.  The filter field becomes blank and the list displays all 
information again. 
 
You can quickly delete all filters by clicking the Filter button.  The filter fields are hidden and all 
information is listed on the screen again. 
  

Export Export allows you to export the entire list to a comma-delimited text file.   
  
  
When the Export button is selected, a screen appears allowing you to specify where the exported data 
will be saved on your computer.  An example of the Export screen is shown on the next page: 
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Make sure you save this to a location you can remember.  You must also choose a name for your file on 
this screen.  After you have made your selections, click Save to export your data. 
  
A confirmation message will appear when your data has been successfully exported by the system.   
  

Print Print allows you to print the list.  When this button is selected, a standard Page Setup screen appears 
allowing you to enter margins.  An example of this screen is shown below: 
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Click the OK button on the Page Setup screen to print the list.  The list will print to your default printer. 
 To change which printer the list is sent to, click the Printer button on the Page Setup screen.  A Printer 
selection screen similar to the one shown below appears: 
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Section B: Contents List 

The contents list displays all data related to the selected list.  For example, if you selected Employees or 
Timecards, all employees will display here, if you selected Groups, all Groups will display here, etc. 

 
 
Sorting Columns: Most of the columns that appear in the lists can be sorted ascending or descending. 
 The columns sort ascending by default.  To change the sort order, click on the column heading.  An 
arrow will appear next to the column name to let you know in which direction the information is sorted. 
 The example below shows a Last Name column sorted Ascending. 
  

 
  
Selecting a Listing: The list screens can display up to 1000 lines of information at a time.  You can 
quickly scroll through the listings using the buttons directly below the contents list.  Keep in mind that you 
can also use the Filter button to limit the items that appear in the list (see Section A: Toolbars, above).   
  
Click on a listing to highlight it, then click the button that accesses the desired function.  For example, if 
you want to edit Employee deBlonk, Sebastian, use your mouse to click on that listing in your Employee 
List, then click the Edit button. 
  
Arranging Columns: You can arrange the columns in the list into any order you wish.  To change the 
order, click on a column heading and drag it somewhere else on the list.  For example, if you want to 
make Group the first column in your Employee List, click on the Group column heading and drag it to 
the first column in the list as shown below: 
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After you drop the column into its new position, the list will reorganize with the Group information 
appearing first: 
 

 
 

 

Section C: Buttons 

 
  
This section contains the following buttons: 
  
Help (F1) - Click this button (or hit the F1 key on your keyboard) to access this help document. 
  
Show: Use the drop down menu to limit the listings on the screen by those employees marked Active, to 
Include Inactive/On Leave employees or display Archived information.  By default, the screen is set to 
Active Only. 
 

 
  
Close - Click this button to close the List.  Keep in mind when closing the list that your groups and column 
settings will be retained. 

 

Context-Sensitive Menus 

The software provides you with a toolbar for quick access to various list features and, in addition, many of 
these features can also be accessed via "context-sensitive menus".  By right-clicking on a column 
heading, a list of available features appears, as shown below (Note that not all options shown below are 
available on all screens): 
 

 
  
 Any changes you make to the list via this menu will be retained when the screen is closed and re-
opened; however, if you install a patch or upgrade, the list settings will be lost.  You must reapply 
your list settings after installing a patch or upgrade. 
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This menu allows you to: 
  
Sort Ascending - Select this option to sort the column in ascending order (A through Z or 1 through 10, 
etc.). 
  
Sort Descending - Select this option to sort the column in descending order (Z through A or 10 through 
1, etc.). 
  
Group By this Column - Select this option to group the screen by the selected column.  Please see 
Section A - Toolbar above for more information on grouping. 
  
Show Grouping - Select this option to show the groups selected for this list screen.  Please see Section 
A - Toolbar above for more information on grouping. 
  
Hide Columns - The list allows you to hide columns by right-clicking on a column label and selecting 
Hide Column.  This enables you to hide information you do not usually need.  When you hide a column, it 
will remain hidden until you manually return it to the List screen by following the instructions below. 
  
Show Hidden Columns -  You can quickly view the columns you have hidden by right clicking on any 
column and selecting Show Hidden Columns.  A pop-up screen similar to the one below appears listing 
all columns that are not currently visible. 
  

  
  
You can return these columns to the full List screen by clicking on a listing in the Hidden Columns 
screen and dragging it back to the column labels section on the List screen.   
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Command Line Functions 

Command Line Functions are designated with a dash, as illustrated below. 
  
wasptime.exe –x -y 
  
Parameters can be passed to the Command Line Functions.  These parameters are designated with a 
slash, and must immediately follow the function to which they correspond.  An example is shown below: 
  
wasptime.exe –x /a /f /l /[c:\myexportfile] -y 
  
Payroll Export (x): 
  
USAGE: Use an x on the command line to perform a Payroll Export. 
  
wasptime.exe –x 
  
PARAMETERS: The Payroll Export Command Line Function accepts parameters to designate file format, 
pay period, employee selection, and output file.  If no parameters are specified, the values specified in 
WaspTime’s System Settings will be used.  If there are not sufficient values specified in the System 
Settings, the payroll export will not execute. 
  
File Format: 
a : ADP 
c : CSV 
q : QuickBooks 
Pay Period: 
l : Last Pay Period (default) 
t : This (current) Pay Period 
Employee Selection: 
f : All Employees (default) 
(dept code) : Employees from a given Department (by Dept. Code) 
{group name} : Employees from a given Group (by Group Name) 
Output File: 
[filename] : Desired Output filename 
  
EXAMPLES: 
  
The following command line will export a file named ‘sample export.csv’ to the root C directory, with the 
last pay period in ADP format for employees in the Research and Development department (Code: RND). 
  
wasptime.exe –x /a /l /(RND) /[c:\sample export.csv] 
  
The following command line will export a file named ‘sample export.csv’ to the root C directory, with the 
current pay period in QuickBooks format for employees in the NonExempt group. 
  
wasptime.exe –x /q /t /(NonExempt) /[c:\sample export.csv] 
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Licenses and the About Screen 

About Screen 

The About Screen allows you to view and manage licenses and provides program version details. 
To access this screen: 

1. From the Main Window, click Help > About.  A screen similar to the following will appear: 
 

 
 
 

2. From this screen you can: 
 
 
View Your License Agreement - Click the View License Agreement button to display your 
license agreement for the software.  This is a text document that will open in a separate window. 
 
 
When you are adding employees, keep in mind that the number of employees allowed on your 
system by your license is equal to the number of employees + admin/managers you add on the 
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Add/Edit Employee screen.  
 
 
Manage Licenses - Click this button to review your current licenses for this software and/or to 
add a new license.  When this button is selected, a screen similar to the following will appear: 
 
 

 
 
 
To add a new license: 

1. Click the Add License button.  A screen similar to the following will appear: 
 
 

 

2. Type in the new license key, then click the OK button. 

3. Click the Done button on the Manage License screen when you are finished adding 
licenses. 
 
  

Copy Settings to Clipboard - To quickly copy the settings listed in Version Details section, click 
the Copy Settings to Clipboard button.  Now you can paste this information into another 
document (such as a Word document) by pressing Ctrl+V on your keyboard. 
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Manage Licenses 

The Manage Licenses screen allows you to set up a license to a new user through the Add License box 
and view the License and License Details, such as the total number licenses available and in use.  For 
more information on Managing Licenses, please refer to the topic About Screen. 
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End User License Agreement Screen 

The End User License Agreement screen allows you to read the entire license agreement.  This screen 
is accessed from the Main Window by clicking Help > About.  The About screen appears with an 
overview of license information.  For detailed information regarding the About screen, please refer to the 
topic About the About Screen. 
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Glossary 

B 
Bi-weekly Pay Period: This pay period is always 14 days long. It can start any day of the week, but it 

starts on the same day every week. There are always two complete weeks, which means two 
complete sets of overtime, in each bi-weekly pay period. There are 26 to 28 pay periods in a year 
depending on the year and when the pay periods start. In this software when you specify the date 
of the first day in any pay period, the software calculates the first day of the week and all the other 
pay periods. The pay period will include the date specified plus the next 13 days. Note that you 
are not specifying the pay day but the day pay starts to accumulate. For example you might 
select July 23rd. That means that your pay week always runs from Sunday through Saturday 
because the 23rd is a Sunday. The pay period would be the two weeks starting on Sunday July 
23rd through Saturday August 5th. 

D 
Daily Overtime: This time is calculated using a daily total threshold after which all time is overtime. The 

standard daily overtime threshold is 8 hours. Once an employee works 8 hours in a day, all time 
worked after the 8 is overtime.For example if you work 10 hours today, you will get 8 hours of 
regular pay and 2 hours of overtime. 

F 
First Day of the Pay Period: The first day that time starts to accumulate in a given pay period. 

Depending on the type of pay period, the first day of the pay period and the first day of the week 
may not be the same. 

M 
Monthly Pay Period: This pay period means one pay period per month. It can be 28 to 31 days long. 

The first day of the week will change from month to month because the length of most months is 
not a multiple of 7 days. There will always be 12 pay periods in a year. To define when the 
monthly pay period starts and ends, you will select the date of the month that is the first day of the 
pay period. In the software when you specify the date of the first date in any pay period, the 
software will calculate the length of the pay periods. You can also specify the first day of the week 
because the pay period will rarely start on the same day from month to month. This also means 
that some pay periods will include partial weeks. For example, you might select July 2nd 2006 as 
the first day of your monthly pay period. That means that your pay period for July will run from 
July 2nd to August 1st- 31 days. August will include August 2nd to September 1st -32 days. Most 
monthly pay periods start on the 1st of the month and are as long as the month. 

O 
Overtime Calculation: By law, overtime is always calculated weekly. A week is defined as 7 days but not 

necessarily Sunday through Saturday. This allows you to pick which day of the week you want to 
start your overtime week. You might change the first day of the week to simplify your reporting or 
because your industry has weekly days off different from Saturday and Sunday. There are 
exceptions to the rule that requires overtime to be calculated on a 7 day week, but the software 
does not support those kinds of overtime weeks at this time. 
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P 
Partial Weeks in a Pay Period: Some Monthly and Semi-Monthly pay periods will be longer than 7 or 14 

days and therefore will include partial weeks. These weeks can be the end of one week or the 
beginning of another or both. Assume the pay period type is Monthly and the pay period starts on 
the 1st of the month and the week runs from Sunday through Saturday. In 2006, August 1st was 
on a Tuesday. The last week of July has Sunday July 30th and Monday July 31st as part of the 
week but the rest of the week is in August. The end of the pay period is July 31st. The 30th and 
31st is a partial week. Regular time for each day that is part of a pay period will be included in 
that pay period. Using the above July example, if the employee worked 8 hours on Monday July 
31st, that 8 hours would be included in the total hours for the month of July. Overtime is always 
calculated weekly. If the overtime calculation is daily any overtime earned on the days included in 
the pay period will be paid in that pay period. Using the July 2006 example above, if the 
employee worked 10 hours on the 30th and 10 on the 31st and the daily threshold was overtime 
after 8 hours, that employee would get 8 hours of regular time and 2 hours of overtime for each of 
the last 2 days on his July timecard totals. If the overtime calculation method is weekly, once the 
weekly threshold is reached overtime on each day included in a pay period will be included in that 
period. If the employee worked 10 hours on the 30th and 31st but his weekly threshold of 40 
hours was not reached until Thursday, he would see 10 hours of regular time on his timecard for 
the 30th and 31st for July. If on the other hand he worked 24 hours a day on the 30th and 31st his 
40 hours would be reached on the 31st and he would see 4 hours of overtime for that week in 
July. If the software is set up to calculate both weekly and daily and choose the best method, 
when a pay period includes partial weeks, the method of calculating overtime for the partial week 
will default to daily. If the calculation switches from daily to weekly after the pay period is closed, 
any overtime due the employee will be paid in the second pay period. If overtime was paid in the 
first pay period that was not earned then, it will be subtracted from the next pay period. The net 
effect will always be correct and since the only legal limitation is that overtime be paid as part of 
the week it was earned.For example an employee works 9 hours on the 30th and 31st and is 
given 2 hours of overtime for that partial week in July. He continues to work 8 hours a day for the 
next 4 days for a total of 50 hours. Calculated daily he would get 2 hours of overtime but weekly 
he is due 10 hours. He has already been paid 2 hours in the July pay period for that partial week 
so in the August pay period he will get 8 hours of overtime for the rest of the week. 

Pay Day: The day the paychecks are distributed. A pay day may be different from the last day of the pay 
period because it takes some time to calculate and create the pay checks. Some companies pay 
in arrears by some number of days, weeks or even a month. 

Pay Period: The actual calendar days included in one paycheck. Any time worked or vacation spent on 
the first day of the pay period through the last day of the pay period is added together to 
determine total hours worked. 

S 
Semi-Monthly Pay Period: This pay period means two pay periods per month. It is different from bi-

monthly because semi-monthly pay periods are not always the same number of days. There are 
always 26 pay periods a year. To define when the pay period starts and ends, you will select the 
day of the month that starts the first and second pay period. In the software you specify the day of 
the month where pay starts to accumulate for the first and second pay periods. You must also 
specify the first day of the week because the pay period will rarely start on the same day month to 
month. This means that some pay periods will include partial weeks For example, if you select the 
1st and 15th as the start of the first and second pay periods. Then for July 2006, the first pay 
period will be from July 1st through July 14th -14 days. The second pay period would be July 15th 
to July 31st-16 days. 

W 
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Weekly Overtime: This time is calculated using a threshold total after which all time is overtime. The 
standard weekly overtime threshold is 40 hours. Once an employee works 40 hours in a pay 
week, all time worked after the 40 hours is overtime. For example, if the first day of the week is 
Tuesday and you work 8 hours every day of the week, then on Saturday you will have 
accumulated 40 hours. If you work any hours on Sunday or Monday, these hours count as 
overtime. 

Weekly Pay Period: This pay period is always 7 days long. It can start any day of the week, but it starts 
on the same day every week. There are always 52 pay periods in a year. In the software when 
you select the first day of the week, the pay period will include that first day plus 6 more days. For 
example, if you select Sunday as the first day of the week, all time on Sunday through the 
following Saturday is included on the timecard. If you select Tuesday as the first day of the week, 
the timecard will run from Tuesday through the following Monday. 
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