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Introduction 
 

Wasp BarcodeMaker is a powerful barcode creation program that seamlessly allows you to 
create barcodes in Microsoft® Word, Excel, and Access as well as in Crystal Reports depending 
on the version you purchased. 

The Professional version of Wasp BarcodeMaker allows you to: 

1. Create barcodes directly in Microsoft Word or Access using the integrated ActiveX toolbar 
and share those files with other people. 
 

2. Create barcodes in Excel using the integrated ActiveX toolbar, or the Fonts toolbar and 
share those files with other people. 
 

3. Create barcodes in Crystal Reports. 
 

4. Create a barcode directly in BarcodeMaker, save it as a .bcm file, and share the file with 
other people. 
 

5. Print and scan barcodes created using BarcodeMaker. 
6. Create 2D barcodes. 

The Standard version of Wasp BarcodeMaker allows you to: 

1. Create barcodes directly in Microsoft Word using the integrated ActiveX toolbar and share 
those files with other people. 
 

2. Create barcodes in Excel using the integrated ActiveX toolbar, or the Fonts toolbar and 
share those files with other people 
 

3. Create a barcode directly in BarcodeMaker, save it as a .bcm file, and share the file with 
other people. 
 

4. Print and scan barcodes created using BarcodeMaker. 

Ease of Use 

BarcodeMaker is the next generation in fast, accurate barcode creation.  It frees you from 
having to know the technical specifications about a particular barcode symbology, 
such as check digit calculation and START and STOP characters, all of which are 
translated automatically. It makes addition of Special and Nonprinting characters simple. 
 As a result, the user can be more productive.  

To create a barcode, the user simply selects a barcode symbology (the type of barcode) 
from a list, types a barcode value in a document, selects the value and clicks a button. The 
barcode appears in the document.  A few simple mouse clicks allow the user to control 
barcode attributes, such as the barcode size, bar width, show caption, use and show 
check digit, and background and foreground colors. Special and Nonprintable ASCII 
Characters are easily added by clicking a button and selecting from a list. Any characters 
that do not apply to the type of barcode chosen become unavailable to make the user's job 
easier. 
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After you select the barcode symbology, the program makes your job easy because 
any attributes that do not apply to that symbology will not be available to you on the toolbar 
or in the BarcodeMaker Main Window.  For example, if the symbology does not support 
check digit, the check digit box will be unavailable. 

If you enter a barcode value that is not supported by a particular barcode symbology, 
BarcodeMaker will display a message letting you know that the barcode value is either 
illegal or incomplete.  For example, the Interleaved 2 of 5 barcode symbology requires 
numbers.  If you include a letter in the barcode value, you will receive a message telling 
you that there is an illegal character in your barcode.  An incomplete barcode is one that 
does not include the required number of characters.  For example, PostNet, which is used 
to barcode zip codes, requires 5, 9 or 11 digits.  If the barcode you enter only has 4 digits, 
you will receive an incomplete character message. 

Microsoft Excel 

In Excel, BarcodeMaker allows you to create many barcodes very quickly. The program 
allows you to link a cell with a variable to a barcode.  If the variable changes, the barcode 
will reflect the change.  You have two options for creating barcodes in Excel.  You can use 
the ActiveX toolbar, or create a font-based barcode using the Font toolbar.  See the 
section When to Use the BarcodeMaker ActiveX Toolbar  vs. the BarcodeMaker 
Fonts Toolbar for help deciding which method will best suit your needs. 

Microsoft Word 

In Word, BarcodeMaker allows you to create multiple barcodes in one file.  The barcodes 
can be moved on the page and printed. 

Microsoft Access 

Available in the Professional Version Only 

In Microsoft® Access, BarcodeMaker allows you to create a barcode on an Access form 
using data from an Access database. For example, if you have a database of book titles, 
and each book title has a different purchase price, using BarcodeMaker, you can easily 
create one barcode for the category - purchase price, and every book title record will show 
a barcode with the purchase price of that particular book displayed under the barcode. 
 Then, if you also want to barcode the publisher's name of each book on every record, you 
can create a barcode called publisher name, and every book title will show the publisher's 
name. 

Crystal Reports 

Available in the Professional Version Only 

Barcodes can be created directly in Crystal Reports using BarcodeMaker or they can be 
created using BarcodeMaker and copied/pasted or dragged and dropped directly into a 
Crystal Reports document. 
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Symbologies Supported in Wasp BarcodeMaker 

BarcodeMaker supports the following barcode symbologies. 

Codabar 
Code 128 
Code 3 of 9 Full ASCII 
Code 3 of 9 Standard 
Code 93 
EAN/JAN-8 
EAN/JAN-13 
Interleaved 2 of 5 
LOGMARS 
MSI/Plessey 
PostNet 
UPC-A 
UPC-E 

2D Barcode Symbologies 

Professional Version Only 

Data Matrix 
MaxiCode 
PDF417 
 

Now you are ready to review the Getting Started section. 
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Getting Started 
 

Creating barcodes using BarcodeMaker is quick and easy.  You can become an expert in no 
time by familiarizing yourself with a few simple steps before you begin.  This help file is divided 
into sections based on how you will be using the software (with Access, Word, Excel or stand-
alone).  Take a moment to read the section titled Determining Which Help Topics to Use, 
below, to help you determine which sections pertain to you.   Reading Important BarcodeMaker 
Program Features will help you understand how the program functions to make your job easier. 

What is a Barcode? 

Barcodes are symbols that store information.  They simplify the movement and sale of 
goods and the storage, movement, tracking and use of information.  Barcodes consist of a 
series of scannable bars and spaces that can be printed on packages, cartons, bottles, 
and other commercial products.  The bars and spaces in each symbol are grouped in such 
a way to represent a specific ASCII character or function.  In addition to the scannable part 
of a barcode, many barcodes have readable numbers and letters that appear below and 
surrounding the bars.  With products in the grocery store, for example, the barcode stores 
a number that is associated with a product.  Through the stored number, the barcode can 
be set up to cross reference an electronic file with information such as the price and on-
hand inventory counts. 

 

There are many different types of barcodes.  Each type has its own symbology, or set of 
rules.  One very familiar barcode symbology is UPC-A (Universal Product Code-A).  UPC-
A is fixed length and is the most common UPC barcode for retail product labeling. It is 
seen in most grocery stores across the United States. The symbology encodes a 12-digit 
numeric only number. The first six digits are assigned from the GS1 US in Lawrenceville, 
New Jersey (formerly the Uniform Code Council or UCC), the next five digits are assigned 
by the manufacturer, and the final digit is a modulo 10 check digit.  The nominal height for 
the UPC-A barcode is one inch.  The reduced size is 80% of the nominal size. 

Specifications, or rules, govern the way the bars and spaces are grouped and whether or 
not and how numbers are used for each barcode symbology.  Various symbologies have 
been developed for particular industries.  Some examples are shipping and receiving, 
manufacturing, retail, health care, transportation, document processing and tracking, and 
libraries. 

Before you begin using the software, review the information below: 

1. Determining Which Help Topics to Use 
2. Choosing a Barcode Symbology 
3. BarcodeMaker Program Features 
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Note:  The screen shots that appear in this help document were taken using Microsoft 
Windows XP® operating system and Microsoft® Office 2003 Pro software.  Some of your 
screens may look slightly different depending son which version of Windows you are using. 

 

 

Determining Which Help Topics to Use 

Microsoft Word and Excel Users 

If you will be working in Word or Excel, the fastest way to get started creating 
barcodes is to begin by reading the BarcodeMaker Toolbar section followed by 
Creating Barcodes in Microsoft Word and Excel. 
 
If you are working in Excel but will not be linking barcodes to any cell in the file, use 
the BarcodeMaker Main Window to create a barcode and then move it into Excel. 
 In that case, read these topics: Creating a Barcode Using the Main Window and 
Moving Barcodes Into Documents. 

Microsoft Access Users 

If you are working with Access databases, read Creating Barcodes in Microsoft 
Access.  There are two different ways to create barcodes in Access using variable 
data.  In one method, you use the BarcodeMaker Main Window and then move 
the barcode into the database. In the other method, you work directly in the Access 
form. You may find that one method is more efficient than another.  

Crystal Reports Users 

If you are working in Crystal Reports, read Creating Barcodes in Crystal Reports. 

Creating Barcodes with Special or Nonprintable Characters 

If you know you will be creating barcodes with Special or Nonprintable ASCII 
Characters, it may be fastest to create them using the BarcodeMaker Main 
Window and then either save each one as a .bcm file or move each one (using 
drag and drop or copy and paste) into Word, Excel or Access. If you are working in 
Excel, the barcodes created using this method will not be linked to any cell. See 
Barcode Symbologies for information on Special Characters associated with 
specific symbologies and ASCII Table for definitions of the Special Characters 
available in BarcodeMaker. 

Using the BarcodeMaker Main Window to Create Barcodes   

Barcodes can be created one at a time in the BarcodeMaker Main Window and 
then either saved using a .bcm file extension or moved (using copy and paste or 
drag and drop) to a Word, Excel or Access document. Please refer to Creating a 
Barcode Using the Main Window or Moving Barcodes Into Documents 
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Commands and Controls 
Information about using commands and controls in BarcodeMaker can be found in these 
topics: 

Main Window 

BarcodeMaker Toolbar 

File Menu Commands 

Edit Menu Commands 

Help Menu Commands 

 

•  Choosing a Barcode Symbology 

As a general rule, the business you are in and the need you have for a barcode will 
determine the type of barcode you would use. Some symbologies, such as UPC, are used 
for retail product labeling and are licensed to the user by a third party. Code 3 of 9 is the 
most popular of all the symbologies and is recommended for first-time users. Please refer 
to Symbologies Supported in BarcodeMaker for a list of symbologies supported in 
BarcodeMaker. Detailed information about barcode symbology standards can be found in 
Barcode Symbologies. 

 

BarcodeMaker Program Features 

Below are features of the BarcodeMaker program that are important to understand. 

Unavailable Options and Tools - After you select the barcode symbology, the 
program makes your job easy because any barcode attributes that do not apply to 
that symbology will not be available to you on the toolbar or in the BarcodeMaker 
Main Window.  For example, if the symbology does not support check digit, the 
check digit box will be unavailable. This feature applies as well to Special and 
Nonprintable Characters, described below. 

Special and Nonprintable Characters - BarcodeMaker makes it possible to add 
Special and Nonprintable Characters to the barcode value by simply clicking a 
button and selecting an ASCII Character from the list. Any Characters that do not 
apply to a symbology become unavailable. 

Illegal and Incomplete Barcode Messages - If you enter a barcode value that is 
not supported by a particular barcode symbology, BarcodeMaker will display a 
message letting you know that the barcode value is either illegal or incomplete.  For 
example, the Interleaved 2 of 5 barcode symbology requires numbers.  If you 
include a letter in the barcode value, you will receive a message telling you that 
there is an illegal character in your barcode.  An incomplete barcode is one that 
does not include the required number of characters.  For example, PostNet, which 
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is used to barcode zip codes, requires 5, 9 or 11 digits.  If the barcode you enter 
only has 4 digits, you will receive an incomplete character message. 

Special and Nonprintable Characters:  Certain barcode symbologies use Special 
or Nonprintable Characters. For example, Code 3 of 9 Full ASCII can be extended 
to an 128 character symbology (full ASCII) by combining one of the special 
characters ($, /, %, +) with a letter (A-Z) to form the characters that are not present 
in the standard Code 3 of 9 symbology. In standard Code 3 of 9 a lowercase "a" 
cannot be represented. In Code 3 of 9 Full ASCII a lowercase "a" is represented as 
"+A". See Barcode Symbologies for more information about the use of Special 
and Nonprintable Characters in barcodes. 

Check Digit - Check digit is a character included within a barcode symbol that is 
used to perform a mathematical check to ensure the accuracy of the scanned data. 
It checks that the barcode meets the specifications set for the barcode symbology. 
Not all barcode symbologies support check digit. If you select a symbology that 
does not support check digit, BarcodeMaker makes check digit unavailable to you 
on the toolbar or in the Main Window. See Barcode Symbologies for more 
information on barcode symbology specifications. 

Bar Width - When you create barcodes, you have the option of choosing a range of 
widths for your barcode.  

Foreground/Background Colors - When you create a barcode, you can choose a 
foreground color (the color of the barcode itself) and a background color (the color 
of the surface behind the barcode). Choose foreground and background colors that 
print with sufficient contrast to be scannable.  Black barcodes on white backgrounds 
are commonly used because they scan easily.  It may be useful to test a few of your 
barcodes by printing them out and scanning them. 
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Symbologies Supported in BarcodeMaker 
 

The following barcode symbologies are supported in BarcodeMaker. 

Codabar 
Code 128 
Code 3 of 9 Full ASCII 
Code 3 of 9 Standard 
Code 93 
EAN/JAN-8 
EAN/JAN-13 
Interleaved 2 of 5 
LOGMARS 
MSI/Plessey 
PostNet 
UPC-A 
UPC-E 

2D Barcode Symbologies 

Available in the Professional Version Only 

Data Matrix 
MaxiCode 
PDF417 
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Main Window 
 

This section gives an overview of BarcodeMaker's Main Window, which can be used to create 
barcodes.  More specific instructions about using these features to create barcodes can be found 
in Creating a Barcode Using the Main Window. 

The Main Window can be used to create one new barcode at a time. The Main Window appears 
when you click the BarcodeMaker icon on your desktop.   
 
 
The Main Window includes the following areas: 
 

 
 
  

• Title Bar -  The Title Bar identifies the BarcodeMaker program.  It also identifies a 
filename or, if the file has not been named, it says, "Untitled".  You can save a barcode 
created in the Main Window.  The file will end with a .bcm extension. 

• Control Boxes: These are used to create a barcode by selecting attributes, such as: 

Symbology - In the Symbology box, click the arrow and select a barcode 
symbology from the list. 
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Value - Enter a barcode value in this box.  This value will appear below the barcode 
as a caption if a caption is supported in the symbology and if you check the Show 
[Caption] box. 

Character Input button - To input Special or Nonprintable Characters that are part 
of a barcode value, click this button and choose one of the available ASCII 
characters from the list.  See Barcode Symbologies for information on Special 
Characters associated with specific symbologies and ASCII Table for definitions of 
the Special Characters available in BarcodeMaker. 

Bar Height - Use the barcode point size arrows to select a barcode size from 1 to 
100 or manually enter a size in the same range. 

Foreground and Background Colors - Click the foreground or background 
buttons to change the default black and white colors. 

Bar Width - Choose for a range of widths.  Choose a low width for a narrow, more 
dense barcode that takes up less space when printed.  Choose a greater width for 
wider barcodes. High Density=15, Medium Density=20, Low Density=36. This 
applies to the width and height of an individual bar inside the barcode. Settings 
lower than 15 correspond to very high densities that some scanners will not read.  

Use Check Digit check box - Select this check box to activate check digit. Click it 
again to clear it. 

Show Check Digit check box - To display the check digit in the caption, select the 
Show Check Digit check box. Hide check digit by clicking the box again to clear it. 

Show check box - To display the barcode value below the barcode as a caption, 
select the Show check box.  Hide the barcode value by clicking the check box again 
to clear it. 

Point Size - To increase or decrease the caption size, click the Point Size arrows. 
The point size ranges from 1 to 100. 

• Barcode Symbology Help Box - This box provides reference information about the 
symbology, such as whether the symbology requires numerals only.  It changes each time 
you choose a different symbology in the Symbology area. 
 

• Barcode Display Window - The barcode appears in the Barcode Display Window after 
you enter a barcode value. 
 

• Menu Bar - The options on the Menu Bar control file management (such as opening, 
closing and printing) and editing activities and provide access to BarcodeMaker User Help. 
Listed below are menu items for BarcodeMaker.  The Menu Bar has an associated toolbar, 
described below, which provides direct access to the most frequently used menu items. 

File - General options for opening, closing, saving, and printing files and for exiting 
the BarcodeMaker program. 

Edit - Includes options for cutting and copying barcodes from BarcodeMaker so 
they can be moved into documents. 
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Help - Provides Help Topics, which describe how to use BarcodeMaker, and an 
About BarcodeMaker item, with BarcodeMaker's version and copyright information. 

• Main Window Toolbar - The Main Window toolbar provides direct access to the most 
common menu bar items: File, Edit, and Help. Click Here for more information on each 
option listed below.  The options available on the Toolbar, along with their keyboard 
shortcuts, are listed below. 

    New (File/New - Ctrl+N)  

    Open (File/Open - Ctrl+O)  

    Save (File/Save - Ctrl+S)  

    Cut (Edit/Cut - Ctrl+X) 

    Copy (Edit/Copy -Ctrl+C) 

    Print (File/Print - Ctrl+P) 

    Help 
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BarcodeMaker ActiveX Toolbar 
 

This section discusses the BarcodeMaker ActiveX Toolbar. 

For more in-depth information about creating barcodes in Microsoft Word, Excel, or Access 
(Professional Version Only), click one of the preceding links.  

The toolbar is available at the top of the screen when you open Word, Excel, or Access 
(Professional Version Only).  If the toolbar does not automatically appear, click the Add-in 
menu option at the top of the screen.  The ActiveX toolbar allows you to create new barcodes.  It 
also allows you to change the attributes of the barcodes already in a document. Below is an 
example of the ActiveX toolbar. 

 

Using the Toolbar: 

Note:  The Toolbar does not allow you to:  (1) increase the barcode caption size, (2) control 
background and foreground colors, or (3) input Special or Nonprintable Characters. In Word, 
Excel and Access, these three barcode attributes can be changed as follows: 

1. Select a barcode already created in a document. 
 

2. Click the Edit Barcode button.  This opens the BarcodeMaker Dialog Bar. The Dialog 
Bar includes most of the same features as the BarcodeMaker Main Window. See Main 
Window for an overview of the features on the Dialog Bar.  See Creating a Barcode 
Using the Main Window for specific instructions on using the features on the Dialog Bar. 

Hiding the Toolbar: To hide the Wasp BarcodeMaker ActiveX toolbar, go to View> Toolbars 
and clear the BarcodeMaker toolbar checkbox.   

Moving the Toolbar:  If it is in your document, click it and use the move handle to drag and drop 
it to a different location. If it is in the toolbar area, scroll over it until you see the move handle and 
drag and drop it to a different location. 

Toolbar Buttons and Boxes: Below is a description of the toolbar buttons and boxes and how 
to use them. 

About 
button 

Allows you to see the BarcodeMaker version number and copyright notice. 

Barcode 
Symbology, 
Bar Height, 
Bar Width 
Boxes 

To use these three boxes, click the associated arrow button next to the box 
and select from the list of choices. 

Symbology box - allows you to choose a symbology supported in 
BarcodeMaker. 
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Barcode Height box - allows you to choose a size for the barcode itself 
from a range of 8 to 72 points. It does not control the size of the barcode 
value. 
 

 

Bar Width box - allows you to select the barcode width from a range of 
options.  High Density=15, Medium Density=20, Low Density=36. This 
applies to the width and height of an individual bar inside the barcode. 
Settings lower than 15 correspond to very high densities that some 
scanners will not read. 

  

  New 
Barcode 
Button 

Allows you to create a new barcode in a document. 

Design Mode 
Toolbox 

 

Allows you to resize the box surrounding the barcode.  This toolbox 
appears when you create a barcode in a document.  Click it once to enter 
design mode. The sizing handles appear surrounding the barcode.  Click it 
again to exit design mode, and the sizing handles disappear. (To move 
the Design Mode Toolbox itself, click it and use the move handle to drag 
and drop it.) 

 

Show 
Allows you to toggle between showing and hiding the barcode value as a 
caption below the barcode.  To activate this tool, click the button. It will 
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Caption appear highlighted in orange on the toolbar. Click the button again to 
deactivate it, and it will no longer be highlighted on the toolbar.  

Use 
Check Digit 

Allows you to use check digit in a barcode.  It does not control whether the 
check digit is visible in the caption.  To activate this tool, click the button. It 
will appear highlighted in orange on the toolbar. Click the button again to 
deactivate it, and it will no longer be highlighted on the toolbar.  

Show 
Check Digit 

 

Allows you to display the check digit in the barcode caption.  To activate 
this tool, click the button. It will appear highlighted in orange on the 
toolbar. Click the button again to deactivate it, and it will no longer be 
highlighted on the toolbar.  

Link 
This button is used in conjunction with the Mail Merge feature found in 
Word, Excel and Access.  If you are using Office XP or Office 2003 (not 
Office 2000) the Mail Merge option will be available under the Tools> 
Letters and Mailings menu in Word, Excel or Access. In Vista, Mail Merge 
is available under the Mailings menu. 

During the mail merge process, you will: 

1.  Select the Data Source. 

2.  Create blank barcode, then stretch outline to accommodate barcode 
value. 

3.  Click on the Link icon in the toolbar.  The screen will appear listing all 
available fields. 

4. Select the field you want linked to the barcode. 

5.  Proceed with the mail merge process. 

Edit 
Barcode 
button 

Accesses the Dialog Bar of BarcodeMaker so that you can edit any 
attributes of a selected barcode.  To use the Edit Barcode button, select a 
barcode in a document by clicking it.  Then, click the Edit Barcode button. 
 The Dialog Bar of BarcodeMaker will appear on the left.  To leave the 
Main Window, click anywhere in the document. 

Note:  You cannot change the caption point size or the 
foreground and background colors of a barcode using the toolbar. 
You must create a barcode, then select it and click the edit barcode 
button, which opens the Main Window, where you can change any 
attributes of the barcode. 

Format 
Painter 
button 

 Allows you to copy and paint the symbology and attributes of one barcode 
onto another barcode.  It will have not change the barcode value.  It will 
apply the symbology, bar height, bar width, show caption, use check digit, 
and show check digit of the copied barcode onto another barcode. 

To use this tool, select a barcode with a symbology and attributes that you 
want to copy to another barcode.  Click the Format Painter button.  Then, 
click the barcode you want to change. 

Note:  A button that is not highlighted is different than a button that is not available. 
 Unavailable buttons are not available because they do not meet the specifications of the 
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symbology that is selected in the in the symbology box.  They appear to be gray and when 
you try to click them, nothing happens. 
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Creating a Barcode Using the Main Window 
 

This section discusses how to create a barcode using the BarcodeMaker Main Window.  The 
Main Window, can be used to create one new barcode at a time and to change barcodes that 
have already been created in documents.  The Main Window appears when you click the 
BarcodeMaker icon on your desktop. 

When working from within the Main Window, one barcode can be created at a time and then 
copied and pasted or dragged and dropped into a Word, Excel or Access document. (See 
Moving Barcodes into Documents.)  More than one barcode can be created when you work 
directly within a Word, Excel or Access document. 

There are additional steps involved in using the Main Window  to create barcodes in Access 
that are not covered here.  They are covered in detail in Working in the Main Window to 
Barcode Variable Data in Access. You may find that using the Main Window to create 
barcodes in Access is more efficient than working directly in Access. We recommend that you 
familiarize yourself with the Main Window of BarcodeMaker and then read Creating Barcodes 
in Microsoft Access, where there are two different methods for creating barcodes in Access 
using variable data and decide if working in the Main Window is the most efficient method for 
you. 

Click the link to see an example of a 3 of 9 Full ASCII barcode created using the Main 
Window of BarcodeMaker. 

 

Creating a Barcode Using the Main Window 

Listed below are steps to create a barcode using the BarcodeMaker Main Window.  Once you 
select the symbology, only the barcode attributes that apply to that symbology will be available to 
you in the Main Window.  Therefore, the steps below cover attributes that may not be available 
in certain symbologies. 

1. Open BarcodeMaker by clicking the BarcodeMaker icon on your desktop. The Main 
Window, shown below, will appear. 
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2. Click the down arrow next to the Symbology box to view a list of available barcode 
symbologies.   

 
  

Select the barcode symbology you are interested in creating from the list.  When you 
select a listing, the Help box in the bottom, left corner of the Main Window provides 
reference information about the selected symbology.  For more information about which 
barcodes are supported in BarcodeMaker, see Symbologies Supported in 
BarcodeMaker.  For information about barcode symbology specifications, see Barcode 
Symbologies. 

Note:  After you select the barcode symbology, any attributes that do not apply 
to that symbology will not be available to you in the Main Window.  For example, if 
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the symbology you chose does not support check digit, the check digit box will be 
unavailable. 

3. Enter a barcode value in the Value box. The barcode will appear in the display window. 
 
 

 
 
Character Input button - If the barcode value includes any special or nonprintable 
characters, click the Character Input button and choose an available ASCII character 
from the list.  
 

 
 
Only those characters that apply to the chosen symbology will be available. See Barcode 
Symbologies for information on Special Characters associated with specific symbologies 
and ASCII Table for definitions of the Special Characters available in BarcodeMaker. 
 

If you enter a barcode value that is not supported by a particular barcode symbology, 
BarcodeMaker will display a message letting you know that the barcode value is either 
illegal or incomplete. 
 
  

4. Select the barcode attributes: Bar Height, Bar Width, and Foreground and Background 
colors.  The barcode can be seen in the Barcode Display Window taking on the new 
attributes.   

The Bar Height box, located below the Value box, controls the size of the barcode 
itself.  It offers a range of 1 to 100 points. Use the up and down arrows shown in the 
image below to select a size, or manually enter a size in the same range. 
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If you delete the displayed size, the following alert box appears: 
 
 

 
 
  

Click OK and enter the size in the height box.  The barcode will appear in the 
designated size.  To resize the barcode, click the arrows or manually enter a 
new size. 

Bar Width - Click the up or down arrow to designate a width for the barcode.  High 
Density=15, Medium Density=20, Low Density=36. This applies to the width and 
height of an individual bar inside the barcode. Settings lower than 15 correspond to 
very high densities that some scanners will not read. 
 

 

Foreground and Background - Click the foreground or background buttons to 
change the default black and white colors.  The Foreground color chosen 
determines the color of the barcode.  The Background color determines the color 
behind the barcode. 

 

The following screen appears when you click the Foreground or 
Background buttons. Choose a color by clicking one of the colored squares 
and OK. 

Populating the Custom Color Area 
Up to 16 custom colors can be added to the custom color area. The same 
group of colors will be available to you when you are choosing Foreground or 
Background. To add colors to the Custom color area, click a blank box from 
the Custom colors area, then click a color and Add to Custom Colors. 
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5. Select the Use Check Digit check box to activate it. Click it again to clear it. 

 

6. Use the Caption area to control the following barcode attributes: 

 
 
  

Select the Show check box to display the barcode value as a caption below the 
barcode. Hide the caption by clicking the check box again to clear it. 



 

21 

Select the Show Check Digit check box to display the check digit in the caption. 
Hide check digit by clicking the check box again to clear it. 

Choose a caption size:  Click the Point Size box up or down arrows to size the 
barcode caption. The point size ranges from 1 to 100. 

7. Save the file.  If you are creating a new file, click File>Save As and enter a file name. 
BarcodeMaker files carry a *.bcm file name extension. 
 

8. Move the new barcode into a Word, Excel or Access (Professional version only) document 
by using copy and paste or drag and drop.  See Moving Barcodes into Documents for 
information about moving barcodes into a Word, Excel or Access (Professional version 
only) document. 
 

9. Print the file.  Click the Print button or File>Print on the Menu Bar. 
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Example:  3 of 9 Full ASCII Barcode 
 

The screen shot below shows how a Code 3 of 9 Full ASCII barcode with a barcode value of 
1234 would appear in BarcodeMaker. Because Show Check Digit was selected, the letter A, 
which is the check digit, appears at the end of the barcode caption.  The check digit enhances 
data security. 
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Moving Barcodes into Documents 
 

A barcode can be copied and pasted or dragged and dropped from the Main Window of 
BarcodeMaker to a Microsoft® Word, Excel or Access document. This section covers how to 
move a barcode created in the Main Window of BarcodeMaker into a Microsoft Word or Excel 
document. 

Moving Barcodes into Access is available in the Professional version only. For 
instructions on moving a barcode from the Main Window into Microsoft Access, see Creating 
Barcodes in Microsoft Access. 

 

Moving Barcodes From the Main Window to Word or Excel 

1. Open BarcodeMaker and your Word or Excel document and resize them so that both can 
be seen on the monitor, as shown below. 
 

 
 

2. You can two options to move the barcode: 
 
Copy and Paste - To copy and paste a barcode from BarcodeMaker into a Word or Excel 
file: 

a. From the BarcodeMaker Main Window, copy the barcode by selecting it with your 
cursor, then click Edit, Copy on the Main Menu (Ctrl+C on your keyboard) or the 

copy button . 
b. In the document, place your cursor where you want the barcode to be, then paste 

the barcode into the document by clicking Edit, Paste on the Main Menu (Ctrl + V 

on your keyboard), or the Paste button . 
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Drag and Drop - To drag and drop a barcode from BarcodeMaker into another document: 

In BarcodeMaker, click the barcode with the mouse and, keeping the mouse button held 
down, drag the barcode out of BarcodeMaker, into the document and release the mouse. 
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Creating Barcodes in Microsoft® Word and Excel 
 

This section provides step-by-step instructions for creating barcodes in Microsoft Word and 
Excel using the BarcodeMaker Toolbars.  When you work directly in Word or Excel, 
BarcodeMaker allows you to create one or multiple barcodes in the same file using the Wasp 
BarcodeMaker ActiveX Toolbar. 

In addition to the ActiveX Toolbar, Excel contains another toolbar that allows you to create 
barcodes using text barcode fonts.  This toolbar, called the Wasp BarcodeMaker Fonts toolbar, 
allows you to can easily create 1000+ barcodes in Excel because these barcodes are lightweight 
and consume less resources.  

This topic covers the following areas: 

How to Create Barcodes in Word and Excel Using the Wasp BarcodeMaker ActiveX 
Toolbar 

How to Create Barcodes in Excel Using the Wasp BarcodeMaker Fonts Toolbar 

Additional Information for Excel Users 

Examples of Barcodes that can be Created in Excel 

When to Use the BarcodeMaker ActiveX Toolbar  vs. the BarcodeMaker Fonts 
Toolbar 

How To Send a Worksheet to a User that does not have BarcodeMaker Installed 

 

 

How to Create Barcodes in Word and Excel 

1. Open a document.  The BarcodeMaker toolbar appears in your document.  If you are using 
Vista and the toolbar does not appear, click the Add-in option on the Word or Excel menu 
bar. 
 

 
 
Note:  When viewed from Excel, the BarcodeMaker Fonts toolbar may appear first.  To 
access the ActiveX toolbar, click the Switch to ActiveX option on the Fonts toolbar. 
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2. Select a symbology from the symbology box. Notice that once you choose a symbology, 
some of the toolbar features become unavailable because they are not a required by the 
specifications for the chosen symbology.  This program feature makes choosing the 
symbology before you choose other barcode attributes an efficient way to work. 
 

 
 
  

3. If you are working in Word, enter a barcode value directly into the document and select the 
value. 
 
If you are working in Excel, you must select the cell, not the value in the cell.  Do this by 
clicking once on a blank cell and then selecting the cell or cells with the values. 
 
See the screen shots for Word and Excel below. 

Example:  Word 
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Example:  Excel 
 

 
 
  

4. Choose the following attributes of the barcode from the buttons on the toolbar.  See 
BarcodeMaker Toolbar for information on using each tool. 

Bar Height 
 

 

Bar Width:  High Density=15, Medium Density=20, Low Density=36. This applies to 
the width and height of an individual bar inside the barcode. Settings lower than 15 
correspond to very high densities that some scanners will not read. 

 

Show Caption 

Use Check Digit 

Show Check Digit 
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Link 

 

5. Once you have created the barcode, you can: input Special and Nonprintable 
Characters into the barcode value, resize the caption, and change the foreground and 
background colors by following the procedures below. 

a. Open the Dialog Bar by selecting the barcode and clicking the Edit Barcode 

button. Alternatively, you can open the Dialog Bar by right clicking the bar code, 
and selecting WaspBarcodeMaker Control Object and then Edit. (Note: To leave 
the Dialog Bar, click anywhere in the document.) 

b. Input Special or Nonprintable Characters:  In the Dialog Bar, click the Character 
Input button next to the Value box and choose an available ASCII character from 
the list. Only those characters that apply to the chosen symbology will be available. 
 
When you select the special character from the list it will be added wherever the 
cursor is in your cell or text. Position the cursor before selecting the special 
character because some special characters do not have a representation that can 
be seen on the screen as text. After adding the special character you may get a 
very strange character or series of characters or nothing at all. Trying to manually 
edit these characters or change them may cause the special character to not 
convert to a barcode properly. The only way to confirm that the special character is 
converted to a barcode properly is to print and scan the barcode and test that the 
special character does what you intend it to do when the barcode is scanned.  
 

c. Foreground / Background colors - Click the foreground or background buttons to 
change the default black and white colors. The Foreground color determines the 
color of the barcode. The Background color determines the color behind the 
barcode. 

 

The following screen appears when you click the Foreground or Background 
buttons. Choose a color by clicking one of the colored squares and OK. 
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d. Caption Point Size: Choose a caption size:  Click the Size box up or down arrows 
to size the barcode caption. The point size ranges from 1 to 100. 

 

6. Click the New Barcode button.  

The barcode(s) appears in your document and the Design Mode toolbox appears on the 
page. 

Scroll over the barcode with your mouse. Use the move handle to drag and drop the 
barcode. 
 
 

 
 



 

30 

 
Example:  Excel 
 
In the example using Excel below, the barcode was moved to another cell.  This revealed 
the underlying barcode value. The cell with the barcode (cell B1) is linked to the cell with 
the barcode value (cell A1). 
 

 
 
 
 
Example:  Word 
 
 

 
 
  

7. To edit an existing barcode, select the barcode, and click the Edit Barcode button. 
This accesses the BarcodeMaker Dialog Bar. To leave the Dialog Bar, click anywhere in 
the document. 
 
Note: To edit the barcode, you should right-click on it and select Edit, or click the Edit 
Barcode button on the toolbar.  Do not double-click on the barcode, or a Visual Basic 
window will appear, as is normal with ActiveX controls.  If you do inadvertently open the 
Visual Basic window, simply close it to return to Excel and continue working. 
 

8. To resize the barcode, select it. Use the sizing handles to increase or decrease the box 
surrounding the barcode. 
  

9. Save the file.  If you are creating a new file, click File>Save As and enter a file name. 
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9. If you are working in Excel, set the print area and choose the page setup options before 
you print the document. 
 

10. Print the document. Click the Print button or File>Print on the Word or Excel Menu Bar. 

   
 

How to Create Barcodes in Excel Using the Wasp BarcodeMaker Fonts 
Toolbar 

1. Open a document.  The BarcodeMaker toolbar appears in your document.  If you do not 
see the toolbar, click the Add-In option on Excel's menu bar. 
 

 
 
Note: You can switch to the ActiveX toolbar bar clicking Switch to ActiveX. 
 

2. Select a symbology from the symbology box. Notice that once you choose a symbology, 
some of the features on the toolbar become unavailable because they are not a required 
by the specifications for the chosen symbology.  This program feature makes choosing 
the symbology before you choose other barcode attributes an efficient way to work. 
 

 
 

3. Select the cell (not the value in the cell) by clicking once on a blank cell and then 
selecting the cell or cells with the values. 
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4. Click the Create Font Barcode button from the toolbar. 
 

 
 

5. Choose the following attributes of the barcode from the buttons on the toolbar.   
 
Bar Height: Select a size for the barcode itself from a range of 8 to 72 points. This does 
not control the size of the barcode value. 
 

 
 
Bar Width:  Choose High Density, Medium Density or Low Density. This setting applies 
to the width and height of an individual bar inside the barcode.  
 

 
 

Enable/Disable Check Digit Calculation - This option allows you to use check digit in 
a barcode.  It does not control whether the check digit is visible in the caption.  To activate 
this tool, click the button. It will appear highlighted in orange on the toolbar. Click the 
button again to deactivate it, and it will no longer be highlighted on the toolbar.  
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Show/Hide Caption - Click this option to show or hide the caption that goes with the 
barcode. 
 

Format Painter - To quickly transfer one barcodes attributes to another (or to many), 
highlight the barcode whose formatting you want to copy, then click on the barcode(s) you 
want to "paint" with that formatting.  The attributes (width, height, etc.) will be copied to the 
selected barcodes.  This does not change the value of your barcode. 
 

Undo Barcode - Highlight a barcode, then click this option to revert the barcode to 
text (or it's original value). 

   

 

Additional Information for Excel Users 

Examples of Barcodes That Can Be Created in Excel 

In Excel, BarcodeMaker allows you to create many barcodes very quickly, as long as they 
are all using the same symbology and attributes.  The program also allows you to link a 
cell with a variable to a barcode.  If the variable changes, the barcode will reflect the 
change.  If you want to create a barcode in Excel that is not linked to any other cell, use 
the Main Window of BarcodeMaker to create the barcode and then move it into the Excel 
spreadsheet.  See Creating a Barcode Using the Main Window and Moving Barcodes 
Into Documents. 

Creating Multiple Barcodes Quickly 
If you want to create multiple barcodes quickly using values already entered into multiple 
cells, follow the steps in this topic. (The barcodes can be moved to another location.  The 
cell with the value will be linked to the cell with the barcode.) 
 
In the example below, barcode values were entered in cells A1 to A4 and all the cells were 
selected.  Next, the New Barcode button was clicked and barcodes appeared covering the 
values in cells A1 to A4.  Each barcode was moved to the B column.  If the value of any 
barcode in column A changes, its linked barcode in column B will reflect the change. 
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Note for Windows 2003 Users/Excel 2000:  When creating an EAN/JAN13 barcode with 
17 or more digits in Excel, the system may try to convert your number to scientific notation. 
 To prevent this, you should type the digits as below: 

'1234567890123456789.... 

Putting the ' before the digits prevents Excel from formatting the number in scientific 
notation. 

Creating a Barcode that is Linked to a Cell with a Variable 
BarcodeMaker allows you to link a cell with a variable to a barcode.  If the value in that cell 
changes, the barcode will reflect the change.  The barcode can be moved.  The cell with 
the barcode will be linked to the cell with the value. 

In the example below, a barcode has been created by selecting cell B8 (which is the sum 
of cells B3 through B7) and clicking the New Barcode button. After the barcode was 
created, it was moved to a different cell.  If any of the numbers in B3 through B7 change, 
the value in cell B8 and the barcode will change to reflect the new sum total. 
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When to Use the ActiveX Barcode Control Feature vs. Using  Text Barcode 
Fonts 

You should use the ActiveX barcode control for creating barcodes with the Wasp 
BarcodeMaker ActiveX toolbar when: 

1. You want to send the Excel spreadsheet to another user who does not have BarcodeMaker 
installed.  
  

2. You want to create a barcode that can be placed anywhere on the Excel sheet (i.e. not 
bound to a cell). 
 

3. Your Excel spreadsheet will contain less than 200 barcodes (number chosen for optimal 
performance). 
 

4. You want to link the value of a cell to a barcode, so that when the value changes the 
barcode also changes. 
 

5. You want to control the Bar Width property and fine tune the density of the generated 
barcode to be different than “High”, ”Medium”, ”Low”.  
 

6. You need 2D symbologies. The 2D symbologies are only available through the ActiveX 
barcode control.  2D symbologies are available in the Professional version. 

Use text barcode fonts by creating barcodes with the Wasp BarcodeMaker Fonts toolbar when: 

1. You  want to create more than 1000+ barcode in the Excel spreadsheet. 
 

2. You do not need portability (sending to another user who does not have BarcodeMaker 
installed) and printing will be done on machines that have BarcodeMaker installed. 
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3. You will be exporting the Excel spreadsheet to PDF format.  In this case, our TTF (True 
Type Fonts) are recommended since we use embeddable fonts. 
 

4. You want to use OCR fonts for Optical Character Recognition Applications.  
 

5. You want to use MICR font to print checks. Please be aware that the Wasp MICR must be 
picked from the Excel font list to use the MICR fonts. 

How To Send a Worksheet to a User that does not have BarcodeMaker 
Installed 

Note:  These instructions apply only to text/font barcodes created using the Wasp 
Barcodemaker Fonts toolbar, not the ActiveX toolbar. 

1. In the worksheet you want to send, select the barcodes. With the barcodes selected right-
click, then select Copy or press CTRL-C to copy selection. 
 

2. Right-click and select Paste Special on the selection. A menu will appear providing options 
on how to paste. 
 

3. Select Values from the menu.  The system will paste the translated value in the selected 
cells.  This means the original formula that was in the cell(s) is cleared and replaced by the 
translated values. 
 

4. Save the document.  The user you are sending it to must have the barcode font installed to 
properly view the barcodes. 
 
Note: Barcodes based on translated values (when BarcodeMaker's formula is not in the cell) 
cannot be changed.(i.e. symbology, resolution etc).  This means the user you send the 
spreadsheet to will not be able to edit the barcodes. 
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Creating Barcodes in Microsoft® Access 
 

This option is available in the Professional version only. 

BarcodeMaker allows you to barcode variable data (also referred to as Control Source Data in 
this section) in an Access database.  It allows you to create several variable data barcodes in the 
same database. 

Note:  Access needs to be in design mode for barcodes to print on Forms/Reports. 
  

Sharing a MSAccess Database with Barcodes Across the Network 

1. BarcodeMaker must be installed on each machine that accesses the database shared on 
the network (MDB) 
 

2. In BarcodeMaker, navigate to the Settings screen (Main Window>Help>About 
BarcodeMaker>Settings), and uncheck the Load the BarcodeMaker add-in everytime 
Microsoft Access starts option.  This disables the BarcodeMaker toolbar from loading 
each time MSAccess is opened, which can cause conflicts with sharing the database.  

These steps need to be performed on every PC on which the MDB file will be shared across the 
network. 

After these two steps are performed, you can open the network-shared MDB simultaneously with 
no errors.  Any design changes to the MDB (adding an extra barcode on a form, changing the 
form layout or changing a report in someway) can only be done by one user at a time.  Two 
users cannot make changes simultaneously. 

In the example used below, the Book Collection database contains book titles.  Each book title 
has a different purchase price.  Using BarcodeMaker, you can easily create one barcode for the 
Control Source Data, in this case the PurchasePrice (shown in Image 1 below), and every book 
title record will show a barcode with the purchase price of that particular book displayed under the 
barcode (shown in Image 2 below).  You can add more than one variable data barcode to the 
same Access database. For example, you could also barcode the publisher name, and each book 
title would also show a barcode that displays the book's publisher.  
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Image 1 

 

Image 2 
 

 

You can even add a barcode with information that is not contained in the Access database.  See 
Creating a Static Barcode that Appears in Every Record. 

Barcodes can be created directly in Microsoft Access using the Main Window or they can be 
created using BarcodeMaker and copied and pasted or dragged and dropped into an Access 
database.  You may find one method works more efficiently than the other.  Full instructions for 
both methods are provided in this section as well as Quick Start instructions for working directly 
in Access. 

Note:  You must work in Forms>Design View in Access to create, edit and move barcodes. 

This section explains: 

Quick Start: Working Directly in Access to Barcode Variable Data 
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Working in the Main Window to Barcode Variable Data in Access 

Working Directly in Access to Barcode Variable Data 

Creating a Static Barcode that Appears in Every Record 

Quick Start:  Working Directly in Access to Barcode Variable Data 

The instructions in this section are a condensed version of Working Directly in Access to 
Barcode Variable Data. 

1. Insert a blank barcode box in an Access database:   
a. Open the database in Form, Design view.  

b. Click Insert>ActiveX Control on the Menu.  
 

c. Select WaspBarcodeMaker Control and click OK. A blank barcode box appears in 
the Access database. 

Or:  Toolbar Method: To do the same thing using the toolbar: 

a. Open the database in Form, Design view.  
 

b. Click anywhere in the form.  

c. Click the New Barcode button on the toolbar. A blank barcode box appears. 
 

d. To identify variable data you want to barcode:   
 
a. Right click the blank barcode box.  

 
b. Select Properties. The ActiveX Control form appears.   

 
c. Select the Data tab, and click the Control Source arrow.  

 
d. From the list, select the Control Source Data you want to barcode (in the example, 

PurchasePrice was chosen).   
 

e. Keep the ActiveX Control form open during the next step. 

3. To open the BarcodeMaker Dialog Bar:   
 
a. Right click the blank barcode box.  

 
b. Select WaspBarcodeMaker Control Object>Edit from the menu. The 

BarcodeMaker Dialog Bar appears.  
 

c. In it, select a symbology, such as Code 128, that takes alpha and numeric 
characters.   
 

d. In the Value box, enter Control Source Data from the Access database (such as 
PurchasePrice) exactly as it is spelled and spaced in the database.   
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e. Click Show to display the caption.   
 

f. Choose any other barcode attributes applicable to your task.  
 

g. Click anywhere in the Access database. The barcode appears and the Dialog Bar 
disappears.   
 

h. Move and resize barcode by clicking it and using the move and resizing handles. 

 

Working in the Main Window to Barcode Variable Data in Access 

You can use the BarcodeMaker Main Window to create a barcode using variable data 
from an Access database and then move it into your Access database by following these 
steps.  If you decide to use this method to create barcodes in Access, familiarize yourself 
with using the BarcodeMaker Main Window by reading Main Window. 

1. Open the BarcodeMaker Main Window using the icon on your desktop. 
 
 
 

 
 
  

2. Open Microsoft Access and the database.  Select Forms on the left pane, select a form in 
the right pane then click the Design button. 
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A screen similar to the one below appears. 
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3. Resize the Main Window and the database form to fit side by side on the monitor. 
 

4. To barcode Control Source Data (also known as a text box) from the Access Form, make 
a note of the exact spelling and spacing of the Control Source Data.  (See the example 
outlined in red below.) 
 

 
 
  

5. In the BarcodeMaker Main Window, select a symbology from the Symbology box that 
supports the barcode value you are using.  In the example, we chose Code 128 because 
it supports both alpha and numeric characters. 

6. Type the Control Source Data into the Value box exactly as it appears in the Access 
form.   
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7. Click Show in the Caption area if you want to show barcode value below the barcode. 
 The barcode will appear in the Barcode Display area.   
 

 
 
Select any other available attributes in the Main Window that apply to what you are trying 
to achieve:  Bar Width/Height, Foreground and Background Colors, Caption Point Size, 
Use Check Digit, Show Check Digit.  For more information about these attributes, see 
Main Window and/or Creating a Barcode Using the Main Window. 
 

8. Move the barcode from the Main Window to the Access database by either copy/paste or 
drag/drop, as described below. 

Copy and Paste 

In the BarcodeMaker Main Window, copy the barcode by selecting it with the 
cursor, then click Edit>Copy on the Main Menu (Ctrl+C on your keyboard) or click 

the copy button . 

In the document, place your cursor where you want the barcode to be, then paste 
the barcode into the Word document by clicking Edit > Paste on the Main Menu 

(Ctrl + V on the keyboard), or the Paste button . 

Drag and Drop 

In the BarcodeMaker Main Window, click the barcode with the mouse and, 
keeping the left mouse button held down, drag the barcode out of BarcodeMaker 
and into the document. 
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10. Resize and move the barcode in the Access database. 

Use the move handle to reposition the barcode so that it does not hide other data. 

 

Use the sizing handles to increase or decrease the barcode box. 

 
  

11. In Access, link the barcode to the Control Source Data. 

Right click the barcode. 

Select Properties. 

The ActiveX Control form appears. 

Click the Data tab. 

Click the Control Source arrow and from the list, select the Control Source Data 
you barcoded (PurchasePrice, for this example).  
 
The data, PurchasePrice, is now barcoded in the Design View.  (See Screen Shot 
1 above.) 

12. To view individual records, click View>Form View on the Menu Bar.  Use the Record 
arrows at the bottom of the screen to view each record.  You will see that the barcode 
changes for each record. (See Screen Shot 2 above.) 
 

13. Save the database by clicking File>Save on the Access Menu Bar. 

Working Directly In Access to Barcode Variable Data 

The instructions below discuss working directly in Access to create a barcode using variable data 
(also referred to as Control Source data in this section). Where applicable, instructions for using 
the toolbar to accomplish the same task are included.  

1. Open Microsoft Access and the database. The BarcodeMaker toolbar will appear at the 
top of the screen. Select Forms on the left pane, and select a form in the right pane, and 
click Design View. 
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2. To create a barcode in the form: On the Menu Bar, select Insert>ActiveX Control.   In 
the Insert ActiveX Control form, scroll down and select WaspBarcodeMaker Control and 
select OK. 
 

Toolbar Method:  On the Toolbar, click the New Barcode button and click the form 
to insert a blank barcode box. 
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A blank barcode box appears in the form. Your screen will be similar to the one shown 
below after you have completed the steps above. 
 

 
 
  

3. Next, in the database, link the variable, or Control Source Data that you want to use to 
create a barcode (in the example used, the PurchasePrice) to the blank barcode box. 
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Note:  Skip this step if you are creating a static barcode, which is a barcode that does 
not change on each record. 

4. Right click the blank barcode box.  Select Properties. 
 

 
 
 
The ActiveX Control form appears. 
 
  

5. Click the Data tab.  In the Control Source row, select the arrow and from the list that 
appears, select the Control Source Data you want to barcode.  Keep the ActiveX Control 
form open during the next step. 
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6. With the ActiveX Control form shown above still open, right click the blank barcode box. 
 From the list that appears, select WaspBarcodeX Control Object>Edit. 
 

 
 
 
The BarcodeMaker Dialog Bar appears on the left side of the screen. 
 
  

7. Select a symbology from the Symbology box that supports the barcode value you are 
using.  In the example, we chose Code 128 because it supports both alpha and numeric 
characters. 
 

8. In the Value box, type the name of the Control Source data exactly as it appears in the 
ActiveX Control form, using the same spacing and same spelling. The barcode will appear 
in the Access database as you type. 
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9. Click the Show check box in the Caption area to display the data as a caption below the 
barcode.  For more information on the options available in the Dialog Bar, see Main 
Window for an overview or Creating a Barcode Using the Main Window for detailed 
information on using each option. 
 

10. Select any other available attributes in the Dialog Bar that apply to what you are trying to 
achieve:  Special or Nonprintable Characters, Bar Height, Foreground and Background 
Colors, Caption Point Size, Use Check Digit, Show Check Digit.  For more information 
about these attributes, see Main Window and/or Creating a Barcode Using the Main 
Window. 
 

11. Resize the barcode:  Click the barcode and use the resizing handles to expand the 
barcode box so that the barcode and caption show. 
 
Your screen will look similar to the one below after you have completed the steps above. 
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12. To leave the BarcodeMaker Dialog Bar, click anywhere in the Access database. 
 

13. To move the barcode, click the barcode. The move handles are available so that you can 
reposition it to a location where it will not obscure other data. 
 
The Control Source Data PurchasePrice, is now barcoded in the Design View, as shown 
in Screen Shot 1 above. 
 

14. To view individual records, click View>Form View on the Menu Bar. (See Screen Shot 2 
above.) Use the Record arrows at the bottom of the screen to view each record.  You will 
see that the barcode changes for each record. 
 

15. Save the database by clicking File>Save on the Access Menu Bar. 

Creating a Static Barcode that Appears in Every Record 

To create a static barcode that appears in every record (one that does not change on 
every record), follow the steps above in Creating a Barcode from Variable Data in 
Access.  However, skip step 3, in which you link the Control Source Data to the blank 
barcode box. 

In the example, below, a barcode was created from the company name, Book 
Warehouse. 
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Creating Barcodes in Crystal Reports 
 

This option is available in the Professional version only. 

Barcodes can be created directly in Crystal Reports using BarcodeMaker or they can be created 
using BarcodeMaker and copied/pasted or dragged and dropped directly into a Crystal Reports 
document; see Moving Barcodes into Documents.  The Wasp CrystalReports Addin is a set of 
two DLLs.  These DLLs appear in the Additional Functions tree (menu) listed as "u2lwasp.dll. 

The following topics are discussed in this section: 

Creating a 1D Barcode 

Creating a Data Matrix Barcode  

Creating a PD417 Barcode  

Barcoding Numbers 

Adding the Barcode to Your Report 

Changing the Barcode Font and Resizing 

Barcode Font Descriptions 

OCR-A, OCR-B and Microfonts 

 

Creating a 1D Barcode 

1. Create your report in Crystal Reports.  If you want to practice creating a barcode, you can 
open an example report to work with.  In this example, we will use the Order Packing List 
found under Sample reports > General. 
 

2. With the report open in Crystal Reports, click Report>Formula Workshop  
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The Formula Workshop>Formula Editor will appear: 
 

 
 
  

3. Right-click on Formula Fields and select New. 
 

 
 
The Formula Name field will appear. 
 

 
 

4. Enter a name for this formula, then click OK.  You can name this formula anything you want, 
but it is a good idea to name it something easily identifiable, such as the type of data you are 
barcoding.  In this example we will be barcoding the Order Number, so we have named the 
formula fOrderNumber (formula - order number). 
 
When you click OK, the formula is added to the Formula Fields tree. 
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5. Now, with your new formula highlighted, select Functions>Additional Functions>Wasp. 

 You will see the available dlls listed here.  
 

 
  
6. Double click on StringTo1DBarCode (string, symbology, checkdigit).  This creates a 

standard 1D barcode.   
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7. Now you can enter in your values for your selection in the window at the bottom of the 
screen. 
 
 

 
 
Enter information as follows: 
  

• String - enter the value you want to bar code.  You can do this by typing in a static 
string (for a barcode that will contain the same data each time it appears) or click on a 
item in your Fields list (for a barcode that pulls data from a table).  For this example, we 
want to bar code the value stored in the "Order ID" field.  With the cursor positioned 
after the first parenthesis and before the first comma, double click "Orders.Order ID" in 
the Fields list. 
 
Important Note: If the value you want to barcode is a number, as in the Order Number 
example above, Crystal Reports will try to format it as it "thinks" it should appear.  For 
example, if you are barcoding the order number 2430, Crystal will try to format it as 
2,430.00.  To prevent this from happening, you need to convert the number to a string. 
 For instructions on how to convert the value to a string, please see the Barcoding 
Numbers section in this topic. 
  

• Symbology - The second parameter of the "StringToBarCode" function is a number 
that represents the desired barcode symbology.  Each symbology is assigned a unique 
number.  Enter the number that corresponds to the desired symbology, then, when the 
report is created, Crystal Reports will translate that number to the correct barcode 
symbology.   The symbology numbers are listed below: 

1 =  Code 3 of 9 Full ASCII 
2 =  Interleaved 2 of 5 
3 =  Codabar 
4 =  MSI Plessey 
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5 =  Code 93 
6 =  Universal Product Code A (UPC-A) 
7 =  Universal Product Code E (UPC-E) 
8 =  U.S. Postal code (PostNet) 
9 =  EAN/JAN 8 digits 
10 =  EAN/JAN 13 digits 
11 =  Code 128 
12 =  Code 3 of 9 Standard 
16 =  LOGMARS 
 
For example, if you want to create a PostNet bar code to print on envelopes, the 
second parameter of the "StringToBarCode" function is 8.  If you want to create a Code 
3 of 9 Full ASCII bar code, the second parameter is 1.  
 
In this example, we are creating a Code 3 of 9 Standard barcode.  Therefore,  type in 
the number 12 for the second parameter.  
 
Your string will look similar to the following: 
 
StringTo1DBarcode (Order.Order ID),  12,) 

• Check Digit - The third and final parameter of the "StringToBarCode" function can be 
either "True" of "False" depending on whether or not a check digit is desired.  In this 
example, we will set the final parameter to True.   
 
Your string will look similar to the following: 
 
StringTo1DBarcode (Order.Order ID),  12, True) 

7. When you are finished entering in the parameters, click Save and Close.  The Formula 
Editor closes.  Now you can Add the Barcode to Your Report.  

 

Creating a Data Matrix Barcode 

1. Create your report in Crystal Reports.  If you want to practice creating a barcode, you can 
open an example report to work with.  In this example, we will use the Order Packing List 
found under Sample reports > General. 
 

2. With the report open in Crystal Reports, click Report>Formula Workshop  
 

 
 
The Formula Workshop>Formula Editor will appear: 
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3. Right-click on Formula Fields and select New. 
 

 
 
The Formula Name field will appear. 
 

 
 

4. Enter a name for this formula, then click OK.  You can name this formula anything you want, 
but it is a good idea to name it something easily identifiable, such as the type of data you are 
barcoding.  In this example we will be barcoding the Order Number, so we have named the 
formula fOrderNumber (formula - order number). 
 
When you click OK, the formula is added to the Formula Fields tree. 
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5. Now, with your new formula highlighted, select Functions>Additional Functions>Wasp. 

 You will see the available dlls listed here.  
 

 
6. Double-click on StringToDataMatrixBarCode(string). 

 
7. Now you can enter in your values for your selection in the window at the bottom of the 

screen. 
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8. Enter information as follows: 
 
• String - Enter the value that you want to barcode in the parentheses.  You can do this by 

typing in a static string (for a barcode that will contain the same data each time it 
appears) or click on a item in your Fields list (for a barcode that pulls data from a table). 
 For this example, we want to barcode the value stored in the "Order ID" field.  With the 
cursor positioned after the first parenthesis and before the first comma, double click 
"Orders.Order ID" in the Fields list. 
 
Important Note: If the value you want to barcode is a number, as in the Order Number 
example above, Crystal Reports will try to format it as it "thinks" it should appear.  For 
example, if you are barcoding the order number 2430, Crystal will try to format it as 
2,430.00.  To prevent this from happening, you need to convert the number to a string. 
 For instructions on how to convert the value to a string, please see the Barcoding 
Numbers section in this topic. 
  

9. When you are finished entering in the parameters, click Save and Close.  The Formula 
Editor closes.  Now you can Add the Barcode to Your Report.  

 

Creating a PDF417 Barcode 

1. Create your report in Crystal Reports.  If you want to practice creating a barcode, you can 
open an example report to work with.  In this example, we will use the Order Packing List 
found under Sample reports > General. 
 

2. With the report open in Crystal Reports, click Report>Formula Workshop  
 

 
 
The Formula Workshop>Formula Editor will appear: 
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3. Right-click on Formula Fields and select New. 
 

 
 
The Formula Name field will appear. 
 

 
 

4. Enter a name for this formula, then click OK.  You can name this formula anything you want, 
but it is a good idea to name it something easily identifiable, such as the type of data you are 
barcoding.  In this example we will be barcoding the Order Number, so we have named the 
formula fOrderNumber (formula - order number). 
 
When you click OK, the formula is added to the Formula Fields tree. 
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5. Now, with your new formula highlighted, select Functions>Additional Functions>Wasp. 

 You will see the available dlls listed here.  
 

 
6. Double-click on StringToPDf417Code(string. rows, columns, truncate, errlvl). 

 
7. Now you can enter in your values for your selection in the window at the bottom of the 

screen. 
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8. Enter information as follows: 
 
• String - Enter the value that you want to barcode in the parentheses.  You can do this by 

typing in a static string (for a barcode that will contain the same data each time it 
appears) or click on a item in your Fields list (for a barcode that pulls data from a table). 
 For this example, we want to bar code the value stored in the "Order ID" field.  With the 
cursor positioned after the first parenthesis and before the first comma, double click 
"Orders.Order ID" in the Fields list. 
 
Important Note: If the value you want to barcode is a number, as in the Order Number 
example above, Crystal Reports will try to format it as it "thinks" it should appear.  For 
example, if you are barcoding the order number 2430, Crystal will try to format it as 
2,430.00.  To prevent this from happening, you need to convert the number to a string. 
 For instructions on how to convert the value to a string, please see the Barcoding 
Numbers section in this topic. 
 

• Rows - This represents the number of data rows in the PDF417 symbol.  The settings for 
'rows are  
 
0  - Calculate the number of rows for the given the number columns, or  
3 to 90 - specify number of data rows. 
 

• Columns - The settings for 'columns' are - 
 
0 - best fit columns and rows for a 1 to 3 column to row ratio, or 
1 to 30 - specify number of data columns. 
 

• Truncate - The settings for ‘truncate’ are - 
 
TRUE - omit the right indicators and stop pattern from the PDF417 symbol. 
FALSE - include the right indicators and stop pattern. 
  

• Errlvl - The settings for 'errlvl' are - 
 
1 - Calculate the recommended error correction level from the number of data codewords 
in the PDF417 symbol as per the following table: 
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Number of Data Code 
Words 

Error Correction 
Level 

1 - 40 2 
41 - 160 3 
161 - 320 4 
321 - 863 5 

0 to 8 - Specify the error correction level where level 0 provides only error detection, and 
level 8 provides the maximum error detection and correction capacity. 

9. When you are finished entering in the parameters, click Save and Close.  The Formula 
Editor closes.  Now you can Add the Barcode to Your Report.  

 

Barcoding Numbers 

If the value you want to barcode is a number, as in the Order Number example above, Crystal 
Reports will try to format it as it "thinks" it should appear.  For example, if you are barcoding the 
order number 2430, Crystal will try to format it as 2,430.00.  To prevent this from happening, you 
need to convert the number to a string.  To do this, follow the steps below: 
  

1. After you name your formula, in the Formula Editor, go to Functions > Type 
Conversion > CStr. 
 

2. Double-click on CStr(x,y,z).  CStr(,,,) will appear in the editing window: 
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3. Now you can enter how you want the string to be formatted.  With your cursor 
before the first comma, navigate to the database field you want to turn into a 
barcode and double click it.  In this example, we are barcoding the Order ID field. 
  

4. In the y spot, enter a zero.  This tells the CStr function to show 0 decimal places. 
 

5. In the z spot, enter two double quotes.  This tells the CStr function not to use a 
separator between thousands.  Now your formula will look something like this: 
 
CStr {{Orders.Order ID}, 0, "",} 
 

6. Save and close the function and add the formula to your report (see the Adding 
the Barcode to Your Report section for information on how to do this). 
 

7. Preview the report to make sure the number is formatted correctly (no decimal 
point or thousand separator).  For example, the number should be 123456, not 
123,456.00. 
 

8. Now you can edit the formula to add the barcode function.  Right-click on the 
formula  and select Edit.  The Formula Editor will reappear. 
 

9. Double-click on StringTo1DBarcode(,,,) under Additional Functions > Wasp. 
 

10. In the first space (before the first comma, place the entire CStr function you just 
created and fill in the other variables as needed.  The StringTo1DBarcode should 
be the only line in your function.  The function will look something like this: 
 
 

 
 
  

 

Adding the Barcode to Your Report 

With the report open in Design mode, click in the Field Explorer and drag it to where you want it 
in your report.   
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Now you need to change the barcode to the correct font and resize it.   
  

 

Changing the Barcode Font and Resizing 

Now that you have inserted the barcode formula into your report, you need to change the font to 
the appropriate barcode font.  For each symbology, there is at least one barcode font.  Most 
barcode symbologies have 6 different fonts: a font for the symbology with a caption and without 
in low, medium, and high resolutions. In this example, we are creating a code 128 barcode at 
high resolution.  To change to the appropriate font: 

1. Click on the formula that was just inserted. 
 

2. Change the font to the applicable font for the barcode you created.  In this example, we have 
created a Code 3 of 9 barcode, so we will select Wasp 39 EHC (Wasp 39 embedded, high 
density with caption).  A full list of supported barcode fonts is found in the Barcode Font 
Descriptions section of this topic. 
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3. Change the Font Size to a larger size.  In this case, we have selected 20.  Be aware that 
you will almost always need to change the font to a larger size to make the barcode 
scannable. 
 

4. You may need to enlarge the barcode display size by clicking and dragging on the edges of 
it. 
 

 
5. Click the Preview tab to switch to Preview mode to make sure the barcode is displayed as 

desired. 
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6. It is a good idea to print your report at this point and make sure the barcode scans properly. 

 

Barcode Font Descriptions 

The Wasp Bar Code Add-in for Crystal Reports supports all the popular barcode symbologies and 
provides a high, medium, and low density (resolution) fontset for each symbology. 

A Hint About Barcode Resolution:  The resolution of a font determines its relative density. The 
lower the resolution, the less dense the bar code. The Wasp Bar Code Add-in for Crystal Reports 
provides three resolution font sets for each symbology: high, medium, and low. The resolutions 
provide "coarse" sizing adjustments while the font point size provides "fine" sizing adjustments.  

For example, changing a bar code font from "WASP 39 MC" (medium resolution) to "WASP 39 
LC" (low resolution) widens the bar code (makes it less dense), but the bar code maintains the 
same height.   

The following Wasp Fonts are supported: 
 
Note:  Most of these fonts are embedded so will appear with as EH or EHC, etc. in the Crystal 
Reports fonts list. 

Code 3 of 9 

• WASP 39 H  High Density 
• WASP 39 HC High Density with Caption 
• WASP 39 M Medium Density 
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• WASP 39 MC Medium Density with Caption 
• WASP 39 - L Low Density 
• WASP 39LC Low Density with Caption 

LOGMARS 

• WASP LOGMARS H High Density 
• WASP LOGMARS HC High Density with Caption 
• WASP LOGMARS M Medium Density 
• WASP LOGMARS MC Medium Density with Caption 
• WASP LOGMARS L Low Density  
• WASP LOGMARS LC Low Density with Caption  

Universal Product Code (UPC-A and UPC-E) 

• WASP UPC EAN JAN Nominal height 
• WASP UPC MC Half Height 
• WASP UPC LC Quarter Height 

European Article Numbering/Japanese Article Numbering (EAN/JAN) 

• WASP UPC EAN JAN Nominal 
• WASP UPC MC Half Height 
• WASP UPC LC Quarter Height 

Interleaved 2 of 5 

• WASP I2of5 H High Density 
• WASP I2of5 HC High Density with Caption 
• WASP I2of5 M Medium Density 
• WASP I2of5 MC Medium Density with Caption 
• WASP I2of5 L Low Density 
• WASP I2of5 LC Low Density with Caption 

Code 128 

• WASP 128 H High Density 
• WASP 128 M Medium Density 
• WASP 128 L Low Density 

 
Note: We recommend that you do not use the Wasp Code 128 Fonts with caption. To 
create a Code 128 bar code with a caption, you will need to create your own caption using 
a text field. 

Codabar 

• WASP CODABAR H High Density 
• WASP CODABAR HC High Density with Caption 
• WASP CODABAR M Medium Density 
• WASP CODABAR MC Medium Density with Caption 
• WASP CODABAR L Low Density 
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• WASP CODABAR LC Low Density with Caption 

Code 93 

• WASP 93 H High Density 
• WASP 93 HC High Density with Caption 
• WASP 93 M Medium Density 
• WASP 93 MC Medium Density with Caption 
• WASP 93 L Low Density 
• WASP 93 LC Low Density with Caption 

MSI Plessey 

• WASP MSI H High Density 
• WASP MSI HC High Density with Caption 
• WASP MSI M Medium Density 
• WASP MSI MC Medium Density with Caption 
• WASP MSI L Low Density 
• WASP MSI LC Low Density with Caption 

PostNet 

• WASP POSTNET 

OCR-A 

• WASP OCR A OCR-A 

OCR-B 

• WASP OCR-B OCR-B 

MICR 

• WASP MICR MICR 

PDF417 

• w417l.ttf PDF417 Low Density 
• w417m.ttf PDF417 Medium Density 
• w417h.ttf PDF417 High Density 

Data Matrix 

• wdatamatrix.ttf DataMatrix 
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OCR-A, OCR-B, and MICR Fonts 

OCR-A and OCR-B 

OCR-A and OCR-B are human readable fonts and are used in Optical Character Recognition 
applications such as remittance processing, point of sale, library circulation/accounting, billing, 
etc.  An OCR reader is required to optically decode the character string.  When using OCR-A or 
OCR-B, we recommend selecting the font size to be 12 points.   

Note:  Most printers do not print at the exact same point size nor do all OCR readers interpret the 
same way.  Therefore, another point size (e.g. 11 pt or 11.5 pt) may be selected for your 
particular environment. 

MICR (Magnetic Ink Character Recognition)  

MICR is commonly used to print checking account information at the bottom of bank checks. 
 Magnetic ink toner (which is commonly available) is required to print the checks.  An OCR or 
MICR reader is required to optically/magnetically decode the character string.  When using MICR, 
we recommend selecting the font size to be 11 points. 

Note:  Most printers do not print at the exact same point size nor do all OCR readers interpret the 
same way.  Therefore, another point size (e.g. 10 pt, 10.5 pt, or 11.5 pt) may be selected for your 
particular environment. 
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2D Barcode Creation 
 

This option is available in the Professional version only. 

The steps for creating a 2D barcode are the same as the ones described in Creating a Barcode 
Using the Main Window or in Creating Barcodes in Microsoft Word and Excel, Microsoft 
Access, or Crystal Reports.  When you create a barcode using BarcodeMaker, any attributes 
that do not apply to that symbology will not be available to you on the BarcodeMaker toolbar or in 
the Main Window of BarcodeMaker.  For example, if the symbology you chose does not support 
check digit, the check digit box will be unavailable. 

The barcode attributes that are available when you choose Data Matrix, MaxiCode or PDF417 
are a slightly different than those of other barcode symbologies. This topic lists the barcode 
attributes available to you after you have selected one of the following symbologies, Data 
Matrix, MaxiCode or PDF417, and after you have entered a barcode value.  Detailed 
information about the specifications of 2D Barcodes is available in the 2D Barcode section of the 
Barcode Symbologies topic. 

Data Matrix - Choose the Bar Height and Foreground and Background colors. 

MaxiCode - Choose the Mode (2, 3, 4, or 5), input the Postal Code, Country Code, and 
Class of Service. 

PDF417 - Choose the Bar Height, Foreground and Background colors, and Density. In 
the PDF417 Settings area, choose the number of: 

Rows (ranging from 3 to 90) 

Columns (ranging from 0 to 9) 

Error Level (ranging from 0 to 8) 
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Barcode Symbologies 
 

Barcodes are symbols consisting of a series of bars and spaces which can be applied to 
packages, cartons, bottles, and other commercial products. The bars and spaces in each symbol 
are grouped in such a way to represent a specific ASCII character or function. The interpretation 
of these groups is based on a particular set of rules called symbologies. Various symbologies 
have been developed for particular applications. Some examples are shipping and receiving, 
manufacturing, retail, health care, transportation, document processing and tracking, and 
libraries.  

Listed below are the most common Barcode Symbologies including a partial specification for 
each symbology. In general, Code 3 of 9 is the most popular of all the symbologies and is what 
we recommend if you are a first-time user. 

Barcode Widths 

The resolution of a barcode is dependent on the narrowest element of a barcode (X dimension), 
and can vary from high density (nominally less than 0.009 in./0.23 mm), medium density 
(between 0.009 in./0.23 mm and 0.020 in./0.50 mm), and low density (greater than 0.020 in./0.50 
mm). 

Check Digit 

Check digit is a character included within a barcode symbol which is used to perform a 
mathematical check to ensure the accuracy of the scanned data.  It checks that the barcode 
meets the specifications set for the barcode symbology.  Not all symbologies support check digit. 

Common Barcode Symbologies 

Code 3 of 9 

Code 3 of 9 Standard is variable length and is the most frequently used symbology in industrial 
barcode systems today. The principal feature is to encode messages using the full alphanumeric 
character set. Three of the nine elements (bars) are wide and six elements are narrow. The Code 
3 of 9 barcode uses four special characters "$", "/", "+", "%" which can be paired with 
alphanumeric characters to extend to the full ASCII character set. Listed below are the options for 
the Code 3 of 9 symbology.  

Code 3 of 9 Full ASCII - Standard Code 3 of 9 contains only 43 characters (0-9, A-Z, $, /, %, +). 
Code 3 of 9 Full ASCII can be extended to an 128 character symbology (full ASCII) by combining 
one of the special characters ($, /, %, +) with a letter (A-Z) to form the characters that are not 
present in the standard Code 3 of 9 symbology. For example, in standard Code 3 of 9 a 
lowercase "a" cannot be represented. In Code 3 of 9 Full ASCII a lowercase "a" is represented as 
"+A".  

Check Digit - A modulo 43 check character can be used to enhance data security for 
Code 3 of 9 symbols. The last digit of the symbol is assumed to be the check digit, and it is 
compared to a calculated check digit to verify the symbol.  
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Universal Product Code (UPC)  

UPC-A (Universal Product Code-A) is fixed length and is the most common UPC barcode 
for retail product labeling. It is seen in most grocery stores across the United States. The 
symbology encodes a 11, 13 or 16 digit numeric only number. The first six digits are 
assigned by the GS1 US in Lawrenceville, New Jersey (formerly the Uniform Code Council 
or UCC), the next five digits are assigned by the manufacturer, and the final digit is a 
modulo 10 check digit. The nominal height for the UPC-A barcode is one inch.  The 
reduced size is 80% of the nominal size. 

UPC-E (Universal Product Code-E) is a fixed length, compressed, six digit code used for 
marking small packages including magazines and paperback books. UPC-E symbols are 
UPC-A symbols that have been zero suppressed (i.e., consecutive zeros are not included 
in the symbol). The printed value of the UPC-E code is a twelve digit code.  The nominal 
height for the UPC-E barcode is one inch.  The reduced size is 80% of the nominal size. 

European Article Numbering/Japanese Article Numbering (EAN/JAN)  

EAN/JAN-13 is fixed length and is similar to the UPC-A symbology, but encodes a 13th 
digit. The 12th and 13th digit define the country code. The code 00-04 and 06-09 are 
assigned to the United States.  The nominal height for the EAN/JAN-13 barcode is one 
inch.  The reduced size is 80% of the nominal size. 

EAN/JAN-8  is fixed length and is similar to the UPC-E code, but includes two more digits 
for the country code. The nominal height for the EAN/JAN-8 barcode is one inch.  The 
reduced size is 80% of the nominal size.  

Interleaved 2 of 5  

Interleaved 2 of 5 is a variable length, even numbered, numeric barcode symbology. It is 
typically used in industrial and master carton labeling. The symbology uses bars to represent the 
first character and the interleaved (white) spaces to represent the second character. Each 
character has two wide elements and three narrow elements.  Listed below are the options for 
the Interleaved 2 of 5 symbology.  

Check Digit - A modulo 10 check character can be used to enhance data security for 
Interleaved 2 of 5 symbols. When this option is selected, the last digit of the symbol is 
assumed to be the check digit, and it is compared to a calculated check digit to verify the 
symbol.  

Code 128 

Code 128 is variable length and encodes the full 128 ASCII character set. Each character is 
represented by 11 modules that can be one of four bar widths. Code 128 is the most easily read 
code with the highest message integrity due to several separate message check routines.  

Of all the common linear symbologies, Code 128 is the most flexible. It supports both alpha and 
numeric characters easily, has the highest number of characters per inch, and is variable length. 
Code 128 is usually one of the best choices when implementing a new symbology.  
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UCC/EAN-128 - Inserts a unique, reserved start code, Function Code 1 (F1) for application 
assignments by the UCC (now the GS1 US) and EAN. The initial digits are interpreted as 
Application Identifiers (AIs).  

Special Characters - Use the following keyboard characters in the input string to insert 
the Special Characters: F1 (Alt+0185), F2 (Alt+0178), F3 (Alt+0179), and F4 (Alt+0188). 
For instructions about inserting Special Characters into a barcode, click the preceding 
link. 

Codabar 

Codabar is a variable length symbology capable of encoding 16 characters within any length 
message. Codabar can encode six special alphanumeric characters, capital letters A through D, 
and all numeric characters. Codabar symbology for any new applications today should not be 
considered except under unusual circumstances. Listed below are the options for the Codabar 
symbology.  

Check Digit - A modulo 16 check character can be used to enhance data security for 
Codabar symbols. When this option is selected, the last digit of the symbol is assumed to 
be the check digit, and it is compared to a calculated check digit to verify the symbol.  

Special Characters - Use the following keyboard characters in the input string to insert 
the Special Characters: A (Alt+065), B (Alt+066), C (Alt+067), and D (Alt+068). For 
instructions about inserting Special Characters into a barcode, click the preceding link. 

Code 93  

Code 93 encodes the full 128 ASCII character set using 9 modules arranged into 3 bars with 
adjacent spaces. Two of the characters are check characters. Code 93 is similar to Code 3 of 9 
but encodes more characters per inch. Code 93 encodes the full 128 ASCII character set and is 
encoded similarly to the Full ASCII Code 3 of 9. Listed below are the options for the Code 93 
symbology.  

MSI Plessey 

MSI Plessey is a variable length numeric symbology. Each character consists of four bars with 
intervening spaces for each encoded digit, one or two symbol check digits, and a reverse start 
code. MSI Plessey is primarily used in marking retail shelves.  

Second Check Digit -  A modulo 10 check digit calculation is always performed on the 
data string. A second modulo 10 check digit is optional and is used to perform a check on 
the entire string including the first check digit.  

PostNet 

Postal Numeric Encoding Technique is used to encode zip code information on letter mail. 
PostNet utilizes redundant information within a compact barcode format to provide error 
detection capability and a significant degree of error correction capability. 
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LOGMARS 

LOGMARS (Logistics Applications of Automated Marking and Reading Symbols) is a special 
application of Code 39 used by the U.S. Department of Defense and is governed by Military 
Standard MIL-STD-1189B. The Modulus 43 check digit, optional with Code 39, is defined and 
recommended in the specification.  

Check Digit - A modulo 43 check character can be used to enhance data security for 
LOGMARS symbols. The last digit of the symbol is assumed to be the check digit, and it is 
compared to a calculated check digit to verify the symbol.  

2D Barcode Symbologies 

2D Barcodes are available in the Professional Version only. 

Two dimensional (2D) barcode symbologies break from the traditional linear barcode 
symbologies such as Code39 and UPC where most applications only need to encode 
between ten and twenty characters of information. In contrast, 2D symbologies are able to 
encode up to several thousand characters of machine readable data. In effect, a portable 
database or portable data file can travel with the product and drive the decision making. 
2D bar coding provides the freedom of movement for a database file allowing it to travel 
with a person or package, item, form, document, card or label. 2D bar coding provides a 
powerful communications capability without the need to access an external database. 
Furthermore, you can add 2D symbols to the documents and labels you are already 
printing.  

By employing 2D symbols, more detailed information can be encoded and multiple linear 
barcode symbols can be reduced to a single symbol. When implemented properly, 2D 
symbologies can make industrial and commercial procedures faster, less costly, and more 
reliable by providing immediate access to the portable data file for that container. As an 
example, the manifest, bill of lading, and material safety data sheet could all be encoded 
into one 2D symbol. 2D symbols are much more resistant to damage than traditional linear 
symbols. By building error correction formulas into the 2D symbol, a significant portion of 
the surface area can be damaged and the information will still be intact. For example, 
some 2D symbols can lose up to a third of its surface and still be decoded.  

The most common 2D symbols employed today are PDF417 and Data Matrix. The 
intellectual property rights (patents) for each of these codes are in the public domain 
eliminating the form of payment of royalties for use of this technology. 2D codes are 
currently represented in matrix symbologies or stacked-bar (multi-row). 

Matrix Codes are 2D symbologies that are similar in appearance to checkerboards with 
each square representing a bit and must be read by a camera or CCD reader. Data Matrix 
and MaxiCode are examples of a Matrix code. 

Data Matrix is a 2D, matrix symbology with a variable length and is capable of 
encoding all 128 ASCII characters and a number of different character sets. Each 
Data Matrix symbol consists of a perimeter quiet zone, border with two solid edges 
and two dashed edges and cells inside the border that are dark or light. The 
border's two solid lines with data cells are used for symbol identification, orientation 
and cell location. Data Matrix can accommodate up to 500 MB per square inch with 
a data capacity of 1 to 2335 characters. Data Matrix has a high degree of 
redundancy and resists printing defects.  
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MaxiCode is a fixed-size 2D matrix symbology having 866 hexagonal elements 
arranged in 33 rows around a central finder pattern. Predominately used by United 
Parcel Service to sort mail at high speed, MaxiCode is well suited to being read 
quickly and often in any direction.  The size of a MaxiCode symbol is 1.1 inch by 
1.05 inch.  A single MaxiCode symbol can encode up to 93 characters of data and 
uses five different code sets to encode all 256 ASCII characters. MaxiCode uses 
three unique properties when encoding the data:  Class of Service, Country Code 
and Mode. 

Stacked-barcodes are a 2D symbology and look like a set of linear barcodes stacked on 
top of each other. PDF417 is the best example of a stacked-bar symbol and is the most 
common of all 2D symbols today. Stacked-bar symbologies can be read by laser scanners, 
cameras, or CCDs.  

PDF417 is a 2D stacked-bar symbol that can encode full ASCII, numeric or binary 
data and uses sophisticated error correction algorithms to keep intact the Portable 
Data File (PDF). PDF417 is variable length and consists of 4 bars and 4 spaces in a 
17 module structure. Each PDF417 symbol consists of 3 to 90 stacked rows 
surrounded by a quiet zone on all four sides. Each row consists of a leading quiet 
zone, start pattern, left row indicator character, one to thirty data characters, right 
row indicator character, stop pattern, and trailing quiet zone. PDF417 can 
accommodate up to 340 characters per square inch with a maximum data capacity 
of 1850 text characters.  
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2D Barcode Symbologies 

Overview: 2D Barcode Symbologies 

Two dimensional (2D) barcode symbologies break from the traditional linear barcode 
symbologies such as Code39 and UPC where most applications only need to encode 
between ten and twenty characters of information. In contrast, 2D symbologies are able to 
encode up to several thousand characters of machine readable data. In effect, a portable 
database or portable data file can travel with the product and drive the decision making. 
2D bar coding provides the freedom of movement for a database file allowing it to travel 
with a person or package, item, form, document, card or label. 2D bar coding provides a 
powerful communications capability without the need to access an external database. 
Furthermore, you can add 2D symbols to the documents and labels you are already 
printing.  

By employing 2D symbols, more detailed information can be encoded and multiple linear 
barcode symbols can be reduced to a single symbol. When implemented properly, 2D 
symbologies can make industrial and commercial procedures faster, less costly, and more 
reliable by providing immediate access to the portable data file for that container. As an 
example, the manifest, bill of lading, and material safety data sheet could all be encoded 
into one 2D symbol. 2D symbols are much more resistant to damage than traditional linear 
symbols. By building error correction formulas into the 2D symbol, a significant portion of 
the surface area can be damaged and the information will still be intact. For example, 
some 2D symbols can lose up to a third of its surface and still be decoded.  

The most common 2D symbols employed today are PDF417 and Data Matrix. The 
intellectual property rights (patents) for each of these codes are in the public domain 
eliminating the form of payment of royalties for use of this technology. 2D codes are 
currently represented in matrix symbologies or stacked-bar (multi-row). 

Matrix Codes are 2D symbologies that are similar in appearance to checkerboards with 
each square representing a bit and must be read by a camera or CCD reader. Data Matrix 
and MaxiCode are examples of a Matrix code. 

Data Matrix is a 2D, matrix symbology with a variable length and is capable of 
encoding all 128 ASCII characters and a number of different character sets. Each 
Data Matrix symbol consists of a perimeter quiet zone, border with two solid edges 
and two dashed edges and cells inside the border that are dark or light. The 
border's two solid lines with data cells are used for symbol identification, orientation 
and cell location. Data Matrix can accommodate up to 500 MB per square inch with 
a data capacity of 1 to 2335 characters. Data Matrix has a high degree of 
redundancy and resists printing defects.  

MaxiCode is a fixed-size 2D matrix symbology having 866 hexagonal elements 
arranged in 33 rows around a central finder pattern.- Predominately used by United 
Parcel Service to sort mail at high speed, MaxiCode is well suited to being read 
quickly and often in any direction.  The size of a MaxiCode symbol is 1.1 inch by 
1.05 inch.  A single MaxiCode symbol can encode up to 93 characters of data and 
uses five different code sets to encode all 256 ASCII characters. MaxiCode uses 
three unique properties when encoding the data:  Class of Service, Country Code 
and Mode. 

Stacked-barcodes are a 2D symbology and look like a set of linear barcodes stacked on 
top of each other. PDF417 is the best example of a stacked-bar symbol and is the most 
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common of all 2D symbols today. Stacked-bar symbologies can be read by laser scanners, 
cameras, or CCDs.  

PDF417 is a 2D stacked-bar symbol that can encode full ASCII, numeric or binary 
data and uses sophisticated error correction algorithms to keep intact the Portable 
Data File (PDF). PDF417 is variable length and consists of 4 bars and 4 spaces in a 
17 module structure. Each PDF417 symbol consists of 3 to 90 stacked rows 
surrounded by a quiet zone on all four sides. Each row consists of a leading quiet 
zone, start pattern, left row indicator character, one to thirty data characters, right 
row indicator character, stop pattern, and trailing quiet zone. PDF417 can 
accommodate up to 340 characters per square inch with a maximum data capacity 
of 1850 text characters.  
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ASCII Table 
 

A limited number of the code set for the American Standard Code for Information Interchange 
(ASCII) is listed below along with their definitions. These Special and Nonprintable Characters 
are available with some symbologies when you click the Character Input button on the Main 
Window of BarcodeMaker or when you access the Dialog Box. 

Information about the use of Special Characters with specific symbologies can be found in the 
Barcode Symbologies. 

ASCII Value ASCII 
Character 

Description 

0 NUL null 
1 SOH start of heading 
2 STX start of text 
3 ETX end of text 
4 EOT end of transmission 
5 ENQ enquiry 
6 ACK acknowledge 
7 BEL bell 
8 BS backspace 
9 TAB horizontal tab 
10 LF NL line feed, new line 
11 VT vertical tab 
12 FF NP form feed, new page 
13 CR carriage return 
14 SO shift out 
15 SI shift in 
16 DLE data link escape 
17 DC1 device control 1 
18 DC2 device control 2 
19 DC3 device control 3 
20 DC4 device control 4 
21 NAK negative acknowledge 
22 SYN synchronous idle 
23 ETB end of trans. block 
24 CAN cancel  
25 EM end of medium 
26 SUB substitute 
27 ESC escape 
28 FS file separator 
29 GS group separator 
30 RS record separator 
31 US unit separator 
32 Space Space 
127 DEL delete 
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File Menu Commands 
 

The BarcodeMaker File menu offers the following commands: 

New Creates a new document. 

 
Open Opens an existing document in a new window.  You can open multiple 

documents at once.  Use the Window menu to switch among multiple open 
documents. 

 
Save Saves an opened document with the file name it currently has to its current 

directory.  To name a new document, change the name of an existing document 
or change the storage location to another directory, use the Save As menu item. 
 All BarcodeMaker files end with the following file extension:  .bcm 

 
Save As Use this command to save and name the active document. BarcodeMaker 

displays the Save As dialog box so you can name your document.  To save a 
document with its existing name and directory, use the Save command.  All 
BarcodeMaker files end with the following file extension:  .bcm 

 
Print Prints a document.  This command presents a Print dialog box, where you may 

specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options. 

 
Print Preview Displays the document on the screen as it would appear in print.   When you 

choose this command, a print preview window appears in which one or two 
pages will be displayed in their printed format. The print preview toolbar offers 
you options to view either one or two pages at a time; move back and forth 
through the document; zoom in and out of pages; and initiate a print job. 

 
Print Setup Use this command to select a printer and a printer connection. 

 
Recent Files This area of the File Menu shows recently used files.  It makes file retrieval 

quick.  Click a file to open it. 

 
Exit Use this command to end your BarcodeMaker session.  Barcode prompts you to 

ask whether you want to save an untitled document. 
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Edit Menu Commands 
 

The BarcodeMaker Edit menu offers the following commands: 

Cut Removes the currently selected data from the document and puts it on the 
clipboard. This command is unavailable if there is no data currently selected. 
Cutting data to the clipboard replaces the contents previously stored there. 

 
Copy Copies selected data onto the clipboard. This command is unavailable if there is 

no data currently selected.  Copying data to the clipboard replaces the contents 
previously stored there. 
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Help Menu Commands 
 

The BarcodeMaker Help menu offers the following commands, which provide assistance with 
this application:  

Help Topics Offers an index to topics describing how to use BarcodeMaker.  Use this command to 
display the opening screen of help. From the opening screen, you can jump to step-
by-step instructions for using BarcodeMaker. 

 
Settings Click this button to display the Barcode Add-in Settings Screen.  This screen allows 

you to control when the BarcodeMaker toolbar opens in Word, Excel and Access 
(Professional version only).  Below is an example of this screen: 

Uncheck any of the Load checkboxes to disable the BarcodeMaker toolbar for that 
application.  When the option is unchecked, the BarcodeMaker toolbar will not appear 
in the selected application until you reselect this checkbox.  You may want to disable 
these checkboxes (uncheck) if you want to share your Access database across the 
network by placing your MDB Access database in a network share folder.  When the 
database is in a share folder, Access runs in Shared mode, which can cause conflicts 
with the BarcodeMaker add-in toolbar (the add-in opens Access in exclusive mode, 
meaning the database cannot be shared across the network). 
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Select the Reset Office Toolbars button to reinstall the toolbar for all of the 
applications.  This should be done if you want to re-install after uninstalling the 
toolbar.   

About 
BarcodeMake
r 

Displays the BarcodeMaker version number and copyright notice. 
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System Requirements 
 

Listed below are the system requirements for using BarcodeMaker. 

Computer/Processor Pentium II 600 MHz or better 
Memory 512 MB of RAM 
Hard Disk 10MB 
Drive CD-ROM 
Mouse Required 
Keyboard  Required 
Operating Systems Windows 2000 SP4, XP SP2, 2003 Server (32 bit only) and Vista 

(32 bit) 
Office Versions Office 2000, Office XP, Office 2003, Office 2007 
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Technical Support 
 

 Wasp Technical Support, Knowledge Base and Downloads  

This link will lead you to the online support center, where you can contact us. 

 Wasp Barcode Online Store 

This link will lead you to the online store. 
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