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Chapter 1 - Getting Started 
1.1 Introduction 

Thank you for your purchase of the Wasp Labeler barcode creation software.  This topic contains 
information that will help familiarize you with barcodes and show you how to create customized 
barcodes.  The Introductory Materials section contains important information you should familiarize 
yourself with prior to creating barcodes.   
  
Introductory Materials 
  
Wasp Labeler Capabilities 
What is a Barcode? 
Navigating the Main Screen 
Creating a Static Label 
Binding a Data Source to an Object 
Using String Builder to Concatenate Data 
Creating Enumerated Labels 
Example Labels 
Barcode Symbology Reference 
  
After you have read the introductory materials, you are ready to start using Wasp Labeler.  Click on the 
link below to go to the next step in the Getting Started section. 
  

 
Software activation system licensed under Patent No. 5,490,216 
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1.2 Getting Started - Wasp Labeler Capabilities 
Wasp Labeler is a professional label generation application designed to meet the most demanding 
barcode labeling and printing requirements. Easily generate barcode labels, asset or inventory labels, 
address labels and envelopes with PostNet Zip Codes, ID badge labels, business checks, and date and 
time stamps for perishable goods, then print your labels from any local or network Windows printer. You 
can import data directly from your corporate databases or you can create a new Microsoft Access 
database. In addition, Wasp Labeler can generate compliance labels for practically every industry. 
  
Wasp Labeler: 

  
• Supports the following barcode languages: 

 
AztecCode, Codabar, Code 128, Code 39, Code 93, DataMatrix, EanJan13, EanJan8, 
Interleaved2of5, Isbn, Itf14, MaxiCode, MicroPDF417, MicroQRCode, Msi, PDF417, 
Postnet, QRCode, GS1, GS1Stacked, GS1Omnidirectional, GS1Truncated, GS1Expanded, 
GS1Limited, UCCEAN128, UPC-A, UPC-E 
 
For a description of each of these symbologies, please refer to the Barcode Symbology 
Reference. 
  

• Prints the most popular 2D barcodes: 
 
DataMatrix, MaxiCode, MicroPDF, MicroQRCode, PDF417, Aztec Code and QRCode 
  

• Supports any laser, dot matrix, thermal or ink jet printer using a standard Windows printer 
driver. 
  

• Allows you to edit multiple labels concurrently. 
  

• Allows you to input data on the label at print time. 
  

• Capable of advanced graphic resizing and graphic rotation. 
  

• Allows import of bitmap files (*.bmp), JPEG (*.jpg, *.jpeg, *.jpe, *jfif), PNG (*.png), TIFF 
(*.tiff, *.tif), GIF (*.gif), ICON (*ico). 
  

• Allows connecting to external databases: 
 
Microsoft Access, Microsoft SQL Server, ODBC data sources, 
QuickBooks® as well as comma separated files or other delimited text files.  
  

• Allows import of text files or Microsoft Excel worksheets. 
  

• Allows import of QuickBooks® data (version 2008 or later). 
  

• Includes over 100 label layout templates. 
  

Wasp Labeler supports drawing objects including text, lines, rectangles, ellipses, and barcodes. Each of 
these drawing objects has full edit capabilities including draw style, size, position and color.  In addition, 
practically any picture can be imported onto the label design, linked to the original file, or retrieved from 
a database. 
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Wasp Labeler supports Static, Serialization, Prompt at Print Time, External Data Source, Bind to 
Another Object, and Date/Time for objects. The 'Prompt at Print Time' feature is used to interactively 
enter information onto the label at print time. The 'External Data Source' feature allows you to import, 
view, and edit information from the most common databases and allows your Text and Bar Code 
objects to retrieve their source value from an external file. In addition, Wasp Labeler provides the 
capability to quickly create your own database.  
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1.3 Getting Started - What is a Barcode? 
A barcode is a graphical representation of a set of numeric or alphanumeric characters that can be read 
by a barcode scanner.   

1234 becomes: . 

Whse1 becomes: . 
  
Assigning a permanent barcode to each site, location, item, supplier and customer creates an 
environment where a mobile device can be used to easily keep track of inventory movements and 
alleviates the problem of data-entry errors. 
  
Barcodes get wider with the amount of numbers and characters you want represented by them.  In 
other words, the width is determined by the amount of numbers or characters represented by the 
barcode.  Some barcode scanners have a limited width that they can read.  If you have very long item 
numbers or location numbers you may need to reconsider the numbering scheme or the scanner you 
are using.  Also be aware that many of the less expensive barcode readers do not read barcodes that 
are bent, at an angle, are too small or are damaged.  Consider the possible disposition of your 
barcodes before choosing a scanner. 
  
There are many different barcode formats or symbologies.  The different symbologies can be thought of 
as different fonts.  The same characters are represented by different symbologies in different ways.  For 
example, the two symbologies below represent the same information (Whse1). 
  

 

 
These different formats exist to provide ways to compress more data into a smaller space, to represent 
a different set of characters or to enable scanning at different angles or distances.  
  
When using Wasp Labeler, barcodes should be printed using a high quality laser or ink jet printer, or a 
thermal label printer.   You want the barcode label to be high quality because low quality barcodes are 
harder to scan and usually do not last long.  Wasp Labeler can print to a regular printer or a barcode 
printer.   
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1.4 Getting Started - Navigating the Main Screen 
In this topic: 
  
Help/Resizing Icons 

Accessing Help 
Resizing/Minimizing Wasp Labeler 

Tabs 
Icon Toolbar 
Design Window 
Properties Box 

Hide/Show the Properties Box 
Move the Properties Box 

  
This topic provides a brief overview of Wasp Labeler's Main screen.  The Main screen provides access 
to all of the features and functions you will need to create customized labels or to create labels using 
the templates. Use this topic to help familiarize yourself with getting around in the application.  Links to 
detailed instructions for using each function are provided throughout this topic. 
  

 
  
A: Help/Resizing Icons 
B: Tabs 
C: Icon Toolbar 
D: Design Window 
E: Properties Box 
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1.4.1 Section A: Help/Resizing Icons 

This section contains icons that allow you to adjust the size of the Labeler screen, access this Help file 
or close the Labeler window. 

Accessing Help 

Launching the Help File: You can launch this Help file from anywhere in the Labeler application 
by clicking the question mark icon in the top right of the screen.  Using this method launches the 
Help with the topic related to the currently open screen/tab displayed.  You can search for or 
navigate to other topics as needed. 
 

 
  
Context-Sensitive Help: You can access a Help topic specific to the screen or feature you are 
currently using by clicking on the small question mark arrow that appear on most screens and in the 
Properties box.  Clicking the Help icon on the Properties box launches Help specific to the object 
you have selected.  You can also launch context-sensitive help by hitting the F7 key on your 
keyboard. 
 
Help Button Example - Screen 
 

 
 
Help Button Example - Properties Box 
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Resizing/Minimizing Wasp Labeler 

Wasp Labeler can be resized to fit your whole screen or reduced to appear as a portion of your 
screen.   
  
To resize the window, click the icon in the top, right of the Main screen, as shown below: 
  

 
  
The screen will reduce in size when the icon is clicked.  You can resize the screen by dragging any 
of the corners or borders.  Labeler will remember the size when it is closed and re-opened. 
  
To minimize the screen and place it on the taskbar, click the minimize icon in the top, right of the 
Main screen, as shown below: 
  

 
  
Labeler will be placed on your taskbar.  To reopen it, click on the icon on your taskbar. 
  

 

1.4.2 Section B: Tabs 

File Tab: 

The File Tab contains save, open, and close options.  This tab also allows you to launch example 
labels and  check for updates to your software.  Click on an icon to access a function.   

Design Tab: 

The Design Tab contains all of the options for customizing your label.  Click on an icon to access that 
function.  The toolbar on this tab is divided into 5 sections: 
  
Clipboard - This section contains basic commands such as Cut, Copy, Paste, Undo and Redo. 
Insert - The Insert options allow you to insert text, basic shapes, a picture or a barcode into your label. 
Arrange - The Arrange menu allows for precision placement of objects or text you insert onto your 
label. 
Position – Center selected objects horizontally or vertically on the label. 



 

8 
 

  
Wasp Labeler User Manual 

Layout Options - Use these options to change the layout of your label or to hide/show the ruler along 
the top and side of the label. 
View - The View menu allows you to zoom in or out. 
  
Changes you make will appear in the Label Design window. 
  

Data Tab: 

The Data Tab allows you to add a database, spreadsheet, .csv file or other data source to your label 
project.  You can then associate an object on your label, such as a text field or a barcode with the data 
source. 
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Print Tab: 

The Print Tab contains functions relating to printing your labels, including Page Layout. 
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1.4.3 Section C: Icon Toolbar 

The tabs at the top of the Main screen allow you to switch between functionalities.  The tabs act as a 
way to group Wasp Labeler's features together by task.  For instance, the File tab contains functionality 
related to opening a new file, closing a file, saving a file, etc., while the Design tab contains 
functionality related to creating and designing your labels.  When you first open Wasp Labeler, the 
Design tab is displayed and this is the tab you will probably use the most.   
 
You can switch to a different tab by clicking on the desired tab label. 
 

 
 

  

1.4.4 Section D: Design Window 

The Wasp Labeler Design window, by default, shares space on the Main screen with the Properties 
box.  You can Hide the Properties box entirely, or you can resize the Design window as needed.  To 
resize the window, place your mouse over the dividing line between the Design window and the 
Properties box until your cursor turns into a double arrow, as shown below: 
  

 
  
With the left button held down on your mouse, drag the dividing line either left or right.  Keep in mind 
that you cannot expand the Design window over the Properties box.  When the Design window 
reaches it's maximum width, it will stop moving.  If you need more design area, hide the Properties 
Box. 
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1.4.5 Section E: Properties Box 

The Properties box contains options specific to the type of object you have selected in the Design 
window (barcode, text box, picture or drawing object).  You can hide the Properties box or "dock" it in a 
different location as needed. 

Hide/Show the Properties Box 

The Properties box is displayed on the Main screen by default.  This box displays information 
relating to the tab you are currently using.  For example, on the Design tab, the Properties box 
displays the various options available to the selected object..  If you want to have a larger design 
area, you can hide the Properties box by clicking on the Pin icon in the right-hand corner of the box, 
as shown below: 
  

 
  
When the Properties box is hidden, a label will appear on the right side of the screen as shown 
below: 
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Move the Properties Box 

By default the Properties Box is docked on the right side of the Labeler screen.  You can move, or 
redock, the Properties Box to the center-left, center-right or left side of the screen as needed. 
  

1. Click on the top of the Properties Box and drag it.  The box will undock from it's current 
location and appear as a small, floating box similar to the example shown below: 
 

 
2. Drag the box to the center or left of the screen.  Arrows appear on the screen showing you all 

dockable locations as shown below: 
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3. Drag the box to an arrow..  The screen will highlight yellow indicating the area in which the 
box will appear if docked there.  In the example shown below, the box would appear from the 
center of the window to the right. 
 

 
 
 You can then let go of the box and it will dock where indicated. 
 
To move the Properties box back to the default location, click the Reset Docking icon on 
the Design Tab toolbar. 
 
  

  
  

  
  
  

  
  

  



 

14 
 

  
Wasp Labeler User Manual 

1.5 Getting Started - Creating a Static Label 
Now that you are familiar with the basics of moving around the Main screen, you can begin creating 
your labels.  This topic will take you through the steps to create the most basic label - a static barcode 
label.  A static label means the information on it does not change.  The label does not pull information 
from a database, isn't serialized, etc.   
  
For this example, we are going to create one name badge label containing a standard Code 128 
barcode and a text field containing a name and employee ID number.  Links are provided in each step 
to detailed information regarding the tabs and screens. 

  
1. Open a document: 

 
Open a New Document and make sure the Design tab is selected.   
  

2. Add a barcode: 
 
Click on the barcode icon and drag it to the Design window. 
 

 
 
You can move the barcode around on your label as needed by clicking on it and dragging it 
where you want it. 
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3. Define your barcode: 
 
By default, a Code128 barcode with content123456789 will be placed onto your label.  Use the 
Properties box to select the appropriate barcode and enter the content (what you want 
encoded in the barcode). 
  

a. Make sure the barcode is selected in the Design window. 
  

b. Click the Barcode tab in the Properties box. 
  

c. Make sure Code 128 is selected in the Symbology drop down box. 
 

 
  

d. Enter the data you want encoded in the barcode into the Content box.  In this case, we 
want the employee name and employee ID number so entered Jane Doe123456 into 
the Content box.  
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Note that your label changes to display Jane Doe123456 below the barcode. 
 

 
  

e. Now that we have the content in the barcode, we can specify how it should be 
formatted.  In this case, we want the employee ID number to appear below the 
employee name.  To do this, click the ellipse (...) button to the right of the Content field. 
 The Special Characters menu option appears. 
 

 
 
Place your cursor where you want the break to occur.  Here we will place the cursor 
after the e in Doe.  Then click the Special Characters button.  A list of all available 
special characters appears.  Scroll through the list and select <CR> (carriage return). 
 Now your data will appear as follows: 
 

 
 
Note: For a description of the ASCII Special Characters, please refer to the topic ASCII 
Special Character Codes. 
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The barcode on your design label will look similar to the following: 
 

 
 

4. Add additional objects to your label: 
 
You can include additional objects on your label as needed.  In the case of the name badge we 
are creating in this example, a graphic such as a picture of the employee or a company logo 
might be included.  To add objects, you will follow the same steps you used for adding a 
barcode.  Click on the icon of the object you want to add and drag it to your label.   
  

5. Save your label: 
 
It is a good idea to save your label periodically so you won't lose any information in the event of 
an unexpected shutdown.  To save your Label, click the File tab.  Select Save from the toolbar, 
then select a name and location for your label.  You can also save by pressing CTRL + S on 
your keyboard to save the label. 
  

6. Choose the label stock on which you want to print: 
 
When you have your label designed the way you want, you can print it to the label printer of 
your choice.  You can select the label stock on the Print tab.  When you open the Print tab, an 
example of how your label will print is displayed as shown below: 
 

 
 



 

18 
 

  
Wasp Labeler User Manual 

The example in the screen shot above shows a layout of 4 labels per page.  To change the 
type of label, click the Layout button on the toolbar.  The Page Setup screen appears: 
 

 
  
 
The Page Setup screen allows you to choose a different label template or create custom 
templates.  The template should match the label stock you are using. For our example label, we 
want to print just one employee badge for Jane Doe.  Let's assume our example company uses 
a laser printer with Avery name badge labels for the employee badges.   In this case, we should 
select Avery Laser from the Family drop down and Name Badge from the Type drop down. 
 The screen will now look like this: 
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Click Done to close the Page Setup screen.  Notice that the Print Preview window changes 
based on the Family and Type of label you selected.  The Properties box indicates that 8 
labels will be printed, because this particular type of label (Avery Name Badge) has 8 labels per 
page.  We just want to print one label, so in the Number of Labels section select Specify and 
enter 1 as shown below: 
 

 
  

7. Print your label: 
 
Now you are ready to print your label.  Click the Print button on the Print tab toolbar.  The 
standard Windows Print screen will appear allowing you to select a printer. 

  
That's it!  You've created a static barcode label.  You can move on to the next step: 
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1.6 Getting Started - Binding a Data Source to an Object 
Now that you can create a basic label (see Getting Started - Creating a Static Label), let's try binding 
a data source to an object.  This allows you to create one label template, attach a database to it, then 
let Labeler pull information from the database when printing.  For example, if you are creating employee 
badges, you can create one template badge, then bind a database containing all employee names and 
ID numbers to objects on your label.  When printing, Labeler will pull the information from the database 
and place it in the associated (bound) barcode or text box on the badge. 
  
This topic will show you the basic steps for attaching a database to your label using the Static Label you 
created in the previous step. 
 
  

1. Open your label. 
 
On the File tab, select the Open icon.   
 

 
 
Recently opened files will appear in the drop down.  If you see your label listed, click on it to 
open.  If you do not see your label in the list, click Open Files From Folder.  Browse to your 
label and select it.  It will appear in the Design window. 
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2. Select an External Data Source on the Data tab. 
 
We'll add a data source to this project using the Data tab.  Your data source options are listed 
on the Data tab.   
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Select the type of database you want to add.  For this example, we want to add a .txt file that 
contains a list of employee ids, and names so click on Text. 
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The Data Source - Text File (delimited) screen appears: 
 
 

 
 
Select your file and the associated Delimiter, then click Apply.  For detailed instructions on 
adding a Text file, see the topic Connecting to a Text File. 
 

3. Bind an object on the label to a column in the data source. 
 
On the Design tab, select the object to which you want to bind data.  The property options for 
the selected object appear in the Properties box. 
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Here we have selected the barcode object and want to bind it to the Employee ID column in the 
data source.  On the Properties box > Content tab, click the Database button.  A window 
appears displaying all available columns from the data source. 
 

 
Select the appropriate column from the drop down list and click Done. 
 

 
 
Notice that the Properties Box now indicates that this object is using the Employee ID column as 
the data source. 
 

 
 

That's all there is to adding a data source and binding an object to it.  You can continue binding 
objects to columns or other data sources (Serialized Numbers or Letters, Data/Time, Etc.) as needed.   
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1.7 Getting Started - Using String Builder to Concatenate Data 

In the previous example we learned how to add a data source to the label project and bind an object to 
a column within that data source.  Now let's learn how to concatenate, or combine, two different 
columns. Joined data is called a "string".  Creating strings allows you to bind data from two different 
columns in your data source to one object.  Continuing the Employee Badge example: we previously 
bound the column containing the Employee ID to a barcode, now let's bind the Employee First Name 
and Employee Last Name columns to a text box. 

  
1. Add a Text Box Object. 

 
Click on the barcode icon and drag it to the Design window. 
 

 
 
The Properties Box updates with options for the text box. 
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2. Create a String using String Builder. 
 
On the Properties Box > Content tab, click the String Builder button. 
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The String Builder screen appears. 
 

 
 
For this example we want to create a string containing two database columns: Employee Last 
Name and Employee First Name.  Let's assume we want the Last Name first, then a comma and 
a space, followed by the First Name.  The result should look like this: 
 
Doe, John 
 

a. First, select Database Column from the drop down, then click the Add Substring 
button. 
 



 

28 
 

  
Wasp Labeler User Manual 

 
 
The Data Source - Database screen appears allowing you to select a column.   
 

b. Select Employee Last Name, then click Done. 
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The substring appears in the window as shown: 
 

 
 
c. Now repeat Steps a and b, but this time select Employee First Name from the drop 

down list and click Done.  Another substring will be added. 
 

 
d. Highlight the substring Column: Employee First Name and select Add Space Before 

in the Substring Properties box. 
 

 
 
 



 

30 
 

  
Wasp Labeler User Manual 

e. Now we just need to add the comma.  To do this, we'll add a static substring with the 
character "," in it.  Select Static from the drop down menu, then click Add Substring. 
 The Static content screen appears.  Enter a comma in the text box provided, then click 
OK. 
 

 
 

f. The Static substring appears in the String list.  Highlight it and click the up arrow icon 
once to move it between the Employee Last Name and Employee First Name 
substrings. 
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g. Notice that your sample data at the bottom of the String Builder screen now shows the 
correct formatting for your data.  Click OK to save your new string.  The Content 
Source for your text box now shows <StringBuilder>. 
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1.8 Getting Started - Creating Enumerated Labels 
A common need when printing labels is a "label counter" or "copy counter".  Counters tell you what 
number out of a set each label represents: i.e. 1 of 12, 2 of 12, 3 of 12, etc.  
  
You can create these counters using a text field and the String Builder screen.  You have four 
counter field options on the String Builder screen: 
  
Label Counter - This counts the number of unique labels. 
Label Total - The total number of unique labels. 
Copies Counter - This counts the number of copies of unique labels. 
Copies Total - The total number of copies. 
  
Example One: Your warehouse wants to create inventory labels for a set of 20 printers.  Each printer 
is the same make and model, but has a unique serial number.  You need a label that has a barcode 
connected to your inventory database containing the inventory number for the printer type, a 
serialized barcode representing the serial number and a label counter.  
  
Steps: 
  

1. Add your Inventory Database to the label project. 
 

2. Insert a barcode onto your label and connect it to the inventory number column in your 
inventory database. 
 

3. Insert another barcode and bind it to Serial Number.  Make sure the Last value as next 
print job's seed checkbox is selected on the Serial Number Settings screen. 
 

4. Add a textbox to your label. 
 

5. With the textbox selected, click String Builder in the Properties Box > Content tab.  The 
String Builder screen appears. 
 

6. On the String Builder screen, select Label Counter, then click Add Substring. 
 

 
 
The substring will be added to the list as shown below: 
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7. Now select Static from the drop down and click Add Substring. 

 
The Static window appears. 
 

8. Highlight the sample text and type "of" (without quotation marks), then click OK. 
 

 

9. With your Static substring highlighted in the list, select Add > SPACE Before and Add > 
SPACE After. 
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10. Finally, select Label Total from the drop down list and click Add Substring.  Label Total will 
be added to your substring list.  Your screen should look similar to the following: 
 

 
 

11. On the Print tab enter 20 in the Number of Labels > Specify field. 
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Now your label will look similar to the following: 
 

 
  

 
  
Example Two:  You are sending a shipment to a customer.  The items will be packed into two 
separate boxes.  You need identical labels on each box with a counter indicating 1 of 2 and 2 of 2. 
  
Steps: 
  

1. Create your label as desired 
 

2. Add a textbox to your label. 
 

3. With the textbox selected, click String Builder in the Properties Box > Content tab.  The 
String Builder screen appears. 
 

4. On the String Builder screen, select Copies Counter, then click Add Substring. 
 

 
 
The substring will be added to the list as shown below: 
 

 
 

5. Now select Static from the drop down and click Add Substring. 
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The Static window appears. 
 

6. Highlight the sample text and type "of" (without quotation marks), then click OK. 
 

 
 

7. With your Static substring highlighted in the list, select Add > SPACE Before and Add > 
SPACE After. 
 

 
 

8. Finally, select Copy Total from the drop down list and click Add Substring.  Copy Total will 
be added to your substring list.  Your screen should look similar to the following: 
 

 
 

9. On the Print tab enter 2 in the Number of Copies > Manual from User field. 
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 1.9 Getting Started - Example Labels 
Wasp Labeler includes a set of example labels that you can access for a quick demonstration of various 
Labeler features.  Choosing an example label is a good starting point for your label design. Review the 
descriptions in the list of example labels and choose one that best fits your needs. 

  
1. On the File tab, select the Example Templates icon. 

 

 
 
The Example Templates screen appears. 
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2. Scroll through the list of available label templates.  Highlight a label to see a preview and 
description.   
 

 

3. To open an example template in the design window, highlight a template and click the Open 
button.  The label will open in the design window. 
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You can click on any of the elements on the label and see their associated properties in the 
Properties box. 
 
You can do a "Save As" function to save the label under a different name and make changes to 
it as needed.  You cannot make changes directly to the label template.  If you try to save 
changes directly to the template file, the following screen appears: 
 

 
 
Click OK on the warning screen to pick a new name and location for your new label. 
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1.10 Barcode Symbology Reference 
Note:  All example barcodes use the Wasp Labeler default properties unless otherwise noted. 
  

 C | D | E | G | I | M | P | Q | U 
C 
  
Codabar 
  

Codabar is a variable length symbology capable of encoding 16 characters within any length message. 
Codabar can encode six special characters ("+" (plus), "-" (minus), "$" (dollar sign), "/" (slash), ":" 
(colon), and "." (point)) and all numeric digits.  There are also 4 start/stop code choices possible when 
using the Codabar symbology. These characters (A, B, C, or D) must be included at the beginning or 
ending of a string.  Codabar symbology for any new applications today should not be considered except 
under unusual circumstances because it is limited and out-dated. 
  
Codabar is widely used in library systems and blood banks and for some package transport companies. 
  
Codabar Example (No Check Digit) 
  

 
  
  

Code 11 
  

Code 11 is used primarily in telecommunications. The symbol can encode any length string consisting 
of the digits 0-9 and the dash character (-). One or more modulo-11 check digit(s) can be included. 
  
Code 11 Example (No Check Digit) 
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Code 128 
  

Code 128 is variable length and encodes the full 128 ASCII character set. Each character is 
represented by 11 modules that can be one of four bar widths. Code 128 is the most easily read code 
with the highest message integrity due to several separate message check routines. Of all the common 
linear symbologies, Code 128 is the most flexible. It supports both alpha and numeric characters easily, 
has the highest number of characters per inch, and is variable length. 
  
Code 128 is widely used in the shipping industry. 
  
The Code 128 character set includes the digits 0-9, the letters A-Z (upper and lower case), and all 
standard ASCII symbols and control codes.  The codes are divided into three character sets: A, B, and 
C.   
  

• Character Set A - Contains capital letters, control characters and digits.   
• Character Set B - Contains all printable characters. 
• Character Set C - Contains only numbers and the FNC1 character. 

  
Code 128 Example 
  

 
  
  
A special version of Code 128 called GS1 (formerly known as UCC/EAN 128) is used extensively 
world wide in shipping and packaging industries.   

  
  

Code 39 
  

Code 39 is variable length and is the most frequently used symbology in industrial bar code systems 
today. The principal feature is to encode messages using the full alphanumeric character set. Three of 
the nine elements (bars) are wide and six elements are narrow. 
  
Code 39 Extended (Full ASCII Code): Standard Code 39 contains only 43 characters (0-9, A-Z, $, /, %, 
+). Code 39 can be extended to an 128 character symbology (full ASCII) by combining one of the 
special characters ($, /, %, +) with a letter (A-Z) to form the characters that are not present in the 
standard Code 39 symbology. For example, in standard Code 39 a lowercase "a" cannot be 
represented. In Code 39 Full ASCII, however, "a" is represented as "+A". 
  
Code 39 Example (No Check Digit) 
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Code 93 
  

Code 93 encodes the full 128 ASCII character set using 9 modules arranged into 3 bars with adjacent 
spaces. Two of the characters are check characters. Code 93 is similar to Code 39 but encodes more 
characters per inch. Code 93 encodes the full 128 ASCII character set and is encoded similarly to Code 
39 Extended. 
  
Code 93 Example 
  

 
  

D 
 
Data Matrix 
  

Data Matrix is a 2D, variable length symbology capable of encoding all 128 ASCII characters and a 
number of different character sets. Each Data Matrix symbol consists of a perimeter quiet zone, border 
with two solid edges and two dashed edges, and cells inside the border which are dark or light. The 
border's two solid lines with data cells are used for symbol identification, orientation, and cell location. 
Data Matrix can accommodate up to 500 MB per square inch with a data capacity of 1 to 2335 
characters. Data Matrix has a high degree of redundancy and resists printing defects. 
  
Data Matrix is popular for labeling small products because it can encode many characters in a small 
area.  It is becoming the industry standard for marking small electronic equipment.  It is also used in the 
aeronautical industry and the US Department of Defense.  Data Matrix barcodes can be read by smart 
phones by downloading a reader. 
  
Data Matrix Example 
  

 
  

E 
 
EAN/JAN  
  

The EAN/JAN-13 is fixed length and is similar to the UPC-A symbology, but encodes a 13th digit. Also, 
the "12th and 13th" digits of an EAN-13, may represent a country code in its entirety or just the 
beginning of the country code, which may vary from 2 to 3 digits. The code 00-04 and 06-09 are 
assigned to the United States. The nominal height for the EAN/JAN-13 bar code is one inch. The 
reduced size is 80% of the nominal size. 
   
The EAN/JAN-8 is fixed length and is similar to the UPC-E code, but includes two more digits for the 
country code. The nominal height for the EAN/JAN-8 bar code is one inch. The reduced size is 80% of 
the nominal size. 
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EAN/JAN 8 Example 
  

 
  
EAN/JAN 13 Example 
  

 
  
  

G 
GS1 (Formerly RSS) 
  

The GS1 family contains three linear symbologies to be used with the GS1 (formerly EAN.UCC) 
system. The use of this symbology is intended to comply with the GS1 application guidelines. 
  
GS1 bar code symbols are intended for encoding identification numbers and data supplementary to the 
identification. The administration of the numbering system by GS1 ensures that identification codes 
assigned to particular items are unique worldwide and they and the associated supplementary data are 
defined in a consistent way. The major benefit for the users of the GS1 system is the availability of 
uniquely defined identification code and supplementary data formats for use in their trading 
transactions. 
  
GS1-14 encodes the full 14-digit GS1 item identification in a linear symbol that can be scanned 
omnidirectionally by suitably programmed point-of-sale scanners. 
  
GS1-Limited encodes a 14-digit GS1 item identification with indicator digits of zero or one in a linear 
symbol for use on small items that will not be scanned at the point-of-sale. 
  
GS1-14 Stacked is a variation of GS1-14 symbology that is stacked in two rows and is used when the 
normal symbol would be too wide for the application. It comes in two versions – a truncated version 
used for small item marking applications, and a taller omnidirectional version that is designed to be read 
by omnidirectional scanners. 
  
GS1 Expanded encodes GS1 item identification plus supplementary AI element strings such as weight 
and "best before" date in a linear symbol that can be scanned omnidirectionally by suitably 
programmed point-of-sale scanners. GS1 Expanded can also be printed in multiple rows as a stacked 
column. 
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GS1Stacked Omnidirectional allows the full height GS1-14 to be printed in two rows of two segments 
each, which reduces the overall length of the linear bar code so it can fit better on certain packaging 
configurations. The separator pattern between the two rows is designed to eliminate cross-row 
scanning errors. 
  
GS1 Truncated 
  
Any member of the GS1 family can be printed as a stand-alone linear symbol or as a composite symbol 
with an accompanying 2D Composite component printed directly above the GS1 linear component. 

 
GS1-128 (Formerly UCC/EAN 128) 

GS1-128 is a Serial Shipping Container Code with a secure bar code symbology. It allows all 
participants in the supply chain to use a common, standard solution for their individual tracking and 
tracing needs. 
  
The GS1-128 bar code symbology requires AIs to define the data architecture. AIs are prefixes which 
indicate the meaning and format of the data which follows. Among the things they  may be used for are 
 item identification, measurements, quantities, traceability, dates, transaction references and location 
numbers. 
  
GS1-128 Example 
  

 
 
The GS1-128 symbology has three composite types - CC-A, CC-B and CC-C. These composite 
types are actually two barcodes on top of each other. Due to this, in addition to the AI, you will need to 
use the | symbol to differentiate between the two barcodes. If you do not use the | symbol, the scanner 
will not be able to read the barcode. 
 
For example, the data you enter in the Content field (on the Design tab) for a composite barcode might 
look like the following: 
 
 
(01)03212345678906|(21)A1B2C3D4E5F6G7H8  
 
This is actually two barcodes. The | symbol marks the end of the first barcode "(01)03212345678906" 
and the beginning of the second "(21)A1B2C3D4E5F6G7H8 ". The data in the () marks is the AI for 
each barcode. 

I 
 
Intelligent Mail 
 

The Intelligent Mail barcode is used for domestic mail in the United States.  It combines the capabilities 
of the POSTNET and PLANET barcodes into one.  It includes the routing ZIP code and tracking 
information. 
  
Intelligent Mail Example 
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Interleaved 2 of 5 
  

Interleaved 2 of 5 is a variable length, even-numbered, numeric bar code symbol. It is typically used in 
industrial and master carton labeling. The symbology uses bars to represent the first character and the 
interleaved (white) spaces to represent the second character. Each character has two wide elements 
and three narrow elements.  A modulo 10 check character can be used to enhance data security for 
Interleaved 2 of 5 barcode symbols. When this option is selected, the last digit of the symbol is 
assumed to be the check digit, and it is compared to a calculated check digit to verify the symbol. 
  
Interleaved 2 of 5 Example (No Check Digit) 
  

 
  

ISBN 
  

The International Standard Book Number (ISBN) is a unique machine-readable identification number 
used to identify books. ISBN is based on an ISO International Standard that was first published in 1972 
as ISO 2108. ISO 2108 specifies the basic structure of an ISBN, the rules for its allocation, and the 
administration of the ISBN system. 
  
ISBN barcodes have consisted of 13 digits since 2007.  Prior to 2007 they contained 13 digits.  An 
International Standard Book Number consists of 4 or 5 parts: 
  

• for a 13-digit ISBN, a GS1 (Code 128) prefix: 978 or 979 (indicating the industry; in this case, 
978 denotes book publishing) 

• the group identifier, (language-sharing country group) 
• the publisher code, 
• the item number, (title of the book) and 
• a check sum character or a check digit. 

  
The ISBN separates its parts (group, publisher, title and check digit) with either a hyphen or a space. 
Other than the check digit, no part of the ISBN will have a fixed number of digits 
  
ISBN Example 
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ITF14 
  

The ITF-14 Traded Unit Case Code is used in the retail sector on outer cases and pallets (traded units). 
Based on Interleaved 2 of 5, the 14-digit code is numeric and used to display the unique traded unit 
number. Bearer bars must be included in horizontal form for codes printed on labels, and as a full box 
(with H gauges) when printed directly on corrugated surfaces. 
  
ITF14 Example 
  

 
 
M 
 
MaxiCode 
  

Predominantly used by United Parcel Service to sort mail at high speed, MaxiCode is well suited to 
being read quickly and often in any direction. MaxiCode is a fixed-size 2D matrix barcode symbology 
having 866 hexagonal elements arranged in 33 rows around a central finder pattern. The size of a 
MaxiCode symbol is 1.1 inch by 1.05 inch. A single MaxiCode symbol can encode up to 93 characters 
of data and uses five different code sets to encode all 256 ASCII characters. MaxiCode uses three 
unique properties when encoding the data: Class of Service, Country Code, and Mode. 
  
Maxicode Example (Postal Code 75074, Country Code 840, Class of Service 003) 
  

 
MicroPDF417 
  

MicroPDF417 is a multi-row 2D symbology, derived from and closely based on PDF417. It is designed 
for applications that need improved area efficiency but without the requirement for PDF417's maximum 
data capacity. A limited set of symbols is available, together with a fixed level of error correction for 
each symbol size. Module dimensions are user-specified to enable symbol production and reading by a 
wide variety of techniques. 
  
MicroPDF417 Example 
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Micro QR Code 
  

Micro QR Code is a very small QR Code that fits applications that require a smaller space and use 
smaller amounts of data, such as ID of printed circuit boards and electronics parts, etc. 
  
Micro QR Code Example 
  

 
  
  

MSI 
  

The MSI character set consist of the numbers 0..9 as well as two "guard" characters (representing the 
beginning and end of the barcode). The symbology does not support alphabetic characters. 
  
MSI Example 
  

 
  
  

P 
 
PDF417 
  

PDF417 is a stacked linear barcode symbol format used in a variety of applications, primarily transport, 
identification cards, and inventory management. PDF stands for Portable Data File.  Each character 
consists of 4 bars and 4 spaces in a 17 module structure. The name of the symbol is derived from the 
format of the code. PDF stands for "Portable Data File" and "417" is derived from the module structure. 
Each PDF417 symbol consists of 3 to 90 stacked rows surrounded by a quiet zone on all four sides. 
Each row consists of a leading quiet zone, start pattern, left row indicator character, one to thirty data 
characters, right row indicator character, stop pattern, and trailing quiet zone. 
   
PDF417 supports text compaction, numeric compaction, and byte compaction that correlate the 
mapping between codeword values and decoded data. PDF417 can accommodate up to 340 
characters per square inch with a maximum data capacity of 1850 text characters. 
  
PDF 417 Example 
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POSTNET 
  

POSTNET (Postal Numeric Encoding Technique) is a barcode symbology that is used by the United 
States Postal Service to assist in directing mail. The ZIP Code or ZIP+4 code is encoded in half- and 
full-height bars. Most often, the delivery point is added, usually being the last two digits of the address 
or PO box number. 
  
The barcode starts and ends with a full bar (often called a guard rail or frame bar and represented as 
the letter "S" in one version of the USPS TrueType Font) and has a check digit after the ZIP, ZIP+4, or 
delivery point. The encoding table is shown on the right. 
  
Each individual digit is represented by a set of five bars, two of which are full bars (i.e. two-out-of-five 
code). The full bars represent "on" bits in a pseudo-binary code in which the places represent, from left 
to right: 7, 4, 2, 1, 0. (Though in this scheme, zero is encoded as 11 decimal, or "binary" 11000.) 
  
POSTNET Example 
  

 
  
  

Q 
 
QR Code 
  

A QR code (abbreviated from Quick Response code) is a specific matrix barcode (or two-dimensional 
code) that is readable by dedicated QR barcode readers and camera telephones. The code consists of 
black modules arranged in a square pattern on a white background. The information encoded may be 
text, URL, or other data. 
  
QR Code Example 
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U 
 
UPC-A 
  

Each UPC-A barcode consists of a scannable strip of black bars and white spaces, above a sequence 
of 12 numerical digits. No letters, characters, or other content of any kind may appear on a standard 
UPC-A barcode. The digits and bars maintain a one-to-one correspondence - in other words, there is 
only one way to represent each 12-digit number visually, and there is only one way to represent each 
visual barcode numerically. 
  
The UPC-A barcode is used on retail goods. 
  
 
 
 
UPC-A Example 
  

 
  
  

UPC-E 
  

To allow the use of UPC barcodes on smaller packages where a full 12-digit barcode may not fit, a 
'zero-compressed' version of UPC was developed called UPC-E. This symbology differs from UPC-A in 
that it only uses a 6-digit code, does not use middle guard bars, and the end bit pattern (E) becomes 
010101. The way in which a 6-digit UPC-E relates to a 12-digit UPC-A is determined by the last (right-
hand most) digit. 
  
UPC-E Example 
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Chapter 2 - File Tab 
2.1 File Tab Overview 

The File tab contains basic functions that you would typically find on a Windows File menu.  The Open, 
Close and New Document functions are found on this tab.  You can access the Example Templates 
here or search for updates to Labeler.  In addition, you can Activate the product from this tab and view 
the About screen. 
  
  

 
  
File Toolbar Function Descriptions 
  

• New Label - Click the New Label icon to open a new label project in the Design window. You 
can have multiple label projects open in the Design window at the same time. 

• Open - Click the Open icon to select a saved label project to open.  When you click Open, a 
drop down menu of recently opened label projects appears.  Select the project you want to 
open from the list or click Open Files From Folder to navigate to your project. 

• Close - Click the Close icon to close the currently active label project.  If the project is unsaved, 
you will be prompted to save it before closing. 

• Save - Opens an Explorer window allowing you to navigate to a folder to save and name your 
project. 

• Save As - Allows you to save an already saved project under a new name.  This is useful if you 
want to create a copy of a label that can be changed without altering the original. 

• Save All - Saves changes to all projects currently open in the Design window. 

• Example Templates - Launches the Example Templates.  Please refer to the topic Example 
Templates for a complete description of available templates. 

• Check for Updates - Opens an Internet connection to Wasp Barcode Technologies to 
determine if any new updates are available for your version of Labeler.  If an update is found, 
you will be prompted to install it. 
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• About - Opens the About screen.  The About screen lists the version number and serial 
number of your product.  For a description and example of the About screen please refer to the 
topic About Screen. 

• Update License - This icon only appears if you are running Wasp Labeler in Trial Mode.  Click 
on this button to access the Activate Labeler screen where you can enter your activation code 
and register your software. 

• Exit - Closes the Wasp Labeler application.  If you have any unsaved label projects open, the 
Save and Exit screen appears.  Please see the topic Exiting Wasp Labeler with Unsaved 
Labels for detailed instructions on using the Save and Exit screen. 

  

2.2 Exporting a Barcode as an Image File 
You can export any barcode you create in Labeler as an image file.   
  
Steps to Export a Barcode as an Image File 
  

1. Select the barcode, then right click to see the pop up menu. 

2. Select Save as image from the pop up menu: 
 

 
 
 
The Export Barcode as Image File screen appears. 
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3. The Barcode Information section of the Export Barcode...screen 
lists the Symbology and Value encoded into the barcode.   
 
Note:  If the barcode is bound to a database or other external 
source, the placeholder value will appear in the Value field. 
 
In the Target section, select the Format to which you want to 
convert your barcode.  Options are: 
 
 
Bitmap Image (BMP) 
GIF Image (GIF) 
JPEG Image (JPG) 
PNG Image (PNG) 
TIFF Image (TIFF) 
WMP Image (WMP) 

4. Enter the Resolution you want for your image.  Resolutions as low 
as 72 dpi and as high as 1800 dpi may be specified.  If you intend to 
print the image file for subsequent decoding by bar code scanners, 
you should specify resolution values no lower than 200 dpi. The 
default of 300 dpi is ideal for printing.  If you only intend to display 
the image on a monitor, 72 dpi is sufficient. 

5. Click the Export button when you are ready to save the image.  A 
browser window will appear allowing you to select a save location. 

  
  

2.3 Exiting Wasp Labeler with Unsaved Labels 
Click the Close button on the File tab to close the Wasp Labeler application.  If you have any unsaved 
label projects open, the Save and Exit screen (shown below) appears.   
 

 
  
Select the labels you want to save, then click Yes.  A standard Windows browser screen appears 
allowing you to choose a location and name for your label.  If you have selected to save multiple labels, 
a browser window will appear for each label.   
  
Select No to close without saving or Cancel to cancel the exit process and return to Labeler. 
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Chapter 3 - Design Tab 
In this topic: 
  
Design Toolbar Function Descriptions 

Clipboard 
Insert 
Arrange  
Layout Options 
View 
  

The Design tab contains all of the options for customizing your label.  This tab allows you to place 
items such as barcodes, text boxes, graphics and drawing objects onto your label. 
  
This topic provides details on the functions contained on the Design tab.  For an example of creating a 
label using the Design tab, please refer to the topic Getting Started - Creating a Static Label. 
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3.1 Design Toolbar Function Descriptions 
The toolbar on this tab is divided into 6 sections: 
  

1. Clipboard 
2. Insert 
3. Arrange 
4. Position 
5. Layout Options 
6. View 

  
Clipboard - This section contains basic commands: 
  

• Cut - Removes the selected object from the canvas and saves it to the clipboard. 
  

• Copy - Copies the selected object from the canvas and saves it to the clipboard. 
  

• Paste - Places an object saved to the clipboard onto a new location. 
  

• Undo - Click this icon to undo the most recent action. 
  

• Redo - Click this icon to redo the most recent action undone (by clicking Undo). 
  
Insert - The Insert options allow you to insert text, basic shapes, a picture or a barcode into your label. 
After you insert an object, you can add content to it from a variety of sources.  The options in the 
Properties box will vary depending on the type of object you chose to insert.  These icons use the 
Drag and Drop method for placement.  Place your cursor on the desired object, then drag it to the 
Design window and drop it where you want it.  You can place it more precisely or move it as needed. 
  

• Insert Text - This icon allows you to insert a text box onto your label.  You can enter static 
content into your text box or attach a database, string, spreadsheet, etc. to it.  For complete 
instructions on adding a Textbox to your label, please refer to the topic Adding a Textbox. 
  

• Insert Drawing Object - The Box, Line and Ellipse icons allow you to add basic shapes to your 
label.  You can add a rectangle, ellipse or line.  For complete instructions on adding a shape to 
your label, please refer to the topic Adding a Drawing Object. 
  

• Insert Picture - This icon allows you to insert a graphic onto your label.  The supported graphic 
formats are: 
  

o Bitmap Files (*.BMP) 
o JPEG (*.JPG, *.JPEG, *.JPE, *.JFIF) 
o PNG (*.PNG) 
o TIFF (*.TIFF, *.TIF) 
o GIF (*.GIF) 
o ICON (*.ICO) 

 
For complete instructions on adding a picture, please refer to the topic Adding a Picture. 
  

• Insert Barcode - This icon allows you to insert a barcode onto your label.  After placing the 
barcode, you can choose the symbology and data source using the options in the Properties 
box.  For complete instructions on adding a barcode to your label, please refer to the topic 
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Adding a Barcode. 
  

Arrange - The Arrange menu allows for precision placement of objects or text you insert onto your 
label.  
  

• Rotate - This option allows you to rotate a select object clockwise or counter clockwise.  Note 
that you can also use the top grab point on a selected item to rotate it as shown below: 
 

 
  

• Align - This option allows you to align a selected object or multiple selected objects.  You can 
align Left, Right, Top, Bottom, Vertical Center or Horizontal Center.  To select multiple 
objects, click on the objects while holding down the CTRL key.   
 
All alignments are relative to the first object you select when using CTRL + click to select them. 
If you select objects using CTRL + A, the first object you added to the barcode will be used for 
alignment.  The object that is used for alignment, known as the base object, will appear 
selected in blue as shown in the example below. 
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If you want to change your base object, hold down the SHIFT key and click on a different object. 
 The blue outline will change to the newly selected object.  The previous base object will still be 
selected for alignment, but will no longer be the base object. 
 

 
 

Example - Using the Align Function  
   

You have three barcodes on your label and you want to align two of the 
barcodes centered horizontally relative to the third one.  Use CTRL+ click to 
select the barcodes, making sure to select the barcode to which you want the 
other barcodes aligned first.  Your label will look similar to the following: 
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Now select Align > Horizontal Center.   
 

 
 
The barcodes are now aligned relative to the center of the first barcode you 
selected. 
 

 
  
  

• Space - This option allows you to evenly space multiple selected objects across or down. 
  

• Bring to Front - Use this option to move a selected object in front of other objects. 
  

• Send to Back - Use this option to move a selected object behind other objects. 
  

• Bring Forward - Use this option to move a selected object forward. 
  

• Send Backward - Use this option to move a selected object backward. 
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Position - Use these buttons to position the barcode on the label. 
 

• Center Horizontally - Places all selected objects in the middle of the label, horizontally.  
 

    
 

• Center Vertically - Places all selected objects in the middle of the label, vertically.     
 

 
 

Layout Options - Use these options to change the layout of your label or to hide/show the ruler along 
the top and side of the label. 
  

• Units/Ruler - Changes the ruler units.  Options are Inches, Centimeters and Millimeters 
  

• Layout - Accesses the Page Setup screen where you can choose the label type/size. 
  

• Reset Docking- You can move and "redock" the Properties box to the left or center of the 
Labeler window (by default it is docked on the right side of the screen).  To move it back to the 
default position, click the Reset Docking icon. 
  

View - The View menu allows you to zoom in or out of the Design window. 
  

• Zoom In - Allows you to get a close up view of your label. 
  

• Zoom Out - Allows you to see more of the page at a reduced size. 
  

• Zoom - Select a percentage from the drop down to zoom in on the label. 
  

• Reset Zoom - Returns the view to default settings (100%). 
  



 

60 
 

  
Wasp Labeler User Manual 

 3.2 Adding a Drawing Object 
You can add Boxes, Lines and Ellipses to your label using the drag and drop method.  Drawing objects 
can be moved, resized and customized as needed. 
  
  

1. On the Label Design tab click the Box, Line or Ellipse icon on the toolbar. 
 

 
Drag and drop the object where you want the drawing object to appear on your label (you can 
change the location at any time).  When you place the object on your label, notice that the 
Properties box displays any options for the object. 
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2. You can move the drawing object by clicking on it and dragging it.  Resize the object by clicking 

on a corner of the object and dragging it.  You can also enter precise size and location 
coordinates in the Properties Box > Format tab.  Options are: 

• Object Name - You can optionally enter a new name for the object here. 
• Left - Enter the precise location you want your barcode relative to the left side of the 

label. 
• Top - Enter the precise location you want your barcode relative to the top of the 

label. 
• Width - Enter the width of your text box. 
• Height - Enter the height of your text box.   
• Rotate - Rotate the text box on your label. 
• Display on Print - Make sure this checkbox is selected if you want the text box to 

display when your label is printed. 
• Anchor - Select where you want to anchor the object on the page.  For example, if 

you set the Anchor for a box to Top, then adjust the Height, the Top will stay in the 
same position and the box will "grow" from the bottom.  If you anchor it Center, the 
center position will stay the same and the box will "grow" from the top and bottom. 
  

Note: By default the unit of measurement is inches.  To change this, select Units/Ruler on the 
Design tab toolbar and select a different unit of measure. 
 

 
 
The units on the Format tab will update with the new unit of measure. 
 

 
  
3. Add color and/or change the line size using the options in the Drawing section of the Properties 

box.  Options are: 
 
  
• Line Color - This is the color of the outline of your drawing object (or the color of the line). 

 This color defaults to Black.  Click the ellipse button (...) to view the color selection pop up, 
shown below: 
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Click on a color to select it or click More Colors...to view the Advanced Color Palette 
screen, shown below: 
 

 
 
Click on an area of the palette and/or drag the arrow up or down on the shade bar.  A sample 
of your color appears in the lower, left corner.  Click OK to save your selection. 
  

• Line Style - Select how you want the outline to appear (dashed, solid, dot, etc.) from the 
drop down menu. 
  

• Line Width - Enter how thick you want the outline (in pixels). 
  

• Fill Color - (Ellipses and Boxes only) The fill color is the color of the interior of the drawing 
object.  By default the fill color is transparent.  Click the ellipse button (...) to view the color 
selection pop up, shown above. 
  

• Fill Style - (Ellipses and Boxes only)  Select a style for the interior of the drawing object. 
 By default the style is transparent.   
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3.3 Adding a Picture 
In this topic: 
  
Adding a Picture to a Label 
Picture Properties Box: Format Tab 
Picture Properties Box: Content Tab 
  
You can add pictures to your label either "statically", meaning you add a single picture that will appear 
on all labels, or you can link a picture placeholder to a database and have Labeler pull the pictures onto 
each label at print time.  Labeler allows import of bitmap files (*.bmp), JPEG (*.jpg, *.jpeg, *.jpe, *jfif), 
PNG (*.png), TIFF (*.tiff, *.tif), GIF (*.gif), ICON (*ico). 

3.3.1 Steps to Add a Picture to a Label: 

  
1. On the Label Design tab click the Picture icon on the toolbar. 

 

 
Drag and drop the picture where you want it to appear on your label (you can change the 
location at any time). 
 

2. A browser window will appear allowing you to navigate to a picture file.   
 
For Static Images:  Browse to the desired graphic, then click OK.  Your graphic will 
appear on the label.  You can now use the Format tab or the buttons on the Design 
toolbar to edit your image. 
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For Pictures Bound to a Database: If you do not want to import a single graphic, click 
Cancel on the browser window.  This inserts a Placeholder representing your image as 
shown below: 
 

 
 
You can now use the Format tab or the buttons on the Design toolbar to edit the 
placement/alignment of your image. Use the Properties Box > Content tab to bind the 
picture object to a data source. 
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3.3.2 Picture Properties Box: Format Tab 

The Format tab allows you to specify an exact location for a selected barcode on your label.  You can 
also enter precise height and width measurements on this tab.  Below is an example of the Format tab. 
 

 
  
The Format tab is divided into two sections, General and Picture. 
  
Format Tab - General Options are: 
  

• Left - Enter the precise location you want your barcode relative to the left side of the label. 
• Top - Enter the precise location you want your barcode relative to the top of the label. 
• Width - Enter the width of your text box. 
• Height - Enter the height of your text box.   
• Rotate - Rotate the text box on your label. 
• Display on Print - Make sure this checkbox is selected if you want the text box to display when 

your label is printed. 
• Anchor - Select where you want to anchor the object on the page.  For example, if you set the 

Anchor for the image to Top, then adjust the Height, the Top will stay in the same position and 
the picture will "grow" from the bottom.  If you anchor it Center, the center position will stay the 
same and the picture will "grow" from the top and bottom. 
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Note: By default the unit of measurement is inches.  To change this, select Units/Ruler on the Design 
tab toolbar and select a different unit of measure. 
 

 
 
The units on the Format tab will update with the new unit of measure. 
 

 
  
Format Tab - Picture Options are: 
  

• Picture File - If you imported a graphic, the path to it will be listed here.  Click the ellipse button 
(...) to open a browser window to choose a new graphic file. 
  

• Link to File - This checkbox performs different functions depending on whether you have 
bound the object to an actual picture or if you are using an external data source. 
 
Link to a Picture: If this checkbox is NOT selected, Labeler will save the picture to the .LAB file. 
 If this box is not selected, Labeler will save a link to the picture in the .LAB file.  Saving a link 
decreases the size of the .LAB file, however, if you move either the .LAB file or the picture file 
to a different location, the link will be broken and the picture will not display on the label.  If you 
select Link to File, make sure that any moves keep the link intact. 
 
Data Source: When the picture is linked to a column on the datasource, the 'Link to File' 
checkbox represents what type of data is in the column: a path to a picture file, or actual picture 
data. Select this checkbox if the linked column contains a path to picture file (ex: 
D:\Pictures\mypic.jpg). Do not select this checkbox if the column is an actual picture file stored 
in the database. 
  

• Size - Select an option from the drop down: 
 
Original - This options keeps the graphic at it's original size. 
 
Resize with Aspect Ratio - This option allows you to resize the image (by dragging the 
corners) while maintaining aspect ratio. 
 
Resize - This option allows you to resize the image (by dragging the corners) without regard to 
aspect ratio. 
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3.3.3 Picture Properties Box: Content Tab 

The Content tab allows you to specify the content of your barcode (if you are not using a static picture). 
 Below is an example of the Content tab. 
  

 
 
Basic Source Section 
  
The Basic Source section lets you choose a source for the picture.  Your options are: 
  
Database 
Prompt at Print 
  
Clear Content Section 
  
Click the Clear Content button to remove the currently selected data source (including a string).  When 
this button is selected, the following question screen appears: 
  

 
  
Click Yes to remove the current data source or No to cancel and keep the data source. 
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3.4 Adding a Barcode 
Adding a barcode to your label is as simple as dragging and dropping it where you want it to appear. 
After you have placed your barcode, you can select a symbology, choose a data source (or bind it to a 
data source you have added via the data source screen) or add static content, add and format a 
caption, etc. 
  
For a detailed example of adding a static barcode to your label, please refer to the topic Getting 
Started - Creating a Static Label. 
  

3.4.1 Steps to Add a Barcode 

  
1. On the Label Design tab click the Barcode icon on the toolbar. 

 

 
 
Drag and drop the icon where you want the barcode to appear on your label (you can 
change the location at any time).  You can use the buttons on the Label Design toolbar to 
rotate the barcode, move it forward or backward, etc.  When you place the barcode on 
your label, notice that the Properties box displays the options for defining your barcode. 
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2. Define your barcode by using the Barcode Properties box - Barcode Tab to select the 
symbology and any available optional settings for the selected symbology.   

3. You can move your barcode on your label by clicking on it and dragging it where you want. 
 You can enter precise location coordinates using the Barcode Properties box - Format 
Tab.   

4. Attach your barcode to an external data source or define serialization, date/time, etc using 
the Barcode Properties box - Content Tab. 
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3.4.2 Adding a Barcode: Properties Box 

In this topic: 
  
Entering Static Data 
Barcode Tab 
Format Tab 
Content Tab 

Basic Source Section 
String Builder Section 
Formatting Section 

  
After you add a barcode to a label, the Properties box populates with the options available to barcodes 
(symbology, data source, formatting, etc.)  You can use these options to define the information encoded 
in your barcode, the caption that appears with your barcode or for precise location placement on your 
label. 
  

 

Contents Box - Entering Static Data: 

  
Static Data is data that does not change as your labels are printed.  The content for that object will be 
the same on each label.  For a detailed example of creating a static barcode, please refer to the topic 
Getting Started - Creating a Static Label. 
  
Steps to Enter Static Data 
  

1. Make sure your barcode object is selected in the Object List drop down menu. 
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2. Enter your data directly into the Content text box.    If you need to add special 
characters to your barcode, click the ellipse (...) button to the right of the Content 
field. 
 

 
 
 
The Special Characters list appears.  Special Characters are ASCII Codes. 
 These are printable and non-printable markers that tell a printer, scanner, etc. 
how to handle spaces.  For a complete list of ASCII Codes available, please refer 
to the topic ASCII Special Character Codes. 

3. The data you entered into the Content box will appear in the text box on the 
Special Characters List as shown in the example above. 
 
Select any special characters you want to appear in the Content of your barcode. 
 The data will change depending on the code you select.  Note that codes that 
represent a non-printable marker, such as a space or carriage return will be 
represented by a symbol. 

4. Click anywhere off of the Special Character box to close it. 
 
 
The barcode on your label will change to depict the content you entered. 
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Barcode Tab: 

The Barcode tab on the Properties box is where you will select the symbology for your barcode.  This 
tab also has fields for precision placement of your barcode.  Below is an example of the Properties 
Box > Barcode tab.  The options available on this tab vary depending on the symbology you have 
selected.  The example below is with Code 128 selected, the actual screen will look slightly different 
depending on your selected symbology. 
  

 
  
The fields available on the Barcode tab vary depending on the symbology selected.  Click a symbology 
below to view a description for the related properties: 
  

• Code 128 
• Aztec Code 
• Codabar 
• Code 39 
• Code 93 
• Code 11 
• Data Matrix 
• EAN/JAN 8 
• EAN/JAN 13 
• Interleaved 2 of 5 
• Intelligent Mail 
• ISBN 
• ITF 14 
• Maxicode 
• MicroPDF417 

• MicroQRCode 
• MSI 
• PDF417 
• POSTNET 
• QRCode 
• GS1-14 
• GS1 Limited 
• GS1 Stacked Omnidirectional 
• GS1 Truncated 
• GS1 Expanded 
• GS1 128 
• UPC-A 
• UPC-E 
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Format Tab: 

The Format tab allows you to specify an exact location for a selected barcode on your label.  You can 
also enter precise height and width measurements on this tab.  Below is an example of the Format tab. 
  

 
  
The Format tab is divided into three sections: General, Caption and Drawing. 
  
Format tab - General options are: 
  

• Object Name - You can optionally enter a new name for the barcode object. 
• Left - Enter the precise location you want your barcode relative to the left side of the label. 
• Top - Enter the precise location you want your barcode relative to the top of the label. 
• Width - Enter the width you want your barcode. This is the width of your entire barcode, 

including the caption, if it has one. Keep in mind that this affects the density of your 
barcode which could make it harder to scan. 

• Height - Enter the height you want your barcode.  This is the height of your entire barcode, 
including the caption, if it has one.  Keep in mind that a barcode that is too tall or too short 
could cause distortion which could make it harder to scan. 

• Rotate - Rotate the barcode on your label. 
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• Display on Print - Make sure this checkbox is selected if you want the barcode to display when 
your label is printed. 

• Anchor - Select where you want to anchor the barcode on the page.  For example, if you set 
the Anchor to Right, if the barcode grows or shrinks due to variable data from a data source, 
the Right side will stay in the same position and the barcode will "grow" from the left.  If you 
anchor it Center, the center position will stay the same and the barcode will "grow" from the 
right and left. 

  
Format tab - Caption options are: 
  

• Align -Select an option from the drop down list to set the alignment of your caption above or 
below your barcode. 
  

• Font - Click the ellipse button (...) to select a font for your caption.  Below is an example of the 
Font screen 
 

 
 
Select the desired font from the Font Family drop down menu.  Click on the desired Typeface 
and font Size.  A sample of your selections will appear in the Sample section. 
 
Click OK to save your selections or Cancel to close the Font screen without saving your 
selection. 

  
Format tab - Drawing options are: 
  

• Fore Color/Back Color - The Fore color (the color of your barcode) defaults to black.  The 
Back color (the background color) defaults to white.  Click the ellipse button (...) to view the 
color selection pop up, shown below: 
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Click on a color to select it or click More Colors...to view the Advanced Color Palette screen, 
shown below: 
 

 
 
Click on an area of the palette and/or drag the arrow up or down on the shade bar.  A sample of 
your color appears in the lower, left corner.  Click OK to save your selection. 
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Content Tab: 

The Content tab allows you to specify the content of your barcode (if you are not using static data). 
 Below is an example of the Content tab. 
  

 
  
  
This tab is divided into four sections: 
  

• Basic Source - This section is where you can bind the barcode to a data source, object, serial 
number or alpha, date/time, etc. 
  

• Strings - To add more than one data source to the barcode, use the String Builder. 
  

• Formatting - This section allows you to build on the general formatting done to the caption on 
the Format tab and to format the value, which is the barcode content.  You can create a 
"mask", or format expression, that will be applied to all data/captions (if using a data source, for 
example). 

• Clear Content - Click the Clear Content button to remove the data source from the barcode. 
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Basic Source 
  
This section lets you choose the data that will be encoded into your barcode.  Click on a source type to 
bind it to your object (barcode, graphic or textbox). 
  
Source options for barcodes are: 
  
Database 
Date/Time 
Serial Alpha 
Another Object 
User Defined List 
Serial Number 
Prompt at Print 

  
 

  
String Builder 
  
To add more than one data source to the barcode, use the String Builder.  Substrings concatenate, or 
join, different values to build what appears to be a single text or barcode object on the label from 
multiple data sources. This option can be for the following: 
  

1. To customize, or build, the caption of a barcode by combining two or more data sources (static 
plus date/time, for example). 
  

2. To compress two or more text or barcode values of different lengths from an external data 
source. 
  

3. To compress multi-line text values to remove blank lines. 
  
For example, if you want your barcode to have a serialized number followed by a space, you would use 
the String Builder to accomplish this.   
  
Click here for a detailed example of using String Builder to concatenate two different data 
sources in your barcode. 
  
Click here for detailed instructions on using the String Builder screen. 
  

  
 

Formatting 
  
The Formatting section on the Properties box > Data Source tab allows you to add formatting to your 
barcode caption or to the value encoded in your barcode.  To do this you will create a Format 
Expression using the Format Value and Format Caption buttons in this section.   
  
Click here for detailed instructions on formatting barcode values and captions and for a list of 
standard characters used to create Format Expressions. 
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Clear Content 
  
Click the Clear Content button to remove the currently selected data source (including a string).  When 
this button is selected, the following question screen appears: 
  

 
  
Click Yes to remove the current data source or No to cancel and keep the data source. 
  

 
  

  



 

79 
 

  
Wasp Labeler User Manual 

3.4.3 Barcode Properties 

Code 128 Properties Box Options 

The table below lists the options available for Code 128 in the Properties box > Barcode tab. 
  

Code 128 

Field Description 

Symbology 
Select Code 128 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a moredense barcode to fit on a small 
label, for example.  Keep in mind that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per inch 

This settings stands for character per inch.  Code 128 is a dense 
barcode and supports a relatively high character per inch.  You can 
add more characters per inch by increasing the number in this field, 
resulting in a more dense barcode.  Notice that as you increase the 
number in the Char per inch field, the Bar Width field decreases.  The 
more characters you add per inch, the more dense your barcode will 
be.  Keep in mind that a barcode that is too dense may be harder for 
a scanner to read and may not be scannable at all. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Char Set 

There are three different character sets for Code 128 - A, B and C 
and Default.  By leaving this set to Default, Labeler will determine the 
best character set to use based on the content of your barcode. 
 Default is the recommended setting to help you avoid. 
     

• Character Set A - Contains capital letters, control characters 
and digits.   

• Character Set B - Contains all printable characters. 
• Character Set C - Contains only numbers and the FNC1 

character. 

Append Use the Append field to add any characters you want included at the 
end of your barcode. 
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Aztec Code Properties Box Options 

The table below lists the options available for Aztec Code in the Properties box > Barcode tab. 
  

Aztec Code 

Field Description 

Symbology 
Select Aztec Code from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Code Format 

This setting determines the size of the barcode (along with error 
correction and code module size).  The smallest Aztec Code symbol 
encodes 13 numeric or 12 alphabetic characters, while the largest 
Aztec Code symbol encodes 3832 numeric or 3067 alphabetic 
characters or 1914 bytes of data. No quiet zone is required outside 
the bounds of the symbol.  There are 32 sizes from which to choose, 
plus an additional 4 compact sizes.  You can leave this setting at 
Auto to have Labeler determine the size based on the included 
content. 

Error 
Correction 

This settings determines the amount of RS (Reed-Solomon) error 
correction for the barcode.  This allows the scanner to read the 
barcode correctly even in the case of a partially damaged barcode. 
You can choose from 5% to 95% of the data in the barcode for error 
correction.  
    
The higher the amount of data you select for error correction, the 
larger your barcode will be.  This makes your barcode less 
susceptible to damage, but could potentially make it harder to read if 
your barcode contains a large amount of data.  The default setting is 
23%.  This correction amount (23%) is usually the amount of 
correction necessary to make your barcode data safe from damage, 
while also ensuring readability by most scanners.   

Code Rune You can optionally create a "rune" containing the value 0 - 255, if 
needed.  Aztec runes are small, machine-readable symbols. 

Code Module 
Size 

A module in an Aztec barcode is a square dot and is the smallest 
component of the barcode.  In essence, the barcode is made up of 
many light and dark square modules.  You can adjust the module size 
up, which will increase the size of your barcode, or down to decrease 
it. 

  
  



 

81 
 

  
Wasp Labeler User Manual 

Codabar Properties Box Options 

The table below lists the options available for Codabar in the Properties box > Barcode tab. 
  

Codabar 

Field Description 

Symbology 
Select Codabar from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per Inch 

This settings stands for character per inch. You can add more 
characters per inch by increasing the number in this field, resulting in 
a more dense barcode.  Notice that as you increase the number in 
the Char per inch field, the Bar Width field decreases.  The more 
characters you add per inch, the more dense your barcode will be. 
 Keep in mind  that a barcode that is too dense may be harder for a 
scanner to read and may not be scannable at all.  It is recommended 
that you do not exceed 12.8 characters per inch for Codabar 
barcodes. 

Check Digit 

Select the Check Digit checkbox to include an optional check digit 
on your barcode to enhance data security. A check digit appears last 
on the barcode and checks for errors in the preceeding content. A 
modulo 16 check character is used.  When this option is selected, the 
last digit of the symbol is assumed to be the check digit, and it is 
compared to a calculated check digit to verify the symbol. 

Show in 
Caption 

When this option is selected, the check digit will appear in the 
barcode caption. 

Ratio This is the wide to narrow bar ration.  The default setting is 2 (2:1). 

Start 
Character 

Select a Start Character for your barcode or choose Auto to let 
Labeler assign one for you.  A Start Character at the beginning of a 
barcode tells a scanner or barcode reader that the content is about to 
start.  Your options are: A, B, C or D. 

Stop 
Character 

Select a Stop Character for your barcode or choose Auto to let 
Labeler assign one for you.  A Stop Character at the end of a barcode 
tells a scanner or barcode reader that the content has ended.  Your 
options are: A, B, C or D. 

Show 
Start/Stop 

Select this checkbox to display the Start and Stop characters in the 
caption of the barcode. 
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Code 39 Properties Box Options 

The table below lists the options available for Code 39 in the Properties box > Barcode tab. 
  

Code 39 

Field Description 

Symbology 
Select Code 39 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Extended 
Select this checkbox if you want this to be Code 39 Extended 
symbology.  Code 39 Extended supports all ASCII characters by 
using double character encoding.   

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per Inch 

This settings stands for character per inch. You can add more 
characters per inch by increasing the number in this field, resulting in 
a more dense barcode.  Notice that as you increase the number in 
the Char per inch field, the Bar Width field decreases.  The more 
characters you add per inch, the more dense your barcode will be. 
 Keep in mind  that a barcode that is too dense may be harder for a 
scanner to read and may not be scannable at all.   

Bar Height 
  

This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Check Digit 

Select the Check Digit checkbox to include an optional check digit 
on your barcode to enhance data security. A check digit appears last 
on the barcode and checks for errors in the preceeding content. A 
modulo 43 check character can be used to enhance data security for 
Code 39 symbols. The last digit of the symbol is assumed to be the 
check digit, and it is compared to a calculated check digit to verify the 
symbol. 

Show in 
Caption 

When this option is selected, the check digit will appear in the 
barcode caption. 

Ratio This is the wide to narrow bar ratio.  The default setting is 2 (2:1). 

Show 
Start/Stop 

Select this checkbox to display the Start and Stop characters in the 
captions of the barcode.  In Code 39 the * character is automatically 
used as the Start and Stop characters.  Start and Stop characters tell 
a reader where the barcode content begins and ends.   

Stop 
Character 

Select a Stop Character for your barcode or choose Auto to let 
Labeler assign one for you.  A Stop Character at the end of a barcode 
tells a scanner or barcode reader that the content has ended.  Your 
options are: A, B, C or D. 
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Code 93 Properties Box Options 

The table below lists the options available for Code 93 in the Properties box > Barcode tab. 
  

Code 93 

Field Description 

Symbology 
Select Code 93 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per Inch 

This settings stands for character per inch. You can add more 
characters per inch by increasing the number in this field, resulting in 
a more dense barcode.  Notice that as you increase the number in 
the Char per inch field, the Bar Width field decreases.  The more 
characters you add per inch, the more dense your barcode will be. 
 Keep in mind  that a barcode that is too dense may be harder for a 
scanner to read and may not be scannable at all.   
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Code 11 Properties Box Options 

The table below lists the options available for Code 11 in the Properties box > Barcode tab. 
  

Code 11 

Field Description 

Symbology 
Select Code 11 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per Inch 

This settings stands for character per inch. You can add more 
characters per inch by increasing the number in this field, resulting in 
a more dense barcode.  Notice that as you increase the number in 
the Char per inch field, the Bar Width field decreases.  The more 
characters you add per inch, the more dense your barcode will be. 
 Keep in mind  that a barcode that is too dense may be harder for a 
scanner to read and may not be scannable at all. 

  
  

Data Matrix Properties Box Options 

The table below lists the options available for Data Matrix in the Properties box > Barcode tab. 
  
  

Data Matrix 

Field Description 

Symbology 
Select Data Matrix from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 
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EAN/JAN 8 Properties Box Options 

The table below lists the options available for EAN/JAN 8 in the Properties box > Barcode tab. 
  
  

EAN/JAN 8 

Field Description 

Symbology 
Select EAN/JAN 8 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

% of Nominal The nominal size for a EAN/JAN barcode is 1inch.  The usual 
reduced size is 80% of the nominal size. 

Specify Bar 
Height Check this box to enter a specific bar height. 

Bar Height Enter the exact bar height in the field provided. 

  
  

EAN/JAN 13 Properties Box Options 

The table below lists the options available for EAN/JAN 13 in the Properties box > Barcode tab. 
  

EAN/JAN 13 

Field Description 

Symbology 
Select EAN/JAN 13 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

% of Nominal The nominal size for a EAN/JAN barcode is 1inch.  The usual 
reduced size is 80% of the nominal size. 

Specify Bar 
Height Check this box to enter a specific bar height. 

Bar Height Enter the exact bar height in the field provided. 
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Intelligent Mail Properties Box Options 

The table below lists the options available for Intelligent Mail in the Properties box > Barcode tab. 
  

Intelligent Mail 

Field Description 

Symbology 
Select Intelligent Mail from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Postal 4 
State Tracker 
Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Postal 4 
State Tracker 
Bar Height 

This setting determines how tall your barcode will be.  The bar height 
does not affect density.  
  

Postal 4 
State Bars 
Spacing 

This settings stands for character per inch.  Code 128 is a dense 
barcode and supports a relatively high character per inch.  You can 
add more characters per inch by increasing the number in this field, 
resulting in a more dense barcode.  Notice that as you increase the 
number in the Char per inch field, the Bar Width field decreases.  The 
more characters you add per inch, the more dense your barcode will 
be.  Keep in mind  that a barcode that is too dense may be harder for 
a scanner to read and may not be scannable at all. 

Interleaved 2 of 5 Properties Box Options 

The table below lists the options available for Interleaved 2 of 5 in the Properties box > Barcode tab. 
  
  

Interleaved 2 of 5 

Field Description 

Symbology 
Select Interleaved 2 of 5  from the drop down list.  For a complete list 
of available symbologies along with examples and descriptions of 
each, please refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per Inch 

This settings stands for character per inch. You can add more 
characters per inch by increasing the number in this field, resulting in 
a more dense barcode.  Notice that as you increase the number in 
the Char per inch field, the Bar Width field decreases.  The more 
characters you add per inch, the more dense your barcode will be. 
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 Keep in mind  that a barcode that is too dense may be harder for a 
scanner to read and may not be scannable at all. 

Check Digit 

Select the Check Digit checkbox to include an optional check digit 
on your barcode to enhance data security. A check digit appears last 
on the barcode and checks for errors in the preceeding content. A 
modulo 10 check character is used.  When this option is selected, the 
last digit of the symbol is assumed to be the check digit, and it is 
compared to a calculated check digit to verify the symbol. 

Show in 
Caption 

When this option is selected, the check digit will appear in the 
barcode caption. 

Ratio This is the wide to narrow bar ration.  The default setting is 2 (2:1). 

Bearer Bars 

Bearer bars are lines that can be added to frame your barcode.  Your 
options are None, Top and Bottom and Top, Bottom and Sides.  
    
Bearer bars were introduced to prevent barcode distortion when 
flexible, rubber stamps are used to print Interleaved 2 of 5 barcodes 
onto cardboard boxes.  Adding lines all around the barcode stamp or 
just on the top and sides of the stamp  was found to provide 
additional stability so the stamp did not bend as the box was being 
stamped.   

Bearer Bar 
Width Enter the width for the bearer bar(s). 

  

ISBN Properties Box Options 

The table below lists the options available for ISBN in the Properties box > Barcode tab. 
  
  

ISBN 

Field Description 

Symbology 
Select ISBN  from the drop down list.  For a complete list of available 
symbologies along with examples and descriptions of each, please 
refer to the topic Barcode Symbology Reference. 

% of Nominal The nominal size for a EAN/JAN barcode is 1inch.  The usual 
reduced size is 80% of the nominal size. 

Specify Bar 
Height Check this box to enter a specific bar height. 

Bar Height Enter the exact bar height in the field provided. 
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ITF 14 Properties Box Options 

The table below lists the options available for ITF 14 in the Properties box > Barcode tab. 
  

ITF14 

Field Description 

Symbology 
Select ITF 14 from the drop down list.  For a complete list of available 
symbologies along with examples and descriptions of each, please 
refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per Inch 

This settings stands for character per inch. You can add more 
characters per inch by increasing the number in this field, resulting in 
a more dense barcode.  Notice that as you increase the number in 
the Char per inch field, the Bar Width field decreases.  The more 
characters you add per inch, the more dense your barcode will be. 
 Keep in mind  that a barcode that is too dense may be harder for a 
scanner to read and may not be scannable at all. 

Ratio This is the wide to narrow bar ration.  The default setting is 2 (2:1). 

Bearer Bars 

Bearer bars are lines that can be added to frame your barcode.  Your 
options are None, Top and Bottom and Top, Bottom and Sides. 
 Bearer bars must be included in horizontal form for codes printed on 
labels, and as a full box (with H gauges) when printed directly on 
corrugated surfaces.  
     
Bearer bars were introduced to prevent barcode distortion when 
flexible rubber stamps are used to print barcodes onto cardboard 
boxes.  Adding lines all around the barcode stamp or just on the top 
and sides of the stamp provides additional stability so the stamp did 
not bend as the box was being stamped.   

Bearer Bar 
Width Enter the width for the bearer bar. 
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Maxicode Properties Box Options 

The table below lists the options available for Maxicode in the Properties box > Barcode tab. 
  

Maxicode 

Field Description 

Symbology 
Select Maxicode from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Mode 

Select a Mode from the drop down list.  Options are: 
  

1. Mode 2 - Formatted data containing a structured Carrier 
Message with a numeric postal code. (Primarily used for US 
domestic destinations.) 

2. Mode 3 - Formatted data containing a structured Carrier 
Message with an alphanumeric postal code. (Primarily used 
for international destinations.) 

3. Mode 4 - Unformatted data with Standard Error Correction. 
4. Mode 5 - Unformatted data with Enhanced Error Correction. 
5. Mode 6 - Used for programming hardware devices. 

  
Note: UPS codes use Mode 2 or Mode 3. 

Postal Code Enter the postal code of the destination address. 
Country 
Code 

Enter the Country Code of the destination address.  This field defaults 
to 840 (United States). 

Class of 
Service Enter the Class of Service code.  These codes vary by carrier. 

  
  

MicroPDF417 Properties Box Options 

The table below lists the options available for MicroPDF417 in the Properties box > Barcode tab. 
  

MicroPDF417 

Field Description 

Symbology 
Select MicroPDF417 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 
This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
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may be harder for a scanner to read and may not be scannable at all. 

Version Select the barcode version.  The version represents predefined 
combinations of numbers of columns and rows 

  
  



 

91 
 

  
Wasp Labeler User Manual 

MicroQRCode Properties Box Options 

The table below lists the options available for MicroQRCode in the Properties box > Barcode tab. 
  

MicroQRCode 

Field Description 

Symbology 
Select MicroQRCode from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Code Version 

Select the Code Version for your barcode.  You have five options: 

• Auto - Use this option to have Labeler select the version for 
you based on the barcode's content. 

• M1 - This version is capable of encoding: 
o up to 5 numeric characters with no error correction. 

• M2 - This version is capable of encoding: 
o  up to 10 numeric characters and 6 alphanumeric 

characters with L error correction or, 
o  up to 8 numeric characters and 5 alphanumeric 

characters with M error correction. 
• M3 - This version is capable of encoding: 

o  up to 23 numeric characters and 14 alphanumeric 
characters with L error correction or, 

o  18 numeric characters and 11 alphanumeric 
characters with M error correction. 

• M4 - This version is capable of encoding: 
o up to 35 numeric characters and 21 alphanumeric 

characters with L error correction, 
o up to 30 numeric characters and 18 alphanumeric 

characters with M error correction or, 
o up to 21 numeric characters and 13 alphanumeric 

characters with Q error correction level. 

Error 
Correction 
Level 

Select the Error Correction Level.  Options are: 

• L - Approx 7% capability 
• M - Approx 15% capability 
• Q - Approx 25% capability 
• H - Approx 30% capability 

Code 
Encoding 

Select the type of data you want to encode.  Options are: 

• AlphaNumeric 
• Auto 
• Byte 
• Numeric 

Code Module 
Size 

Select the size ofyour barcode or let Labeler determine the sized 
based on content or previous selections. 
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MSI Properties Box Options 

The table below lists the options available for MSI in the Properties box > Barcode tab. 
  

MSI 

Field Description 

Symbology 
Select MSI from the drop down list.  For a complete list of available 
symbologies along with examples and descriptions of each, please 
refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per Inch 

This settings stands for character per inch. You can add more 
characters per inch by increasing the number in this field, resulting in 
a more dense barcode.  Notice that as you increase the number in 
the Char per inch field, the Bar Width field decreases.  The more 
characters you add per inch, the more dense your barcode will be. 
 Keep in mind  that a barcode that is too dense may be harder for a 
scanner to read and may not be scannable at all. 

Check Digit 

Select the Check Digit checkbox to include an optional check digit 
on your barcode to enhance data security. A check digit appears last 
on the barcode and checks for errors in the preceeding content. A 
modulo 10 check digit calculation is always performed on the data 
string. A second modulo 10 check digit is optional and is used to 
perform a check on the entire string including the first check digit. 

Show in 
Caption 

When this option is selected, the check digit will appear in the 
barcode caption. 

Ratio This is the wide to narrow bar ratio.  The default setting is 2 (2:1). 
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PDF417 Properties Box Options 

The table below lists the options available for PDF417 in the Properties box > Barcode tab. 
  

PDF417 

Field Description 

Symbology 
Select PDF417 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Columns Select the number of columns for your barcode (1-30). 

Rows Select the number of rows for your barcode (3-90). 
Error 
Correction 
Level 

Select the error correction level (1-8).  The error correction level 
depends on the amount of data that needs to be encoded, the size 
and the amount of symbol damage that could occur. 

Truncate 
Select this checkbox to truncate, or remove, the right side of the 
PDF417 barcode.  This is useful if you need a smaller barcode, but 
makes it more susceptible to damage. 
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POSTNET Properties Box Options 

The table below lists the options available for POSTNET in the Properties box > Barcode tab. 
  

POSTNET 

Field Description 

Symbology 
Select POSTNET from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Short Bar 
Height 

This setting determines how tall the short bars on your barcode will 
be.  The bar height does not affect density. 

Tall Bar 
Height 

This setting determines how tall the tall bars on your barcode will be. 
 The bar height does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Columns Select the number of columns for your barcode (1-30). 
Ratio This is the wide to narrow bar ratio.  The default setting is  (1:1). 

  
  



 

95 
 

  
Wasp Labeler User Manual 

QR Code Properties Box Options 

The table below lists the options available for QR Code in the Properties box > Barcode tab. 
  

QR Code 

Field Description 

Symbology 
Select QR Code from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 
 

Code Version 
Select the Code Version for your barcode.  You can choose Auto to 
have Labeler select the version for you based on the barcode's 
content, or select Version V01 through V40. 

Error 
Correction 
Level 

Select the Error Correction Level.  Options are: 

• L - Approx 7% capability 
• M - Approx 15% capability 
• Q - Approx 25% capability 
• H - Approx 30% capability 

Code 
Encoding 

Select the type of data you want to encode.  Options are: 
 

• AlphaNumeric 
• Auto 
• Byte 
• Numeric 

Code Module 
Size 

Select the size ofyour barcode or let Labeler determine the sized 
based on content or previous selections. 
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GS1-14 Properties Box Options 

The table below lists the options available for GS1-14 Code in the Properties box > Barcode tab. 
  

GS1-14 

Field Description 

Symbology 
Select GS1-14 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Bar Height 
  

This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

  
  

GS1 Limited 

The table below lists the options available for GS1 Limited Code in the Properties box > Barcode tab. 
  

GS1 Limited 

Field Description 

Symbology 
Select GS1 Limited from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Bar Height 
  

This setting determines how tall your barcode will be.  The bar height 
does not affect density. 
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GS1 Stacked Omnidirectional 

The table below lists the options available for GS1 Stacked Omnidirectional in the Properties box > 
Barcode tab. 
  
  

GS1 Stacked Omnidirectional 

Field Description 

Symbology 
Select GS1 Stacked Omnidirectional from the drop down list.  For a 
complete list of available symbologies along with examples and 
descriptions of each, please refer to the topic Barcode Symbology 
Reference. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Bar Height 
  

This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

  

GS1 Truncated Properties Box Options 

The table below lists the options available for GS1 Truncated in the Properties box > Barcode tab. 
  
  

GS1  Truncated 

Field Description 

Symbology 
Select GS1 Truncated from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Bar Height 
  

This setting determines how tall your barcode will be.  The bar height 
does not affect density. 
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GS1 Expanded Properties Box Options 

The table below lists the options available for GS1 Expanded in the Properties box > Barcode tab. 
  

GS1 Expanded 

Field Description 

Symbology 
Select GS1 Expanded from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Bar Height 
  

This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

  
  

UCC/EAN 128 Properties Box Options 

The table below lists the options available for UCC/EAN 128 in the Properties box > Barcode tab. 
  

UCC/EAN 128 

Field Description 

Symbology 
Select UCC/EAN 128 from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

Bar Height This setting determines how tall your barcode will be.  The bar height 
does not affect density. 

Bar Width 

This setting determines density of the barcode.  Increase the bar 
width (applies to the individual bars in the barcode) and the density is 
decreased.  You might want a more dense barcode to fit on a small 
label, for example.  Keep in mind  that a barcode that is too dense 
may be harder for a scanner to read and may not be scannable at all. 

Char per Inch 

This settings stands for character per inch. You can add more 
characters per inch by increasing the number in this field, resulting in 
a more dense barcode.  Notice that as you increase the number in 
the Char per inch field, the Bar Width field decreases.  The more 
characters you add per inch, the more dense your barcode will be. 
 Keep in mind  that a barcode that is too dense may be harder for a 
scanner to read and may not be scannable at all. 
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UPC-A Properties Box Options 

The table below lists the options available for UPC-A in the Properties box > Barcode tab. 
  

UPC-A 

Field Description 

Symbology 
Select UPC-A from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

% of Nominal Nominal symbol height for UPC-A is 25.9 mm (1.02 in.)  You can set 
the magnification from 80% to 200%. 

Specify Bar 
Height Check this box to enter a specific bar height. 
Bar Height Enter the exact bar height in the field provided. 

  
  

  

UPC-E Properties Box Options 

The table below lists the options available for UPC-E in the Properties box > Barcode tab. 
  

UPC-E 

Field Description 

Symbology 
Select UPC-E from the drop down list.  For a complete list of 
available symbologies along with examples and descriptions of each, 
please refer to the topic Barcode Symbology Reference. 

% of Nominal Nominal symbol height for UPC-E is 25.9 mm (1.02 in.)  You can set 
the magnification from 80% to 200%. 

Specify Bar 
Height Check this box to enter a specific bar height. 
Bar Height Enter the exact bar height in the field provided. 
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3.5 Adding a Text Box 
Labeler allows you to add Text Boxes to your label and place them where you need them using the 
drag and drop method.  You can bind your text box to a variety of data sources, or enter static text (text 
that does not change as labels are printed). 
  

3.5.1 Steps to Add a Text Box 

  
1. On the Label Design tab click the Text Box icon on the toolbar. 

 

 
 
 
Drag and drop the icon where you want the text box to appear on 
your label (you can change the location at any time).  When you 
place the text box on your label, notice that the Properties Box 
displays the options for defining your text box. 
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2. You can move the text box on the label by clicking on it and dragging 
it where you want it. Enter precise location coordinates and size 
using the Text Box Properties box - Format Tab.   

3. Attach your text box to an external data source or define 
serialization, date/time, etc using the Text Box Properties box - 
Data Source tab. 
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3.5.2 Adding a Text Box: Properties Box 

After you add a barcode to a label, the Properties box populates with the options available to barcodes 
(symbology, data source, formatting, etc.)  You can use these options to define the information encoded 
in your barcode, the caption that appears with your barcode and even allows for precise location 
placement on your label. 
  
The topics covered in this section are: 
  
Entering Static Data 
Format Tab 
Content Tab 

Basic Source Section 
String Builder Section 
Formatting Section 

  
 

Content Field - Entering Static Data: 

  
Static Data is data that does not change as your labels are printed.  The content for that object will be 
the same on each label.  For a detailed example of creating a static barcode, please refer to the topic 
Getting Started - Creating a Static Label. 
  
Steps to Enter Static Data 
  

1. Make sure your text box object is selected in the Object List drop 
down menu. 
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2. Enter your data directly into the Content text box.    If you need to 

add special characters to your text box, click the ellipse (...) button to 
the right of the Content field.  The Special Characters List appears. 
 

 
 
Special Characters are ASCII Codes.  These are printable and non-
printable markers that tell a printer, scanner, etc. how to handle 
spaces.  Note that for text boxes, the only available Special 
Characters are <TAB> and  <CR>.   These are the characters for 
Tab and Carriage Return. 
 
For a complete list of ASCII Codes available, please refer to the 
topic ASCII Special Character Codes 

3. The data you entered into the Content box (of the place holder text) 
will appear in the text box on the Special Characters List as shown 
in the example above. 
 
Select the special characters you want to appear in the Content of 
your text box.  The data will change depending on the code you 
select.  Note that codes that represent a non-printable marker, such 
as a space or carriage return will be represented by a symbol. 

4. Click anywhere off of the Special Characters list to close it. 
 
The text box will display the content you entered. 
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Format Tab: 

The Format tab allows you to specify an exact location for a selected text box on your label.  You can 
also enter precise height and width measurements on this tab.  Below is an example of the Format tab. 
  

 
  
The Format tab is divided into two sections: General and Text.. 
  
Format tab - General options are: 
  

• Object Name - You can optionally enter a new name for the text box object. 
• Left - Enter the precise location you want your barcode relative to the left side of the label. 
• Top - Enter the precise location you want your barcode relative to the top of the label. 
• Width - Enter the width of your text box. 
• Height - Enter the height of your text box.   
• Rotate - Rotate the text box on your label. 
• Display on Print - Make sure this checkbox is selected if you want the text box to display when 

your label is printed. 
• Anchor - Select where you want to anchor the text box on the page.  For example, if you set 

the Anchor to Right, if the text box grows or shrinks due to variable data from a data source, 
the Right side will stay in the same position and the text box will "grow" from the left.  If you 
anchor it Center, the center position will stay the same and the text box will "grow" from the 
right and left. 
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Note: By default the unit of measurement is inches.  To change this, select Units/Ruler on the Design 
tab toolbar and select a different unit of measure. 
 

 
 
The units on the Format tab will update with the new unit of measure. 
 

 
  
Format tab - Text options are: 
  

• Justification - Select an option from the drop down list to set the justification of your text box. 
 Options are Left, Center or Right. 
  

• Font - Click the ellipse button (...) to select a font for your caption.  Below is an example of the 
Font screen 
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Select the desired font from the Font Family drop down menu.  Click on the desired Typeface 
and font Size.  A sample of your selections will appear in the Sample section. 
 
Click OK to save your selections or Cancel to close the Font screen without saving your 
selection. 
  

• Auto Size - Select how you want Labeler to handle text wrapping for your text box.  Options are 
Size Rectangle to Text (default) or Wrap Text to fit Rectangle. 

  
  

 

Content Tab: 

The Content tab allows you to specify the content of your text box (if you are not using static data). 
 Below is an example of the Content tab. 
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This tab is divided into four sections: 
  

• Basic Source - This section is where you can bind the text box to a data source, object, serial 
number or alpha, date/time, etc. 
  

• String Builder - To add more than one data source to the data source (serial number plus 
static content, for example), use the String Builder. 
  

• Formatting - This section allows you to build on the general formatting done to the caption on 
the Format tab.  Here you can format the value, which is the barcode content and/or format the 
caption by creating a "mask" that will be applied to all data/captions (if using a data source, for 
example). 

• Clear Content - Click the Clear Content button to remove the data source from the barcode. 
  
Basic Source 
  
This section lets you choose the data that will be encoded into your text box.  Click on a source type to 
bind it to your object (barcode, graphic or textbox). 
  
Source options for text boxes are: 
  
Database 
Date/Time 
Serial Alpha 
Another Object 
User Defined List 
Serial Number 
Prompt at Print 

 
  
String Builder 
  
To add more than one data source to the text box, use the String Builder.  You can create multiple 
substrings on the String Builder screen.  Substrings allow you to concatenate, or join, different values 
to build what appears to be a single text box or barcode object on the label from multiple data sources. 
This option can be for the following: 
  

1. To customize, or build, the caption of a barcode by combining two or more data sources (static 
plus date/time, for example). 
  

2. To compress two or more text or barcode values of different lengths from an external data 
source. 
  

3. To compress multi-line text values to remove blank lines. 
  
For example, if you want your text box to have a serialized number followed by a space, you would use 
the String Builder to accomplish this.   
  
Click here for a detailed example of using String Builder to concatenate two different data 
sources in a barcode. 
  
Click here for detailed instructions on using the String Builder screen. 
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Formatting 
  
The Formatting section on the Properties box > Content tab allows you to add formatting to your 
barcode caption or to the value encoded in your barcode.  To do this you will create a Format 
Expression using the Format Value and Format Caption buttons in this section.   
  
Click here for detailed instructions on formatting barcode values and captions and for a list of 
standard characters used to create Format Expressions. 
  

 
  
Clear Content 
  
Click the Clear Content button to remove the currently selected data source (including a string).  When 
this button is selected, the following question screen appears: 
  

 
  
Click Yes to remove the current data source or No to cancel and keep the data source. 
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3.6 Content Options 

3.6.1 Object Data Source - Date/Time 

You can set your object (text box or barcode) to display the current date/time or a set date/time. 
  
Steps to Add Date/Time to an Object 
  

  
1. With the text box or barcode selected in the Design window, select 

the Date/Time option from the Properties box > Data Source tab. 
 The following screen appears: 
 

 

2. Select what information you want to appear or be encoded in the 
object from the Includes drop down list.  Options are: 
 
Date/Time 
Time/Date 
Date 
Time 

3. Select how you want the date formatted from the Date Format drop 
down list.  Options are: 
 
Short Date - 8/31/2011 (default) 
Medium Date - 31-AUG-2011 
Long Date, Wednesday, August 31, 2011 

4. Select how you want the time formatted from the Time Format drop 
down list.  Options are: 
 
Short Time - 13:18 
Medium Time - 1:18 PM (default) 
Long Time - 1:18:36 PM 
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5. If you want the date to start earlier or later than today, enter in the 
duration in the Offset by Years, Months, Days fields.  For example, 
to start the dates one year from the current date, enter 1 in the 
Years fields or click the up arrow once.  To start the dates one year 
prior to today, enter -1 in the Years field or click the down arrow 
once. 
 
Notice that an example of how your date/time will look appears in the 
Sample field. 

6. Click OK to save your data. 
  

3.6.2 Object Data Source - Serial Alpha 

The Serial Alpha setting allows you to serialize your labels alphabetically.  Objects that can be 
serialized alphabetically are Barcodes and Textboxes. 
  
Steps to Serialize an Object Alphabetically 
  

  
1. With the object (Text or Barcode) in the Design window, click the 

Serial Alpha button on the Properties box > Data Source tab.  The 
following screen appears: 
 

 

2. Select the how you want your letters to appear from the Character 
Set drop down list.  Options are: 
 
Upper case 
Lower case 
Upper then lower case 
Lower then upper case 
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3. Enter the beginning character in the Start at seed: field, then enter 
how many characters you want to increase per a set number of 
labels in the Step and Every fields.  For example, the default 
settings (shown in the screen shot above) sets the serialization to 
start at letter A and increase one letter (step) every one label.  So 
each label will go up one level.  Changing the Every field to 2 means 
that the alpha serialization will increase one letter (step) every 2 
labels. 

4. By default the serialization continues past Z to AA, BB, etc..  If you 
want to change this, select the Rollover after checkbox and enter a 
value.  After the entered value is reached (the default is Z), the 
serialization will start over with the seed value. 

5. If you set the labels to rollover after a set value and do not want 
them to reset to the seed value, select the Reset after rollover 
checkbox.  Enter the value you want to restart at in the field 
provided. 

6. In the Serialization Configuration section, check the checkbox if 
you want to do one of the following: 
 
- increment the sequence with each new record in an external data 
source, or 
 
- resume the serialization where it left off at the next printing. 

7. Click the Preview button to view how your serialization will look. 
 Below is an example of the Serialization Preview screen: 
 

 

8. By default 100 samples are displayed.  You can adjust this number 
up or down using the Number of samples to display field arrows or 
enter a sample number.  Click the Refresh button to update the 
samples with any changes you have made or Close to close the 
Serialization Preview screen. 

9. Click OK on the Serial Alpha screen to save your changes. 
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3.6.3 Object Data Source - Database 

You can attach, or bind, your barcode, graphic or text box to a database to obtain data.  For example, if 
you are creating conference badges, you may have attendee names in one database.  You can create 
your label, then attach various objects to different columns in the database from which they can pull 
data.  You might have a text box pull data from the company column and a barcode with a caption pull 
data from an employee name column.  Then when you print the badges, the appropriate data will 
appear in the text box and encoded on the barcode. 
  
There are three ways you can attach a database.   
  

1. You can select it from the Data tab, allowing you to select which columns you want to make 
available to your label project and to sort/filter data. 
 

2. You choose a database on the Properties Box > Data tab for a selected object. 
 

3. You can select it when you create substrings on the String Builder screen. 
  
Steps to Select a Database Column as the Data Source 
  

1. Select an object (barcode, picture or text box) in the Design window, 
then click on the Properties Box > Content tab and select 
Database, or select Database Column from the drop down list on 
the String Builder screen and click Add Substring.  The following 
screen appears. 
 

 
 
Note: If you have not already selected a Data Source on the main 
Data Source tab, the following message will appear: 
 

 
 
Click Yes to go to the Data tab and select a Data Source.    
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2. The Content Source - Database screen allows you to "map" a 
column in your data source to the selected object.  For example, if 
you are creating a name badge, you might "map" the column 
containing employee names to a text box. 
 
Keep in mind that you can use this screen to map one column to 
your object.  If you want to add data from more than one column 
to an object, use the String Builder to concatenate (join) data. 

3. To map a column to the selected object, select a column from the 
drop down menu.  If you creating any filters or joins for the database 
on the Data tab, only the columns you selected will appear in the 
drop down list. 

4. Click Done after you have made your selection.   
  

3.6.4 Object Data Source - Another Object 

You can give a text box or barcode the same data source as another text box or barcode already on 
your label using the Bind to Another Object feature.  If you want two or more objects to use the same 
data, you can go through the adding data source and column mapping functions once, then use the 
Bind to Another Object feature to quickly add the same data source and column to a new object. 
  
Steps to Bind an Object to Another Object 
  

1. Select an object (barcode, picture or text box) in the Design window, 
then click on the Properties Box > Data Source tab and select 
Another Object. 
 
The Bind to Another Object screen appears: 
 

 

2. Select which object you want to bind from the drop down menu. 

3. Click OK on the Bind to Another Object screen. 
  
Note:  If you change the data source on the object to which you have bound 
another object, the data source will change for both objects 
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3.6.5 Object Data Source - User Defined List 

Labeler contains a set of lists you can use as a data source, or you can create a custom list.   
  
Steps to Bind an Object to a User Defined List 
  

1. Select an object (barcode, picture or text box) in the Design window, then click on the 
Properties Box > Data Source tab and select User Defined List. 
 
The User Defined list screen appears; 
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2. There are three pre-built lists contained in Labeler: Colors.txt, State Abbreviations.txt and State 
Names.txt.  You can select one of these lists from the drop down: 
 

 
 
or click Manage Lists to create a new list or select a list you have already created.  When 
Manage Lists is selected, a Manage Lists browser window appears: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  



 

116 
 

  
Wasp Labeler User Manual 

3. This browser window opens to the <path> folder on the machine where Labeler was installed. 
 In this folder are the three pre-built lists.  You can create a new list from scratch by right-
clicking anywhere in the window and selecting New > Text Document.   
 

 
 
Save the file with the name of your choosing (make sure the extension stays .txt) then double-
click on the file name to open and edit the document.  The new list will appear in the browser 
window. 
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3.6.6 Object Data Source - Serial Number 

The Serial Number setting allows you to serialize your labels numerically.  Objects that can be 
serialized numerically are Barcodes and Text boxes. 
  
To Create a Serial Number Object 
  

1. With the object (Text or Barcode) in the Design window, click the 
Serial Number button on the Properties box > Data Source tab. 
 The following screen appears: 
 

 
 

2. Select if you want your labels serialized in Incrementing series or 
Decrementing series by selecting the appropriate radio button. 
 

3. Enter the beginning number in the Start at seed: field, then enter 
how many characters you want to increase per a set number of 
labels in the Step and Every fields.  For example, the default 
settings (shown in the screen shot above) sets the serialization to 
start at the number 1 and increase one digit (step) every one label. 
 So each label will go up one level.  Changing the Every field to 2 
means that the number will increase one (step) every 2 labels. 
 

4. By default the serialization continues past Z to AA, BB, etc. If you 
want to change this, select the Rollover after checkbox and enter a 
value.  After the entered value is reached (the default is Z), the 
serialization will start over with the seed value. 
 

5. If you set the labels to rollover after a set value and do not want 
them to reset to the seed value, select the Reset after rollover 
checkbox.  Enter the value you want to restart at in the field 
provided. 
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6. In the Serialization Configuration section, check the checkbox if 
you want to do one of the following: 
 
- increment the number with each new record in an external data 
source, or 
 
- resume the serialization where it left off at the next printing. 

7. Click the Preview button to view how your serialization will look. 
 Below is an example of the Serialization Preview screen: 
 

 
 

8. By default 100 samples are displayed.  You can adjust this number 
up or down using the Number of samples to display field arrows or 
enter a sample number.  Click the Refresh button to update the 
samples with any changes you have made or Close to close the 
Serialization Preview screen. 
 

9. Click OK on the Serial Number screen to save your changes.  
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3.6.7 Object Data Source - Prompt at Print 

Prompt at Print is used to permit keyboard entry of information onto the label during the Print process. 
 Prompt at Print should be considered when the label information is available only at the time of print. 
The Prompt at Print Time information is not stored anywhere; it is dynamically input by the user when 
the label is configured to print.   Prompt at Print can be used with Text, Barcode or Picture objects. 
  
Steps to Enable Prompt at Print for an Object 
  

1. With the object (Text, Barcode or Picture) in the Design window, 
click the Prompt at Print button on the Properties box > Data 
Source tab.  The following screen appears: 
 

 

2. Enter a description for the prompt in the field provided.  This should 
be descriptive enough that the user printing the labels will know what 
value to enter. 

3. Click the OK button. 

4. When the labels are ready to be printed, on the Print tab, click the 
Print button.  A Keyboard Entry screen similar to the following: 
 

 

5. Any objects that are setup for a prompt appear in the top window. 
 Type in data in the Value field for each object that has a prompt.   
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6. Click Next to move on to the next label. 

7. Select the Loop continuously checkbox to apply the data you 
entered in the Value field to that object on all labels. 

8. Click the Print button when you have finished entering values at all 
the prompts. 
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3.6.8 String Builder 

To add more than one data source to the barcode, use the String Builder.  Substrings concatenate, or 
join, different values to build what appears to be a single text or barcode object on the label from 
multiple data sources. This option can be used for the following: 
  

1. To customize, or build, the caption of a barcode by combining two or more data sources (static 
plus date/time, for example). 
  

2. To compress two or more text or barcode values of different lengths from an external data 
source. 
  

3. To compress multi-line text values to remove blank lines. 
  
For example, if you want your barcode to have a serialized number followed by a space, you would use 
the String Builder to accomplish this.   
  
Click here for a detailed example of using String Builder to concatenate two different data 
sources in your barcode. 
  
Steps to Create Substrings Using String Builder 
  

1. With the text box or barcode object selected, click the String Builder 
button on the Properties Box > Data Source Tab.  The String 
Builder screen appears.  Note that the String Builder screen is 
different for barcodes and text boxes. 
 
String Builder Screen - Barcodes 
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String Builder Screen - Text Boxes 
 

 
  

2. Select the data source from the drop down menu, then click the Add 
Substring button.  The options will vary depending on the type of 
object you have selected.  Options are: 
  

• Database Column - This option allows you to select a 
column from the data source associated with your label file. 
 You must have a data source associated with the current 
label in order to use this option. If you have not yet 
connected to a data source, please refer to the topic Data 
Tab Overview for detailed instructions. 

• Serialized Number - The Serialized Number option allows 
you to create serial numbers for your labels based on a 
beginning number you select. 

• Serialized Alpha - The Serialized Alpha option allows you to 
serialize your labels alphabetically based on a beginning 
letter you select. 

• Static - This option allows you to enter static text or 
characters that will appear on all of your labels. 

• User Defined List - Labeler contains a set of pre-defined 
lists you can select from or you can create your own lists. 

• Date/Time - This option displays the current date/time (or a 
date/time of your choosing) on the associated object. 

• Prompt at Print - This option allows you to enter a question, 
or prompt, for information that will appear when you print the 
label. 

• Bind to another Object - This allows you to bind the 
substring to another object that already has a data source.  

• Label Counter (Text Box Only) - This option allows you to 
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put a label counter on a text box.  A Label Counter counts 
the number of physical, unique labels that are printed 
(determined in the Number of Labels fields on the Print tab). 

• Label Total (Text Box Only) - This option displays the total 
number of physical, unique labels printed. 

• Copies Counter (Text Box Only) - This option allows you to 
put a copies counter on a text box.  A “copies counter” 
counts the number of identical copies of a label that are 
printed (determined in the Number of Copies fields on the 
Print tab). 

• Copies Total (Text Box Only) - This option displays the 
total number of identical copies of a label that are printed. 

 
Note:  You can use the Counter and Total substrings to create 
enumerated labels (1 of 5, 2 of 5, 3 of 5, etc.)  For a detailed 
example of how to create enumerated labels with and without serial 
numbers, please refer to the topic Creating Enumerated Labels. 
  

3. Substrings you add will appear in the window as shown below: 
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A sample of the entire string appears in the Sample result after 
concatenating all substrings field.  You can reorder substrings by 
clicking the up or down arrows to the right of the substring list: 
 

 
You can edit a substring by clicking on the Pencil icon or delete it by 
clicking the red X icon. 
  

4. To edit Substring Properties, highlight a substring in the window. 
 The selected Substring name appears in the Substring: field: 
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5. For dynamic data sources that pull data from an external source, 
such as a text file or Access database, you can enter a place holder 
in the Place Holder field.  The content you enter here will appear in 
the text box or barcode as a 'place holder' for display purposes, but 
will change to the content pulled from the external source at print 
time. 
  

6. Select the Add checkbox(s), then select Carriage Return or Space 
from the drop down.  This adds a carriage return or space Before 
and/or After the selected substring. 
  

7. Select the Ignore if Previous substring is blank if you want Labeler 
to skip the selected substring if no data is found for the previous 
substring in the list. 
  

8. You can add formatting to a substring by clicking the Data 
Formatting button.  Click here for a detailed description of 
creating format expressions. 
  

9. For barcodes, you have two additional options: 
 
Use in barcode value - Select this checkbox to include the 
substring in the barcode value.  This means the substring will be 
encoded in the barcode. 
Use in barcode caption - Select this checkbox to include the 
substring in the barcode caption.   

  

3.6.9 Formatting Data 

In this topic: 
  
Steps to Access and Use the Format Value Screen 
Character Formatting Definitions and Examples 
Number Formatting Definitions and Examples 
String Formatting Definitions and Examples 
Custom Date and Time Formatting (DATEFORMAT Command) 

DATEFORMAT Characters and Definitions 
Example DATEFORMAT Expressions 

Removing Unwanted Spaces from Data (TRIM Command) 
  

The Formatting section on the Properties box > Data Source tab allows you to add formatting to your 
barcode caption or to the value encoded in your barcode.  To do this you will create a Format 
Expression using standard characters to represent digits placeholders, decimal placeholders, 
percentage placeholders, etc. 
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Steps to Access and Use the Format Value/Caption Screen 

  
1. There are two methods for accessing the Format screen. 

a. After you have added a barcode or text box to your label and bound data to it, click on 
the Format Value or Format Caption buttons in the Properties Box > Content Tab > 
Formatting section. 
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b. If you are creating an object with substrings, click String Builder in the Strings 
section.  Add a Substring, then click Data Formatting (the Data Formatting button will 
be disabled until you create at least one substring).  For detailed information on creating 
substrings, please refer to the String Builder topic. 
 
  

 
 
The Format Value/Format Caption screen appears. Note:  The Format Value and 
Format Caption screens are identical and function the same way.  The screen 
shots/verbiage in this topic refer to "Format Value" but are applicable to the Format 
Caption screen. 
 

 

2. Enter your format expression in the Format String text box.  This expression serves as a 
"mask" that will be placed on all data pulled from the data source.  You can create format 
expressions for Strings (Characters or combination of numbers and characters), Numbers or 
Dates. 
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Formatting Character Definitions and Examples 

The tables below contain the formatting characters, their meanings and additional information about 
each one.  You will combine these characters to create your format expression. 
  

Number Formatting 
Character Definition Additional Information Examples 

0   Digit 
Placeholder 

Display a digit or a zero.  If there is a digit in the position 
where the 0 appears in the format string, display it; 
otherwise display a zero in that position.  
    
If the number being formatted has fewer digits than there 
are zeros (on either side of the decimal) in the format 
expression, leading or trailing zeros are displayed. If the 
number has more digits to the right of the decimal 
separator than there are zeros to the right of the decimal 
separator in the format expression, the number is rounded 
to as many decimal places as there are zeros. If the 
number has more digits to the left of the decimal separator 
than there are zeros to the left of the decimal separator in 
the format expression, the extra digits are displayed 
without modification. 

1234.5678 
("00000") = 
012345  
   
0.45678 ("0,00") = 
0.46  
  

#   Digit 
Placeholder 

Display a digit or nothing. If there is a digit in the position 
where the # appears in the format string, display it; 
otherwise, display nothing in that position. 
This symbol works like the 0 digit placeholder, except that 
leading and trailing zeros aren't displayed if the number 
has the same or fewer digits than there are # characters on 
either side of the decimal separator in the format 
expression. 

1234.5678 
("#####") = 12345  
   
0.45678 (#.##") = 
.46 

.   Decimal 
Placeholder 

The decimal placeholder determines how many digits are 
displayed to the left and right of the decimal separator. If 
the format expression contains only numbers sign to the 
left of this symbol, numbers smaller than 1 begin with a 
decimal separator. If you want a leading zero to always be 
displayed with fractional numbers, use 0 as the first digit 
placeholder to the left of the decimal separator instead. 

0.45678 ("0.00") = 
0.46 

%   Percentage 
Placeholder 

The expression is multiplied by 100. The percent character 
(%) is inserted in the position where it appears in the 
format string. 

0.3697 ("%#0.00") 
= %36.97  
   
0.3697 ("##.0%") 
= 37.0% 

,   Thousand 
Separator 

The thousand separator separates thousands from 
hundreds within a number that has four or more places to 
the left of the decimal separator. Surround the thousand 
separator with the digit placeholders (0 or #). Two adjacent 
commas or a comma immediately to the left of the decimal 
separator (whether or not a decimal is specified) means 
"scale the number by dividing it by 1000, rounding as 
needed." You can scale large numbers using this 

2147483647 
("#,#,,") = 2,147 
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technique. For example, you can use the format string 
"##0,," to represent 100 million as 100. Numbers smaller 
than 1 million are displayed as 0. Two adjacent commas in 
any position other than immediately to the left of the 
decimal separator are treated simply as specifying the use 
of a thousand separator. The actual character used as the 
thousand separator in the formatted output depends on the 
Number Format specified in the International section of the 
Control Panel. For some countries, a period is used as the 
thousand separator. 

E-   E+   e- 
  e+   

Exponential 
Notation 

If the format expression contains at least one digit 
placeholder (0 or #) to the right of E-, E+, e-, or e+, the 
number is displayed in scientific format and E or e is 
inserted between the number and its exponent. The 
number of digit placeholders to the right determines the 
number of digits in the exponent. Use E- or e- to place a 
minus sign next to negative exponents. Use E+ or e+ to 
place a minus sign next to negative exponents and a plus 
sign next to positive exponents. 

987654 ("0.0e0") 
= 98.8e4  
   
1503.92311 
("0.0##e+00") = 
1.504e+03 

-  +  $  (  ) 
Display a 

literal 
character 

To display a character other than one of those listed, 
precede it with a backslash (\) or enclose it in double 
quotation marks (" "). 

  

\ Escape 
Character 

Many characters in the format expression have a special 
meaning and can't be displayed as literal characters unless 
they are preceded by a backslash. The backslash itself 
isn't displayed. Using a backslash is the same as enclosing 
the next character in double quotation marks. To display a 
backslash, use two backslashes (\\). For example, the 
numeric-formatting characters (#, 0, %, E, e, comma, and 
period) and the string-formatting characters (@, &, <, >, 
and !) can't be displayed. 

987654 
("\###00\#") = 
#987654# 

"ABC" 
Literal 
String 

Delimiter 

Indicates that the enclosed characters should be copied to the 
result string unchanged. 

68 ("#' degrees'") = 
68 degrees 

; Section 
Separator 

Defines sections with separate format strings for positive, 
negative and zero numbers.  A format expression can have from 
one to four sections separated by semicolons.  The first section 
applies to positive values, the second to negative values, the third 
to zeros and the fourth to Null values. 
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String Formatting 

Character Definition Additional Information and Examples 

@ Character 
placeholder 

Display a character or a space. If there is a character in the string being formatted in 
the position where the @ appears in the format string, display it; otherwise, display 
a space in that position. Placeholders are filled from right to left unless there is an ! 
character in the format string. 

& Character 
placeholder 

Display a character or nothing. If there is a character in the string being formatted in 
the position where the & appears in the format string, display it; otherwise, display 
nothing in that position. Placeholders are filled from right to left unless there is an ! 
character in the format string. 

< Force lowercase All characters are displayed in lowercase format 
> Force uppercase All characters are displayed in uppercase format. 

! 

Force 
placeholders to 
fill from left to 

right instead of 
right to left 

  

"ABC" Literal String 
Delimiter 

Indicates that the enclosed characters should be copied to the result string 
unchanged. 
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Custom Date and Time Formatting (DATEFORMAT Command) 

  
Labeler always stores date as DateTime format.  This means that if you have a column in your data that 
is just a date, Labeler will add the default time of 12:00:00 AM to it. If you do not want to show the time 
on your label, use the DATEFORMAT function described below.  
  
DATEFORMAT Characters and Definitions 
Example DATEFORMAT Expressions 
  

DATEFORMAT Characters and Definitions 
Character Definition Additional Information Result 

d   Day of the 
Month The day of the month, from 1 through 31. 

9/26/2011 
1:33:45 = 26  
   
9/1/2011 
1:33:45 = 1 

dd  Day of the 
Month The day of the month, from 01 through 31. 

9/26/2011 
1:33:45 = 26  
   
9/1/2011 
1:33:45 = 01 

ddd 
Abbreviated 

Day of 
Week 

The abbreviated day of the week. 9/26/2011 
1:33:45 = Mon 

dddd Full Day of 
Week The full name of the day of the week. 

9/26/2011 
1:33:45 = 
Monday 

g or gg Period or 
Era The period or era (A.D.) 9/26/2011 

1:33:45 = A.D. 

h Hour The hour using a 12-hour clock from 1 to 12. 

9/26/2011 
1:33:45 AM = 1  
   
9/26/2011 
1:33:45 PM = 1 

hh Hour The hour using a 12-hour clock from 01 to 12. 

9/26/2011 
1:33:45 AM = 
01  
   
9/26/2011 
1:33:45 PM = 01 

H Hour The hour using a 24-hour lock from 0 to 23. 

9/26/2011 
1:33:45 AM = 1  
   
9/26/2011 
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1:33:45 PM = 13 

HH Hour The hour using a 24-hour clock from 00 to 23. 

9/26/2011 
1:33:45 AM = 
01  
   
9/26/2011 
1:33:45 PM = 13 

m Minute The minute from 1 through 59 

9/26/2011 
1:01:45 AM = 1  
   
9/26/2011 
1:01:45 PM = 1 

mm Minute The minute from 00 through 59 

9/26/2011 
1:01:45 AM = 
01  
   
9/26/2011 
1:01:45 PM = 01 

M Month The month from 1 through 12. 9/26/2011 
1:01:45 AM = 9 

MM Month The month from 01 through 12. 
9/26/2011 
1:01:45 AM = 
09 

MMM Month The abbreviated name of the month. 
9/26/2011 
1:01:45 AM = 
Sept 

MMMM Month The full name of the month 
9/26/2011 
1:01:45 AM = 
September 

s Second The second from 0 through 59. 9/26/2011 
1:01:01 AM = 1 

ss Second The second from 00 through 50. 
9/26/2011 
1:01:01 AM = 
01 

t AM/PM The first characters of the AM/PM designator. 9/26/2011 
1:01:45 AM = A 

tt AM/PM The AM/PM designator. 
9/26/2011 
1:01:45 AM = 
AM 

y Year The year from 0 to 99.   
yy Year The year from 00 to 99.   

yyy Year The year with a minimum of three digits.   
yyyy Year The year as a four digit number.   
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: Time 
Separator The time separator. 9/26/2011 

1:01:45 AM = : 

/ Date 
Separator The date separator. 9/26/2011 

1:01:45 AM = / 

"ABC" 
Literal 
String 

Delimiter 

Indicates that the enclosed characters should be copied to the result 
string unchanged. 

9/26/2011 
1:01:45 AM 
("arr:" h"m t) 
arr: 1:45 A 

% 
Custom 
Format 

Specifier 
Defines the following character as a custom format specifier. 

9/26/2011 
1:01:45 AM 
(%h) = 1 

\ Escape 
Character 

Many characters in the format expression have a special meaning 
and can't be displayed as literal characters unless they are preceded 
by a backslash. The backslash itself isn't displayed. Using a 
backslash is the same as enclosing the next character in double 
quotation marks. To display a backslash, use two backslashes (\\). 
For example, the numeric-formatting characters (#, 0, %, E, e, 
comma, and period) and the string-formatting characters (@, &, <, 
>, and !) can't be displayed. 

9/26/2011 
1:01:45 AM (h 
\h) = 1 h 

Any other 
character   The character is copied to the result string unchanged. 

9/26/2011 
1:01:45 AM (arr 
hh:mm t) = arr 
01:45 A 
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Example Data and Time Format Expressions 

Enter a custom date format in the format shown below: 
  
[DATEFORMAT:<format string here>] 
 
The “DATEFORMAT:” prefix must be specified, followed by the <format string here> section. 
Inside the <format string here> you can enter any valid formatting string from the table above.  The [] 
brackets are required. 
  
Example 1 
  
[DATEFORMAT:dd/MM/yyyy] 
 
If the value Oct 4, 1973 is entered, the Test Results will display  04/10/1973 as shown in the screen 
example below: 
 

 
 
Example 2 
  
[DATEFORMAT: hh:mm:ss] 
  
If the value Dec 1, 2011 5:15:35 PM is entered, the Test Results will display 05:15:35. 
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Example 3 
  
[DATEFORMAT: hh:mm tt] 
  
If the value Dec 1, 2011 5:15:35 PM is entered, the Test Results will display 05:15 PM. 
 

 
  
Example 4 
  
[DATEFORMAT: MMMM dd, yyyy hh:mm tt] 
  
If the value Dec 1, 2011 5:15:35 PM is entered, the Test Results will display December 01, 2011 05:15 
PM. 
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Removing Unwanted Spaces from Data (TRIM Command) 

  
There may be instances where data source has spaces at the end or beginning of data.  You can use the 
"TRIM" function to remove unwanted spaces from the final output on your label.  The formatting 
commands for removing spaces are provided below: 
  

• [LEFT:3] - This command returns the first 3 characters from the input. 
• [LTRIM LEFT:3] ------> same as above, but before it performs a LTRIM on the input, then the 

LEFT:3 will be applied to the result 
• [RTRIM LEFT:3] ------> same as above, but before it performs a RTRIM on the input, then the 

LEFT:3 will be applied to the result 
• [TRIM LEFT:3] ------> same as above, but before it performs a TRIM on the input, then the 

LEFT:3 will be applied to the result 
• [RIGHT:3] ------> This command returns the last 3 characters from the input. 
• [LTRIM RIGHT:3] ------> same as above, but before it performs a LTRIM on the input, then the 

RIGHT:3 will be applied to the result 
• [RTRIM RIGHT:3] ------> same as above, but before it performs a RTRIM on the input, then the 

RIGHT:3 will be applied to the result 
• [TRIM RIGHT:3] ------> same as above, but before it performs a TRIM on the input, then the 

RIGHT:3 will be applied to the result 
• [MID:2,3] ------> This command returns the substring starting at position 2 returning the next 3 

chars that appear 
•  [LTRIM MID:2,3] ------> same as above, but before it performs a LTRIM on the input, then the 

MID:2,3 will be applied to the result 
• [RTRIM MID:2,3] ------> same as above, but before it performs a RTRIM on the input, then the 

MID:2,3 will be applied to the result 
• [TRIM MID:2,3] ------> same as above, but before it performs a TRIM on the input, then the 

MID:2,3 will be applied to the result 

  

ASCII Special Character Codes 

ASCII (American Standard Code for Information Interchange) codes represent 128 characters. 33 of 
these are non-printable markers that define how spaces are handled by a scanner or printer (line breaks, 
tabs, etc.).  Below is a table of the non-printable ASCII character codes and their associated definitions: 
  

Code Definition 
<SOH> Start of Header 
<STX> Start of Text 
<ETX> End of Text 
<EOT> End of Transmission 
<ENQ> Enquiry 
<ACK> Acknowledgment 
<BEL> Bell 
<BS> Backspace 
<TAB> Horizontal Tab 
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<LF> Line Feed 
<VT> Vertical Tab 
<FF> Form Feed 
<CR> Carriage Return 
<SO> Shift Out 
<SI> Shift In 
<DLE> Data Link Escape 
<DC1> Device Control 1 
<DC2> Device Control 2 
<DC3> Device Control 3 
<DC4> Device Control 4 
<NAK> Negative Acknowledgment 
<SYN> Synchronous Idle 
<ETB> End of Transmission Block 
<CAN> Cancel 
<EM> End of Medium 
<SUB> Substitute 
<ESC> Escape 
<FS> File Separator 
<GS> Group Separator 
<RS> Record Separator 
<US> Unit Separator 
<SP> Space 
<DEL> Delete 

  
The remaining codes represent printable characters such as the exclamation point (!), period (.), comma 
(,), etc.  Upper and lower case alphabetic characters are also represented. 
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Chapter 4 - Data Tab 
4.1 Data Tab Overview 

In this topic: 
  

Select an External Data Source 
Sort the Data Source Content 
Filter the Data Source Content 
Join Tables 
Refresh Data 
Edit Connection 
Remove Connection 

  
  

The Data tab allows you to add a database, spreadsheet, .csv file or other data source to your label 
project.  You can then associate an object on your label, such as a text field or a barcode with the data 
source using the Properties > Contents box on the Design tab.  Using a data source allows for the 
"automation" of your labels as Labeler will extract the data from the associated data source and use 
that as the content for your text field, barcode, picture, etc.   
  

Example - When to Use an External Data Source 
  

Using an external database from which to draw data is useful if your 
company has inventory information stored in a database (Microsoft 
Access or Excel, any ODBC compliant data source, a delimited text file, 
etc) from which inventory labels with barcodes are produced.  
  
Another example might be that a company needs to print mailing labels 
for their customers where the customer address information is stored in a 
spreadsheet.  In either case, Labeler can easily access the data from the 
external data source and apply it to the label. 
  
Please refer to the topic Getting Started - Binding a Data Source to an 
Object for a step-by-step example of linking an object to an external 
source. 
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On the Data tab you can add one external data source and define which columns and rows you want to 
include.  Adding a data source here makes it available to bind to objects on the Design Tab. 
  

 
  

Select an External Data Source 
 

To create a connection to an external data source, click on the desired data source type on the Data 
tab. 
  
Your options are: 
  
CSV File 
Access Database 
Excel Spreadsheet 
MSSQL 
ODBC Connection 
QuickBooks® 
Text File 
Wasp Data (this option allows you to create your own Wasp database) 

  



 

141 
 

  
Wasp Labeler User Manual 

4.2 Connecting to a CSV File 
  

1. On the Data tab click the CSV option. 
 

 
 

2. The Data Source - Comma Separated File screen appears: 
 

 

3. Enter the file name and location or click the Browse button to navigate to the file. 
 
 
When you click Browse, a browser window will appear allowing you to navigate to your file. 
 After you select your file and click OK on the browser window, the Data Source - Comma 
Separated File screen will populate with the path and name of your data source in the File 
Name field. 

4. If the first row of your file contains column headers, make sure the First Row is Column 
Headings checkbox is selected. 

5. The maximum rows included in your label defaults to 1,000.  You can enter a smaller or larger 
number as needed in the Max Rows field.   
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Keep in mind that a very large number of rows may result in slower performance. 
 

6. Click Test Connection to make sure Labeler is able to successfully establish a connection to 
the selected file.  If a connection is established, the message shown below appears: 
 

 
 
Click OK on the Test Connection message to close it. 

7. Click Apply to add the connected file to your Labeler project.  The data contained in the 
selected file will appear on the Data tab as shown in the example below: 
 

 

8. You can now perform the following functions: 
 
Refresh the Data 
Edit the Connection 
Remove Connection 
Sort the Data 
Filter the Data 
Join two or more tables 
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4.3 Connecting to a Microsoft Access Database 
  

1. On the Data tab click the Access option. 
 
 

 
 

2. The Data Source - Microsoft Access screen appears: 
 

 

3. Click Browse to navigate to the Access database.  After you make your selection the path will 
appear in the File Name field. 
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4. If you have security setup on the database, enter your user name and password.  This is the 
same User Name and Password used when opening the database directly.    
 
You can click the Test Connection button to make sure you are connected to the database.  If 
a connection is established, the message shown below appears: 
 

 
 
Click OK on the Test Connection message to close it. 
 

5. Click Apply to select the database.  You can optionally change the Max Row count to return 
more rows from the database. Keep in mind that returning a large number of rows can result in 
slower performance 
 
Your data will appear on the Data tab.. 

6. You can now perform the following functions: 
 
Refresh the Data 
Edit the Connection 
Remove Connection 
Sort the Data 
Filter the Data 
Join two or more tables 
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4.4 Connecting to an Excel File 
  

1. On the Data tab click the Excel option. 
 

 
 

2. The Data Source - Microsoft Excel screen appears: 
 

 

3. Enter the file name and location or click the Browse button to navigate to the file. 
 
 
When you click Browse, a browser window will appear allowing you to navigate to your file. 
 After you select your file and click OK on the browser window, the Data Source - Text File 
(delimited) screen will populate with the path and name of your data source in the File Name 
field. 

4. If the first row of your file contains column headers, make sure the First Row is Column 
Headings checkbox is selected. 
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5. The maximum rows included in your label defaults to 1,000.  You can enter a smaller or larger 
number as needed in the Max Rows field.   
 
Keep in mind that a very large number of rows may result in slower performance. 
 

6. You can click the Test Connection button to make sure you are connected to the database.  If 
a connection is established, the message shown below appears: 
 

 
 
Click OK on the Test Connection message to close it. 

7. Click Apply to add the connected file to your Labeler project.  The data contained in the 
selected file will appear on the Data tab as shown in the example below: 
 

 

8. You can now perform the following functions: 
 
Refresh the Data 
Edit the Connection 
Remove Connection 
Sort the Data 
Filter the Data 
Join two or more tables 

  
  



 

147 
 

  
Wasp Labeler User Manual 

4.5 Connecting to Microsoft SQL Server 
  

1. On the Data tab click the MSSQL option 
 

 
 
The Data Source - Microsoft SQL Server screen appears: 
 

  
 

2. Any SQL servers setup on your network will appear in the Server drop down menu.  Select the 
desired Server from the drop down. 

3. If you have your SQL server setup to accept Windows Authentication, select the Use Windows 
Authentication checkbox (default).  If you want to use the SQL Server Authentication, enter 
your User Name and Password in the fields provided.  . 
 
You can click the Test Connection button to make sure you are connected to the server. 

4. A list of available databases appears in the Database field.  Select a database from the list.   
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5. Click Apply to add the database to your label project.  The Data tab will display the selected 
data. 

6. You can now perform the following functions: 
 
Refresh the Data 
Edit the Connection 
Remove Connection 
Sort the Data 
Filter the Data 
Join two or more tables 

  
  

  

4.6 Data Source - ODBC Compliant Data Source 

1. On the Data Source tab click the ODBC option. 
 

 
 

2. The Data Source - ODBC screen appears: 
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3. Click the ODBC Configuration button to configure the connection.  The Connection 
Properties screen appears. 
 

 

4. The installed ODBC driver read from your system will appear in the Data Source field.  If you 
want to select a different driver, click the Change button.  The Change Data Source screen 
appears.  The Change Data Source screen is a Microsoft screen.  From here you can select a 
different data source and make changes to it or to the connection.  These changes should only 
be attempted if you are an advanced user. 

5. The Data Source Selection screen appears again displaying the data source you selected.   
 
 
Optional:  You can specify and edit delimiters if needed. 
   

a. Click the Advanced Delimiter Options button if you want to edit which delimiters 
Labeler will use for the data.   The ODBC Options screen appears: 
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b. Enter the beginning and ending delimiter in the Begin and End fields.  For instance, if 
the data in the ODBC data source is divided by commas, enter commas here. 
 Brackets appear by default.  Some ODBC drivers have difficulty handling square 
brackets [ ] in the query string.   
 

c. Select the Use only when table or column contains: checkbox and accept the 
default entry or enter a new parameter in the text field.   
 

d. Click Reset to return the options to the default values. 
 

e. Click OK to save your changes and return to the Data Source - ODBC screen. 

6. Click Apply to add the database to your label project.  The Data tab will display the selected 
data. 

7. You can now perform the following functions: 
 
Refresh the Data 
Edit the Connection 
Remove Connection 
Sort the Data 
Filter the Data 
Join two or more tables 

  
 

4.7 Connecting to QuickBooks® 
Note: Make sure you have QuickBooks® running before connecting. 
  
  

1. On the Data tab, click the QuickBooks® icon: 
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2. Select QuickBooks® from the Source Type drop down list, then click the OK button.  The 
following Connecting to QuickBooks® message appears: 
 

 
 
As indicated in the warning message, you may see a QuickBooks® message similar to the one 
shown on the screen after you close the Connecting to QuickBooks® message screen. 
 
Select the Don't show me this reminder again checkbox if you don't want this message to 
display each time you connect to QuickBooks®. 

3. Click OK to close the Connecting to QuickBooks® message screen.   
 
 
 



 

152 
 

  
Wasp Labeler User Manual 

4. If you see a QuickBooks® screen similar to the one indicated in the Connecting to QuickBooks® 
message, select one of the following options, then click OK 
 
 
Yes, Prompt each time 
Yes, Whenever this QuickBooks® company file is open 
Yes, Always: allow even if QuickBooks® is not running 

5. A screen will appear showing all data from QuickBooks®.  Select the tables from which you want 
to retrieve data.  You can set up a filter to limit the data you bring into your Labeler file from the 
Credit Memo, Invoice, Purchase Order and Sales Receipt tables.  All data from Customer and 
Vendor tables will be retrieved 
 
 

 
 
The Max Rows field allows you to specify a maximum number of rows to be brought into your 
Labeler file.  The default is 1,000 rows.  You can enter any number between 1 and 10,000.  Keep 
in mind that Labeler will return however many rows are contained in your Filter or in your 
Customer/Vendor table.  This means that if you have selected to retrieve Customer data, and you 
have 5,000 customers, all 5,000 will be retrieved.  If you set your Max Rows to 1,000, only the 
first 1,000 customers will be available for use in your label. 
 
If you select Credit Memo, Invoice, Purchase Order or Sales Receipt, you must enter a filter to 
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specify a range or dates for your data.  For each of these tables you can filter by Transaction 
Date or Modification Date. 
 
To Create a Filter: 
 

1. Highlight the table for which you want to create a filter.  The filters will appear in the 
Filter section.  In this example, we have selected Credit Memo: 
 

 
2. Select Transaction Date or Modification Date and enter a date range in the fields 

provided.  You can click on the calendar icon to the right of each field to select a date if 
needed. 
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You can scroll through the months using the arrows at the top of the calendar or click on 
the Month label to select a different month. 
 
Note:  If you select a date too far in the past, 30 years for example, QuickBooks® will 
return an error message similar to the message below: 
 
 

 
 
You will need to reset the filter date to a more recent date. 

6. Click Apply when you are done selecting tables and creating filters.  A progress bar similar to the 
one shown below will appear: 
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7. The Data tab will populate with the data from the selected QuickBooks® file.  
 

  
 

8. You can now perform the following functions: 
 
Edit the Connection 
Remove Connection 
Sort the Data 
Filter the Data 
Join two or more tables 
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4.8 Connecting to a Text File (delimited) 
  

1. On the main Data Source tab click the Text option 
 
 

 
 

2. The Data Source - Text File (delimited) screen appears: 
 

 

3. Enter the file name and location or click the Browse button to navigate to the file. 
 
 
When you click Browse, a browser window will appear allowing you to navigate to your file. 
 After you select your file and click OK on the browser window, the Data Source - Text File 
(delimited) screen will populate with the path and name of your data source in the File Name 
field. 
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4. Select the Delimiter from the drop down menu.  Options are: 
 
Comma (default) 
Semicolon 
Tab 
Space 
Other.. 
 
If you select Other, enter the delimiter in the text box to the right of the Delimiter field. 
 

 
 

5. If the first row of your file contains column headers, make sure the First Row is Column 
Headings checkbox is selected. 

6. The maximum rows included in your label defaults to 1,000.  You can enter a smaller or larger 
number as needed in the Max Rows field.   
 
Keep in mind that a very large number of rows may result in slower performance. 
 

7. You can click the Test Connection button to make sure you are connected to the database.  If 
a connection is established, the message shown below appears: 
 

 
 
Click OK on the Test Connection message to close it. 
 
 
 
 
 
 

8. Click Apply to add the connected file to your Labeler project.  The data contained in the 
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selected file will appear on the Data tab as shown in the example below: 
 

 
 
 

9. You can now perform the following functions: 
 
Refresh the Data 
Edit the Connection 
Remove Connection 
Sort the Data 
Filter the Data 
Join two or more tables 
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4.9 Creating a Wasp Labeler Data Source 
Wasp Labeler provides the capability to creating a new data source from within the application. 
  Labeler generates a Wasp Data File (extension .WDF) and provides the capability to create a single 
database table by entering the column and data. 
  
Use this option only when you want to create labels that will be composed of one or more variable fields 
for which you do not currently have an external data source. 
  

1. On the main Data tab click the Wasp Data option. 
 

 
 

2. The Data Source - Wasp Data Source screen appears: 
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3. Click Create New Wasp Data Source.  The New Wasp Labeler Data Source screen 
appears.   
 

 
 

4. Two sample columns appear in the Create Column section.  Click in the Column1 area and 
type in a new column header.   
 

5. Press TAB or click in the Type field and select the type of data that will be contained in this 
column.  Options are: 
 
String - This can be a combination of text and numbers. 
Date 
Number 
 

6. Click in the Column2 field and repeat steps 4 and 5.   
 

7. When you are ready to add a new column, select Click here to add new column.  A new 
Column and Type column will appear.  Repeat steps 4 and 5. 
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8. After you have created your columns, you are ready to add data to them.  Any columns you 
have created will appear as column headings in the Enter Data section as shown in the 
example below: 
 
 

 
 
Click in a field and add data that corresponds to the column heading and type.  You can tab 
from field to field to speed up data entry. 

9. When you have completed entering data, click the Save button.  A browser window appears. 
 You can navigate to the location of your choice, rename your database and save it.  The 
default Wasp Labeler Data Source name is DataSource1.WDF. 

10. Your data will appear in the Data tab. 
 

11. If you connected to the file from the main Data Source tab, you can now perform the following 
functions: 
 
Refresh the Data 
Edit the Connection 
Remove Connection 
Sort the Data 
Filter the Data 
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4.9.1 Deleting Columns or Data From the Database: 

Highlight the row(s) you want to delete, then click the Delete Selected button.  Press the CTRL + A 
keys on your keyboard to select all rows.  Select multiple rows by pressing SHIFT + Click. 

  

4.10 Sorting Data Source Content 
After you have attached a data source to your project, you can sort the data on the Data tab.  Sorting is 
a useful way to make sure your data prints in the order you want.  For example, you might want to print 
mailing labels in zip code order or conference badges alphabetically by participant name.   
  
There are two methods for sorting data: 

4.10.1 Method 1: Sort Data Using Column Headers 

  
  

You can sort the data ascending or descending by clicking on the column 
heading in the Data tab.  When you click the header an arrow appears 
indicating if it is sorted ascending (up arrow) or descending (down arrow). 
 The first time you click a heading it will sort ascending.  An example of 
columns with a sort arrow displayed on a header is shown below: 
 

 
 

 
 

  



 

163 
 

  
Wasp Labeler User Manual 

4.10.2 Method 2: Sort Data Using the Sort Button 

  
  
Using the Sort button allows you to create and save multiple sort criteria.  This is useful if you want to 
sort by multiple criteria.  For example, you may want to sort alphabetically by Company, then 
alphabetically by employee name.   
  

1. On the Data tab, select the Sort button on the toolbar.  
  
 

 
 
The Sort Criteria List screen appears: 
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The top of the screen displays all sort criteria you have already created along with their status 
(active or inactive).  The bottom of the screen shows a preview of your data with one of the sort 
criterion applied.  You can only have one criterion set as active at a time. 
 
  

2. To add a new criterion select the Add button at the bottom of the Sort Criteria List.  The Add 
Sort Criteria screen appears: 
 

 

3. Enter the name of your new Sort Criterion in the Sort Criteria Name field.  
  
  

4. The Column drop down menu lists all columns from the data source that you have selected to 
be included in your label project.  Select the column you want to sort from the drop down menu.  
  
  

5. Select Ascending or Descending from the Sorting Order drop down menu. 
 
  

6. You can add additional criteria to by clicking the Add Criteria button.  Now a new pair of 
Column and Sorting Order drop down menus appear. 
 

 
 
  

7. Repeat steps 4 and 5.  You can continue adding additional sort criteria as needed.  In this 
example, we have created a list that will be sorted first by Asset Tag, then by UPC Code. 
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8. Check the Set as Active checkbox if you want the sort criteria you just created to be applied to 
your data.   
  

9. Click OK to save your new criteria.  Click Clear to delete the criteria and start over.  When you 
click OK the Sort Criteria List screen appears displaying your changes: 
 

 
 
  

10. To change which sort criteria is currently active, highlight a listing, then click the Set as Active 
button.   
  

11. Click Done on the Sort Criteria List to return to the Data Source tab.  Notice that if you have 
active sort criteria, your data will now be sorted according to the set parameters. 
 
 
When you have an active sort applied to the data source contents, the name of the sort 
currently in use will appear in the contents preview window as shown below: 
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4.11 Filter the Data Source Content 
Filtering the data source content on the Data tab allows you to only  the data that meets the criteria you 
specify. For example, if the data source contains a list of item numbers, descriptions, and quantity in 
stock, you can display only the item numbers that are out of stock (QTY=0). 
  

4.11.1 Creating a Filter 

  
1. After you have selected a data source on the Data tab, click the Filter button on the toolbar. 

 

 
 
The Filter Criteria List screen appears: 
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2. Click Add to create a new filter for the selected data source.  The Filter Criteria screen 
appears: 
 

 

3. Enter a name for the filter in the Filter Criteria Name field. 
 
An operator selection bar appears at the top of the screen.  Click in the middle of the bar to 
toggle between the And and Or operators.  Leave the first filter as And. 
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4. Click the green + sign to add a criterion to this filter.  A new criterion bar appears: 
 

 

5. The first drop down menu contains the columns from your data source.  Select a column from 
the first drop down.   

6. Select a parameter from the second drop down. 
 
Options are: 

  
• Is equal to 
• Is not equal to 
• Is less than 
• Is less than or equal to 
• Is greater than or equal to 
• Is greater than 

7. Enter a value in the last field. 
 
Example:  In the screen shot below the entered parameters are Asset Tag is equal to 2456. 
 This means that only rows in which the column Asset Tag equals the value 2456 will appear in 
the results.  The preview window displays what rows would be returned for given parameters. 
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You can add additional parameters as needed by clicking the green join icon. 
 

 
 
As you add criteria, the preview window will continue to update to display what your results will 
look like with the filter applied. 

8. Click Save and Close to save the new filter and return to the Filter Criteria List. 
 
The new filter will appear on the Filter Criteria List.   
 

 

9. Highlight the desired filter and click the Set as Active button to apply it to the database results. 
 The Status will update to Active. 
 
Notice that the database results on the Data Source tab update to the highlighted filter.  This is 
to provide you with a preview of the filter results.  The filter is not active until you click the Set 
as Active button. 
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When you have an active filter applied to the data source contents, the name of the filter 
currently in use will appear in the contents preview window as shown below: 
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4.11.2 Deleting a Filter 

  
1. Click the Filter icon on the Data tab toolbar.  The Filter Criteria List appears. 

2. Highlight the filter you want to delete, then click the Delete button.  The following warning 
message appears: 
 

 

3. Click Yes on the warning message to delete the filter. 
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4.12 Joining Tables 
After selecting a data source on the Data Source tab, one or more tables (or spreadsheets) can be 
selected for use with the label you are designing.  While you can't select more than one data source at 
a time for your label, you can select more than one table within a single data source.  In order to use 
data from more than one table, you will need to join the tables by creating a link between them.  To join 
tables you will link two columns with common data, then select which columns from each table you 
want to include on your label. 
  

Example - When to Use the Join Tables Function  
  

Joining tables is useful if, for example, you are creating an employee badge 
and want to include the employee and department.  You might have two 
spreadsheets, one containing the employee name and department ID code 
and another containing department ID codes and the corresponding 
department name.  You can combine the two tables by creating a link 
between the department ID code column in the first spreadsheet with the 
department ID code in the second spreadsheet.  Then you can select to 
include only the employee name from the first table and department name 
from the second table on your labels. 
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4.12.1 Steps to Join Tables 

  
  

1. After selecting a data source on the Data tab, click the Join button. 
 

 
 
 
 
The Join Tables screen appears: 
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2. On the Join Tables screen, click the Add button.  The Add Link screen appears: 
 

 
  

3. On the Add Link screen select the table, spreadsheet, .csv or .txt file from which you want to 
create a link in the From Table drop down menu.  All available tables, spreadsheets, etc. from 
the selected data source will appear here.  
 

  
 
 
 
A list of columns in the selected table, spreadsheet, etc. will appear in the top preview pane. 
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4. Select the column from which you want to create a link using the From Column drop down 
menu. 
  

5. Now select the table, spreadsheet, etc. to which you want to link using the To Table drop down 
menu. 
  

6. Select the column to which you want to create a link using the To Column drop down menu.  A 
list of columns in the selected table, spreadsheet, etc. will appear in the bottom preview pane 
 

. 
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7. Click the Save button to create your link.  Your link will now appear in the List of Links window 
on the Join Tables screen. 
 

 

8. Click Save on the Join Tables screen to return to the Data tab. 
  

9. All columns from both tables, spreadsheets, etc. will appear in the Properties > Select 
Columns to Use on Label window.  Select those columns you want to use on your label and 
deselect those you do not want to use on your label.  The preview window will update with your 
column selections. 
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4.13 Refreshing Data Source Information 
When you establish a connection to a data source, the data contained within the selected file is added 
to your Wasp Labeler project and displayed on the Data Source tab.  While the path/connection 
information is retained, a constant, live connection to the file is not maintained, meaning that changes 
made within the source file after you create the Labeler connection will not be reflected in the Labeler 
project.  To add new or edited information from the source file, use the Refresh Data function.  This 
function is also useful if you have created sorts and filters and want to make sure they have been 
applied to the data contained in Labeler.  Each time you click Refresh Data, Labeler will pull data 
from the data source using any filters and sorts you have created (except in the case of QuickBooks® 
connections - see note below). 
  
Note:  QuickBooks® users should be aware that clicking Refresh applies filters and sorts to the data 
that is already contained in the Labeler project.  New/edited data is not pulled from the QuickBooks® 
source file.  To pull new or edited data from the QuickBooks® source file, you will need to use the Edit 
Connection function. 
  

To update the data contained on the Data Source tab, click the Refresh 
Data button on the toolbar.  
  

 
  
Labeler will establish a connection using the same parameters you initially 
entered.  You will not need to reenter a path or other connection 
information.  All data contained in the source file that meets any sorts/filters 
you have created in Labeler will be returned. 
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4.14 Editing the Data Source Connection 
The Edit Data Source Connection allows you to change from one external data source to another, 
as long as they are the same time.  For example, if you are connected to an Excel file, but want to 
change to a different Excel file, you can use the Edit function to browse to the new file.  Keep in mind 
that any filters or sorts you have created for your existing external data source will be deleted.  You 
can also use this feature if you move the external data source to a new location. 
  
For QuickBooks® users, you can use the Edit function to pull new/edited data from the existing 
QuickBooks® file. 
  
If you want to switch to an entirely different type of external data source, use the Remove function to 
delete the existing data from your project, then create a new connection. 
  

To edit the connection to the external data source, click the Refresh Data 
button on the Data Source Tab toolbar.  
  

 
  
The Connection screen specific to the type of file you are currently connected 
to will appear.  Follow the steps you used to connect to that data type to 
establish a connection with a different file of the same time.  
  
CSV File 
Access Database 
Excel File 
Microsoft SQL Server 
ODBS Compliant Data Source 
QuickBooks® 
Text File 
Wasp Labeler Data Source 
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4.15 Removing the Data Source Connection 
  
To completely break a connection with a data source and remove the data source's information from 
your project, use the Remove Connection function.  You will use this function if you want to delete 
the data source information and change your label to a static label (that does not use an external data 
source at all) or if you want to change to a different external data source type.   
  
Note:  If you want to change to a data source within the same type, CSV to CSV or MSSQL to 
MSSQL, for example, you will use the Edit Connection function.   
  

1. On the Data Source tab, click the Remove Connection button.  The warning message 
shown below appears: 
 

 

2. Click Yes to continuing removing the connection.   All Joins, Filters and Sorts you have 
created for the current data source will be removed and the data source connection 
parameters (the path to a file/SQL settings, etc.) will be deleted from the project. 
 
The Data tab will appear as shown below after the connection is removed. 
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Chapter 5 - Print Tab 
5.1 Print Tab Overview 

In this topic:  
  
Print Toolbar Function Descriptions 
Print Tab Properties Box 

Number of Copies 
Number of Labels 
Starting Label and Order 
Data Source 

Prompt at Print Time Function 
  

The Print tab provides a preview of how your printed labels will look.  From the Print tab you can 
modify the Page Layout, select specific records from the data source to print, sort and filter which 
labels to print and enter the number of copies to print for each label. 
  
The Print tab consists of a toolbar containing function icons, a preview window that displays how your 
labels will look when printed and a Properties box containing print options.   
  
If your labels consist of multiple pages, you can use the navigation buttons on the toolbar to scroll 
through the various pages.  You can manually enter a page number, or click First, Prev, Next or Last 
to scroll. 
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5.1.1 Print Toolbar Function Descriptions 

Layout (Page Setup)-  The Layout icon accesses the Page Setup screen where you can choose the 
label type/size. 

  
  

Sort - Sort accesses the Sort Criteria List where you can create a new sort.  Keep in mind that when 
the Sort function is accessed from the Print tab, any sort criteria already created and set as active on 
the Data Source tab will already be applied to the data. 
  
Print - The Print icon accesses the standard Windows Print screen where you can select a printer 
and print your labels. 
  
Select Records Now - Click the Select Records Now icon to select records to print.   
 
 

 
 
You can CTRL + Click on records to select multiple, non-adjacent records, or SHIFT + Click to select 
multiple, adjacent records.  You can also: 
  

• click Sort to access the Sort Criteria screen and apply an existing sort or create new sort 
criteria to the chosen records, 

• click Filter to access the Filter Criteria screen and apply an existing filter or create a new 
filter to the chosen records.  

• select a record(s) and click Print to print directly from the Select Records Now screen.  Any 
filters put on the data, other than those created from the Select Records Now screen, will be 
ignored.  

  
The left Magnifying Glass icon takes you to the previous search entry and the right Magnifying Glass 
icon takes you to the next search entry.  Click the center Magnifying Glass button to access the Find 
screen (shown below): 
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The Find screen allows you to enter parameters to search for specific data.  Enter the text or number 
for which you want to search in the Find text box, then select a controller and the column in which you 
want to search.  For example, here we have entered Payroll Liabilities in the Find text box, selected the 
Equal (=) controller and the Name column.  This means Labeler will look for any text that equals Payroll 
Liabilities in the Name column. 
  
  

 
  

5.1.2 Print Tab Properties Box - Number of Labels 

  
The Number of Labels section allows you to select how many unique labels will be printed.  This 
should not be confused with copies of labels.  The Number of Labels section controls the number of 
physical, unique labels you want printed.  Your options are: 
  

• One Full Page - The number of labels printed using this option will vary depending on the label 
type you selected on the Page Setup screen.  For example, here we have selected a page that 
contains 2 labels across and 2 labels down (2 x 2).  This means that 4 labels will print if One 
full page is selected.  
 
If you are using an external data source, 4 labels for each record in the data source that you 
have selected to print will print if One full page is selected. 
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• Specify - Enter the number of labels for each record you want to print in the text box.  In the 
example below a value of 10 is entered.  This means that 10 labels for each record in your data 
source (if you are using one) will be printed.   
 
Enter 1 in the Specify field if you want one label for each record in the data source to print. 

  
Examples - Specifying the Number of Labels and Copies 

  
  

Example 1: A label is setup with Numeric Serialization to produce a series 
of labels (1 through 500).  If you enter 50 in the Specify box, the first fifty 
serialized labels will be printed.  
  

 
  
If you enter 50 in the Number of Labels - Specify box and 2 in the Number 
of Copies - Manual from User box, 2 copies each of the first 50 serialized 
labels will be printed, resulting in 100 physical labels. 
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Example 2: The label is pulling data from an external data source.  If you 
have 3 records in the data source and you enter 5 in the Number of Labels - 
Specify box, you will get 15 labels.  3 records x 5 labels each = 15 labels. 
 Now if you also enter 2 in the Number of Copies - Manual from User box, 
you will end up with 30 labels printing.  3 records x 5 labels each = 15 x 2 
copies = 30 labels. 
  
This is especially useful if you are creating enumerated labels with serial 
numbers.  If you have multiple boxes of the same item, and each item has a 
unique serial number, you can print labels that specify 1 of N with N being 
the number of boxes. 
  

 
Example 3: If you are using an external data source and want one label for 
each record in your data source, enter 1 in the Number of Labels - Specify 
box. 
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5.1.2 Print Tab Properties Box - Number of Copies  

  
The Number of Copies section allows you to enter how many copies of each unique label you want to 
print.   
  

• Manual from User - The number of copies of each label is determined by the user entering a 
value in the Manual from User text field.  The default value is 1, meaning one copy of each 
label.  This field is always used to determine the number of copies if no objects are mapped to 
an external data source. 
 

Examples - Specifying the Number of Labels and Copies 
  
  

Example 1: A label is setup with Numeric Serialization to produce a series 
of labels (1 through 500).  If you enter 50 in the Specify box, the first fifty 
serialized labels will be printed.  
  

 
  
If you enter 50 in the Number of Labels - Specify box and 2 in the Number 
of Copies - Manual from User box, 2 copies each of the first 50 serialized 
labels will be printed, resulting in 100 physical labels. 
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Example 2: The label is pulling data from an external data source.  If you 
have 3 records in the data source and you enter 5 in the Number of Labels - 
Specify box, you will get 15 labels.  3 records x 5 labels each = 15 labels. 
 Now if you also enter 2 in the Number of Copies - Manual from User box, 
you will end up with 30 labels printing.  3 records x 5 labels each = 15 x 2 
copies = 30 labels. 
  
This is especially useful if you are creating enumerated labels with serial 
numbers.  If you have multiple boxes of the same item, and each item has a 
unique serial number, you can print labels that specify 1 of N with N being 
the number of boxes. 
  

 
Example 3: If you are using an external data source and want one label for 
each record in your data source, enter 1 in the Number of Labels - Specify 
box. 
  

 
 

  

• As consecutive labels - If you enter a value greater than 1 in the Manual from User text field, 
you can select the As consecutive labels checkbox to indicate you want all copies printed 
together, one after the other. (Rather than all of one copy printing, followed by all of a second 
copy.) 
 
Note: As consecutive labels is always selected if you have checked Dynamic from column 
in data source, As consecutive labels. 
  

Example - Printing Copies as Consecutive Labels 

  

You have a label connected to an external data source containing 2 records. 
 If you print: 
  

• With the As consecutive labels checkbox selected and 2 
entered in the Manual from User field: 2 copies of the first label 
will print, followed by 2 copies of the second label and 2 copies of 
the third label. 
 

• With the As consecutive labels checkbox unchecked and 2 
entered in the Manual from User field: One copy of all labels will 
print, followed by the second copy of all labels. 
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• Dynamic from column in data source - Select this option if you want to control the number of 
copies on a label-by-label basis.  The number of copies for the labels will be determined by an 
associated column in the external data source.  The associated column must contain a numeric 
value.   
 

Example - Using the Dynamic from Column Option 
  

An Excel spreadsheet containing data columns mapped to multiple label 
objects could be modified to include an additional column in which the user 
specifies the number of copies Labeler is to print for each record.  Each 
record can have a different number of copies specified in this column.  
  
  
You might find that data already existing within an External Data Source is 
ideal for controlling the number of copies to print of each label - the quantity 
column of an inventory database could be used for printing item labels, for 
example. 
  

 
  

  
Steps for Using the Dynamic from Column Option 
 
Note: You should already have an external data source setup for your label via the Data tab and bound 
to at least one object. 
 

1. Select the Dynamic from column in data source checkbox. 

2. Click the Select button.  The Dynamic from Column in Data Source screen appears: 
 
 

 
 
This screen displays the first few rows of the data source associated with this label file. 
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3. Select the column from which you want to pull the number of copies from the Column drop 
down menu (the column must be numeric). 

4. Next, in the Substitute the value with field, enter the number of copies to print if rows of 
the selected column are blank or contain non-numeric values. 

5. The next section applies if the value is equal to zero.  You can select to: 
 
 
Print no copies for the record - this option means no labels will be printed if the value 
equals zero. 
 
 
Use the substitution value from above - this is the number you entered in the Substitute 
the value with field. 

6. Finally, you can limit the maximum number of copies to a specified amount.  Labels will not 
be printed over this amount even if the number in the associated column is greater.  The 
default is 999. 
 

7. Click OK on the Dynamic from Column in Data Source when you are finished entering 
information. 
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 5.1.3 Print Tab Properties Box - Starting Label and Order 

  
• Beginning Label - This option allows you to select where on the page of labels you want to 

start printing.  This is a useful feature if you want to continue printing on a partially printed label 
sheet.  
 
 To use this feature: 

  
1. Click the Select button next to the Beginning Label field.  The Select Beginning 

Label field appears. 
 

 
 
The preview pane shows how many labels are on the page (as per the label format you 
selected on the Page Setup screen).   
 

2. Click on the label in the preview pane where you want to start printing.  Or, you can 
enter the Row and Column number in the Label fields. 
 

3. Click OK when you are done making your selection.  The Print Preview pane on the 
Print tab will update to reflect your selection. 

• Order - You can use this feature to tell Labeler in what order to print the labels on the page. 
 Your options are: 
 
Across, then down - this tells the printer to start at the left side of the page, print across, then 
go down one row and across. 
Down, then across - this tells the printer to print all the way down the column on a page, then 
across to the next column and down. 
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5.1.4 Print Tab Properties Box - Data Source 

  
The Data Source section allows you to limit the number of rows contained in this print job.  This section 
contains two options: 

  
Max Rows - If your data source contains many rows, you can set how many you want to print at a time by 
entering a value in the Max Rows field.  The default value is 50.   

  
Prompt for Filter Values - If you want to be prompted to enter filter values. 

 

5.1.5 Print Tab Properties Box - Print Summary 

 This section displays a summary of the print options you have selected.   
 

 
  

• Number of labels - Indicates the number of unique, physical labels. 
• Number of copies - Indicates the number of copies of each label. 
• Total pages to print - The total number of label pages that will print. 
• Total labels to print - The Number of Labels x Number of Copies.  This is the total number 

of labels that will print based on your settings. 
• Current Printer - The printer you currently have selected for label printing.  You can change 

this by clicking the Print button and selecting a different printer. 
• Print Page Size - The size of the label page you selected on the Page Setup screen (via the 

Layout icon). 
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5.2 Page Setup Screen 
In this topic: 
  
Access and Use the Page Setup Screen 
Create a Custom Layout 
Copy a Layout 
Delete a Layout 
  
The Page Setup screen allows you to specify label placement on the page and the page size.  You can 
choose a custom layout or use one of the predefined Avery label templates.   
  
Wasp Labeler contains a predefined set of Avery label templates. 
  
The available predefined families of templates are: 

• Avery Dot Matrix 
• Avery Ink Jet 
• Avery Laser 
• One Up Labels 
• W - 300/305 
• E - 600/606 
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5.2.1 Access and Use the Page Setup Screen 

  
1. On the Design tab, select Layout. 

 
 

Or, on the Print tab, select Layout. 
 

 
 
The Page Setup screen appears: 
 

 

2. On the Page Setup screen, select the label you want to create from the Family  and type drop 
down menus.  You can choose Custom Layout or one of the Predefined Label Layouts.   
  

3. Click Done on the Page Setup screen. 
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5.2.2 Create a Custom Layout 

1.  Select Custom from the Family drop down menu.   

2. Select the Type of label from the Type drop down menu.  By default, Type A is selected (this is 
the only predefined custom type).  If you want to use the settings in Type A, click Done.  You 
have completed your selection on the Page Setup screen.  If you do not want to use the 
settings in Type A, proceed to Step C. 

3. Click New.  The New Layout screen appears. 
 
 

 

4. Enter a name for your new layout type and click OK.  Now the fields on the Page Setup screen 
are enabled allowing you to enter custom Number of Labels, Label Size, Page Margins and 
Space Between Labels.  Notice that as you enter new data into these fields the preview 
display on the right updates to reflect your changes. 
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5. If you do not want changes made to your custom layout select the Lock Edits checkbox.   

6. Select Rounded Borders if the labels have rounded borders.  Uncheck this checkbox for 
square borders. 

7. Click Save to save your new layout template. 

5.2.3 Copy a Layout 

  

1. Select the layout you would like to copy from the Family and Type 
drop down lists.   

2. Click Copy.  The New Layout screen appears. 
 
 

 

3. Enter a name for your new layout type and click OK.  Now the fields 
on the Page Setup screen are enabled allowing you to enter custom 
Number of Labels, Label Size, Page Margins and Space Between 
Labels.  Notice that as you enter new data into these fields the 
preview display on the right updates to reflect your changes. 
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4. If you do not want changes made to your custom layout select the 
Lock Edits checkbox.   

5. Select Rounded Borders if the labels have rounded borders. 
 Uncheck this checkbox for square borders. 

6. Click Save to save your new layout template. 
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5.2.4 Delete a Layout 

  

1. Select the layout you would like to delete from the Family and Type 
drop down lists.   

2. Click Delete.  The Warning screen appears. 
 
 
 

 

3. Click Yes to delete the layout.  Click No to cancel the delete process. 
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Chapter 6 - Activating Wasp Labeler 
In this topic: 
  
Activating Wasp Labeler 
Updating Your License 
  
You can run Wasp Labeler in "Demo" mode for 30 days.  During that time, an icon will appear on the 
File tab toolbar allowing you to enter an activation key.   Wasp Labeler will cease to function if an 
Activation Code has been entered within 30 days of product installation..  If you would like to extend the 
trial period beyond thirty days, please contact the Sales department at sales@waspbarcode.com. 
 

6.1 Steps to Activate Wasp Labeler: 
  

1. On the File tab, click the Activate Labeler icon. 
 

 
 
The Activate Labeler screen appears. 
 

 

2. Type in the activation code, then click the Register button.   
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The Registering Products page from the Wasp Barcode Technologies website appears. 
 

 
 

3. Enter your Registration information. 
 
Note:  If you want to register your product later, click OK on the Activate Labeler screen after 
entering your Activation Code. 

4. Click OK on the Activate Labeler screen.  A Success screen appears: 
 

 
 
Click OK on the Success message screen. 
 
After activation, the Activate Labeler icon changes to Update License. 
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6.2 Updating Your License: 
  

1. (After product activation) On the File tab, click the Update License icon. 
 

 
 
The Update License screen appears. 
 

 

2. Type in the new activation code, then click the OK button.  
 

3. You can also click the Register button to register your product if you did not do so at activation. 
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The Registering Products page from the Wasp Barcode Technologies website appears. 
 

 
 

4. Enter your Registration information. 
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Chapter 7 - Running Labeler from a 
Command Line 

7.1 Application Execution 
The Wasp Labeler application can be executed from the command line (i.e. Run Command). You must 
specify the directory where the Wasp Labeler application was originally loaded and the appropriate 
directory and filename of the LAB file to be opened. Multiple files can be opened using a single 
command. 
  
Syntax 
WaspLabelerV7[.exe] [path/filename] [-p] [-l n] [-c m] [-q] [-h] [-?] [-help]  
  
  
Parameters Description 
  

Parameter Description 

-p Opens the specified LAB file and prints it. (Note: Only one file can be 
printed from the command line at a time.) 

-l n Prints 'n' labels (optional, default=1). (Note: '-p' parameter required.) 
-c m Prints 'm' copies (optional, default=1). (Note: '-p' parameter required.) 

-q  
Launches the application in quiet mode (i.e. does not show the Welcome 
screen on startup, does not show ‘Objects outside label border’ warning 
message) 

-h  Displays a command line help window. (Same as "-?" and "-help".) 
-? Displays a command line help window. (Same as "-h" and "-help".) 

-help Displays a command line help window. (Same as "-?" and "-h".) 
-u Unloads the running WaspLabelerV7.exe (i.e., closes the application) 

  
Example: 
C:\...\Labeler\WaspLabelerV7.exe C:\temp\LABfilename.labx -p -u 
C:\...\Labeler\WaspLabelerV7.exe C:\temp\LABfilename.labx -p -c 6 -u 
C:\...\Labeler\WaspLabelerV72.exe C:\temp\LABfilename.labx -p -l 10 -u 
C:\...\Labeler\WaspLabelerV7.exe C:\temp\file1.lab C:\temp\file2.labx -u 
C:\...\Labeler\WaspLabelerV7.exe -? 
  

  
Note:  In Windows 98 and Me, the command interpreter will not wait for Labeler to exit before executing 
the next command in a batch file.  A small utility called sleep.exe can be found in the .\Labeler folder 
which can be used to delay execution of statements following any call to WaspLabelerV7.exe.  It uses 
one argument; a numeric value that specifies the number of seconds to wait.  For example: 
  
C:\...\Labeler\WaspLabelerV7.exe C:\temp\LABfilename.labx -p -u 
C:\...\Labeler\sleep 10 
C:\...\Labeler\WaspLabelerV7.exe C:\temp\LABfilename.labx -p -c 6 -u 
C:\...\Labeler\sleep 10 
C:\...\Labeler\WaspLabelerV7.exe C:\temp\LABfilename.labx -p -l 10 -u 
C:\...\Labeler\sleep 10 
C:\...\Labeler\WaspLabelerV7.exe C:\temp\file1.lab C:\temp\file2.labx -u 
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Chapter 8 - About Screen 
The About screen allows you to view program version and license details.  The serial number assigned 
to this product appears here as well. 

8.1 Using/Viewing the About Screen 

  
1. On the File tab, click the About icon. 

 

 
 
The About screen appears: 
 

 
  

2. Click OK to close the About screen. 
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